Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Vista Funktionen lassen sich nicht installieren. Meldung Es konnten nicht alle Funktionen geändert werden

Frage Microsoft Windows Systemdateien

Mitglied: mmoellers

mmoellers (Level 1) - Jetzt verbinden

10.01.2009, aktualisiert 18:00 Uhr, 14366 Aufrufe, 13 Kommentare

Ich habe aus andern Gründen den IIS7 deinstalliert. Dann aber festgestellt, das ich den Webserver doch brauche und wollte ihn wieder installieren. Dazu habe ich in der Systemsteuerung unter Programme und Funktionen, dort unter Funktionen ein oder ausschalten die gleichen Features installieren wollen, die schon auf dem PC waren. Nach einiger Festplattenrödelei verschwindet der Fortschrittsbalken und es erscheint eine Meldung: Es ist ein Fehler aufgetreten. Es konnten nicht alle Funktionen geändert werden. Bestätigt man die Meldung, verschwindet das Funktionsfenster und nichts ist installiert. siehe Bild der Fehlermeldung
c0baadd67eeefd6d921aa7a25245bfdd-unbenannt - Klicke auf das Bild, um es zu vergrößern

Ich bin selber Systemadmin mit dem Fokus auf Clientadministration. Daher möchte ich mitteilen, bevor die ersten Gegenfragen aufkommen, das ich aus Berufserfahrung keine Tuningtools oder andere Verschlimmbesserungen verwende. Nur Standard. Auf dem PC sind fast nur MS Produkte installiert und an den Systemeinstellungen ist nichts verändert, was nicht unbedingt einer Änderung bedurfte.
Die Installation ist eine Ultimate Version. Alle Updates, neuester Stand. Außer Zusatztools wie Virenscanner ist da nichts Außergewöhnliches installiert.
Es sei denn, man bezeichnet das Abschalten der schwachsinnigen Sprechblasen als durchgreifende Systemänderung.
Daher gehe ich an dieser Stelle von einem Microsoft Fehler aus. Egal, wie ich die Häkchen in den Submenüs die IIS7 Funktionen zusammenstelle, die Fehlermeldung erscheint immer wieder. Dann wird wohl ein Rollback durchgeführt, weil nach erneuter Kontrolle in der Funktionsauswahl die von mir gesetzten Häkchen weg sind.
Meine Recherche im Web hat bis dato keine brauchbaren Ergebnisse geliefert. Die Fehlermeldung erscheint, wie ich lesen konnte, auf manchen PC'S bei jeder Auswahl einer Funktion. Man kann dort im Grunde nichts nachinstallieren.
Ich kann die IIS Konsole als leeres Fenster installieren. ASP, ISAPI Erweiterungen und Ähnliches waren vorher in der Erstinstallation vorhanden, lassen sich nicht mehr über die Funktionen zurückholen.
Die sogenannten Fachleute, die in den Foren antworten, sind schnell mit Schuldzuweisungen unterwegs oder sind spätestens nach der dritten Antwort völlig vom Thema weg. Nur Lösungen sind keine da.
Bitte hier nur drauf antworten, wenn die Ursache bekannt ist. Ich betrachte eine Neuinstallation von Vista übrigens nicht als Lösung. Dafür bräuchte ich mehrere Stunden, bis alle Programme und Einstellungen wieder so sind wie vorher. Aus beruflicher Erfahrung weiß ich, das das zu 99% auch nicht notwendig ist.
Eine Systemsicherung hatte ich leider nicht, weil ich mit sowas nur gar nicht gerechnet habe. Das gabs unter XP nicht.
Sind bestimmte Dienste, deren Zusammenhang mit dem IIS nicht sofort erkennbar sind, zwingend notwendig? Müssen Registry Keys angepasst werden, damit ich Funktionen wieder nachinstallieren kann ?
Sollte nur eine Neuinstallation die Lösung sein, werde ich zu XP zurückwechseln.

Bitte höflich um Unterstützung

Danke im Voraus
c0baadd67eeefd6d921aa7a25245bfdd-unbenannt - Klicke auf das Bild, um es zu vergrößern
Mitglied: mmoellers
12.01.2009 um 12:25 Uhr
Weitere Recherchen haben ergeben, das sich der Fehler beheben lassen soll, wenn man alle Dienste auf Standard zurücksetzt. Durchgeführt, keine Besserung.
In einem Beitrag habe ich gelesen, das man den Vista Desktop auf Windows Standard zurücksetzen soll, bevor Windows Funktionen nachinstalliert werden.
Auch das habe ich sofort getestet. Kein Erfolg.
Bitte warten ..
Mitglied: gnarff
12.01.2009 um 19:27 Uhr
Es waere schoen gewesen, hier noch den Inhalt des Setup-Logfiles lesen zu koennen, so bleibt mir also nichts anderes uebrig als im Trueben zu fischen, bitte mal durcharbeiten:
1. Error message when you try to install the ASP.NET feature in IIS 7.0: "An error has occurred"

2. Cannot install IIS 7 on Windows Vista Ultimate

3. Unable to install IIS on Vista Ultimate x64 - gre
saludos
gnarff
Bitte warten ..
Mitglied: mmoellers
13.01.2009 um 19:13 Uhr
Danke für die Unterstützung.

Hier ein paar Auszüge aus dem IIS.log. Ich denke, das alle Blöcke mit : "Install of Component....." --> Success! hier der Übersichtlichkeit weggelassen werden können. Die werden in der ersten Hälfte aufgeführt, gefolgt von Einträgen wie
"uninstall of component...." --> Success!
Das deckt sich mit meinen Aussagen.
Die Ursache steckt denke ich in diesen Zeilen:

[01/12/2009 18:27:03] [ * IIS 7.0 Component Based Setup * ]
[01/12/2009 18:27:03] "C:\Windows\System32\inetsrv\iissetup.exe" /install W3SVC
[01/12/2009 18:27:05] < !!FAIL!! > SERVICE_CONTROLLER::StartNamedService W3SVC result=0x8007042c
[01/12/2009 18:27:05] < !!FAIL!! > Install of component W3SVC result=0x8007042c
[01/12/2009 18:27:05] < !!FAIL!! > COMPONENT::ExecuteCommand result=0x8007042c
[01/12/2009 18:27:05] [ End of IIS 7.0 Component Based Setup ]

weiter unten steht:

[01/12/2009 18:29:06] [ * IIS 7.0 Component Based Setup * ]
[01/12/2009 18:29:06] "C:\Windows\WinSxS\x86_microsoft-windows-iis-sharedlibraries_31bf3856ad364e35_6.0.6001.18000_none_10e972c4b4d2574c\iissetup.exe" /launch_uninstall C:\Windows\System32\inetsrv\appcmd.exe clear config -section:system.webServer/log
[01/12/2009 18:29:06] Launching command C:\Windows\System32\inetsrv\appcmd.exe, with params C:\Windows\System32\inetsrv\appcmd.exe clear config -section:system.webServer/log
[01/12/2009 18:29:07] Ignoring acceptable LaunchCommand failure 0x80070002
[01/12/2009 18:29:07] Success!
[01/12/2009 18:29:07] [ End of IIS 7.0 Component Based Setup ]

dann:

[01/12/2009 18:29:54] [ * IIS 7.0 Component Based Setup * ]
[01/12/2009 18:29:54] "C:\Windows\WinSxS\x86_microsoft-windows-iis-sharedlibraries_31bf3856ad364e35_6.0.6001.18000_none_10e972c4b4d2574c\iissetup.exe" /launch_uninstall C:\Windows\System32\inetsrv\appcmd.exe clear config -section:system.webServer/isapiCgiRestriction
[01/12/2009 18:29:55] Launching command C:\Windows\System32\inetsrv\appcmd.exe, with params C:\Windows\System32\inetsrv\appcmd.exe clear config -section:system.webServer/isapiCgiRestriction
[01/12/2009 18:29:56] Ignoring acceptable LaunchCommand failure 0x80070002
[01/12/2009 18:29:56] Success!
[01/12/2009 18:29:56] [ End of IIS 7.0 Component Based Setup ]

Und:

[01/12/2009 18:29:56] [ * IIS 7.0 Component Based Setup * ]
[01/12/2009 18:29:56] "C:\Windows\WinSxS\x86_microsoft-windows-iis-sharedlibraries_31bf3856ad364e35_6.0.6001.18000_none_10e972c4b4d2574c\iissetup.exe" /launch_uninstall C:\Windows\System32\inetsrv\appcmd.exe clear config -section:system.webServer/webLimits
[01/12/2009 18:29:57] Launching command C:\Windows\System32\inetsrv\appcmd.exe, with params C:\Windows\System32\inetsrv\appcmd.exe clear config -section:system.webServer/webLimits
[01/12/2009 18:29:57] Ignoring acceptable LaunchCommand failure 0x80070002
[01/12/2009 18:29:57] Success!
[01/12/2009 18:29:57] [ End of IIS 7.0 Component Based Setup ]
Bitte warten ..
Mitglied: gnarff
13.01.2009 um 22:27 Uhr
Sehr schoen, kannst du das zusaetzlich noch mit den Eintraegen im CBS.log abgleichen [Findet sich unter %windir%\Logs\CBS]* sowie dem iis7.log, zu finden unter \Windows\iis7.log.

Wenn wir die Eintraege gegenueberstellen, sollten wir einen Schritt weiter kommen.

*Weitere Informationen zur Auswertung des CBSlogs: Analysieren von Protokolldateieinträgen, die von der Microsoft Windows-Ressourcenprüfung (SFC.exe) in Windows Vista generiert werden

Kennst du eigentlich Windows SDK, exellent zur Logfileauswertung bei verhunzten Installationen

saludos
gnarff
Bitte warten ..
Mitglied: mmoellers
14.01.2009 um 18:25 Uhr
IIS.log ist IIS7.log. die Zahl habe ich nicht eingetragen. Sorry.
Auszug aus der CBS.log. Gleicher Zeitpunkt wie in der IIS7.log.
Die Fehler beziehen sich auf die Installation des Webserverdienstes W3SVC des IIS 7.
Auch hier wieder der wesentliche Auszug aus der Datei.
Habe SFC /scannow laufen lassen. Will keine Fehler gefunden haben.

2009-01-12 18:27:05, Info CSI 00000144 Performing 1 operations; 1 are not lock/unlock and follow:
LockComponentPath (10): flags: 0 comp: {l:16 b:c0745ffdda74c90145010000cc0d0c0e} pathid: {l:16 b:c0745ffdda74c90146010000cc0d0c0e} path: [l:234{117}]"\SystemRoot\WinSxS\x86_microsoft.windows.s..ation.badcomponents_31bf3856ad364e35_6.0.6001.18000_none_3891bf6bc31ec194" pid: dcc starttime: 128762543704725472 (0x01c974d9ede557e0)
2009-01-12 18:27:06, Info CSI 00000145 Creating NT transaction (seq 2), objectname [6]"(null)"
2009-01-12 18:27:06, Info CSI 00000146 Created NT transaction (seq 2) result 0x00000000, handle @0x6754
2009-01-12 18:27:06, Info CSI 00000147@2009/1/12:17:27:06.104 CSI perf trace:
CSIPERF:TXCOMMIT;54779
2009-01-12 18:27:06, Error CSI 00000148 (F) Done with generic command 2; CreateProcess returned 0, CPAW returned S_OK
Process exit code 1068 (0x0000042c) resulted in success? FALSE
Process output: [l:22 [22]"Failed = 0x8007042c

und einen Augenblick weiter:

2009-01-12 18:27:08, Info CSI 0000014f@2009/1/12:17:27:08.573 CSI Advanced installer perf trace:
CSIPERF:AIDONE;{81a34a10-4256-436a-89d6-794b97ca407c};Microsoft-Windows-IIS-W3SVC,

2009-01-12 18:27:08, Error CSI 00000150 (F) Failed execution of queue item Installer: Generic Command ({81a34a10-4256-436a-89d6-794b97ca407c}) with HRESULT HRESULT_FROM_WIN32(14109). Failure will not be ignored: A rollback will be initiated after all the operations in the installer queue are completed; installer is reliable (2)[gle=0x80004005]
2009-01-12 18:27:09, Info CSI 00000151 End executing advanced installer (sequence 155)
Completion status: HRESULT_FROM_WIN32(ERROR_ADVANCED_INSTALLER_FAILED)

weiter unten:

2009-01-12 18:30:16, Info CBS Failed removing impactful-commit disabling value from CCP. hr: 0x80070002
2009-01-12 18:30:16, Error CBS Exec: An error occurred while committing the transaction, the transaction has been rolled back.
2009-01-12 18:30:16, Info CSI 000006fc@2009/1/12:17:30:16.530 CSI Transaction @0x4971408 destroyed
Bitte warten ..
Mitglied: gnarff
15.01.2009 um 01:40 Uhr
So, Dein Problem zeigt sich meines Erachtens in folgender Zeile:
01.
l:234{117}]"\SystemRoot\WinSxS\x86_microsoft.windows.s..ation.badcomponents_31bf3856ad364e35_6.0.6001.18000_none_3891bf6bc31ec194
Hier faellt auf, dass WinSxS betroffen ist, der Windows Side by Side Assembly
Hier sind alle Treiber gespeichert, der gegenwaertig installierten Programme, der Programme die installiert werden sollen und die die nicht sauber bei der Deinstallation entfern wurden.

Wie das genau funktioniert ist in dem Artikel
About Isolated Applications and Side-by-side Assemblies beschrieben.


Weiter haben wir in den Logfileauszuegen den Eintrag:
01.
Error CSI 00000150 (F) Failed execution of queue item Installer: Generic Command ({81a34a10-4256-436a-89d6-794b97ca407c}) with HRESULT HRESULT_FROM_WIN32(14109)
Meine Meinung daher:
Es sieht aus, als ob der Installer nicht die noetigen Treiber installieren kann, weil die Alten noch vorhanden sind. Also moechte er sie updaten und das geht nicht weil sie von WSxS geschuetzt sind und deswegen wird der Installationsprozess abgebrochen.

Ich vermute, dass die erste Deinstallation von II7 nicht sauber vonstatten ging.
Eigentlich sollten nicht benoetigte Treiberreste nach einiger Zeit automatisch aus WSxS geloescht werden.
Offensichtlich ist dies nicht geschehen.

Werde mal schauen, wie man das Problem beheben kann...

Nachtrag: Unter Umstaenden koennte der Windows Installer Clean Up weiterhelfen, der auch unter Windows Vista laeuft, und dir den Dienst erweisen die Reste der vorhergehenden Installation und von Dieser restlos zu entfernen.

saludos
gnarff
Bitte warten ..
Mitglied: mmoellers
16.01.2009 um 10:37 Uhr
Danke nochmal für die Unterstützung.
Ich möchte nochmal postiv hervorheben, das hier eine fachliche Fehleranalyse stattfindet und nicht mit Try and error und Vermutungen
an die Sache gegangen wird. So muss das sein.
Super, auch wenn noch keine Lösung da ist, aber die Richtung ist gefunden.
Bitte warten ..
Mitglied: gnarff
16.01.2009 um 17:42 Uhr
Zitat von mmoellers:
Danke nochmal für die Unterstützung.
Ich möchte nochmal postiv hervorheben, das hier eine fachliche
Fehleranalyse stattfindet und nicht mit Try and error und Vermutungen

an die Sache gegangen wird. So muss das sein.
Super, auch wenn noch keine Lösung da ist, aber die Richtung ist
gefunden.

Herzlichen Dank fuer das Lob.
Hast Du einmal meinen Loesungsansatz mit dem Installer Cleanup durchgefuehrt?

Worueber ich immer wieder in deinen Logauszuegen stolpere ist:
1. Gemeinsame Treiberbibliotheken koennen nicht verwendet werden; es wird ein anderes Paket vorgefunden als erwartet.
2. Waehrend der Installation soll ein Update ausgefuehrt werden, welches fehlschlaegt, quittiert mit Failed = 0x8007042c entspricht einem Error 1058 oder uebersetzt ERROR_SERVICE_DISABLED, also laeuft ein Dienst nicht.
3. Wir haben HRESULT 14109 mit 0x80004005 was ein FACILITY_ITF Error ist und ein Problem mit einem Interface bezeichnet.
4. Ich sehe das mittels appcmd.exe clear config gesetzt wurde und dieses Kommado nicht ausgefuehrt werden kann.
5. Ich sehe das ISAPI filter nicht installiert werden koennen.

Da IIS7 vorher installiert war und lief, wuerde ich doch dazu raten, alles was mit der vorhergehenden Installation zusammenhaengt, incl. ISAPI und ASP sauberst zu entfernen, danach sicher zu stellen, dass alle Installationsprozesse ausfuehrlich geloggt werden koennen und dann eine Neuinstallation durchzufuehren.

Diesmal aber mit dem kleinen Unterschied, mir alle Logs in ein handliches ZIP-Koefferchen zu packen und zuzusenden, damit ich diese dann im Zusammenhang betrachten und analysieren kann.
Ich muss sehen koennen, welches die vorhergehenden Sequenzen sind, bis es schliesslich zum Fehler kommt.

Ausserdem: Ist dieser PC standalone oder Client eines Netzwerkes?

saludos
gnarff
Bitte warten ..
Mitglied: mmoellers
17.01.2009 um 17:48 Uhr
Mittlerweile habe ich es soweit hinbekommen, das der Internetinformations Dienste Manager läuft.
Allerdings lässt sich die Default Website nicht starten.
Meldung:
Websites können nur gestartet werden, wenn der Windows Prozessaktivierungsdient (WAS) und der www-Publishingdienst (W3svc) ausgeführt werden. Beide Dienste wurden beendet.

Der Windows Prozess Aktivieunrgsdienst greift auf die C:\Windows\System32\iisreset.exe zu. Beim Versuch den Dienst zu starten erscheint: Das System kann die angegebene Datei nicht finden.
Sie existiert aber......zumindestens augenscheinlich
Bitte warten ..
Mitglied: gnarff
18.01.2009 um 01:49 Uhr
Da erinnere ich mich spontan an:

Anwendungen wird der Zugriff auf Ressourcen verweigert
Nach einer Neuinstallation wird IIS 6.0 im Arbeitsprozess-Isolationsmodus in IIS 6.0 ausgeführt. In diesem Modus ausgeführte Anwendungen verwenden standardmäßig die Identität von Netzwerkdienst. Netzwerkdienst ist ein Konto mit weniger Benutzerrechten[...]
Daran duerfte sich auch bei IIS7 nichts geandert haben.
- Hast Du dich vergewissert, dass hier auch wirklich kein Berechtigungsproblem vorliegt? [Stichwort: Vista User Account Control (UAC)]

- Ist das "Wiederverwenden von Arbeitsprozessen" aktiviert?
- Die Arbeitsprozesse werden aus o.g. Gruenden nicht im Systemereignisprotokoll sondern in das Anwendungsereignisprotokoll geschrieben.
Kannst du mir berichten, was dort fuer Eintraege anzufinden sind?

- Mit Debug Diagnostics 1.1 lassen sich fehlerhafte Prozesse analysieren, in vorliegenden Fall mir einer hang rule und/oder einen memory dump der betreffenden Prozesse erzeugen und die Ergebnisse auswerten oder hier posten.

saludos
gnarff
Bitte warten ..
Mitglied: mmoellers
18.01.2009 um 18:40 Uhr
Habe die Dienste wieder zum Leben erweckt.
Habe im abgesicherten Modus versucht den Prozessaktivierungsdienst zu deinstallieren mit dem Ziel, sie wieder "richtig" zu installieren, was aber mit der gleichen Fehlermeldung quittiert wurde, wie hier anfangs als Screenshot zu sehen.
Also habe ich es gelassen und Vista wieder "normal" gestartet.
Ich war dabei, die Benutzerrechte zu prüfen und habe in dem Zusammenhang die Dienste erneut geöffnet. Dabei ist mir aufgefallen, das der Prozessaktivierungsdienst und der www-Publishingdienst auf Gestartet standen.
Damit lief auf der Webserver ebenfalls....

Allerdings fehlt mit eine Funktion. Es handelt sich um die "Handlerzuordnung".
Das Icon ist schlichtweg nicht da.
Es gibt in den Windows Funktionen keine Möglichkeit, das einzeln einzuschalten.
Nun bin ich auf der Suche, wie ich das eingeblendet bekomme...

An dieser Stelle nochmal vielen Dank für die Hilfe. Fachlich absolute Klasse.

Ich denke, man kann das Thema als gelöst betrachten, auch wenn der Lösungsweg in der Ausage sehr schwammig ist.
Es ist weiter unklar, warum die Dienste nicht anliefen.
Der abgesicherte Modus ist denke ich der Schlüssel.
Im eventviewer hat auch nichts anderes gestanden, wie im IIS7.log.
Protokolliert wird immer nur, das es nicht läuft, aber nicht, warum nicht.
Damit mögen logfiles nicht unsinnig sein, aber gerade die Aussagen des Eventviewer sind sehr interpretationsbedürftig.

So, und jetzt die Suche nach dem Icon "Dokumenthandler"
Bitte warten ..
Mitglied: FHornung
22.08.2009 um 00:54 Uhr
Fehler behoben
Verwenden eines Skripts

Alle ISS Komponenten Sauber deinstallieren

cmd (Dos Fenster) starten

(Befehl pkgmgr /uu "alles wird dann deinstalliert")

folgende Zeilen markieren und über rechte Maustaste einfügen in Kommandozeile

start /w pkgmgr /uu:IIS-WebServerRole;IIS-WebServer;IIS-CommonHttpFeatures;IIS-StaticContent;IIS-DefaultDocument;IIS-DirectoryBrowsing;IIS-HttpErrors;IIS-HttpRedirect;IIS-ApplicationDevelopment;IIS-ASPNET;IIS-NetFxExtensibility;IIS-ASP;IIS-CGI;IIS-ISAPIExtensions;IIS-ISAPIFilter;IIS-ServerSideIncludes;IIS-HealthAndDiagnostics;IIS-HttpLogging;IIS-LoggingLibraries;IIS-RequestMonitor;IIS-HttpTracing;IIS-CustomLogging;IIS-Security;IIS-BasicAuthentication;IIS-URLAuthorization;IIS-RequestFiltering;IIS-IPSecurity;IIS-Performance;IIS-HttpCompressionStatic;IIS-HttpCompressionDynamic;IIS-WebServerManagementTools;IIS-ManagementConsole;IIS-ManagementScriptingTools;IIS-ManagementService;IIS-IIS6ManagementCompatibility;IIS-Metabase;IIS-WMICompatibility;IIS-LegacyScripts;IIS-LegacySnapIn;WAS-WindowsActivationService;WAS-ProcessModel;WAS-NetFxEnvironment;WAS-ConfigurationAPI
warten alles wird bis Aufforderung Neustart

Alle ISS Komponenten Sauber installieren

cmd (Dos Fenster) starten

(Befehl pkgmgr /ui "alles wird dann installiert")

folgende Zeilen markieren und über rechte Maustaste einfügen in Kommandozeile

start /w pkgmgr /ui:IIS-WebServerRole;IIS-WebServer;IIS-CommonHttpFeatures;IIS-StaticContent;IIS-DefaultDocument;IIS-DirectoryBrowsing;IIS-HttpErrors;IIS-HttpRedirect;IIS-ApplicationDevelopment;IIS-ASPNET;IIS-NetFxExtensibility;IIS-ASP;IIS-CGI;IIS-ISAPIExtensions;IIS-ISAPIFilter;IIS-ServerSideIncludes;IIS-HealthAndDiagnostics;IIS-HttpLogging;IIS-LoggingLibraries;IIS-RequestMonitor;IIS-HttpTracing;IIS-CustomLogging;IIS-Security;IIS-BasicAuthentication;IIS-URLAuthorization;IIS-RequestFiltering;IIS-IPSecurity;IIS-Performance;IIS-HttpCompressionStatic;IIS-HttpCompressionDynamic;IIS-WebServerManagementTools;IIS-ManagementConsole;IIS-ManagementScriptingTools;IIS-ManagementService;IIS-IIS6ManagementCompatibility;IIS-Metabase;IIS-WMICompatibility;IIS-LegacyScripts;IIS-LegacySnapIn;WAS-WindowsActivationService;WAS-ProcessModel;WAS-NetFxEnvironment;WAS-ConfigurationAPI
Fertig und alles OK

Ggf. noch Neustart
Bitte warten ..
Mitglied: Teutates
07.01.2011 um 12:00 Uhr
Beim Installieren muss es allerdings "pkgmgr /iu" zum installieren, zumindest bei Windows 7
Bitte warten ..
Ähnliche Inhalte
Windows 7
Meldung anzeigen lassen beim herunterfahren
Frage von Flo985Windows 74 Kommentare

Hallo zusammen, kurze Frage, hoffe ihr könnt mir weiterhelfen Ich möchte bei einem Windows 7 Rechner beim herunterfahren eine ...

Microsoft Office
Outlook 2013 Diese Funktion kann nicht ausgeführt werden, da die Nachricht geändert wurde
Frage von has.andMicrosoft Office2 Kommentare

Seit dem umstieg auf Office 2013 klagen einige User über die im Titel genannte Fehlermeldung. Umgebung: Client: Win 2008R2 ...

Windows 7
Java installieren, Meldung interaktiver Dienste
gelöst Frage von ahstaxWindows 75 Kommentare

Hallo, via GPO und Anmeldescript lasse ich in unserem Netzwerk (Win7 Pro 64bit-Clients) Java-Updates installieren. Bis vor kurzem funktionierte ...

Windows 7
Windows Updates lassen sich nicht installieren
Frage von BergEnteWindows 75 Kommentare

Hallo Forum, ich habe auf einem Windows 7 SP1 64 Bit, Lenovo Laptop, das Problem, dass die Windows Updates ...

Neue Wissensbeiträge
Erkennung und -Abwehr

Necur-Botnet soll Erpressungstrojaner Scarab massenhaft verbreiten

Information von BassFishFox vor 2 StundenErkennung und -Abwehr

12,5 Millionen Spam-Mails aus einem Bot-Netz mit 6 Millionen Computern? Eigentlich eine schwache Leistung. Die Erpresser setzen dabei auf ...

Microsoft

Nadeldrucker-Problem unter Windows - Microsoft liefert Updates

Information von BassFishFox vor 2 StundenMicrosoft

Hat ja nicht lange gedauert. Nachdem die November-Updates für Windows 7, 8.1 und 10 zahlreiche Nadeldrucker lahmgelegt hatten, stellt ...

Linux

Limux-Ende in München: Wie ein Linux Projekt unter Ausschluss der Öffentlichkeit zerstört wurde

Information von Frank vor 10 StundenLinux14 Kommentare

Mein persönlicher Kommentar zum Thema "Limux-Ende". Die SPD-Politikerin Anne Hübner hat die Richtung von München ganz klar definiert: "Wir ...

Batch & Shell

Open Object Rexx: Eine mittlerweile fast vergessene Skriptsprache aus dem Mainframebereich

Information von Penny.Cilin vor 1 TagBatch & Shell9 Kommentare

Ich kann mich noch sehr gut an diese Skriptsprache erinnern und nutze diese auch heute ab und an noch. ...

Heiß diskutierte Inhalte
Linux
Limux-Ende in München: Wie ein Linux Projekt unter Ausschluss der Öffentlichkeit zerstört wurde
Information von FrankLinux14 Kommentare

Mein persönlicher Kommentar zum Thema "Limux-Ende". Die SPD-Politikerin Anne Hübner hat die Richtung von München ganz klar definiert: "Wir ...

Router & Routing
Zwei Netzwerke erstellen
Frage von bunteblumeRouter & Routing14 Kommentare

Hallo Zusammen, Ich möchte gerne ein backup von einem bestimmten Folder welcher auf dem Server regelmässig synchronisiert wird auf ...

Off Topic
Fachkräftemangel in Deutschland? - Talentschmiede schreibt alle 2 Tage die gleichen Stellen aus
Frage von Penny.CilinOff Topic12 Kommentare

Hallo, haben wir in Deutschland Fachkräftemangel? Die Talentschmiede schreibt gefühlt alle zwei Tage dieselben Stellen aus. Und das schon ...

Windows Server
Kann man im KMS nachschauen , wieviele Clients den Key in Anspruch genommen haben
gelöst Frage von rainergugusWindows Server12 Kommentare

Hallo, wir haben einen KMS Windows 10 Key. Dieser ist ja W7 kompatibel. Aber unser Windows 7 Pool registriert ...