Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Vista preferiert immer Default Route von aktiver RAS Verbindung?

Frage Microsoft Windows Netzwerk

Mitglied: ts1612

ts1612 (Level 1) - Jetzt verbinden

27.05.2009, aktualisiert 14:47 Uhr, 5572 Aufrufe, 3 Kommentare

Hallo zusammen,

ich habe folgende Konstellation mit Vista Ultimate auf DELL XPS 1330 Laptop (wobei ich vermute, dass das ein generelles Vista Problem ist und HW unabhängig auftritt, da auch in VM-Ware reproduzierbar).

Wenn ich z.B. über UMTS-Wählverbindung mit dem Internet verbunden bin und gleichzeitig im LAN sitze, so gibt es logischerweise 2 Default routen:

UMTS: Default Route1: 0.0.0.0 0.0.0.0 auf Verbindung IP-des-Carriers Metrik

LAN: Default Route2: 0.0.0.0 0.0.0.0 IP-des-Routers IP-des-Laptops Metrik

Topologie:
Internet ----- Router ----- LAN ----- | Laptop | ----- Dialup RAS / UMTS ----- Internet

Soweit so gut. Die Metrik der Default Route 1 (UMTS) sitzt höher (kleinerer Wert) als Default Route 2, sodass alles was nicht im LAN sitzt über die UMTS Verbindung geschickt wird - logisch. Ich möchte aber explizit alles über den Router im LAN schicken und nur bestimmte Routen/Adressen über UMTS erreichen. Setzt man die bessere Metrik entsprechend auf Default Route 2 so wird dies von Vista ignoriert. Alles geht weiterhin über UMTS.

Selbst wenn ich Default Route1 komplett lösche funktioniert es nicht. Ein route print zeigt nach dem Löschen der Default Route1 nur noch die Default Route2 an, die Anzeige ist soweit korrekt, und dennoch versucht Vista alles (bis auf LAN IPs) über die UMTS Verbindung zu erreichen. Nach dem Löschen der Default Route 1 erreiche ich ausser dem LAN nichts mehr, obwohl gem. Routing Tabelle und route print die Default Route 2 aktiv ist und alles über Default Route 2 laufen müsste. Erst nach Beendigung der Wählverbindung ist ein Ping nach Extern wieder erfolgreich.

Selbes Szenario funktioniert mit XP einwandfrei. Nach Löschen der Default Route1 unter XP läuft alles sauber, so wie es auch in der Routingtabelle definiert und gewünscht ist, über das LAN zum Internet.

Vista scheint also bei aktiver Dialup/RAS-Verbindung diese unabhängig von Einträgen in der Routing Tabelle immer zu preferieren ... selbst wenn es keine Default-Route auf der Verbindung mehr gibt??

Im übrigen agiert Windows 7 hier genau wie Vista. XP hingegen interessiert sich für seine Routing Tabelle und agiert richtig.

Ist das ein genereller Vista Bug, oder nur bei mir so? Könnt ihr das auch reproduzieren? Irgendwelche Ideen?

Besten Dank im voraus.
Mitglied: aqui
27.05.2009 um 19:28 Uhr
Du musst die Bindungsreihenfolge der NICs ändern, das löst vermutlich das Problem.
Bei XP geht das so:
http://support.microsoft.com/kb/894564/de

Ob Vista das auch so behandelt musst du mal die MS Knowledgebase fragen...
Bitte warten ..
Mitglied: ts1612
28.05.2009 um 10:02 Uhr
Hallo Aqui,

besten Dank für Deinen Input.

Das hatte ich bereits versucht, die LAN-Verbindung sitzt in der Bindungsreihenfolge bereits ganz oben.

Im Übrigen habe ich zudem folgenden Versuch unternommen:
Bei der Wählverbindung für UMTS habe ich den Haken "Standardgateway für das Remote Netzwerk verwenden" deaktiviert. Wenn ich mich dann einwähle kommt natürlich keine Default Route. Setze ich diese testhalber nun manuell so habe ich ja grundsätzlich die selbe Konstellation wie oben. Wenn ich diese nun wieder lösche, dann funktioniert die Verbindung über LAN nach aussen. Es scheint also wirklich bei Vista und Windows 7 so zu sein, dass wenn die Option "Standardgateway für das Remote Netzwerk verwenden" aktiviert ist, sich das OS für die Routingtabelle einfach nicht interessiert.
Bitte warten ..
Mitglied: ts1612
29.05.2009 um 14:35 Uhr
Hat niemand eine Idee. Kann jemand das o.g. Verhalten bestätigen?

Besten Dank
Bitte warten ..
Ähnliche Inhalte
Router & Routing
gelöst VPN Verbindung bei kaskadierten Routern (9)

Frage von MrNight zum Thema Router & Routing ...

Router & Routing
gelöst Verbindung von 2 Routern (24)

Frage von Pfanne88 zum Thema Router & Routing ...

Linux Netzwerk
gelöst Debian verliert Route trotz default Gateway (10)

Frage von Zigsen zum Thema Linux Netzwerk ...

DNS
gelöst DNS- Verbindung zu fremden Router (4)

Frage von MBHomeservice zum Thema DNS ...

Neue Wissensbeiträge
Ubuntu

Ubuntu 17.10 steht zum Download bereit

(3)

Information von Frank zum Thema Ubuntu ...

Datenschutz

Autofahrer-Pranger - Bewertungsportal illegal

(8)

Information von BassFishFox zum Thema Datenschutz ...

Windows 10

Neues Win10 Funktionsupdate verbuggt RemoteApp

(8)

Information von thomasreischer zum Thema Windows 10 ...

Microsoft

Die neuen RSAT-Tools für Win10 1709 sind da

(2)

Information von DerWoWusste zum Thema Microsoft ...

Heiß diskutierte Inhalte
Router & Routing
Allnet - VDSL2 Modem - SFP (mini-GBIC) (20)

Frage von Dobby zum Thema Router & Routing ...

Monitoring
Netzwerk-Monitoring Software (18)

Frage von Ghost108 zum Thema Monitoring ...

Windows 10
Seekrank bei Windows 10 (17)

Frage von zauberer123 zum Thema Windows 10 ...

Windows Server
gelöst Kopiervorgang schlägt fehl, weil Datei- und Ordnername zu lang sind (14)

Frage von Schroedi zum Thema Windows Server ...