Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Vista Schreibschutz in %ProgramData%

Frage Entwicklung Installation

Mitglied: xcabur

xcabur (Level 1) - Jetzt verbinden

03.06.2008 um 16:44 Uhr, 8124 Aufrufe

Hallo zusammen

Ich benötige mal wieder Hilfe.

Ich habe ein Setup geschreiben (mit NSIS) welches eigentlich nur eine Access-DB und ein paar PDF-Files in einen Ordenr kopiert. Problem ist, dass die Access DB natürlich Daten speichert sprich Sie benötigt Schreibrechte.
Da unter Vista das %programfiles% verzeichniss generel als read-only definiert ist entschloss ich mich das Programm ins %programdata% zu installieren (schreib/lese zugriff, sowie für alle Benutzer erreichbar).

bei Setup start erscheint die UAC, welche ich bestätige. Setup läuft erfolgreich durch, Dateien und Verzeichnisse werden korrekt erstellt. Jedoch wenn ich z.b. eine Datei (egal welche) umbenennen will, erscheint die Meldung, dass diese Geschützt sei und ich dies explizit erlauben muss. Nachdem ich diese Meldung mit "Fortsetzen" bestäigt habe wird die datei umbenannt. Daraus resultiert, dass die DB auch nur in einem Schreibschutz geöfnnet wird. Wenn ich die Daten lösche und manuell hinein kopiere, besteht kein Problem.

8e5c2b4276c1c7f25b53e5f3454351d6-programdata - Klicke auf das Bild, um es zu vergrößern

ich bin lokaler Admin und NTFS-Berechtigungen sind korrekt, Attribut Schreibschutz ist nicht gesetzt.

Es scheint also eine systemübergreifender Schutzfunktion zu sein aber die Meldung sieht auch nicht wie die UAC aus (hintergrund wird nicht schwarz - siehe Bild).
Bei der Installation direkt in C:\ist alles ok - aber das kanns ja nicht sein.

Hat jemand eine Idee?

Gruss und Danke
Neuester Wissensbeitrag
Off Topic

"Ich habe nichts zu verbergen"

(2)

Erfahrungsbericht von FA-jka zum Thema Off Topic ...

Ähnliche Inhalte
Windows Vista
gelöst Vista Home Premium nur Basic Key (8)

Frage von Chonta zum Thema Windows Vista ...

Windows Server
gelöst WSUS auf Server 2008 R2: Windows 10 wird als Vista angezeigt (2)

Frage von honeybee zum Thema Windows Server ...

Windows Update
gelöst WSUS Windows 10 wird als Vista angezeigt (3)

Frage von Dkuehlborn zum Thema Windows Update ...

Heiß diskutierte Inhalte
Linux Netzwerk
gelöst DHCP vergibt keine Adressen (31)

Frage von Maik82 zum Thema Linux Netzwerk ...

Exchange Server
gelöst Bestehende eMails autoamatisch weiterleiten (22)

Frage von metal-shot zum Thema Exchange Server ...

Apache Server
gelöst Lets Encrypt SSL mit Apache2 (20)

Frage von banane31 zum Thema Apache Server ...

Switche und Hubs
LAG zwischen SG300-Switches macht Probleme. Wer weiß Rat? (19)

Frage von White-Rabbit2 zum Thema Switche und Hubs ...