Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Visual Studio.net kein OLE-DB Provider für Jet

Frage Entwicklung Visual Studio

Mitglied: kleinerbub

kleinerbub (Level 1) - Jetzt verbinden

25.02.2009, aktualisiert 12:52 Uhr, 7634 Aufrufe, 2 Kommentare

Ich habe Visual Studio .net 2003 Standard auf meinem Rechner. Ich will in einem Projekt eine Verbindung zu einer Access Datenbank herstellen (per OLE-DB).

Es ist überall (MSDN-Hilfe, Beiträge im Internet) beschrieben, dass ich dazu im Server Explorer als Provider "Jet" auswählen soll. Bei mir gibt es aber nur:
  • MediaCatalogDB OLE DB Provider
  • MediaCatalogMergeDB OLE DB Provider
  • Microsoft OLE DB Provider fo rDTS Packages
  • Microsoft OLE DB Provider for SQL Server
  • SQL Server Replication OLE DB Provider for DTS

Ich habe bereits das ServicePack 1 für Visual Studio .net 2003 installiert. Ein weiterer Vorschlag von einer anderen Seite war die Jet-Version zu überprüfen. Meine msjet40.dll hat die Version 4.0.9511.0
Das ist neuer, als alles andere, was ich gefunden habe.

Als OS läuft XP SP3. Weiterhin habe ich noch SQL Server 2005 Express Edition, Ingres, MySQL etc installiert. Diese dürften damit aber eigentlich nix zu tun haben, da das ja ein Treiber von Microsoft ist.

Hat jemand das selbe Problem oder einen Lösungsansatz?

mfg kleinerbub
Mitglied: lupi102
17.03.2009 um 08:30 Uhr
Hallo,

vielleicht ein Ansatz: (aus Excel-VBA)

Dim acconn As New ADODB.Connection

acconn.Open "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=" & database & ";"

Für database muss der Name (mit Pfad) der Datenbank angegeben werden.

Wichtig auch, dass du einen Verweis setzt auf "Microsoft ActiveX Data Objects 2.5 (oder höher) Library.


Grüße
Heiko
Bitte warten ..
Mitglied: kleinerbub
26.03.2009 um 11:45 Uhr
Nach zahlreichen versuchen die entsprechenden DLLs zu deregistrieren, registrieren, Office neu zu installieren usw usf, habe ich mich dazu entschlossen das System neu aufzusetzen. Ich konnte beim besten Willen nicht die Ursache auch nur Ansatzweise finden...
Passiert eben manchmal!

Aber jetz bin ich froh, dass alles funktioniert.
Bitte warten ..
Ähnliche Inhalte
Cloud-Dienste
Datensyncronisation zwischen email-Provider und owncloud-Provider
Frage von LinuxTuxFanCloud-Dienste

Guten Tag, trotz googlen bin ich nicht wirklich fündig geworden. Gegeben: Erster Provider: Email-Account (historisch älter) Mit Kalender & ...

Datenbanken
Ungültiges Memo- oder OLE-Objekt in Unterabfrage
gelöst Frage von ForgottenRealmDatenbanken4 Kommentare

Guten Morgen! Gleich vorweg muss ich gestehen, dass ich mich noch nicht sonderlich gut mit SQL auskenne, zudem hoffe ...

Microsoft
PROBLEM: Navision 2009 OLE Control
gelöst Frage von Server2503Microsoft3 Kommentare

Hallo Zusammen, wir verwenden MS Navision in der Version 2009. Seit heute taucht bei uns ein Fehler auf (siehe ...

Hosting & Housing
Provider für Firmenwiki
Frage von hajowiHosting & Housing5 Kommentare

Hallo, welchen Provider könnt Ihr für ein Firmenwiki empfehlen? Benötigt wird PHP und MySQL. Das Wiki ist geplant für ...

Neue Wissensbeiträge
Apple

IOS 11.2.1 stopft HomeKit-Remote-Lücke

Tipp von BassFishFox vor 21 StundenApple

Das Update für iPhone, iPad und Apple TV soll die Fernsteuerung von Smart-Home-Geräten wieder in vollem Umfang ermöglichen. Apple ...

Windows 10

Windows 10 v1709 EN murkst bei den Regionseinstellungen

Tipp von DerWoWusste vor 1 TagWindows 10

Dieser kurze Tipp richtet sich an den kleinen Personenkreis, der Win10 v1709 EN-US frisch installiert und dabei die englische ...

Webbrowser

Kein Ton bei Firefox Quantum über RDP

Tipp von Moddry vor 1 TagWebbrowser

Hallo Kollegen! Hatte das Problem, dass der neue Firefox bei mir auf der Kiste keinen Ton hat, wenn ich ...

Internet

EU-DSGVO: WHOIS soll weniger Informationen liefern

Information von sabines vor 1 TagInternet4 Kommentare

Wegen der europäische Datenschutzgrundverordnung stehen die Prozesse um die Registrierung von Domains auf dem Prüfstand. Sollte die Forderungen umgesetzt ...

Heiß diskutierte Inhalte
Hardware
Kein Bild mit nur einer bestimmten Grafikkarten - Mainboard Konfiguration
Frage von bestelittHardware18 Kommentare

Hallo zusammen, ich hatte schon einmal eine ähnliche Frage gestellt. Damals hatte ich genau das gleiche Problem. Allerdings lies ...

Windows Server
RODC kann nicht aus Domäne entfernt werden
Frage von NilsvLehnWindows Server18 Kommentare

HAllo, ich arbeite in einem Universitätsnetzwerk mit 3 Standorten. Die Standorte haben alle ein ESXi Cluster und auf diesen ...

Hardware
Links klick bei Maus funktioniert nicht
gelöst Frage von Pablu23Hardware16 Kommentare

Hallo erstmal. Ich habe ein Problem mit meiner relativ alten maus jedoch denke ich nicht das es an der ...

Netzwerkmanagement
Mehrere Netzwerkadapter in einem PC zu einem Switch zusammenfügen
Frage von prodriveNetzwerkmanagement16 Kommentare

Hallo zusammen Vorweg, ich konnte schon einige IT-Probleme mit Hilfe dieses Forums lösen. Wirklich klasse hier! Doch für das ...