Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

VisualStudio-Leeres Program kann kompiliert, aber nicht debuggt werden-Debugger defekt?

Frage Entwicklung VB for Applications

Mitglied: mathe172

mathe172 (Level 1) - Jetzt verbinden

08.12.2010, aktualisiert 09.12.2010, 5870 Aufrufe, 3 Kommentare

Hallo zusammen!

Seit kurzem habe ich das Problem, das ich eine komplett leeren Windows-FormsAnwendung nicht mehr debuggen kann. Wenn ich also ein neues Projekt machen, eine Windows-FormsAnwendung auswähle und dann auf debuggen gehe, kommt folgende Fehlermeldung (in Application.Designer.vb):
System.InvalidOperationException wurde nicht behandelt. 
  Message=Fehler beim Erstellen des Formulars. Weitere Informationen finden Sie in Exception.InnerException. Fehler: Eine externe Komponente hat eine Ausnahme ausgelöst..
Und hier die genauere Meldung:
  Source=FraktalGenerierer 
  StackTrace: 
       bei FraktalGenerierer.My.MyProject.MyForms.Create__Instance__[T](T Instance) in 17d14f5c-a337-4978-8281-53493378c1071.vb:Zeile 190. 
       bei FraktalGenerierer.My.MyProject.MyForms.get_Form1() 
       bei FraktalGenerierer.My.MyApplication.OnCreateMainForm() in c:\Programme\VB\FraktalGenerierer\FraktalGenerierer\My Project\Application.Designer.vb:Zeile 35. 
       bei Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.OnRun() 
       bei Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.DoApplicationModel() 
       bei Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.Run(String[] commandLine) 
       bei FraktalGenerierer.My.MyApplication.Main(String[] Args) in 17d14f5c-a337-4978-8281-53493378c1071.vb:Zeile 81. 
       bei System.AppDomain._nExecuteAssembly(RuntimeAssembly assembly, String[] args) 
       bei System.AppDomain.ExecuteAssembly(String assemblyFile, Evidence assemblySecurity, String[] args) 
       bei Microsoft.VisualStudio.HostingProcess.HostProc.RunUsersAssembly() 
       bei System.Threading.ThreadHelper.ThreadStart_Context(Object state) 
       bei System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean ignoreSyncCtx) 
       bei System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state) 
       bei System.Threading.ThreadHelper.ThreadStart() 
  InnerException: System.Runtime.InteropServices.SEHException 
       ErrorCode=-2147467259 
       Message=Eine externe Komponente hat eine Ausnahme ausgelöst. 
       Source=System.Drawing 
       StackTrace: 
            bei System.Drawing.SafeNativeMethods.Gdip.GdipCreateFontFromLogfontW(HandleRef hdc, Object lf, IntPtr& font) 
            bei System.Drawing.Font.FromLogFont(Object lf, IntPtr hdc) 
            bei System.Drawing.Font.FromHfont(IntPtr hfont) 
            bei System.Drawing.SystemFonts.get_DefaultFont() 
            bei System.Windows.Forms.Control.get_DefaultFont() 
            bei System.Windows.Forms.Control.GetDefaultFontHandleWrapper() 
            bei System.Windows.Forms.Control.get_FontHandle() 
            bei System.Windows.Forms.ContainerControl.GetFontAutoScaleDimensions() 
            bei System.Windows.Forms.ContainerControl.get_CurrentAutoScaleDimensions() 
            bei System.Windows.Forms.ContainerControl.get_AutoScaleFactor() 
            bei System.Windows.Forms.ContainerControl.PerformAutoScale(Boolean includedBounds, Boolean excludedBounds) 
            bei System.Windows.Forms.ContainerControl.PerformNeededAutoScaleOnLayout() 
            bei System.Windows.Forms.Form.OnLayout(LayoutEventArgs levent) 
            bei System.Windows.Forms.Control.PerformLayout(LayoutEventArgs args) 
            bei System.Windows.Forms.Control.System.Windows.Forms.Layout.IArrangedElement.PerformLayout(IArrangedElement affectedElement, String affectedProperty) 
            bei System.Windows.Forms.ContainerControl.LayoutScalingNeeded() 
            bei System.Windows.Forms.ContainerControl.set_AutoScaleMode(AutoScaleMode value) 
            bei FraktalGenerierer.Form1.InitializeComponent() in c:\Programme\VB\FraktalGenerierer\FraktalGenerierer\Form1.Designer.vb:Zeile 26. 
            bei FraktalGenerierer.Form1..ctor() 
       InnerException: 
Habt ihr eine Idee woran das liegen könnte? -Wie gesagt, kompilieren und dann die .exe ausführen geht einwandfrei...

Mathe172
Mitglied: chuebner-md
09.12.2010 um 16:04 Uhr
Hallo,

ich habe seit heute morgen exakt das selbe Problem (Windows XP SP3).

Gestern habe ich zusätzlich zu VC# 2010 Express noch Visual Studio 2010 Professional installiert.
Außerdem habe ich gestern die Trial-Version von JetBrains dotTrace 3.5 Memory installiert.
Anschließend funktionierte aber noch alles einwandfrei. Erst seit heute morgen nach dem Aufwachen aus
dem StandBy wird beim Debuggen jedes Windows Forms Programms eine SEHException in der InitializeComponent-Methode ausgelöst.

Ich habe schon Visual Studio und JetBrains dotTrace deinstalliert und auch VC# 2010 Express inklusive .Net Framework 4
komplett neuinstalliert, das hat aber nichts gebracht.

Hat noch jemdand dieses Problem beobachtet?
Bitte warten ..
Mitglied: chuebner-md
10.12.2010 um 13:31 Uhr
Das Problem wird durch den Virenscanner Avira AntiVir verursacht.

Folgende Anleitung behebt das Problem:

http://www.avira.com/en/support-for-business-knowledgebase-detail/kbid/ ...

Ein weiterer Beweis dafür, dass Antivirenprogramme mehr Ärger verursachen als sie vermeiden!
Bitte warten ..
Mitglied: mathe172
10.12.2010 um 18:15 Uhr
Hallo chuebner-md!

Vielen Dank! Endlich kann ich wieder programmieren

Eine kleine Frage hätte ich noch (warscheinlich steht es da, aber ich sehs nicht ): Muss ich das automatische Update draussen lassen bis etwas anderes in dem Artikel steht, oder?

Nochmals Danke,
Mathe172
Bitte warten ..
Ähnliche Inhalte
Festplatten, SSD, Raid
RAID 10 defekt, Festplatten leer
Frage von user987Festplatten, SSD, Raid16 Kommentare

Hallo IT Gemeinde, ich bin mit ein MEGA-Problem betraut worden. Nachdem ein übereifriger Mitarbeiter einen Server von einer AVIRA ...

Microsoft
Windows Service über Debugger starten
gelöst Frage von ComputernoobMicrosoft3 Kommentare

Hallo zusammen, ich habe ein Problem, und zwar muss ich einen Service über einen Debugger starten, und bekomme eine ...

Batch & Shell
Batch zum Program-Start
gelöst Frage von ManneKLBatch & Shell30 Kommentare

Hallo, komme hier nicht zum erforderlichen Ergebnis,daß nach dem Eintrag in der Registry das Programm,User bezogen, gestartet wird. hier ...

Apache Server
Apache 2 kompiliert - Unit für SytemD funktioniert nicht
Frage von TiTuxApache Server

Servus, ich habe unter Centos 7 den Apache 2.4 über die Quellen kompiliert. Soweit so gut, ich kann den ...

Neue Wissensbeiträge
Router & Routing

Lets Encrypt kommt auf die FritzBox

Information von bitcoin vor 56 MinutenRouter & Routing

In der neuesten Labor-Version der FB7490 integriert AVM unter anderem einen Let's Encrypt Client für Zugriffe auf das Webinterface ...

Internet

Was nützt HTTPS, wenn es auch von Phishing Web-Seiten genutzt wird

Information von Penny.Cilin vor 3 TagenInternet17 Kommentare

HTTPS richtig einschätzen Ob man eine Webseite via HTTPS aufruft, zeigt ein Schloss neben der Adresse im Webbrowser an. ...

Webbrowser

Bugfix für Firefox Quantum released - Installation erfolgt teilweise nicht automatisch!

Erfahrungsbericht von Volchy vor 4 TagenWebbrowser8 Kommentare

Hallo zusammen, gem. dem Artike von heise online wurde mit VersionFirefox 57.0.1 sicherheitsrelevante Bugs behoben. Entgegen der aktuellen Veröffentlichung ...

Sicherheit

Teamviewer Sessions können gekapert werden - Update tw. verfügbar

Information von sabines vor 4 TagenSicherheit6 Kommentare

In bestimmten Konstellationen können Teamviewer Sessions gekapert werden, wahrscheinlich aber ein recht unwahrscheinliches Szenario. Da der Teamviewer gerne für ...

Heiß diskutierte Inhalte
Vmware
Installation Windows 10 VMware
Frage von Ghost108Vmware17 Kommentare

Hallo zusammen, versuche gerade mit Hilfe des vshpere clients eine virtuelle Windows 10 maschine aufzusetzen. 1. virtuelle Maschine erstellt ...

Exchange Server
SBS 2011 E-Mails können gesendet werden, aber nicht von extern empfangen
Frage von andreas1234Exchange Server14 Kommentare

Hallo Community, ich habe das Problem, dass seit knapp zwei Wochen die E-Mails von meinem SBS 2011 einwandfrei gesendet ...

Voice over IP
Telefonstörung - Ortsrufnummern kein Verbindungsaufbau
Frage von Windows10GegnerVoice over IP10 Kommentare

Hallo, sowohl bei uns als auch beim Opa ist es über VoIP nicht möglich Ortsrufnummern anzurufen. Es kommt nach ...

Windows Server
Server 2012 über Eingabeaufforderung devmgmt.msc geht nicht
gelöst Frage von achim222Windows Server9 Kommentare

Hallo, ich habe hier einen Server 2012 der im Reparaturmodus startet. Es liegt an einem falschen VirtIO Treiber für ...