Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

VLAN mit Distributed Switch

Frage Netzwerke Cluster

Mitglied: Moritz.Er

Moritz.Er (Level 1) - Jetzt verbinden

18.12.2013, aktualisiert 21.12.2013, 2430 Aufrufe, 9 Kommentare, 2 Danke

Guten Abend zusammen,

folgende Problematik macht mir heute zu schaffen:
Ich habe in einem VMware Cluster zwei Host per Distributed Switch mit einem Up-Link über ein vLAN auf einem Netgear Switch verbunden. Die Ports auf dem Netgear Switch sind mit untagged konfiguriert. Wenn ich nun eine neue Gruppe erstelle und die VM’s dort hinzufüge, können diese wunderbar miteinander kommunizieren. Sobald Ich aber die Gruppe mit einem vLAN versehe, bricht die Verbindung zu den VM’s auf dem anderen Host ab. Ich kann leider nicht darauf verzichten den Gruppen vLAN‘s zu vergeben, weil einige VM’s auf Host 1 nur zu bestimmten VM’s auf Host 2 Kontakt haben dürfen.

Gruß Moritz
Mitglied: chfr77
18.12.2013 um 17:35 Uhr
Zuerst aus der Sicht der Switch:
Tagged VLAN bedeutet, dass eingehende Pakete eine VLAN-ID haben.
Untagged bedeutet, dass das Gerät in dem der entsprechende Netzwerkport ist alle Pakete einem VLAN zuordnet, egal ob und welche VLAN-ID die eingehenden Pakete haben.

Wahrscheinlich behandelt Deine Switch die VLAN-ID der Pakete zwischen Deinen Hosts gar nicht und gibt diese einfach innerhalb des gleichen (Default?-) VLAN auf dem gleichen Gerät weiter, das ist soweit gut bis dieser Trick nicht mehr geht.

Du bekommst eingehende Pakete mit unterschiedlichen VLAN-ID' und willst diese als solche von der Switch erkennen und verarbeiten lassen, also brauchst Du einen Trunk und überlappende VLAN-ID auf der Switch.

Weiterhin ist es nicht empfehlenswert bei einer Konfiguration MIT VLAN's das Default-VLAN für Nutzdatentransport zu verwenden, besser nur für die Verwaltungsadresse der Switch und anderer Netzwerkgeräte.
Bitte warten ..
Mitglied: Dobby
18.12.2013 um 17:52 Uhr
Hallo,

Ich habe in einem VMware Cluster zwei Host per Distributed Switch....
- Welchen Switch bitte?

mit einem Up-Link über ein vLAN auf einem Netgear Switch verbunden.
- Welchen Switch von Netgear?
- Ein VLAN über einen Uplink den man dann Trunk nennt verbunden.
Sollte meines Erachtens so heißen

Die Ports auf dem Netgear Switch sind mit untagged konfiguriert.
Welche Ports und wie viele denn ist das ein LAG (LACP)?

Wenn ich nun eine neue Gruppe erstelle und die VM’s dort hinzufüge,
können diese wunderbar miteinander kommunizieren.
Gruppe gleich VLAN, oder?

Sobald Ich aber die Gruppe mit einem vLAN versehe, bricht die Verbindung zu den VM’s
auf dem anderen Host ab.
Nochmal die Frage ist das ein LAG?
Bei einigen neueren Switchen von Netgear verhält es sich nämlich so, dass man wenn man ein LAG (LACP)
angelegt hat, nicht die LAN Ports (Switch Ports) dem LAG hinzufügt sondern das LAG hinzufügen muss!!!

Ich kann leider nicht darauf verzichten den Gruppen vLAN‘s zu vergeben,
In der regel sieht es doch so aus:
- VLAN anlegen
- Mitglieder zuweisen (Switch Ports)
- tagged oder untagged setzen
- abspeichern

weil einige VM’s auf Host 1 nur zu bestimmten VM’s auf Host 2 Kontakt haben dürfen.
Gut das kann man dann ja hinterher über Switch ACLs regeln.

Gruß
Dobby
Bitte warten ..
Mitglied: chfr77
18.12.2013 um 18:02 Uhr
Zitat von Dobby:

Hallo,

> Ich habe in einem VMware Cluster zwei Host per Distributed Switch....
- Welchen Switch bitte?
Eine virtuelle Switch von vSphere innerhalb des vmWare Hypervisors, hat er doch geschrieben.

> mit einem Up-Link über ein vLAN auf einem Netgear Switch verbunden.
- Welchen Switch von Netgear?
- Ein VLAN über einen Uplink den man dann Trunk nennt verbunden.
Sollte meines Erachtens so heißen
Irgendeine mit managebare VLAN's, Modell spielt keine Rolle
Uplink heißt alles mögliche, vielleicht auch Stackport ohne Speicherpuffer, spielt auch keine Rolle

> Die Ports auf dem Netgear Switch sind mit untagged konfiguriert.
Welche Ports und wie viele denn ist das ein LAG (LACP)?
nein ist es nicht, wozu sollte das wichtig sein? Wenn dann wird die Aggregationsgruppe als ein VLAN-Trunk konfiguriert

> Wenn ich nun eine neue Gruppe erstelle und die VM’s dort hinzufüge,
> können diese wunderbar miteinander kommunizieren.
Gruppe gleich VLAN, oder?
Das ist eine Portgruppe auf der virtuellen Switch die dann ein anderes VLAN haben KANN, aber nicht muss.
> Sobald Ich aber die Gruppe mit einem vLAN versehe, bricht die Verbindung zu den VM’s
> auf dem anderen Host ab.
Nochmal die Frage ist das ein LAG?
Nochmal: Spielt keine Rolle
Bei einigen neueren Switchen von Netgear verhält es sich nämlich so, dass man wenn man ein LAG (LACP)
angelegt hat, nicht die LAN Ports (Switch Ports) dem LAG hinzufügt sondern das LAG hinzufügen muss!!!
s.o.
> Ich kann leider nicht darauf verzichten den Gruppen vLAN‘s zu vergeben,
In der regel sieht es doch so aus:
- VLAN anlegen
- Mitglieder zuweisen (Switch Ports)
- tagged oder untagged setzen
oh mann ...
Bitte warten ..
Mitglied: Dobby
18.12.2013 um 18:21 Uhr
Eine virtuelle Switch von vSphere innerhalb des vmWare Hypervisors, hat er doch geschrieben.
Nein hat er nicht, also schreib hier auch nicht so einen Käse!

Distributed Switch
Das war seine Aussage.

nein ist es nicht, wozu sollte das wichtig sein?
Blo´weil Du es nicht schnallst musst Du mich hier nicht so anmachen,
wenn Dir das nicht gefällt lass mich in Ruhe und mach wen anders an!

Nochmal: Spielt keine Rolle
Mensch halt Deinen da raus und quatsch keine Müll zusammen.
Du hast doch wohl gelesen dass es bei einigen Switchen von Netgear sich so verhält,
dass man nicht die Ports sonder das LAG hinzufügen muss sonst funktioniert es nicht!

Gruß
Dobby
Bitte warten ..
Mitglied: it-frosch
18.12.2013 um 18:29 Uhr
hallo Dobby,

wieder zu wenig geschlafen?
Du wirst unsachlich.

grüße vom it-frosch
Bitte warten ..
Mitglied: Dobby
18.12.2013 um 18:31 Uhr
hallo Dobby,
wieder zu wenig geschlafen?
Du wirst unsachlich.
grüße vom it-frosch

Wo "getrollt" wird bist Du nicht weit oder?
Bitte warten ..
Mitglied: Moritz.Er
18.12.2013, aktualisiert um 19:46 Uhr
Wahrscheinlich behandelt Deine Switch die VLAN-ID der Pakete zwischen Deinen Hosts gar nicht und gibt diese einfach innerhalb des
gleichen (Default?-) VLAN auf dem gleichen Gerät weiter, das ist soweit gut bis dieser Trick nicht mehr geht.
Genau das dachte ich mir und deswegen habe ich mich für die Untagged Konfiguration entschieden, der Switch soll die Pakete wie er sie auf Port 19 bekommt, genau so auf Port 20 weitergeben.

Du bekommst eingehende Pakete mit unterschiedlichen VLAN-ID' und willst diese als solche von der Switch erkennen und
verarbeiten lassen, also brauchst Du einen Trunk und überlappende VLAN-ID auf der Switch.
Nachdem ich im Switch Port 19 und 20 in einem vLAN auf Tagged gestellt habe funktioniert es auch nicht.
http://s1.directupload.net/file/d/3475/eoflezkv_png.htm

Weiterhin ist es nicht empfehlenswert bei einer Konfiguration MIT VLAN's das Default-VLAN für Nutzdatentransport zu
verwenden, besser nur für die Verwaltungsadresse der Switch und anderer Netzwerkgeräte.
Die Brücke für die Host befindet sich auf dem Switch in einem eigenem VLAN
Bitte warten ..
Mitglied: aqui
LÖSUNG 19.12.2013, aktualisiert 21.12.2013
Der Links vom internen vSwitch muss tagged sein auf die physische Switch Infrastruktur ! Ansonsten kannst du die VLAN IDs nicht übertragen.
Bei NetGear ist die Konfiguration sehr gewöhnungsbedürftig um das mal vorsichtig auszudrücken. Sie unterscheidet sich erheblich in der Logik von dem was andere Hersteller machen, deshalb ist das immer eine erhöhte Fehlerquelle.
Eigentlich ein Grund generell von NetGear die Finger zu lassen aber mit etwas Geschick bekommt man das problemlos zum Fliegen.
Dieses Tutorial erklärt dir genau wie du die NetGears mit Tagging in den Griff bekommst:
http://www.administrator.de/wissen/vlan-installation-und-routing-mit-m0 ...
Bitte warten ..
Mitglied: chfr77
19.12.2013 um 15:19 Uhr
Ich habe mir gerade Dein Bild angesehen und gehe davon aus, dass Du für die Ports der Server nacheinander die gleichen VLAN-ID' wie auf dem virtuellen Switch als "Tagged" wählen musst. Wenn Pakete aus unterschiedlichen VLAN's auf einem Port hereinkommen nennt man das einen VLAN-Trunk.

Leider muss ich zustimmen, dass die Konfiguration von diesem Gerät gewöhnungsbedürftig ist. Das Tutorial von @aqui und das PDF-Handbuch vom Hersteller sind wohl die beste Wahl.
Bitte warten ..
Neuester Wissensbeitrag
Microsoft

Lizenzwiederverkauf und seine Tücken

(5)

Erfahrungsbericht von DerWoWusste zum Thema Microsoft ...

Ähnliche Inhalte
Heiß diskutierte Inhalte
Windows Netzwerk
Windows 10 RDP geht nicht (16)

Frage von Fiasko zum Thema Windows Netzwerk ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Microsoft Office
Keine Updates für Office 2016 (13)

Frage von Motte990 zum Thema Microsoft Office ...