Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

VLAN nicht erreichbar

Frage Netzwerke LAN, WAN, Wireless

Mitglied: lattenlui

lattenlui (Level 1) - Jetzt verbinden

22.10.2014, aktualisiert 12:27 Uhr, 1075 Aufrufe, 1 Kommentar

Hallo liebes Forum,

ich benötige mal wieder eure Hilfe. Ich habe auf einem Cisco 3750 Switch zwei VLAN eingerichtet:

interface Vlan50
description VLAN50
ip address 192.168.50.240 255.255.255.0
no ip redirects
no ip route-cache cef
no ip route-cache
!
interface Vlan60
description VLAN60
ip address 192.168.60.240 255.255.255.0
no ip redirects
no ip route-cache cef
no ip route-cache


Jetzt habe ich zwei Interfaces wie folgt konfiguriert:

interface GigabitEthernet1/0/11
switchport trunk encapsulation dot1q
switchport trunk native vlan 50
switchport trunk allowed vlan 50,60
switchport mode dot1q-tunnel
!
interface GigabitEthernet1/0/12
switchport trunk encapsulation dot1q
switchport trunk native vlan 50
switchport trunk allowed vlan 50,60
switchport mode dot1q-tunnel

Ich teste jetzt folgendes:
- Ein Laptop hängt am Port 1/0/11 und hat die IP 192.168.50.20; ein zweites Laptop hängt am Port 1/0/12 und hat die IP 192.168.50.30 >>> Ping untereinander klappt (allerdings erst, nachdem ich das Native VLAN gesetzt hatte)

- Ändere ich an einem Laptop die IP auf 192.168.60.20 ist dieses aus dem 50er VLAN nicht zu erreichen.

Das verstehe ich nicht, da ich doch auf beiden Interfaces einen Trunk konfiguriert habe und ich beide VLAN zulasse. sh access-lists ist leer; ich habe keine access-lists konfiguriert.

Warum habe ich keine Konnektivität, wenn sich beide Laptops in unterschiedlichen VLAN befinden?
Mitglied: aqui
LÖSUNG 22.10.2014, aktualisiert um 12:27 Uhr
Der Kardinalsfehler ist das du für den Laptop Anschluss einen Access Port benutzen musst aber KEINEN Tagged Uplink Port wie du es gemacht hast.
Deine Port Konfig ist also vollkommen falsch !
Richtig muss diese lauten:
interface GigabitEthernet1/0/11
description Laptop 1
switchport mode access
switchport access vlan 50
!
interface GigabitEthernet1/0/12
description Laptop 2
switchport mode access
switchport access vlan 50
!

Dann funktioniert es auch alles wie von dir gewünscht !
Das verstehe ich nicht, da ich doch auf beiden Interfaces einen Trunk konfiguriert habe und ich beide VLAN zulasse
Na ja etwas nachdenken über deinen Konfig, dann versteht man es auch...
In deiner Konfig hast du es zwar zugelassen aber da du einen Tagged Uplink Port definiert hast mit beiden VLANs sendet der Switch das VLAN 60 mit einem 802.1q VLAN Tag aus. Durch die Native VLAN Definition hebst du das für das VLAN 50 auf. Der Switch sendet jetzt also alles aus dem VLAN 50 ohne 802.1q Tag an dem Port aus alles vom VLAN 60 aber mit diesem Tag.
Dein Laptop als Endgerät versteht generell ohne entsprechende Konfig aber gar kein Tagging !
Durch das "Verbiegen" des Native VLANs hast du es immerhin so wieder zurechtgefrickelt das VLAN 50 untagged am laptop ankommt.
So oder so ist das komplett die falsche Konfig !
Untagged Accessports musst du auch entsprechend so konfigurieren.
Willst du mehrere VLANs übertragen musst du auch komplett taggen und auch das Endgerät bzw. dessen netzwerkkarte so einstellen das sie tagged VLANs versteht.
So wird ein Schuh draus !!

Hilfe zu genau dem Thema mit Konfig Beispielen von Switch und auch NICs bieten dir auch diese Forums Tutorials:
http://www.administrator.de/wissen/vlan-installation-und-routing-mit-m0 ...
und
http://www.administrator.de/wissen/vlan-routing-über-802-1q-trunk- ...
Bitte warten ..
Ähnliche Inhalte
Netzwerkgrundlagen
VLAN Struktur - Switches in welches VLAN (3)

Frage von ITF02 zum Thema Netzwerkgrundlagen ...

LAN, WAN, Wireless
Management VLAN - tagged oder untagged, VLAN-Hopping (3)

Frage von stephan902 zum Thema LAN, WAN, Wireless ...

Netzwerke
VLAN Tagging (5)

Frage von DerNoob89 zum Thema Netzwerke ...

Neue Wissensbeiträge
Ubuntu

Ubuntu 17.10 steht zum Download bereit

(3)

Information von Frank zum Thema Ubuntu ...

Datenschutz

Autofahrer-Pranger - Bewertungsportal illegal

(8)

Information von BassFishFox zum Thema Datenschutz ...

Windows 10

Neues Win10 Funktionsupdate verbuggt RemoteApp

(8)

Information von thomasreischer zum Thema Windows 10 ...

Microsoft

Die neuen RSAT-Tools für Win10 1709 sind da

(2)

Information von DerWoWusste zum Thema Microsoft ...

Heiß diskutierte Inhalte
Windows 10
Seekrank bei Windows 10 (18)

Frage von zauberer123 zum Thema Windows 10 ...

Windows 10
Windows 10 Fall Creators Update Fehler (14)

Frage von ZeroCool23 zum Thema Windows 10 ...

Router & Routing
gelöst Getrenntes Routing bei VoIP und Daten (12)

Frage von Hobbystern zum Thema Router & Routing ...