Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

VLAN- Firewallproblem extrem langsame Verbindung

Frage Netzwerke LAN, WAN, Wireless

Mitglied: mkaefer

mkaefer (Level 1) - Jetzt verbinden

27.07.2012 um 20:36 Uhr, 3668 Aufrufe, 1 Kommentar

Hallo liebe Mitadmins,

ich hoffe jemand hatte diesen Effekt schon und kann mir einen Tipp geben an welcher Stelle ich den Fehler suchen muss...

Folgendes Setup:

Firewall (Checkpoint R75.40 auf HP Dl360) mit 6 Netzwerkinterfaces
Am DMZ Interface: Switch HP Procurve 3500yl
Am Switch 2 Citrix XenServer mit jeweils 1+2 NIC-Bonding

Firewallseitig:
eth0 keine IP (Default VLAN/untagged)
eth0.2 VLAN2 für das VLAN Interface eines virtuellen Servers am XenServer1(ClientOS Linux)
eth0.3 VLAN3 für das VLAN Interface eines virtuellen Servers am XenServer1(ClientOS Windows Server 2008R2)
eth0.4 VLAN4 für das VLAN Interface eines virtuellen Servers am XenServer2 (ClientOS Linux)
eth0.5 VLAN5 hier hängen die 2 Managementinterfaces der 2 XenServer
eth1 Verbindung ins interne Netzwerk (ebenfalls mit HP Switchen und mehreren VLANs)

XenServer1:
eth0+eth1 = NIC0+1 und hängt untagged im VLAN5 (über diese IP erfolgt z.B. der XenCenter-Zugriff)
NIC0+1.2 VLAN2: einer der virtuellen Maschinen zugewiesen
NIC0+1.3 VLAN3: einer anderen virtuellen Maschine zugewiesen

XenServer2:
eth0+eth1 = NIC0+1 und hängt untagged im VLAN5 (über diese IP erfolgt z.B. der XenCenter-Zugriff)
NIC0+1.2 VLAN4: einer der virtuellen Maschinen zugewiesen

SwitchPorts:

Firewall: Untagged 1 / Tagged 2,3,4,5
XenServer1: Untagged 5 / Tagged 2,3
XenServer2: Untagged 5 / Tagged 4

--

Nun geschieht folgender Effekt:

die Verbindungen aus dem internen Netz auf die XenServer selbst (welche für die Firewall im VLAN 5 liegen und aus Sicht der XenServer normal im Untagged) funktioniert einwandfrei. Die Verbindung aus dem internen Netz zu einer der VMs im VLAN 2,3 und 4 ist extrem langsam (ssh login z.B. dauert gut 2 Minuten um die Zeichen zu übertragen). Umgekehrt auch der gleiche Effekt wenn man den virtuellen Maschinen z.B. Zugriff auf eine Apache Testseite im internen Netz gibt, laden Sie knapp eine Minute daran.

Da der Zugriff über den gleichen physikalischen Übertragungsweg auf die untagged Interfaces aber funktioniert schließe ich mal physikalische Ursachen aus.

Noch interessanter ist folgendes: gebe ich an den virtuellen Maschinen z.B. www.google.de ein öffnet sich google sofort weshalb ich mal davon ausgehe, dass irgendwas mit dem Zusammenspiel zwischen

IntranetSwitch+VLAN->Firewall+VLAN->DMZSwitch+VLAN->XenServer+VLAN

nicht passt. Das NIC-Bonding habe ich schon testweise entfernt und nur mit einem Kabel gearbeitet mit dem gleichen Effekt. Lege ich die betroffenen VMs auf ein eigenes Interface ohne VLAN zu nutzen ist der Fehler auch weg (belegt halt dann mehr Netzwerkports als ich zur Verfügung habe).

Ich hoffe irgendjemand ließt sich das durch und sagt auf anhieb: "so ein Idiot, der Fehler ist doch ganz offensichtlich..." und kann mir bei der Lösung etwas helfen.

Vielen Dank bereits an alle Leser und viele Grüße

Marcel
Mitglied: mkaefer
28.07.2012 um 08:36 Uhr
Erledigt, XenServer 6.0.2 HOTFIX005 löst genau dieses Problem.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
LAN, WAN, Wireless
Langsame Verbindung zu FRITZ!Box (1)

Frage von eQuest zum Thema LAN, WAN, Wireless ...

Switche und Hubs
POE+ Switch langsame RDP-Verbindung (4)

Frage von mksadm zum Thema Switche und Hubs ...

LAN, WAN, Wireless
VLAN Mikrotik keine Verbindung zum Gateway Cisco Switch (16)

Frage von Joshua2go zum Thema LAN, WAN, Wireless ...

Netzwerkgrundlagen
gelöst Vlan Routing Pfsense APU2 vs L3 (6)

Frage von TimMayer zum Thema Netzwerkgrundlagen ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (14)

Frage von liquidbase zum Thema Windows Update ...