Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

VLAN über mehrere Switche und Router

Frage Netzwerke

Mitglied: xtension

xtension (Level 1) - Jetzt verbinden

09.09.2010, aktualisiert 18.10.2012, 8864 Aufrufe, 4 Kommentare

Ich habe folgendes Problem, ich will ein VLAN (Testnetz, ID10) über zwei Netzsegmente aufbauen. Dabei besteht das kompl. Netz aus managebaren ProCurves (meist noch 2650er) und einem Layer3 Cisco Switch welches als Router eingesetzt wird.

So soll das ganze dann aussehen:

Switch1----Switch2----Switch3----Cisco Router----Switch4----Switch5
VLAN 10.............................................................................................VLAN10

An Switch1 und Switch5 ist das VLAN eingetragen und auch die entsprechenden Ports zugewiesen, sowie das Tag bei den Uplink Ports gesetzt.
Muß ich jetzt an den anderen Switchen auch noch das VLAN eintragen für die Uplink Ports bzw. GVRP aktivieren?

Und wie ist das mit dem Cisco Switch bzw. Router, reicht es wenn das auch dort für die Ports aktiviert wird?

Viele Grüße
XT
Mitglied: aqui
09.09.2010, aktualisiert 18.10.2012
Die Konfig ist relativ simpel was die HP Switches anbetrifft und sieht so aus:
HP_Switch#

time timezone 60
time daylight-time-rule Middle-Europe-and-Portugal
spanning-tree protocol-version rstp
spanning-tree force-version rstp-operation
exit
interface 23
name "Tagged Uplink zuSwitch x"
interface 24
name "Tagged Uplink zuSwitch y"
exit
vlan 1
name "DEFAULT_VLAN"
untagged 1-24
ip address 172.16.1.254 255.255.255.0
exit
vlan 10
name "Testnetz"
untagged 1-5
tagged 23-24
exit

Damit hast du die ersten 5 Ports dann im Testnetz mit der VLAN ID 10 und an den Ports 23 und 24 werden das default VLAN 1 und das VLAN 10 dann tagged (VLAN 1 untagged) übertragen. Die Switches verbindest du dann alle immer über diese Uplink Ports 23 und 24.
Bei 48 Port Switches usw. musst du die Portnummern dann ggf. auf deine Belange anpassen !!

Das kritische Problem ist der Cisco in der Mitte !
Wenn das wirklich ein "richtiger" Router ist, dann ist die Konfiguration nur bedingt möglich, denn damit hättest du das "Testnetz" ja mit der gleichen IP Adresse an 2 Ports.
Wie du selber weisst muss ein Router immer unterschiedliche IP Netze an seine Ports haben. Der Router kann lediglich routen aber das tagged VLAN 10 dann nicht weiterreichen.
Ist der "Cisco Router" allerdings ein Cisco Layer 3 Switch, also ein Routing fähiger Switch, ist das problemlos machbar und die Konfig auch relativ simpel und banal:

Cisco_Switch#

clock timezone MET 1
clock summer-time MEST recurring last Sun Mar 2:00 last Sun Oct 3:00
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
description Enduser Ports in VLAN 10
switchport access vlan 10
spanning-tree portfast
!
interface FastEthernet0/2
description Enduser Ports in VLAN 10
switchport access vlan 10
spanning-tree portfast
!
interface FastEthernet0/23
description Tagged Uplink zum HP
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface FastEthernet0/24
description Tagged Uplink zum HP
switchport mode trunk
switchport trunk encapsulation dot1q
!
!
interface Vlan1
ip address 172.16.1.254 255.255.255.0
no ip route-cache
!
interface Vlan10
ip address 172.16.10.254 255.255.255.0
no ip route-cache
!
end

Fertig. Auch hier wieder die Uplink Ports 23 und 24 (ggf. anpassen wenn du andere Ports hast !) und die Ports 1 und 2 als Endgeräteports im VLAN10 das hier im Beispiel im IP Netz 172.16.10.0 /24 arbeitet !!

Wenn der Cisco doch ein Router ist benötigst du zwingend ein IP plus Image auf dem Router und dann musst du dort mit Subinterfaces arbeiten mit folgender Konfig:

!
interface FastEthernet 1
172.16.1.254 255.255.255.0
ip address 172.16.1.254 255.255.255.0
!
interface FastEthernet 1.10
encapsulation dot1Q 10
ip address 172.16.10.254 255.255.255.0
!

Das routet dann allerdings nur am Port FastEthernet 1 und eine Kopplung auf dieselbe VLAN ID auf einem 2ten Port ist dann nur möglich wenn du am Router ein Bridging konfigurierst was dann so aussiehst:
!
interface FastEthernet 1
172.16.1.254 255.255.255.0
ip address 172.16.1.254 255.255.255.0
!
interface FastEthernet 1.10
encapsulation dot1Q 10
bridge-group 10
!
interface FastEthernet 2
bridge-group 10
!
Damit ist ein Routing der VLANs dann unmöglich, denn der Cisco ist dann lediglich eine simple Bridge zwischen den VLANs. Letztlich ist also die Cisco Switch Konfig einfacher aber leider gibst du ja nicht an WAS genau der Cisco Router ist !
Ggf. hilft dir noch dieses Tutorial mit weiteren Infos:
http://www.administrator.de/wissen/vlan-installation-und-routing-mit-m0 ...

Eine Warnung noch zum Schluss: Das Spanning Tree Protokoll zwischen Cisco und HP ist nicht kompatibel. HP supportet kein PVST+ (Per VLAN Spanning Tree) !!
Ein redundantes Szenario kannst du also mit dem Mix Cisco und HP nicht konfigurieren ohne das du Gefahr läufst das dein Netz kollabiert !
Nichtredundant rennt das aber vollkommen problemlos im Handumdrehen !
Bitte warten ..
Mitglied: xtension
09.09.2010 um 12:51 Uhr
Wow! Erst mal vielen Dank für deine ausführliche Antwort!

Mit den HPs ist das so weit klar.

Der Cisco ist ein Catalyst 3550-24 und verbindet die beiden Teilnetze 10.10.0.0/16 mit 10.20.0.0/16.

Beim VLAN soll sich der Cisco aber bestenfalls als Bridge verhalten, also einfach das VLAN weiterreichen. Das Testnetz arbeitet allerdings auch mit 10.10.0.0/16. Würde das den trotzdem gehen?
Bitte warten ..
Mitglied: aqui
09.09.2010 um 15:58 Uhr
Na bestens, dann ist doch alles in Butter und die Installation in 5 Minuten gemacht Die Cisco 3550er Konfig sieht dann so aus:
Cisco_Switch#

clock timezone MET 1
clock summer-time MEST recurring last Sun Mar 2:00 last Sun Oct 3:00
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
description Enduser Ports in VLAN 10
switchport access vlan 10
spanning-tree portfast
!
interface FastEthernet0/2
description Enduser Ports in VLAN 10
switchport access vlan 10
spanning-tree portfast
!

(Die beiden untagged Interfaces 0/1 und 0/2 im Beispiel kannst du weglassen wenn der Cisco das VLAN 10 nur durchreichen soll über die Ports 23 und 24 (oder Ports deiner Wahl) und an ihm KEINE Enderäte im VLAN 10 angeschlossen sind ! )

interface FastEthernet0/23
description Tagged Uplink zum HP Switch 3
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface FastEthernet0/24
description Tagged Uplink zum HP Switch 4
switchport mode trunk
switchport trunk encapsulation dot1q
!
!
interface Vlan1
ip address 10.20.0.254 255.255.0.0
no ip route-cache
!
interface Vlan10
(Kann weggelassen werden wenn KEIN Routing des VLAN 10 erforderlich !)
ip address 10.20.0.254 255.255.0.0
no ip route-cache
!
end

Vorher natürlich auf dem Cisco noch mit vlan 10 name Testnetz das VLAN 10 anlegen.
Wenn du das Testnetz NICHT routen willst auf dem Cisco 3550 dann lässt du einfach die Konfig:
!
interface Vlan10
ip address 10.20.0.254 255.255.0.0
no ip route-cache
!

weg, dann schleift der Cisco nur durch !
Ansonsten wenns doch mit Routing in die anderen netze sein soll einfach auf dem Clients im Testnetz dann die 10.20.0.254 (Beispiel) als Gateway eingeben und gut ist.
Damit hast du dann auch Connectivity in die anderen VLANs.


Wenns das war
http://www.administrator.de/index.php?faq=32
nicht vergessen !
Bitte warten ..
Mitglied: xtension
09.09.2010 um 16:18 Uhr
Ja super, das ist genau die Antowort auf die ich gehofft habe.

Mit den Infos bekomme ich das ans laufen.

Also, nochmals vielen Dank für die schnelle und ausführliche Antwort!

Gruß
XT
Bitte warten ..
Ähnliche Inhalte
Netzwerke
VLAN Problem zwischen Switch und Router
gelöst Frage von Diddi93Netzwerke3 Kommentare

Hallo liebe Community, Ich bin im Moment dabei ein Netzwerk einzurichten und verschiedene Geräte via VLAN's von einander zu ...

Switche und Hubs
VLANs nach Router mit Switch und WLAN AP
gelöst Frage von Yeti123Switche und Hubs13 Kommentare

Hallo zusammen an das Forum, ich habe mich schon etwas in VLANs eingelesen und habe folgendes vor. Ich möchte ...

Netzwerkgrundlagen
VLAN Struktur - Switches in welches VLAN
Frage von ITF02Netzwerkgrundlagen3 Kommentare

Hallo zusammen, ich benötige ein paar Tipps und Anregungen bzlg. der VLAN Struktur. Ich habe folgende Struktur, welche auch ...

Router & Routing
VLAN mit Lancom Router und Switch - Allgemeine Verständnisfragen
Frage von knuddel256Router & Routing5 Kommentare

Hallo zusammen, aufgrund von Firmenumzug und damit verbundenen neuen Anforderungen beschäftige ich mich gerade mit dem Thema VLAN. Momentan ...

Neue Wissensbeiträge
Erkennung und -Abwehr

Necur-Botnet soll Erpressungstrojaner Scarab massenhaft verbreiten

Information von BassFishFox vor 52 MinutenErkennung und -Abwehr

12,5 Millionen Spam-Mails aus einem Bot-Netz mit 6 Millionen Computern? Eigentlich eine schwache Leistung. Die Erpresser setzen dabei auf ...

Microsoft

Nadeldrucker-Problem unter Windows - Microsoft liefert Updates

Information von BassFishFox vor 1 StundeMicrosoft

Hat ja nicht lange gedauert. Nachdem die November-Updates für Windows 7, 8.1 und 10 zahlreiche Nadeldrucker lahmgelegt hatten, stellt ...

Linux

Limux-Ende in München: Wie ein Linux Projekt unter Ausschluss der Öffentlichkeit zerstört wurde

Information von Frank vor 8 StundenLinux14 Kommentare

Mein persönlicher Kommentar zum Thema "Limux-Ende". Die SPD-Politikerin Anne Hübner hat die Richtung von München ganz klar definiert: "Wir ...

Batch & Shell

Open Object Rexx: Eine mittlerweile fast vergessene Skriptsprache aus dem Mainframebereich

Information von Penny.Cilin vor 1 TagBatch & Shell9 Kommentare

Ich kann mich noch sehr gut an diese Skriptsprache erinnern und nutze diese auch heute ab und an noch. ...

Heiß diskutierte Inhalte
Linux
Limux-Ende in München: Wie ein Linux Projekt unter Ausschluss der Öffentlichkeit zerstört wurde
Information von FrankLinux14 Kommentare

Mein persönlicher Kommentar zum Thema "Limux-Ende". Die SPD-Politikerin Anne Hübner hat die Richtung von München ganz klar definiert: "Wir ...

Router & Routing
Zwei Netzwerke erstellen
Frage von bunteblumeRouter & Routing14 Kommentare

Hallo Zusammen, Ich möchte gerne ein backup von einem bestimmten Folder welcher auf dem Server regelmässig synchronisiert wird auf ...

Off Topic
Fachkräftemangel in Deutschland? - Talentschmiede schreibt alle 2 Tage die gleichen Stellen aus
Frage von Penny.CilinOff Topic12 Kommentare

Hallo, haben wir in Deutschland Fachkräftemangel? Die Talentschmiede schreibt gefühlt alle zwei Tage dieselben Stellen aus. Und das schon ...

Windows 10
Alle Programme mit bestimmtem Namen automatisch (per GPO) deinstallieren
gelöst Frage von lordofremixesWindows 1012 Kommentare

Hallo zusammen, gibt es eine Möglichkeit, alle Programme beginnend mit z.B. "Dell" im Namen per Script und somit per ...