Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Vlan und Routing mit HP proCurve Switchen

Frage Netzwerke Router & Routing

Mitglied: willineu

willineu (Level 1) - Jetzt verbinden

23.05.2012 um 06:55 Uhr, 9159 Aufrufe, 12 Kommentare

Hallo an Alle, ich bin neu im Forum und mit meinem Latein am Ende oder ich seh den Wald vor lauter Bäumen nicht mehr. Wir haben ca. 200 Clients, diverse Server und ein Netzwerk mit HP Switchen HP6200(Layer 3) der Rest 2510(Layer 2). Der Internet Anschluß erfolgt über eine Fortigate 110C. Falls jemand helfen kann, werde ich gerne die Switch Konfigurationen posten

Ich vesuche in unserem Firmennetzwerk die MAC Rechner in ein eigenes VLAN zu bringen. Sie sollen aber über unser Firewall ins Internet dürfen, aber nur auf einen Rechner im Default Vlan zugreifen dürfen auf den Rest nicht. Die VLans gehen über mehrere Switche. Wie bekomme ich das Routing hin, oder brauche ich das überhaupt.
Wir haben intern ein 111.0.0.0 und ein 10.10.0.0 Netz, die werden über NAT an der Firewall in gültige IP Adressen umgesetzt.
Konfig Etagenswitch

; J9280A Configuration Editor; Created on release #Y.11.35

hostname "EG IP 202 48er"
snmp-server contact "xxxxxx"
snmp-server location "EG Flur"
qos dscp-map 011010 name "tk-signaling"
qos dscp-map 011010 priority 5
qos dscp-map 101110 name "tk-payload"
qos dscp-map 101110 priority 6
interface 1
name "Trapez EG-Lan"
exit
interface 7
name "10-xxxx"
exit
interface 8
name "hp 1800 Switch"
exit
interface 45
name "OG3 10.50 11"
exit
interface 46
name "OG3 10.50 12"
exit
trunk 45-46 Trk1 Trunk
ip default-gateway 111.111.10.50
snmp-server community "public" Unrestricted
snmp-server host 111.111.11.16 "public"
snmp-server host 10.10.20.116 "public"
vlan 1
name "DEFAULT_VLAN"
untagged 1-23,25-37,39-44,47-Trk1
ip address 111.111.0.202 255.0.0.0
no untagged 24,38
exit
vlan 40
name "MAC"
tagged 8,37,Trk1
exit
fault-finder bad-driver sensitivity high
fault-finder bad-transceiver sensitivity high
fault-finder bad-cable sensitivity high
fault-finder too-long-cable sensitivity high
fault-finder over-bandwidth sensitivity high
fault-finder broadcast-storm sensitivity high
fault-finder loss-of-link sensitivity high
fault-finder duplex-mismatch-HDx sensitivity high
fault-finder duplex-mismatch-FDx sensitivity high
qos type-of-service diff-services
qos type-of-service diff-services 011010 dscp 011010
qos type-of-service diff-services 101110 dscp 101110
spanning-tree
spanning-tree Trk1 priority 4
password manager

Konfig HP 6200

; J8992A Configuration Editor; Created on release #K.15.06.0008
; Ver #01:0d:0c

hostname "MasterProCurve6200"
time timezone 60
time daylight-time-rule Western-Europe
module 1 type J8992A
no stack auto-join
interface 3
name "3.201 /24"
exit
interface 11
name "EG 0.202/45"
exit
interface 12
name "EG 0.202 /46"
exit
name "Backup Port 23"
exit
interface 24
name "Backup Port 24"
exit
trunk 23-24 Trk1 Trunk
trunk 11-12 Trk4 Trunk
ip default-gateway 10.1.3.1
ip routing
vlan 1
name "DEFAULT_VLAN"
untagged 1-8,13-15,17-18,20-22,Trk1-Trk4
ip address 111.111.10.50 255.0.0.0
exit
vlan 10
name "Hipath_FFM"
ip helper-address 111.111.100.2
ip address 10.10.0.1 255.255.0.0
tagged 3,15
voice
exit
vlan 2
name "Transit-GU-FFM"
ip address 10.1.2.1 255.255.255.0
tagged 3
exit
vlan 3
name "Transit-FFM-WAN"
ip address 10.1.3.254 255.255.255.0
tagged 3
exit
vlan 40
name "MAC"
tagged 3,Trk4
no ip address
exit
dhcp-relay option 82 replace validate
no dhcp-relay hop-count-increment
fault-finder bad-driver sensitivity high
fault-finder bad-transceiver sensitivity high
fault-finder bad-cable sensitivity high
fault-finder too-long-cable sensitivity high
fault-finder over-bandwidth sensitivity high
fault-finder broadcast-storm sensitivity high
fault-finder loss-of-link sensitivity high
fault-finder duplex-mismatch-hdx sensitivity high
fault-finder duplex-mismatch-fdx sensitivity high
timesync sntp
sntp unicast
sntp 300
sntp server priority 1 111.111.10.65
ip route 0.0.0.0 0.0.0.0 10.1.3.1
ip route 10.10.0.0 255.255.0.0 10.10.0.1
ip route 10.10.10.21 255.255.255.255 10.1.3.1
ip route 10.10.10.25 255.255.255.255 10.1.3.1
ip route 10.60.0.0 255.255.0.0 10.1.2.254
ip route 10.70.0.0 255.255.0.0 10.1.2.254
ip route 10.80.0.0 255.255.0.0 10.1.2.254
ip route 10.90.0.0 255.255.0.0 10.1.2.254
router vrrp
enable
exit
snmp-server community "public" unrestricted
snmp-server host 111.111.11.116 community "public"
snmp-server host 111.111.11.16 community "public"
snmp-server host 10.10.20.116 community "public"
snmp-server contact "xxx"
spanning-tree
spanning-tree Trk1 priority 4
spanning-tree Trk2 priority 4
spanning-tree Trk3 priority 4
spanning-tree Trk4 priority 4
spanning-tree priority 0
password manager

Die 10.1.3.1 ist die interne IP unsere Firewall. mit dem Client am VLAN 40 komme ich überall hin, cih möchte abr verbieten das er ins default bzw andere vlans kommt.
Danke und Gruß
Willi
Mitglied: MikeAlt
23.05.2012, aktualisiert um 08:27 Uhr
Hi, wenn du Vlan übergreifend Datenverkehr brauchst musst du routen.
Einschränkungen wer mit wem darf oder nicht kriegst du mit access-listen hin.
Das muss auf dem Device gemacht werden welches den Übergang der einzelnen VLAN realisiert. Entweder der Layer-3 Switch oder die Firewall.
Leider kenne ich mich mit HP oder Fortigate nicht so gut aus um dir da ein Beispiel zu nennen. Google ist dein Freund

gruss

Mike
Bitte warten ..
Mitglied: brammer
23.05.2012 um 09:21 Uhr
Hallo,

111.0.0.0 in einem internen Netz zu verwenden das mit dem Internet vebunden ist kann mehr als spaßig werden. Es handelt sich um eine Public IP die China Mobile gehört.
für solche Fälle gibt es doch genug Private IP Adresse nach RFC 1918
Eine Fehlkonfiguration auf deiner Fortigate und es kann spannend werden...

Was du damit erreichen willst die MAC's in ein eigenes VLAN zu bringen ist mir nicht klar.
Ansonsten kannst du auf den L3 Switchen über Access Listen und Routing doch problemlos bestimmen welches Netz, bzw. welcher Client wie wohin kommt.

brammer
Bitte warten ..
Mitglied: MrNetman
23.05.2012 um 10:13 Uhr
Hi Willi,

aber wenn du schon am Umbauen bist, dann vernichte doch das 111.x.y.z Netz. Das macht dir immer wieder Schwierigkeiten. Nutze unbedingt nur 10.x.y.z oder 172.x.y.z oder 192.168.x.y

VLANs werden geroutet - über den Layer 3 Switch oder die Firewall.

VLANs werden über das bei HP genutzte GVRP Protokoll verteilt und sind deshalb erst einmal auf allen Switchen vorhanden.

Die Bezeichnung default VLAN wird von den Herstellern unterschiedlich gehandhabt. Üblicherweise ist das ein VLAN, an dem ein weiterer unkonfigurierter oder schlecht konfigurierte Switch angeschlossen werden kann und dessen ungetaggte Pakete am Getaggten Port dann in das Default VLAN "verschoben" werden. Damit ist der Switch zum Konfigurieren erreichbar und kann evtl. auch sein VLAN- Informationen via das GVRP (bei Cisco VTP-Ptotokoll) erhalten.

Gruß
Netman
Bitte warten ..
Mitglied: aqui
23.05.2012, aktualisiert um 17:46 Uhr
Um mal wieder auf deine Frage zurückzukommen zur Abtrennung der Macs in ein VLAN:
Das ist ganz einfach. Wenn die Macs verteilt sind auf allen Switches musst du als allerersten Schritt ein neues VLAN einrichten wie du es mit dem VLAN 40 ja auch schon gemacht hast.
Das musst du auf allen Switches machen auf denen das VLAN 40 also die Macs angeschlossen sind.
Als nächsten Schritt richtest du das VLAN 40 TAGGED auf den Uplink Ports zwischen den Switches ein !
Das stellt sicher das das VLAN 40 auch zwischen den Switches untereinander ausgetauscht wird.
Genau das hast du ja auch richtigerweise auf dem Etagenswitch gemacht:
vlan 40
name "MAC"
tagged 8,37,Trk1

Fatal ist hier aber das du keinerleie Endgeräte Ports hier auf dem Etagenswitch für den Mac Rechner definiert hast !!!
Du hast die Ports 8, 37 und den Trunk 1 tagged übertragen also die Pakete die dort rausgehen aben als 802.1q Tag die VLAN 40 ID mit am Paket.
Dadurch können es nur Switches verstehen, damit sie diese Pakete wieder sauber einem VLAN zuordnen können.
Sollen die Ports 8 und 37 z.B. Ports für die Mac Rechner sind können diese die Pakete so niemals lesen, denn sie verstehen die 802.1q Erweiterung sprich das Tag nicht schmeissen die Pakete also weg !! Hier hättest du dann eienn Kardinalsfehler begangen !
Richtig würde das in der Konfig dann heissen:
vlan 40
name "MAC"
untagged 8,37
tagged Trk1

Analog das gleiche dann am Core Switch !!
Dort fehlt eibenfals eine gültige IP Adresse für das MAC VLAN so das diese Macs dann niemals mit den anderen VLANs sprich dem Internet kommunizieren können. Wie auch ohne Mac.
Scheinbar siehst du nicht nur den Wald vor lauter Bäumen nicht, du hast das Prinzip von VLANs und Routing auch gar nicht verstanden und vermutlich im Blindflug konfiguriert.
Also, sortieren wir alles einmal.
Wir nehmen jetzt mal an Der Etagenswitch ist mit dem Port 1 mit dem Core Switch verbunden am Port 3 und die Etage hat die Ports 8 und 37 für die Macs. Das Mac VLAN hat die IP 10.1.40.0 /24
Dann sieht dein Konfig für beide Switches so aus:
Core Switch 6200
vlan 40
name "MAC"
tagged 3
ip address 10.1.40.254 255.255.255.0
exit

Etagen Switch 2510
vlan 40
name "MAC"
tagged 1
untagged 8, 37
exit

Mac Client IPs
IP: 10.1.40.100 (z.B.)
Maske: 255.255.255.0
Gateway: 10.1.40.254 (HP L3 Switch)
DNS: Lokaler DNS oder Fortinet IP wenn die DNS proxy ist !

So wird ein Schuh draus !
Denk dran das du das neue IP Netz für die Macs in der Firewall entsprechend einstellst das die Mac Fraktion mit den neunen IPs ins Internet kommt !!

Damit du nochwas lernst solltest du diese Tutorial dringenst mal lesen zum Thema VLANs !!
http://www.heise.de/netze/artikel/VLAN-Virtuelles-LAN-221621.html
http://www.administrator.de/contentid/110259
http://www.administrator.de/contentid/58974
Bitte warten ..
Mitglied: willineu
23.05.2012 um 17:38 Uhr
Hallo,
danke für die schnellen Antworten, ich bin kein Netzprofi, deshalb frage ich ja nach und ja ich habe drauflos konfiguriert
am Etagen Switch hängt an Port 8 ein weiter Switch HP 1800 auf port 8 ist im Vlan 40 getagged. an port 4 (untagged vlan 40) vom 1800 hängt der mac. Am 2510 am trk 1 ist der uplink zum hp6200 getagged. am 6200 an trk4 (port 11 und 12) im vlan 40 getagged kommt der uplink von 2510. daran hängt die Fortinet mit der ip adresse 10.1.3.1. cih werde die konfigurationarbeiten mal auf eure Vorschläe umarbeiten und mich wieder melden. wird leider bis nach Pfingsten dauern, da ich 2 Tage Urlaub habe.
noch mal vielen Dank für die konstruktiven Vorschläge.
Gruß
Gruß
willineu
Bitte warten ..
Mitglied: aqui
23.05.2012 um 17:42 Uhr
Na da sind wir dann mal gespannt aufs Feedback...auch wenns länger dauert..
Bitte warten ..
Mitglied: willineu
23.05.2012 um 18:47 Uhr
Hallo Netman,
da bin ich ja dabei das 111 zu vernichten, aber das geht halt nur Schritt für Schritt. verteilt das GVRP wirklich alle eingetragenen Vlans auf alle Switche? wie schalte ich es ein und hat es irgendwelche Nachteile?
Gruß
Willi
Bitte warten ..
Mitglied: Dani
23.05.2012 um 23:15 Uhr
verteilt das GVRP wirklich alle eingetragenen Vlans auf alle Switche? wie schalte ich es ein und hat es irgendwelche Nachteile?
Die Frage ist doch, brauchst du auf allen Switches alle VLANS?!


Grüße,
Dani
Bitte warten ..
Mitglied: dog
24.05.2012 um 02:29 Uhr
GVRP/MVRP verteilt gar keine VLANs.
Die Edge-Ports registrieren sich für ein VLAN und GVRP propagiert diese Registrierung dann weiter.
Ein Switch der keinen Port in VLAN Y hat wird es per GVRP auch nicht lernen.
Bitte warten ..
Mitglied: aqui
25.05.2012 um 10:45 Uhr
Deshalb: Vergiss GVRP und mach das statisch. Bei deinen Mininetz mit 3 popeligen Switches mit 3 VLANs sollte das ja auch wohl kein Thema sein !
Bitte warten ..
Mitglied: MrNetman
25.05.2012 um 16:49 Uhr
Zitat von aqui:
Deshalb: Vergiss GVRP und mach das statisch. Bei deinen Mininetz mit 3 popeligen Switches mit 3 VLANs sollte das ja auch wohl kein Thema sein !
In der Überschrift steht: Wir haben ca. 200 Clients, diverse Server und ein Netzwerk. 3 Switches werden's da wohl nicht sein.
Aber für die erste Anforderung wird es auch ohen VLAN Automatisierung gehen, da nur wenige MACs in ein eigenes Netz sollen. Aber bei 200 Clients steht die nächste Segmentierung vor der Tür. Da braucht man dann weiter VLANs.

Gruß
Netman
Bitte warten ..
Mitglied: aqui
25.05.2012, aktualisiert um 19:27 Uhr
.. ."am Etagen Switch hängt an Port 8 ein weiter Switch HP 1800 auf port 8 ist im Vlan 40 getagged. an port 4 (untagged vlan 40) vom 1800 hängt der mac. Am 2510 am trk 1 ist der uplink zum hp6200 getagged. am 6200 an trk4 (port 11 und 12) im vlan 40 getagged kommt der uplink von 2510..."
zählt man das zusammen ergibt das 3.
Aber egal für das was der TO wissen will ist die Anzahl der Switches im Netz so oder so irrelevant !
Die HP GVRP Implementierung hat zudem einen gravierenden Nachteil, denn sie funktioniert nur in einem Single Span STP Umfeld. Das ist STP technisch gesehen tiefste Steinzeit....
Mit PVST kann Billichheimer HP ja so oder so nicht umgehen. Das ist jetzt aber eine ganz andere Baustelle die mit dem eigentlichen Thema hier nix zu tun hat !
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
LAN, WAN, Wireless
gelöst HP Procurve VLAN und Routing (3)

Frage von Fisch2005 zum Thema LAN, WAN, Wireless ...

Router & Routing
gelöst HP VLAN routing (5)

Frage von homermg zum Thema Router & Routing ...

LAN, WAN, Wireless
gelöst VLAN Routing - L3 oder Firewall? (17)

Frage von pataya zum Thema LAN, WAN, Wireless ...

Switche und Hubs
gelöst HP Procurve Switch 2650 J4899B Hängt, keine Verbindung möglich (7)

Frage von duke1212 zum Thema Switche und Hubs ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...