Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Vlan Routing zwischen 2 VLANs funktioniert nur auf einer Switch

Frage Netzwerke

Mitglied: LeSchmu

LeSchmu (Level 1) - Jetzt verbinden

23.11.2011, aktualisiert 18.10.2012, 7210 Aufrufe, 3 Kommentare

Hallo Zusammen,

ich habe, aus meiner Sicht, ein etwas größeres Problem.

Das will ich machen:
Ich habe zwei Netze, das eine ist ein reines Datennetz und das andere soll ein Voice-Netz sein. Im Einsatz sind 5x H3C S5500-SI Switche. Für die untenstehende Beschreibung gehe ich von 2 Switchen aus.
Die Switche haben KEIN Stacking Modul, bei diesen Geräten gibt es dies anscheinend nicht mehr. Es gäbe noch die Möglichkeit hier 10Gbit Karten zu beschaffen, diese liegen mir leider nicht vor und ich muss bis Freitag hier eine funktionierende Konfiguration stehen haben. Zum Einsatz kommen VoIP Telefone von Avaya. Der DHCP ist so konfiguriert, dass die Telefone in VLAN 20 booten, erhalten in diesem VLAN 20 eine IP eines VoiP-Servers. Die PCs sind über die Telefone angeschlossen und erhalten aus VLAN 1 Ihre IP.

IST Konfiguration:

Neue Switch 1 (POE):
VLAN 1 (default): 192.168.3.0/24 (Datennetz) / untagged
VLAN 1 interface: 192.168.3.248/24

VLAN 20: 192.168.20.0/24 (Voice Netz) / tagged
VLAN 20 interface: 192.168.20.3 255.255.255.0

IP route-static 0.0.0.0 0.0.0.0 Vlan-interface1 192.168.3.3

Voice-Server ist untagged im VLAN 20.

Neue Switch 2 (POE):
VLAN 1 (default): 192.168.3.0/24 (Datennetz) / untagged
VLAN 1 interface: 192.168.3.247/24

VLAN 20: kein Interface erstellt

IP route-static 0.0.0.0 0.0.0.0 Vlan-interface1 192.168.3.3

Die beiden Switche sind per Ethernetkabel verbunden. Trunk / vlan 1


Firewall
IP: 192.168.3.3
Routingeintrag: Destination 192.168.20.0/24 Gateway 192.168.3.248

Bereits vorhandene Switch: 3Com 5500G-EI
VLAN 1 (default): 192.168.3.0/24 (Datennetz) / untagged
VLAN 1 interface: 192.168.3.250/24

VLAN 20: kein Interface erstellt

Nun zum Problem:
Die Firewall stellt die Verbindung zur bereit vorhandenen Switch her. Von dort aus geht es per LWL auf die neue Switch 2, diese ist per Ethernet im Trunk / Vlan 1 mit der neuen Switch 1 verbunden.
Aus dem Datennetz kann ich das Voice Netz erreichen. Alle Telefone funktionieren auf der ersten Switch. Sobald ich ein Telefon auf der zweiten Switch anschließe, funktioniert das routing nicht. VLAN 20 wird vom Telefon nicht erkannt! An allen Switchen werden jedoch VoIP Telefone angeschlossen.

Der bisherige Grund dafür ist zu einem, dass der Eintrag auf der Firewall als Gateway die 192.168.3.248 hat und somit die anderen Switche nicht kennt. Aber sollten an der Stelle nicht die Switche die Aufgabe erledigen?

Muss hier auf den Switchen evtl. noch eine Route eingetragen werden damit ich es ans Laufen bekomme oder wo ist hier der Konfigurationsfehler?
Ich bin um jeden Kommentar und Rat dankbar.

Viele Grüße,
Smu
Mitglied: clSchak
23.11.2011 um 19:17 Uhr
Hi,

du musst den Uplink der Switches das VLAN20 tagged mitgeben - ansonsten kommt es auf den anderen Swichen erst garnicht an, dann auf den anderen Switchen auch ein VLAN20 einrichten und dort auch dem Trunk/Uplink VLAN20 Tagged mitgeben - dann kommt es auch auf den ersten Switch und der FW an

Aber was anderes, du schreibst das du die PC's am Telefon durchschleifen möchtest, dazu musst du aber die Config am Switch komplett anders einrichten!

Ein paar Grundlegende Sachen:
- alle Ports auf DualMode stellen, damit diese getaggte und ungetaggte Frames akzeptieren (sofern die Switche das können ...)
- einen Port VLAN20 untagged konfigurieren und dort die Telefonanlage anschließen
- alle PoE Ports auf Tagged VLAN20 und untagged default_vlan stellen (man kann es nicht taggen)
- alle Telefone auf Tagged VLAN20 stellen und den UplinkPort aktivieren
- am Switch QoS - am einfachsten mit Layer 3 DifServ einstellen

Alternative zu DualMode:
- VLAN Zuweisung anhand von ACL (Aufwendiger zum einrichten)

Nun kannst du die Telefone am PoE anschließen - bedenke aber das die meisten VoIP Telefon nur 100Mbit Uplink am LAN Port liefern

grobe Config wie es aussehen kann
01.
conf t 
02.
ip address 192.168.3.xx/24 
03.
ip default gateway 192.168.3.3 
04.
ip dns server x.x.x.x 
05.
enable super-user-password xyz 
06.
sntp-server x.x.x.x 
07.
snmp-server community public ro 
08.
snmp-server location Besenkammer 
09.
lldp run 
10.
vlan 20 name voice 
11.
   tagged e 1/1 to 1/48 
12.
   sapnning tree 802.1w 
13.
   exit 
14.
vlan 1 name DEFAULT_VLAN 
15.
   spanning tree 802.1w 
16.
   exit 
17.
interface ethernet 1/1 to 1/48 
18.
   trust dscp 
19.
   dual mode 
20.
   exit 
21.
 
22.
// Uplink 
23.
interface ethernet 1/1 to 1/2 
24.
   link-aggregation conf key 12000 
25.
   link-aggregation active 
26.
   sflow forwarding 
27.
   exit 
28.
write mem / oder copy running-config startup-config 
29.
 
(ungeprüft aus dem Gedächniss geschrieben)

Im allgemeinen wird dort ein LCAP von Port 1+2 am Switch erstellt, alle Ports mit einem Tagged VLAN 20 versehen und RSPT eingerichret - sollte an Grundconfig reichen (CLI Command variieren aber von Hersteller zu Hersteller)


Edit / Add: VLAN Config zu finden unter: http://www.h3c.com/portal/Technical_Support___Documents/Technical_Docum ...
Bitte warten ..
Mitglied: LeSchmu
24.11.2011 um 07:46 Uhr
Morgen,

mein Kollege hat mich gestern Abend noch auf die gleiche Idee gebracht. Ich hatte die Uplink Ports nicht alle korrekt konfiguriert. Dies habe ich gestern Abend bei einem Wartungsfenster noch machen können - und siehe da, es läuft
Das VLAN 20 war überall bekannt, die Switche konnten nur nichts damit anfangen, da sie halt nicht alle den Trunk Port hatten.

Ich habe es nun so gelöst, dass ich eine Core Switch habe. Auf allen Switchen habe ich die route 0.0.0.0 / 0.0.0.0 / 192.168.3.248 eingetragen, da ich ja auf der Firewall das Netz 192.168.20.0/24 auf die 192.168.3.248 route.
Auf der 192.168.3.248 habe ich natürlich die route zur Firewall hinterlegt: 0.0.0.0 / 0.0.0.0 / 192.168.3.3

Den Rest deiner Erklärung hatte ich bereits, aber es hat noch nicht geklappt, das VLAN 20 als Voice zu deklarieren. Das werde ich mir gleich anschauen.

Vielen Dank für deine spontanen, guten Ausführungen!

Cheers...
Bitte warten ..
Mitglied: aqui
24.11.2011, aktualisiert 18.10.2012
Mmmmhhh, ganz korrekt ist deine Beschreibung allerdings nicht.
Wie man ja unschwer sehen kann routet dein Switch 1 ja auch. An dem hast du in beiden VLANs ein IP Interface eingestellt und damit hast du dort auch ein Routing zwischen den beiden VLANs aktiv.
Soll das nicht der Fall sein und willst du ausschliesslich diese beiden VLANs nur über die Firewall routen dann darfst du niemals ein IP Interface ins VLAN 20 konfigurieren !
Ansonsten hast du hier ja einen "Backdoor Router" der dann eine Firewall (und damit die Sicherheit zw. diesen Netzen) völlig überflüssig macht.
Mag aber auch sein das deine o.a. verwirrende Erklärung das durcheinandergewürfelt hat.
Ein paar Beispiele findest du auch hier:
http://www.administrator.de/wissen/vlan-installation-und-routing-mit-m0 ...

Wenns das denn war
http://www.administrator.de/index.php?faq=32
nicht vergessen.
Bitte warten ..
Neuester Wissensbeitrag
Off Topic

"Ich habe nichts zu verbergen"

(2)

Erfahrungsbericht von FA-jka zum Thema Off Topic ...

Ähnliche Inhalte
Netzwerkmanagement
gelöst Richtiges Routing zwischen VLANs (5)

Frage von Kolnak zum Thema Netzwerkmanagement ...

Router & Routing
gelöst Routen zwischen den VLANs verhindern - ACL (11)

Frage von Maik82 zum Thema Router & Routing ...

LAN, WAN, Wireless
gelöst VLAN: Routing ins Internet (18)

Frage von kasimir82 zum Thema LAN, WAN, Wireless ...

Netzwerkgrundlagen
Vlan Routing Pfsense APU2 vs L3 (17)

Frage von TimMayer zum Thema Netzwerkgrundlagen ...

Heiß diskutierte Inhalte
CPU, RAM, Mainboards
Kaufberatung für mind. 8 verschiedene HighEnd-Mainboards (24)

Frage von yperiu zum Thema CPU, RAM, Mainboards ...

Hyper-V
Langsames Netzwerk i210 LAN Karte (11)

Frage von Akcent zum Thema Hyper-V ...

Netzwerke
Abisolierwerkzeug (11)

Frage von SarekHL zum Thema Netzwerke ...

Windows Server
Server 2016 - Kuriositäten (8)

Frage von certifiedit.net zum Thema Windows Server ...