Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

VLAN Switch Konfig Netgear GS724T v2

Frage Netzwerke LAN, WAN, Wireless

Mitglied: photographix

photographix (Level 1) - Jetzt verbinden

29.03.2010, aktualisiert 18.10.2012, 12623 Aufrufe, 14 Kommentare

Hallo Leute,

Folgendes (Verständnis) Problem habe ich bei meiner nicht funktionierenden VLAN Konfiguration.

Vorgaben:
3 Netze, untagged, werden in den Switch eingespeist und über Vlans verwaltet.
Am Port 24 soll ein VLAN Trunk (mehrere VLANS auf einer Leitung) an den nächsten Switch gehen der dort wieder die VLANS aufspaltet und an die Ports verteilt. An allen „Ausgängen“ hängt dumme Hardware die kein VLAN kann.

Was habe ich bis jetzt gemacht.

Switch 1 Konfig:

Port1: VLAN 1 - frei
Port2: VLAN 10 – untagged – PBX 1
Port3: VLAN 20 – untagged – PBX2
Port4: VLAN 30 – untagged – Intranet
Port24: VLAN1,10,20,30 – tagged – (ist das somit ein Trunk?)

Switch 2 Konfig:

Port1 : VLAN1,10,20,30 – tagged
Port2: VLAN 10 – untagged – PBX 1
Port3: VLAN 20 – untagged – PBX2
Port4: VLAN 30 – untagged – Intranet

Leider funktioniert das so gar nicht. Mein Problem ist sicher nicht die Konfig sondern das Verständnis des Zusammenwirkens. Speziell im Zusammenhang mit Netgears PVID.

Vielleicht kann mir jemand das System dahinter erklären.

Danke im Voraus.
LG
Mitglied: aqui
29.03.2010, aktualisiert 18.10.2012
Deine Konfig ist aber logisch absolut richtig und eine korrekte Standardeinstellung zur Kopplung zweier VLAN Switches und damit sollte es auch klappen.
Geräte an Port 2 beider Switches sollten sich problemlos pingen können, ebenso die Geräte an den Ports 3 und 4.
Bedenke aber das ein Ping zw. Geräten z.B. an Port 2 zu Port 3 und 4 unmöglich ist denn VLANs sind auf dem Switch physisch völlig getrennt ! Nur alle Ports in VLAN-10 untereinander und alle in VLAN-20 untereinader können reden...
Um die VLANs wieder zusammenzuführen bzw. eine Kommunikation zu ermöglichen benötigst du einen Router oder Layer 3 (Routing) Switch wie es z.B. in diesen Tutorials beschrieben ist:
http://www.administrator.de/wissen/vlan-installation-und-routing-mit-m0 ...
http://www.administrator.de/wissen/vlan-routing-%c3%bcber-802.1q-trunk- ...
Bitte warten ..
Mitglied: Edi.Pfisterer
29.03.2010 um 15:17 Uhr
Hallo!
Gebe aqui vollinhaltich recht!
DH, ohne einen Layer3 Switch/Router wirst Du keine Kommunikation zwischen den VLANS erzielen!

ist das somit ein Trunk?
Ja und nein!
Trunk im sinn von "mehrere VLANS auf einer Leitung" schon!
Trunk im Sinne von Netgear nicht, da Netgear unter Trunk das Bündeln mehrerer Switchports versteht, um die Bandbreite zu erhöhen...

zum Verständnis von Netgears PVID:
damit ist gemeint, welchen TAG der jeweilige Switchport senden würde, wäre er auf TAGGED gestellt (vielleicht lässt es sich so am ehesten erklären...).
Das bedeutet, jeder Port kann Mitglied in n VLANS sein (und kann dadurch auch Traffic aus diesen VLANS erhalten).
Der Port selbst ist aber originär in EINEM VLAN (dh, wenn ein Paket in diesem Port ankommt, dann wird es dem VLAN, das der PVID des Ports entspricht zugeordnet und kann in weiterer Folge von allen Clients empfangen werden, die an einem Port hängen, der Mitglied in diesem VLAN sind.)

Falls diese Erklärung Dir nicht weitergeholfen hat, dann schreibe ich Dir später ein Beispiel.
Muss jetzt weg (ein Besuch im Nescafe-Shop mit der Holden steht an!)
lg
Edi, der Osterferien mag
Bitte warten ..
Mitglied: photographix
29.03.2010, aktualisiert 18.10.2012
Olá und danke an euch,

Es muss/soll keine Kommunikation zwischen den VLANS ablaufen (Telefon1 und Telefon2 und Intranet sind getrennt). Ich möchte die VLANS nur als verschiedene Netze über eine Leitung schieben um diese so in ein anderes Gebäude transportieren zu können. Wie in Beispiel VLAN, tagged, untagged Grundverständnis, Netgear GS724T v2 möchte ich die VLANS auf jede Etage bringen und wieder aufspalten.

@urobe73 wie wäre die PVID für den Port 24 oder den Port 1 der Switche?
Mein Bsp:

Switch 1 Konfig:

Port1: VLAN 1 - frei - PVID1
Port2: VLAN 10 – untagged – PBX1 - PVID10
Port3: VLAN 20 – untagged – PBX2 - PVID20
Port4: VLAN 30 – untagged – Intranet - PVID30
Port24: VLAN1,10,20,30 – tagged - PVID???

Switch 2 Konfig:

Port1 : VLAN1,10,20,30 – tagged - PVID???
Port2: VLAN 10 – untagged – PBX1 - PVID10
Port3: VLAN 20 – untagged – PBX2 - PVID20
Port4: VLAN 30 – untagged – Intranet - PVID30

PPS: lohnt ein Leitungstrunk LAGG bei der Menge an VLANS auf einer Leitung? -> Wir sind mit jeder Etage 2x Cat7 angebunden.
Bitte warten ..
Mitglied: aqui
29.03.2010 um 20:29 Uhr
Wenn Port 24 von Switch 1 auf Port 1 von Switch 2 geht und das die Verbindung zw. den beiden Switches ist dann MÜssen hier ALLE VLANs tagged auf diesen Ports (1 und 24) eingetragen werden. Port 1 bzw. 24 ist dann der "VLAN Trunk" wenn du so willst beider Switches !
Richtig würde es dann lauten:

Switch 1 Konfig:

Port1: VLAN 1 - frei - PVID1
Port2: VLAN 10 – untagged – PBX1 - PVID10
Port3: VLAN 20 – untagged – PBX2 - PVID20
Port4: VLAN 30 – untagged – Intranet - PVID30
Port24: VLAN1,10,20,30 – tagged - PVID1, 10,20 und 30 --> Verbindung zu Switch 2

Switch 2 Konfig:

Port1 : VLAN1,10,20,30 – tagged - PVID1, 10,20 und 30 --> Verbindung zu Switch 1
Port2: VLAN 10 – untagged – PBX1 - PVID10
Port3: VLAN 20 – untagged – PBX2 - PVID20
Port4: VLAN 30 – untagged – Intranet - PVID30

Du solltest in die VLANs z.B. 10 zum Testen erstmal 2 PC mit gleichem IP Netz z.B. PC-1=172.16.1.1 /24 und PC-2=172.16.1.2 /24 hängen. Wenn die sich anpingen können dann klappts auch mit dem "VLAN Trunk" !
Ob Link Aggregation auf dem Trunk Sinn macht hängt vom Gesamttraffic ab. Wenn die Switchverbindung mit Switch übergreifendem Traffic überbucht ist solltest du ggf. Link Aggregation machen.
Das ist aber erst der 2te Schritt nach der VLAN Konfig !!
Bitte warten ..
Mitglied: Edi.Pfisterer
30.03.2010 um 10:39 Uhr
Hola!
@aqui: Deine Konfig ist zwar grundsätzlich richtig, wäre da nicht Netgear im Spiel

richtig muss es so lauten:


Switch 1 Konfig:

Port1: Mitglied in VLAN 1 - frei - PVID1
Port2: Mitglied in VLAN 10 – untagged – PBX1 - PVID10
Port3: Mitglied in VLAN 20 – untagged – PBX2 - PVID20
Port4: Mitglied in VLAN 30 – untagged – Intranet - PVID30
Port24: Mitglied in VLAN1,10,20,30 – tagged - PVID1 --> Verbindung zu Switch 2

Switch 2 Konfig:

Port1 : Mitglied in VLAN1,10,20,30 – tagged - PVID1 --> Verbindung zu Switch 1
Port2: Mitglied in VLAN 10 – untagged – PBX1 - PVID10
Port3: Mitglied in VLAN 20 – untagged – PBX2 - PVID20
Port4: Mitglied in VLAN 30 – untagged – Intranet - PVID30


Da man pro Port nur eine PVID auswählen kann..

welche PVID Port24 auf Switch1 bzw. Port1 auf Switch2 hat, ist prinzipiell egal, da diese beiden Ports ohnehin keinen originären Traffic erhalten, der nicht getagged ist mit einer anderen PVID.

Beispiel:
Paket kommt von SW1,Port 2 und stammt daher aus dem VLAN 10
intern ist für die Dauer des Aufenthalts des Pakets stets klar, dass das Paket zum VLAN10 gehört.
Nun verlässt dieses Paket den SW1 auf Port 24 und wird getagged, richtigerweise mit dem VLAN10-Tag, damit SW2 weiss, woher das Paket kommt.
Wenn das Paket nun SW2 auf Port2 wieder verlässt (wo anders darf es nicht raus, weil die Ports nicht Mitglied im VLAN10 sind), dann wird der Tag wieder weggenommen (weil das daran angesteckte Gerät möglicherweise mit dem TAG nichts anzufangen weiss...). Fertig.
Comprende?
Bitte warten ..
Mitglied: photographix
30.03.2010 um 10:59 Uhr
Ok werd ich testen ^^
Mehr als nicht gehen kann es ja nicht.

Wie komm ich später an das Management Interface von Switch 2?
Sinnvoll das VLAN1 auch weiterzuleiten?

Worst Case:
alles läuft gut und es gibt keine Probleme.
Irgendwann entferne ich aus versehen das management VLAN wie komme ich dann an den Switch ohne einen totalreset ran?
Bitte warten ..
Mitglied: Edi.Pfisterer
30.03.2010 um 15:39 Uhr
Hoi!
wo sind Deine Bedenken?
wenn du aus versehen das VLAN1 (default) entfernst (was imho gar nicht geht, glaub ich zumindest...), dann ist das doch egal!
Stell Dir die Kiste vielleicht so vor, als würdest Du sie in 3 Teile schneiden...
Und alle 3 haben ein gemeinsames Management...
mit anderen Worten: das Managementvlan brauchst Du nicht mehr, sobald Du ein anderes VLAN hast...

Just do it!

UND: teste das ganze zuerst innerhalb eines Switchs, hänge danach den 2. dazu...
ABER: probiern musst Du es jetzt schon selbst...

lg
gutes gelingen
Bitte warten ..
Mitglied: aqui
03.04.2010 um 09:05 Uhr
@photografix
Wenns das war bitte
http://www.administrator.de/index.php?faq=32
nicht vergessen !!
Bitte warten ..
Mitglied: photographix
06.04.2010 um 06:15 Uhr
@aqui
ich war im verlängerten Osterweekend
diese Woche muss das VLAN Projekt eh fertig werden (wenn nichts dazwischen kommt...).
Heute oder morgen mach ich den Threat zu wenn alles geht
Bitte warten ..
Mitglied: photographix
09.04.2010 um 15:30 Uhr
OK also Fazit:

Es geht so wie urobe73 (danke nochmals) beschrieben hat.
Was nicht geht @urobe73 ist dann ich den Switch dann noch managen kann. Habe das "Konstrukt" zusammengesteckt ist er nicht mehr erreichbar.

Vielleicht kann sich ja noch einmal jemand dazu äußern.

Danke.

Switch 1 Konfig:

Port1: Mitglied in VLAN 1 - frei - PVID1
Port2: Mitglied in VLAN 10 – untagged – PBX1 - PVID10
Port3: Mitglied in VLAN 20 – untagged – PBX2 - PVID20
Port4: Mitglied in VLAN 30 – untagged – Intranet - PVID30
Port24: Mitglied in VLAN1,10,20,30 – tagged - PVID1 --> Verbindung zu Switch 2

Switch 2 Konfig:

Port1: Mitglied in VLAN 1 - frei - PVID1
Port2: Mitglied in VLAN 10 – untagged – PBX1 - PVID10
Port3: Mitglied in VLAN 20 – untagged – PBX2 - PVID20
Port4: Mitglied in VLAN 30 – untagged – Intranet - PVID30
Port24: Mitglied in VLAN1,10,20,30 – tagged - PVID1 --> Verbindung zu Switch 1
Bitte warten ..
Mitglied: Edi.Pfisterer
09.04.2010 um 18:30 Uhr
Hallo!
Was nicht geht @urobe73 ist dass ich den Switch dann noch managen kann

glaub ich Dir nicht
im Ernst:
der Switch muss ja eine IP haben. nehmen wir mal an, es wäre 192.168.0.1
Da Du auf Layer2 - Ebene IPs nicht ändern kannst, musst Du auch über VLAN 10, etc. auf den Layer2-Switch kommen (btw: ich finde nirgends, welches Modell du hast...)

falls Du einen Netgear hast (kann mich nicht genau erinnern, denke aber, dass Du der mit den Netgears bist...):
VLAN1 (default) lässt sich NICHT löschen (soeben auf einem Netgear GS724T getestet....).

lg
Bitte warten ..
Mitglied: photographix
09.04.2010 um 18:38 Uhr
Olá ja ich bin der mit dem Netgear

ich habe mehrere GS724tv2 und auch einige GS724Tv3 (Webbackend übrigens ganz ganz verschieden).

Der "alten" GS724Tv2 kann ich noch managen nach der Konfiguration.
Den neuen GS724Tv3 kann ich dann nicht mehr erreichen.
Bekommen Timeout bei der IP.
Management VLAN ist 1 und auch durchgetaggt wie oben geschrieben.
Bin ratlos.
Bitte warten ..
Mitglied: Edi.Pfisterer
10.04.2010 um 13:03 Uhr
Hallo!
Sorry, ich habe hier nur V2 zum Testen und einen V3 noch nicht zu Gesicht bekommen...

möglicherweise - Netgear ist halt Netgear - handelt es sich um einen Bug beim V3. Hast Du schon geprüft, ob Du die neuese Firmware drauf hast?
Vielleicht löst dies Deine Probleme.
Theoretisch jedenfalls müsste der Zugriff nach Umstellung auf VLANs - wie beim V2 - ohne Probleme Fortbestand haben...

lg
gutes gelingen weiterhin!
Bitte warten ..
Mitglied: photographix
16.04.2010 um 09:49 Uhr
So es ist vollbracht - nach einer neuen Firmware für den GS724tv3 und einen endgültigen Test steht nun mein Konstrukt.
Ich bin froh das es nun geht und das alles doch "einfach" ist wenn man mal PVID und VLAN ID bei Netgear verstanden hat

Danke an euch und speziell an Urobe

Nice Weekend euch



PS: kennzeichnet Ihr eure VLAN Switche von außen irgendwie? Wir haben ja nun VLAN und nicht Vlan Switche.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(3)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Router & Routing
gelöst VLAN Routing mit Netgear GS724Tv4 (7)

Frage von stpb10 zum Thema Router & Routing ...

Netzwerkmanagement
VLAN Konfiguration inkl. Management VLAN Zugriff auf NETGEAR Smartswitches (1)

Frage von tobitobsn zum Thema Netzwerkmanagement ...

Netzwerkmanagement
VLAN mit nur einem Switch (Netgear) - Drucker zur Verfügung stellen (12)

Frage von Vossberger zum Thema Netzwerkmanagement ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...