Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Vlan - Uplink zw. Procurve 2810-48G und J9028A scheitert

Frage Netzwerke LAN, WAN, Wireless

Mitglied: userONE

userONE (Level 1) - Jetzt verbinden

07.07.2014, aktualisiert 08.07.2014, 2318 Aufrufe, 3 Kommentare, 1 Danke

Moin liebe Leser,

habe mich extra angemeldet, um hier hoffentlich den richtigen Tipp zu bekommen, was bei meiner Konfiguration schief läuft.
Bei der Suche hier auf administrator.de konnte ich bisher leider keine Lösung finden.
Hier meine Frage:
In unserem Netzwerk gibt es 2 HP Procurve 2810-48G und 3 HP J9028A.
Alle Switche sind per Uplink miteinander verbunden.

Ich habe nun ein Vlan auf 2 Switchen hinzugefügt (GAST_VLAN, (99)), über welche zukünftig ein Gast-Wlan laufen soll.

Auf dem 2810 ist Port 12 der Uplink-Port, welcher zum Port 1 des 9028 führt.
Port 12 ist Mitglied beider Vlans (also vom Default_Vlan 1 sowie 99).
In Vlan 1 ist alles 'untagged' außer Port 12 tagged,
In Vlan99 hat alles Status 'no' außer Port 12 tagged.

c819b1601307dd8473e3892a0adfe8df - Klicke auf das Bild, um es zu vergrößern

Auf dem anderen Switch (9028) ist Port 1, also der Uplink-Port, ebenfalls Mitglied beider Vlans.
Port 5 führt zum AP (der Vlan-Tags versteht).
So sieht die Konf. des 9028 aus:

1f5c650ca00f3c408ed1accb56fc78e7 - Klicke auf das Bild, um es zu vergrößern

Das Problem ist, dass keine Verbindung zwischen den Switchen zustande kommt, sobald getaggt wird.
Woran kann das liegen? Muss auf dem 9028 etwas anders eingestellt werden, z.B. 'all' statt 'only tagged'?
Die PVID?

Vielleicht kann wer helfen. Würde mich sehr freuen...danke!

Mitglied: aqui
LÖSUNG 07.07.2014, aktualisiert 08.07.2014
habe mich extra angemeldet, um hier hoffentlich den richtigen Tipp zu bekommen
Na dann...willkommen im Forum und wir geben mal unser Bestes...
Vorab: Hilfreich für die Grundlagen des VLAN Setups ist dieses Tutorial:
http://www.administrator.de/wissen/vlan-installation-und-routing-mit-m0 ...

Der Port 12 auf dem 2810 sollte ungefähr so aussehen in der Konfig:
interface 12
name "Tagged Uplink HP-1800"
exit
vlan 1
name "DEFAULT_VLAN"
untagged 1-9
ip address 172.16.1.254 255.255.255.0
exit
vlan 99
name "Gast-WLAN"
untagged 10-11
tagged 12
exit

Wobei die Portnummerierung abhängig von deinen individuellen Ports ist.
VLAN 1 das Default VLAN liegt immer grundsätzlich an allen Ports an auch den Tagged Uplink Ports die die VLAN ID mit transportieren.
VLAN 99 hat hier im Beispiel noch die Ports 10 und 11 untagged und liegt tagged am Port 12 an, sendet hier also seine VLAN ID.

Kommen wir nun zu den HP 1800er Gurken die nur ein GUI haben. Dein Uplink auf den 2810 ist hier Port 1:
HP beschreibt im 1800er Handbuch auf Seite 2-28 das Verhalten wie immer etwas schwamming und diffus.
http://cdn.procurve.com/training/Manuals/1800-MgmtCfg-July2009-59916275 ...
Server bauen können die wahrlich besser als Netzwerk...aber egal.

Versteht man es richtig muss die Port Einstellung auf All stehen, denn dann ordnet der Switch untagged Traffic an diesem Port dem VLAN zu dessen ID hinten mit "PVID" angegeben ist ! Dort steht also 1 oder none und landed dann im Default VLAN.
Tagged Traffic an diesem Port wird dann dem entsprechenden VLAN zugeordnet dessen ID im VLAN Tag steht, vorausgesetzt der Port ist auch Member in dem VLAN !!!
Das musst du also im VLAN Setting einstellen das dieser Port im VLAN 99 liegt.
Analog gilt das für den Port 5 mit deinem Multi SSID Accesspoint da dran.
Das wäre dann das klassische Verhalten und sollte so sauber klappen.
Nebenbei: Typisches HP Verhalten damit DAU User und Netzwerk Noobs zum Erfolg kommen. Mit dieser "All" Einstellung und dem Haken bei VLAN aware enabled hat man gewissermaßen eine "Schrotschuss" Konfig als default die immer rennt.
Leider eine typische dumme HP Angewohnheit bei diesen GUI Billiggurken wie dem 1800er um deren Support Last zu drücken die aber klar mit der Sicherheit des Netzes erkauft wird
Man kann dir also nur dringenst anraten das du ausschliesslich nur am Port 1 und 5 das "VLAN aware enabled" anhakst und NICHT auf den einfachen Accessports !!
Das unterbindet dann das Tagged Frames quasi durch die Hintertür über einen Userport auf den Switch kommen, denn ohne diesen Haken droppt der Switch diese eingehenden Tagged Frames was bei Enduser Accessports ja auch gewollt ist. Nur die tagged Uplinks sollen Tagging machen.

Du hast das auf "tagged only" gesetzt und damait wird untagged Traffic auf diesem Port generell geblockt. Damit also das VLAN 1.
Da du vermutlich Produktivtraffic auch im Default VLAN 1 hast würde das mit der Einstellung komplett geblockt auf dem Port mit dem Ergebnis was du dann siehst. 99 sollte aber dennoch klappen...

Das o.a. Tutorial beschreibt deinen Anwendungsfall recht gut sogar mit einem "Praxisbeispiel" was genau deiner geplanten Anwendung entspricht !
Und... alles zum Thema Gast-WLAN findest du hier:
http://www.administrator.de/wissen/wlan-oder-lan-gastnetz-einrichten-mi ...
Bitte warten ..
Mitglied: userONE
07.07.2014 um 17:04 Uhr
Uff, schnelle Antwort, hervorragend...und das beste, der Uplink steht jetzt dank deiner Hinweise, wofür ich dir SEHR danke...war schon fast am verzweifeln. Hatte das Procedere, so wie es im 1800-Gurkenhandbuch beschrieben ist, so nämlich nicht richtig verstanden
Bitte warten ..
Mitglied: aqui
07.07.2014 um 17:42 Uhr
Da bist du bei HP nicht der einzige. Ist eben die Strafe wenn man HP kauft. Andere können das besser.
Aber klasse wenn nun alles rennt wie es soll

Wenns das denn war bitte dann auch
http://www.administrator.de/faq/32
nicht vergessen !
Bitte warten ..
Neuester Wissensbeitrag
Microsoft

Lizenzwiederverkauf und seine Tücken

(5)

Erfahrungsbericht von DerWoWusste zum Thema Microsoft ...

Ähnliche Inhalte
Switche und Hubs
gelöst HP Procurve 2810-48g Firmware download (2)

Frage von MichiBLNN zum Thema Switche und Hubs ...

LAN, WAN, Wireless
gelöst HP Procurve VLAN und Routing (3)

Frage von Fisch2005 zum Thema LAN, WAN, Wireless ...

LAN, WAN, Wireless
Neuplanung Netzwerk mit VLAN, VOIP, Gästenetz (2)

Frage von GKKKAT zum Thema LAN, WAN, Wireless ...

Heiß diskutierte Inhalte
Windows Netzwerk
Windows 10 RDP geht nicht (16)

Frage von Fiasko zum Thema Windows Netzwerk ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Microsoft Office
Keine Updates für Office 2016 (13)

Frage von Motte990 zum Thema Microsoft Office ...