Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

VLAN mit Virtuelle Maschine

Frage Netzwerke

Mitglied: sosov1

sosov1 (Level 1) - Jetzt verbinden

22.01.2013, aktualisiert 16:48 Uhr, 2014 Aufrufe, 3 Kommentare

Hallo miteinander,

ich hoffe jemand kann mir in meiner Unwissenheit weiterhelfen.

Folgende Konfiguration läuft im Moment:
HP Server mit 4-LAN Anschlüssen und Virtuellen Maschinen
1. VM ist ein SBS mit DC, DHCP, DNS...
2. VM ist ein Datenbank-Server
3. VM ist ein Webserver (<- um den geht es)

Habe alles korrekt an einem HP ProCurve E2910al-48G Switch angeschlossen.

Port 3 und 5 sind als gemeinsamer Port für SBS und Webserver vorgesehen.
Port 7 und 9 sind als LACP-Trunk für den Datenbank-Server eingerichtet.

Nun möchte ich den Webserver sowohl im DEFAULT_VLAN(per 192.168.31.14 erreichbar), als auch in einem eigenen VLAN-60(per 192.168.30.1) erreichen, um das VLAN auf den DMZ Port des Routers zu seiner öffentlichen IP weiterzuleiten.

Wenn ich nun die IP 192.168.30.1 anpinge, bekomme ich eine Antwort, es ist jedoch nicht der Server, sondern der Switch der mir antwortet.

Ich hoffe es kann mir jemand weiterhelfen.

Hier noch die Switch config:


Running configuration:

; J9147A Configuration Editor; Created on release #W.15.08.0012
; Ver #02:11.05:16
hostname "HP-E2910al-48G"
module 1 type j9147a
trunk 7,9 trk1 lacp
timesync sntp
sntp unicast
sntp 30
sntp server priority 1 192.168.31.6
sntp server priority 2 64.236.96.53
time daylight-time-rule western-europe
time timezone 60
ip default-gateway 192.168.31.254
interface 7
name "Pollexsrv_Port_1"
exit
interface 9
name "Pollexsrv_Port_2"
exit
snmp-server community "public" unrestricted
spanning-tree Trk1 priority 4
vlan 1
name "DEFAULT_VLAN"
no untagged 44
untagged 1-6,8,10-43,45-48,Trk1
ip address dhcp-bootp
exit
vlan 60
name "WEBSRV_VLAN60"
untagged 44
tagged 3,5
ip address 192.168.30.1 255.255.255.0
exit
password operator
Mitglied: aqui
22.01.2013, aktualisiert um 18:53 Uhr
Mmhhh, etwas verwirrend deine Beschreibung. Ggf. solltest du erstmal DAS hier lesen bevor wir weitermachen:
http://www.administrator.de/wissen/vlan-routing-über-802-1q-trunk- ...
und
http://www.schulnetz.info/vlan-teil2-woher-weiss-mein-netzwerk-aus-welc ...
Das verschafft dir erstmal etwas Grundlagenwissen in Bezug auf VLANs.
Eine Sachen ist unverständlich:
"Port 3 und 5 sind als gemeinsamer Port für SBS und Webserver vorgesehen..."
Was heisst das ?? Sollen diese Ports auch als Trunks, sprich mit Link Aggregation laufen ?? Oder was meinst du mit "gemeinsam" ?
3 und 5 werden mit einem VLAN Tag übertragen, es ist dann essentiell wichtig das auch das an einem dieser Ports angeschlossene Endgerät das supportet ! (Siehe Tutorial oben !)

Einen Kardinalsfehler hast du begangen:
Niemals vergibt man einem Switch eine dynamische IP Adresse per DHCP ! Das solltest du auf dem VLAN 1 also ändern und dem Switch dort einen feste statische IP geben !

Was den Rest anbetrifft hast du vermutlich ein Verständnisproblem wie ein Layer 3 Switch wie deine HP Gurke funktioniert, kann das sein ? Davon zeugt wenigstens dein etwas laienhafter Connectversuch ?!
Stell dir das also so vor das die VLANs und ihre Ports im Switch sowas wie eigenständige und getrennte Switches sind. Eine Kommunikation dazwischen ist physisch nicht möglich (VLAN Prinzip), schon allein aufgrund der unterschiedlichen IPs.
Folglich muss man also Routen zwischen den VLANs um eine Kommunikation zu gewährleisten.
Das kann man mit externen Routern machen wie HIER beschrieben.
Oder...wie in deinem Falle mit einem Layer 3 Switch, der den Router eingebaut hat.
In jedem VLAN "hängt" also gewissermaßen ein Routerbein, symbolisiert durch die IP Adresse die du im VLAN definierst.
Das kannst du sehen als Router Interface.
Du siehst schon was du falsch gemacht hast....?!
Es ist natürlich Blödsinn einen HTTP Connectversuch auf die Switch IP in dem VLAN zu machen...logisch das da der Switch selber antwortet !
Die VLAN Switch IP ist vielmehr deine Gateway IP !!
Du musst also im Client diese IP Als Gateway angeben und analog beim Server in seinem VLAN die dazu korrespondierende Switch VLAN IP .
So wird ein Schuh draus. Wenn du nun im Client Browser die Web Server IP als Ziel angibst wirst du auch den Webserver sehen.
So einfach ist das ....!
Bitte warten ..
Mitglied: sosov1
24.01.2013 um 15:29 Uhr
Hi aqui,

vielen Dank für die ausführliche Antwort.

Es ist mir nun gelungen das VLAN korrekt einzurichten.
Danke ebenfalls für den Hinweis mit DHCP, diesen hatte ich in der Hektik vergessen auf Manual umzustellen.

Ich habe nun das Routing dem Router übergeben, ich weiß nicht ob das die eleganteste Methode ist, aber es funktioniert.

Als nächsten Schritt werde ich mich nun an zwei VLANs für das WLAN versuchen - mal sehen wie das klappt.


sosov1
Bitte warten ..
Mitglied: aqui
24.01.2013 um 17:38 Uhr
.. ."Ich habe nun das Routing dem Router übergeben"
An WELCHEN Router hast du das denn übergeben ?? Den VLAN Router im Switch (ist ja ein Layer 3 Switch !!)
Wenn ja dann hast du alles richtig gemacht und das ist die eleganteste Methode, denn es ist der Standard.
WO solltest du denn bitte auch routen wenn nicht über den Switch wenn der es kann ?? Du hast ja gar keine anderen Optionen !
Ansonsten bitte nochmal das VLAN Tutorial vom Kollegen pfisterer oben GENAU durchlesen...dann kommt auch der Durchblick

Für die VLANs im WLAN Umfeld findest du hier:
http://www.administrator.de/wissen/vlan-routing-%c3%bcber-802-1q-trunk- ...
unter "Praxisbeispiel" alles was du dazu wissen musst !
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(2)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Server
gelöst Lokale Windows Firewall Server 2012R2 für virtuelle Maschine? (4)

Frage von 1410640014 zum Thema Windows Server ...

Vmware
Virtuelle Maschine - Standardmäßige Hostanwendung? (7)

Frage von Grinskeks zum Thema Vmware ...

Vmware
gelöst VMWare ESXi Virtuelle Maschine Videoprobleme (5)

Frage von florianza zum Thema Vmware ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...