Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Frage Netzwerke Router & Routing

VLANs einrichten auf 4500er 3com switch

Mitglied: brimbolex

brimbolex (Level 1) - Jetzt verbinden

30.08.2010, aktualisiert 18.10.2012, 8575 Aufrufe, 9 Kommentare

Hi, ich habe ein Problem beim einrichten mehrerer VLANs. Ich fürchte ich steh auf dem Schlauch, vielleicht kann mir ja wer helfen.

Folgendes Problem:

Ich möchte mehrere VLANs einrichten.

Was ich geschafft habe ist zwei accessports ungetagged miteinander in ein VLAN zu bringen. Soweit so gut
Ein Hybridport in zwei VLANs zu bringen ist mir nicht gelungen. Er redet immer nur mit einem der VLANs (über entsprechend gesetzte PVID)

Das Problem ist die Rechner die an einem Port hängen sollen auf 2 bis 4 VLANs Zugriff haben (je nach Aufgabe).
So zum Beispiel auch der Drucker und die firtzbox. Sie sollen aus allen VLANs erreichbar sein.

1.

Was muss ich denn dafür genau tun?


2.

Kann ich die IP Adressen für die unterschiedlichen VLANs mit der gleichen IP-Range (10.3.0.xxx) betreiben?
Denn die Trennung der Rechnergruppen erfolgt ja schon auf VLAN-Basis und ich kriege doch ein Problem mit dem Zugriff auf meine fritzbox da die ja nur eine Adresse haben kann.

Vielen Dank schon mal


Gruß Alex
Mitglied: aqui
30.08.2010, aktualisiert 18.10.2012
Der 3Com kann nur portbasierende VLANs. Um einen Port in mehrere VLANs zu bekommen geht das nur tagged, also mit der Tag ID nach 802.1q an den Frames an diesem Port !
Das erfordert aber das die Endgeräte auch tagged Frames verstehen sofern sie mit den VLANs kommunizieren müssen (Siehe Tutorial tagged Serverkarte unten !).
Anders ist es dann nur über Layer 3 Switching (Routing) machbar sofern der Switch das supportet !
Die VLANs haben dann eine switcheigene IP Adresse und routen via Switch zwischen den VLANs. Anders ist es nicht möglich.
Wenn dein Switch kein Routing supportet musst du das Routing mit externen Geräten machen.
Beispiele dazu findest du hier:
http://www.administrator.de/wissen/vlan-routing-%c3%bcber-802.1q-trunk- ... (Serverkarte)
bzw.
http://www.administrator.de/wissen/vlan-installation-und-routing-mit-m0 ...
Generelle Infos zum Thema VLAN findest du hier:
http://www.heise.de/netze/artikel/VLAN-Virtuelles-LAN-221621.html
Bitte warten ..
Mitglied: brimbolex
30.08.2010 um 12:55 Uhr
Der 4500 switch kann L3 routing...

Aber wie ich das genau aufsetzt hab ich irgendwie nicht richtig verstanden.

Dazu gehört dann auch die Frage nach den IP Adressen der Routen und (wenn richtig verstanden) auch die jeweilige vlan-interface adresse je vlan
Bitte warten ..
Mitglied: aqui
30.08.2010 um 13:21 Uhr
Routen benötigst du logischerweise keine, denn die VLANs sind ja direkt am Switch dran. Ausnahme wäre dann nur eine default Route ins Internet.
Hier mal ein Beispiel eines Cisco Switches mit VLAN Routing (VLANs 10, 20 und 30) wo die Logik sofort deutlich wird:
!
interface FastEthernet0/1
description Enduser Ports in VLAN 10
switchport access vlan 10
spanning-tree portfast
!
interface FastEthernet0/2
description Enduser Ports in VLAN 20
switchport access vlan 20
spanning-tree portfast
!
interface FastEthernet0/3
description Enduser Ports in VLAN 30
switchport access vlan 30
spanning-tree portfast
!
interface Vlan10
ip address 172.16.10.254 255.255.255.0
no ip route-cache
!
interface Vlan20
ip address 172.16.20.254 255.255.255.0
no ip route-cache
!
interface Vlan30
ip address 172.16.30.254 255.255.255.0
no ip route-cache
!
end

Hier kannst du sehen das zu jedem VLAN auch ein Routing Interface am Switch gehört (interface VLAN). Endgeräte in den VLANs haben dann DIESE IPs als Gateways eingetragen.
Müssen sie mit anderen VLANs kommunizieren als ihr eigenes schicken sie die Pakete an diese IP Adressen, die der Switch dann an die entsprechenden VLANs an ihm selbst routet.
Eigentlich banal einfach.... Mehr ist nicht zu tun !
Eine HP Konfig sieht dementsprechen analog aus:

vlan 10
name "Firma"
untagged 10-11
tagged 24
ip address 172.16.10.254 255.255.255.0
exit
vlan 20
name "Gast"
untagged 12-13
tagged 24
ip address 172.16.20.254 255.255.255.0
exit
vlan 30
name "Server"
untagged 14-15
tagged 24
ip address 172.16.30.254 255.255.255.0
exit

Analog geht das auch auf deinem 3Com. Ein passendes Layer 3 Schaubild dazu sieht so aus:

971a07ebe2fba9dac01468e633df4a7f - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: brimbolex
30.08.2010 um 13:31 Uhr
ok verstehe, vielen Dank schonmal...

Sind die IP Adressen der angeschlossenen Endgeräte egal, oder müssen die immer im Bereich des VLAN Interfaces liegen?

und:

Wie erkläre ich dem routing wer mit wem reden darf und wer nicht?
Bitte warten ..
Mitglied: aqui
30.08.2010 um 13:36 Uhr
Logischerweise natürlich immer im Bereich des VLAN IP Netzes ! Wie sollte es denn anders funktionieren. (Siehe Schaubild oben !) Die Frage zeigt das du da aber noch erhebliche IP und VLAN Defizite hast !?
Wer mit wem reden darf erklärst du natürlich niemals mit dem Routing selber sondern mit einer Accessliste !!
Da (vermutlich) alle VLANs am 3Com angeschlossen sind routet der in alle Netze die er kennt ..also an ihm direkt dran sind !
Bitte warten ..
Mitglied: brimbolex
30.08.2010 um 14:07 Uhr
ah ok...

das Schaubild hab ich übersehen vorhin, sorry!

das hieße ja dann in meinem Fall muss ich dem Drucker beispielsweise ein eigenes VLAN einrichten und über die Accessliste wiederum den Zugriff aus den anderen VLANs regeln.
Bitte warten ..
Mitglied: aqui
31.08.2010 um 15:29 Uhr
Genauso ist es !! Erstmal routet der Router (L3 Switch) alles ohne Beschränkung. D.h. jeder kann aus jedem VLAN auf jeden zugreifen (sofern die Gateway Eintrage stimmen !).
Den Zugriff aus einzelnen VLANs auf diesen Router regelst du denn mit den ACL genau so wie du es beschrieben hast !
Bitte warten ..
Mitglied: brimbolex
01.09.2010 um 08:20 Uhr
Ah jetzt...

da is er der Denkfehler!

Vielen Dank so werd ich s mal probieren

Gruß Alex
Bitte warten ..
Mitglied: aqui
03.09.2010 um 12:02 Uhr
Wenns das war bitte
http://www.administrator.de/index.php?faq=32
nicht vergessen !
Bitte warten ..
Ähnliche Inhalte
Switche und Hubs
Switch VLAN einrichten
gelöst Frage von TastuserSwitche und Hubs8 Kommentare

Hallo, ich habe einen Switch mit VLAn-Funktion, verstehe jedoch nicht ganz wie das funktioniert. Folgende Punkte sind vorhanden: - ...

Switche und Hubs
3com 5500G-EI 48P Switche und VLAN
gelöst Frage von Ascen77Switche und Hubs12 Kommentare

Hallo Leute, ich habe folgendes Problem und komme nicht mehr weiter, hoffe ihr könnt mir da helfen. Also, ich ...

LAN, WAN, Wireless
3com 5500g-Ei Switch mit Fritzbox 7490 im VLAN
gelöst Frage von vGavenLAN, WAN, Wireless3 Kommentare

Hi Leute, bin gerade am lernen wie man in bestimmten Umgebungen das VLAN konfiguriert. Ich habe folgende: Eine 3Com ...

Switche und Hubs
Switch-Tausch 3com durch HP
Frage von NoobOneSwitche und Hubs3 Kommentare

Hallo Zusammen, wir sind dabei in unserem Betrieb die alten 3com Switche, die am Laufen sind, auszutauschen. Anbei ein ...

Neue Wissensbeiträge
Linux

Meltdown und Spectre: Linux Update

Information von Frank vor 21 StundenLinux

Meltdown (Variante 3 des Prozessorfehlers) Der Kernel 4.14.13 mit den Page-Table-Isolation-Code (PTI) ist nun für Fedora freigegeben worden. Er ...

Tipps & Tricks

Solutio Charly Updater Fehlermeldung: Das Abgleichen der Dateien in -Pfad- mit dem Datenobject ist fehlgeschlagen

Tipp von StefanKittel vor 1 TagTipps & Tricks

Hallo, hier einmal als Tipp für alle unter Euch die mit der Zahnarztabrechnungssoftware Charly von Solutio zu tun haben. ...

Sicherheit

Meltdown und Spectre: Wir brauchen eine "Abwrackprämie", die die CPU-Hersteller bezahlen

Information von Frank vor 1 TagSicherheit12 Kommentare

Zum aktuellen Thema Meltdown und Spectre: Ich wünsche mir von den CPU-Herstellern wie Intel, AMD oder ARM eine Art ...

Sicherheit

Meltdown und Spectre: Realitätscheck

Information von Frank vor 1 TagSicherheit9 Kommentare

Die unangenehme Realität Der Prozessorfehler mit seinen Varianten Meltdown und Spectre ist seit Juni 2017 bekannt. Trotzdem sind immer ...

Heiß diskutierte Inhalte
Sicherheit
Meltdown und Spectre: Die machen uns alle was vor
Information von FrankSicherheit25 Kommentare

Aktuell sieht es in den Medien so aus, als hätten die Hersteller wie Intel, Microsoft und Co den aktuellen ...

Ubuntu
Ubuntu - Starter für nicht vertrauenswürdige Anwendungen
Frage von adm2015Ubuntu17 Kommentare

Hallo zusammen, Ich verwende derzeit die Ubuntu Versionen 17.10 bzw. im Test 18.04. Ich habe mehrere .desktop Dateien in ...

Windows 10
Automatische daten kopieren, USB zu USB unter Win10 im Hintergrund
Frage von DerEisigeWindows 1016 Kommentare

Hallo Leute, ich bin auf der Suche nach einem Skript, dass von einem USB Stick automatisch nach dem einstecken ...

SAN, NAS, DAS
Hilfe beim Einrichten eines Storages (SAN)
gelöst Frage von Vader666SAN, NAS, DAS15 Kommentare

Hallo Admins! Ich bin in einer kleineren Firma und hatte bisher mit dem Thema SAN nur in meiner Ausbildung ...