Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

VMWare Player 3.01 blockiert Vista Standby

Frage Microsoft Windows Vista

Mitglied: dinsdale

dinsdale (Level 1) - Jetzt verbinden

14.04.2010, aktualisiert 14:45 Uhr, 5653 Aufrufe, 8 Kommentare

Wenn der VMWare Player aktiv ist bleibt Vista beim Übergang in den Standby Modus hängen.

Hallo,

die Kurz Überschriften sagen eigentlich alles. Das Problem betrifft eigentlich auch die VMWare Player 2.x Versionen. Jedesmal, wenn ich vergesse, den Guest vor dem abschalten in den Ruhezustand oder Standby vorher zu schliessen, bleibt Vista (Home Premium) hängen. Das ist äußerst lästig. Das kann natürlich ein spezielles Problem meines Notebooks ( Asus F6S) sein, aber man kann ja mal horchen, ob jemand anderes ein ähnliches Problem hat.

Vielen Dank schonmal!

Mit freundlichen Grüßen,
Dinsdale
Mitglied: Phalanx82
14.04.2010 um 15:24 Uhr
Hallo,

Mal dran gedacht die VM einfach zu pausieren bevor du den Standby aktivierst? o.O


Mit freundlichen Grüßen.
Bitte warten ..
Mitglied: dinsdale
14.04.2010 um 15:32 Uhr
Ja, natürlich, aber da ich gerne auch mal ein Tool wie VirtualWin benutze vergesse ich das ganz gerne, weil die VM dann gerade nicht sichtbar ist. Und wenns mal schnell gehen muss auch. Aber vielleicht gibt es ja auch eine Lösung. Ich bin mir ja noch nichtmal sicher, ob das ein spezielles Problem von mir ist, oder ob andere auch ein ähnliches Problem haben. Dr. Google war hier nicht so aussagekräftig.

Mit freundlichen Grüßen,
Dinsdale
Bitte warten ..
Mitglied: Phalanx82
14.04.2010 um 15:40 Uhr
Zitat von dinsdale:
Ich bin mir ja noch nichtmal sicher, ob das ein spezielles Problem von mir ist, oder ob andere auch ein ähnliches Problem haben. Dr. Google
war hier nicht so aussagekräftig.

Dafür bin Ich mir ziemlich sicher das es ein spezielles Problem von dir ist. VMs abwürgen indem man den Windows Standby aktiviert kommt fast
einem Resetknopf drücken oder Kaltstart gleich. Sowas macht man nicht! Früher oder später geht deine VM dardurch mal hopps und dann brauchst
du mehr als 10 Sek. um die wieder hin zu biegen, die es benötigt das Dingen mal eben zu pausieren (auch wenns schnell gehn muss).

Mit freundlichen Grüßen.
Bitte warten ..
Mitglied: dinsdale
14.04.2010 um 16:01 Uhr
Naja, prinzipiell sollten doch beispielsweise beim Übergang des Hosts in den Ruhezustand ALLE Zustände gesichert werden. Die VM ist doch in dem Moment auch nur eine laufende Applikation, allerdings eine Systemnahe, zugegebenermassen. Die VMWare Treiber für die Virtualisierung sollten doch wohl diese Windows Modi Unterstützen, sonst würden die doch nie im Leben WHQL zertifiziert werden. Ausserdem unterstützen ja die VMWare Tools die Reaktion auf Standby / Ruhezustand usw. Jedenfalls in der Servervariante.

Mir gehts auch nicht primär um den Zeitgewinn, allerdings ist die vorgeschlagene Lösung auch nicht gerade komfortabel. Zumal einem der VMWare Player ja inzwischen als quasi "idiotensicher" verkauft wird. Ich vermute doch mal, dass der XP Mode auf VirtualPC Basis unter Win7 da ebenfalls keine Probleme haben wird. Ich kann mir gut vorstellen, dass es ein Problem meiner Hardwarekonfiguration ist. Ich bin mir aber eben nicht sicher.

Ausserdem, wenn ich zu Entwicklungszwecken mehrere VMs am laufen haben würde, dann wird die Lösung mit dem manuellen runterfahren/hibernate ganz schnell unpraktikabel...und wie gesagt, eigentlich unterstützt VMWare das automatische starten / stoppen / pausieren von VMs ja. Vielleicht gibts da einen Unterschied zwischen der Workstation und Player Variante, ich weiss es eben nicht.

Mit freundlichen Grüßen,
Dinsdale
Bitte warten ..
Mitglied: aschaefer
15.04.2010 um 22:38 Uhr
@Phalanx82:

Das Versetzen von Windows in Standby bzw. Ruhezustand hat nichts mit "Abwürgen" der VM zu tun. Der aktuelle Systemzustand einschliesslich der VM wird gesichert und nach dem Wiederhochfahren läuft die VM, wie jede andere Software, an der selben Stelle weiter. Das ist der Sinn von Standby bzw. Ruhezustand.

Das funktioniert normalerweise so gut, dass sogar offene putty's Ihre Verbindung halten. Ich mache das routinemäßig unter XP mit VMWare Player 2.0.5 bzw. VMWare Server 1.0.7 ohne das kleinste Problem.

Ich habe jetzt allerdings das gleiche Problem mit VMWare Player 3.0.1 unter Windows 7 Pro 64: wenn ich das System in den Ruhezustand bzw. Energie sparen fahre, hängt sich Windows meistens komplett auf -> Ausschalten per Netzschalter ist angesagt. Sporadisch geht's, aber das nützt mir nichts. Und der Tip, die VM runterzufahren, ist nicht wirklich hilfreich: der Sinn von Standby ist, dass man innerhalb von Sekunden an der selben Stelle weiterarbeiten kann. Wenn ich erst Eclipse runterfahre (weil das Dateien in der VM geöffnet hat) und dann die VM, kann ich auch gleich regulär runterfahren.

Wenn also jemand eine KONSTRUKTIVE Idee hat, immer raus damit.
Bitte warten ..
Mitglied: dinsdale
16.04.2010 um 10:41 Uhr
da bin ich ja mal beruhigt, dass es auch andere gibt, die sich mit dem Problem herumschlagen...auch wenns keine Lösung ist .

Wobei ich vielleicht noch folgende Anmerkung machen sollte:
Bei mir scheint sich Windows nicht immer völlig aufzuhängen, nur der Standby Prozess wird scheinbar an irgendeiner Stelle blockiert. Das äußert sich so, dass der Bildschirm bereits abgeschaltet wurde, aber auf der Festplatte durchaus noch aktivität vorhanden ist. Warten bringt nichts, der Rechner hat schonmal die ganze Nacht in diesem Zustand verbracht. Es kann also kein Timeout sein, auf den unverhältnismäßig lange gewartet wird, sondern es muss ein Deadlock sein.


Mit freundlichen Grüßen,
Dinsdale
Bitte warten ..
Mitglied: aschaefer
20.04.2010 um 16:18 Uhr
Ich hab's jetzt nochmal mit VMWare Server probiert, da habe ich das gleiche Problem. Offenbar funktioniert Windows 7 mit VMWare noch nicht richtig gut zusammen. Es gilt wieder die alte Regel: beim Umstieg auf eine neue Windows-Version wartet man besser erstmal bis zum Service Pack 1.

Ich habe jetzt wieder auf XP gedowngraded, damit geht alles bestens.

Gruß,

Arno
Bitte warten ..
Mitglied: dinsdale
20.04.2010 um 20:18 Uhr
hmm,tja, die Möglichkeit hab ich nicht wirklich...zudem läuft bei mir ja Vista, da bezweifle ich, das SP1 für Win7 da irgendwas ändert. Ich wollte mal in der VMWare Community nachfragen, aber irgendwie ist das da alles ziemlich unübersichtlich, so dass ich es bisher immer gelassen habe.

Mit freundlichen Grüßen,
Dinsdale
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...