Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

VMWare Player auf einem ESXI 4.6 verschachtelte Virtualisierung funktioniert nicht

Frage Virtualisierung Vmware

Mitglied: schnorz

schnorz (Level 1) - Jetzt verbinden

19.11.2012 um 16:40 Uhr, 2628 Aufrufe, 1 Kommentar

Ich möchte eine verschachtelte Virtualisierung mit mit ESXi 4.1 Build 721871 (Intel VT CPUs) wie folgt vornehmen:
Auf einem VM Server mit Windows Server 2008 R2 über den VMPlayer 5.0.1 ein Windows Server 2008 R2 starten lassen.

Auch wenn es im Produktiven Umfeld ein Unding ist das Vorgehen so durchzuführen, so kann es bei Tests durchaus Sinn machen.

Damit dieser Vorgang überhaupt funktioniert, habe über vSphere im VM unter "Options" - "Advanced" folgende Parameter hinzugefügt (gemäss KBs von VMWARE):

monitor_control.restrict_backdoor = TRUE
monitor_control.vt32 = TRUE

CPU Einschaltung: Virtualized Intel VT

Nach den obigen Einstellungen konnte über den VMPlayer (der in dem VM läuft) zwar das VM File starten, jedoch erscheint nun folgende Meldung:
"Binary translation is incompatible with long mode on this Platform. Disabling long mode......."
Ignoriere ich obige Meldung (da ich ja eingentlich VT Intel CPUs einsetze) erscheint dann die nächste Meldung:
"This virual machine is configured for 64-bit guest operating systems. However, 64-bit operation is not possible". This
host does not support Intel VT-x".

Jedoch verstehe ich das nicht ganz. Die Server HOST Systeme sind 64-bit Intel CPUs auf denen bereits 64-bit Betriesbsysteme laufen (Windows Server 2008 R2), sowie die VT Intel Einstellung aktiviert ist.

In diversen Foren haben zwar einige das gleiche Problem, bin aber auf eine Lösung gestossen.

Wer hat von Euch gleiche Erfahrungen gemacht und eine eventuell Lösung oder einen Workaround?

Besten Dank, Grüsse Schnorz



Mitglied: 16568
19.11.2012, aktualisiert um 18:16 Uhr
Zitat von schnorz:
Ich möchte eine verschachtelte Virtualisierung mit mit ESXi 4.1 Build 721871 (Intel VT CPUs) wie folgt vornehmen:

Ist VT auch im BIOS eingestellt/aktiviert?

monitor_control.restrict_backdoor = TRUE
monitor_control.vt32 = TRUE

Ist falsch:
01.
monitor_control.restrict_backdoor="true" 
02.
monitor.virtual_exec="hardware"
(zumindest für ESXi 5.1, dazu aber ganz unten mehr...)

"Binary translation is incompatible with long mode on this Platform. Disabling long mode......."

Richtig, denn ohne korrekte Settings KEIN 64Bit.

Ignoriere ich obige Meldung (da ich ja eingentlich VT Intel CPUs einsetze) erscheint dann die nächste Meldung:
"This virual machine is configured for 64-bit guest operating systems. However, 64-bit operation is not possible". This
host does not support Intel VT-x".

Genau. Weil Du eben VT-x nicht durchgereicht hast...

In diversen Foren haben zwar einige das gleiche Problem, bin aber auf eine Lösung gestossen.

Weil die auch alle das Thema Virtualisierung nicht verstanden haben.
Man sollte schon am Ball bleiben, wenn man virtualisiert, und auch mal verstehen, WIE so eine Virtualisierung überhaupt

Denn jetzt kommts: Du solltest Deinen ESXi vielleicht mal auf 5.1 aktualisieren...

Wer hat von Euch gleiche Erfahrungen gemacht und eine eventuell Lösung oder einen Workaround?

Siehe letzter Hinweis.


Lonesome Walker
Bitte warten ..
Ähnliche Inhalte
Heiß diskutierte Inhalte
Verschlüsselung & Zertifikate
gelöst Festplattenverschlüsselung im Ausland (13)

Frage von Nicolaas zum Thema Verschlüsselung & Zertifikate ...

Windows Server
gelöst Microsoft-Lizenz CALs und passendes Server-Betriebssystem (12)

Frage von planetIT2016 zum Thema Windows Server ...

Festplatten, SSD, Raid
gelöst Fehlerhafte Blöcke im RAID 10 (12)

Frage von Kojak-LE zum Thema Festplatten, SSD, Raid ...

Netzwerkgrundlagen
gelöst Cisco SG500 Series LAG hat sich von selbst umgestellt (11)

Frage von Ex0r2k16 zum Thema Netzwerkgrundlagen ...