Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

VMWare Server Benutzerabmeldung beim Host

Frage Virtualisierung Vmware

Mitglied: floriank

floriank (Level 1) - Jetzt verbinden

20.01.2008, aktualisiert 22.01.2008, 4383 Aufrufe, 7 Kommentare

Hallo zusammen,

Ich möchte unsere Server mit VMWare Server (ESX ist uns zu teuer) virtualisieren.
Ist auch schon alles fertig und läuft.

Jetzt habe ich aber ein Problem.

VMWare Server ist auf einem 2003 Server 64bit installiert.
Wenn ich mich jetzt von dem System (Host) abmelde, knallen die VM runter und sind aus.
Ist das richtig???? Ist VMWare (Server) so ein billiger Mist?

Kann man das irgendwie ändern??

Grüße und vielen Dank für eure Antworten

Florian
Mitglied: scheriff
20.01.2008 um 23:48 Uhr
Hallo Florian,
ich habe mir angewöhnt, mich zu hinterfragen, ob der Fehler eventuell bei mir liegt, bevor ich etwas kritisiere. Pauschale Äußerungen kommen nicht sonderlich gut....

Nun zum Thema: Hats Du einmal geprüft, ob in den "Virtual Machine Settings" im Reiter "Options" unter "Startup/Shutdown" die entsprechenden Options bei: "On host startup / ....shutdown" gesetzt sind?

Wenn Du einen automatischen Start der VM beim Host Start erreichen möchtest, wähle :"Power on..." - identisch gehst Du beim Host Shutdown vor: Hier wählst Du: "Shut down guest...."

Vorraussetzung für das korrekte funktionieren dieser Optionen sind die im Guest System installierten VMwareTools, welche Du im gestarteten Zustand einer VM installieren kannst.
(erreichbar im Menü der VMware Server Console unter "VM" - "Install VMware Tools..."

Grüße Sheriff
Bitte warten ..
Mitglied: scheriff
20.01.2008 um 23:53 Uhr
sorry noch ein Nachtrag - wenn dieses Problem beim abmelden von der Hostmaschine auftritt, musst Du die VMs entweder mit einem gesonderten Windows Account (vom Host) oder mit dem lokalem System Account (vom Host) laufen lassen. Diese beiden Optionen erreichst Du - wie vorhin beschrieben - über die Startup/Shutdown Options.

Ich hoffe dies hilft Dir weiter.

Grüße Sheriff
Bitte warten ..
Mitglied: utopia
21.01.2008 um 01:07 Uhr
Also VMware Server ist absolut unabhängig von angemeldeten Benutzern. Wenn deine VM so ein Verhalten aufweist, dann aufgrund deiner Fehlkonfiguration derer.

Einfach vorhergehende Beiträge befolgen oder in der Doku nachlesen.
Bitte warten ..
Mitglied: floriank
22.01.2008 um 20:38 Uhr
Hi,

Erst mal danke für eure Antworten.

@ Sheriff nicht böse sein , war an dem Wochenende ein wenig entnervt...

Die Einstellmöglichkeiten kenne ich.
Die lösen aber mein Problem nicht.
(Außer das mikt einem Anderen Benutzer, das habe ich noch bicht versucht)

Da kann ich ja "nur" einstellen, wie sich die VM´s verhalten sollen, wenn ich den Host runterfahre.

Aber ich will ja eigendlich, das die VM´s sozusagen als Dienst laufen.
Ich will ja nicht immer an dem Server angemeldet sein, nur damit die VM´s laufen.

Das Problem tritt auch dann auf, wenn ich als z.B. Admin lokal an der Host Maschiene angemeldet bin, mich dann via Remote Desktop an dieser Hostmaschiene anmelde und wieder vom Remote Desktop abmelde. Ergebniss VM´s tot. Lokaler benutzer ist aber immer noch angemeldet.

Leider finde ich nirgendwo in den Settings was, was mir weiter helfen könnte.

Sobald ich meine Platten wieder habe werde ich mal versuchen die VM´s unter anderem Benutzer laufen zu lassen.

Grüße Florian
Bitte warten ..
Mitglied: utopia
22.01.2008 um 20:53 Uhr
ist mir ziemlich schleierhaft, da die standardeinstellung das nicht verursacht..

Überprüf mal deine Einstellung bei

VM -> Settings

Reiter: Options
Item: Startup/shutdown
Bitte warten ..
Mitglied: floriank
22.01.2008 um 21:08 Uhr
Werde ich noch mal checken.
Wir habe gerade nur ander platten in der Maschiene um ESX mal zu testen.
Hofffe ich kann die Platten morgen oder übermorgen wieder einbauen.

Default war bei mir:
User that powerd on the virtual machine

Je länger ich darüber nachdenke, glaube ich das die Einstellung daran schuld ist.
Wenn ich den User mit dem die VM gestartet wurde abmelde kann ich mir schon vorstellen das die VM dann auch weg ist.

Dann werde ich so schnell es geht mal versuchen, die VM mit einem anderen User zu starten.

Grüße Florian
Bitte warten ..
Mitglied: scheriff
22.01.2008 um 22:32 Uhr
Hallo Florian,
no - problem - wir sind halt alle nicht ohne Emotionen...

Also, wenn bei Dir das Problem nur beim Abmelden besteht, dann sind es definitiv die Settings aus dem 2ten Posting. die zur Lösung führen.

Du kannst der Einfachheit ruhig den System Account nutzen (diesen kann man aber nur mit lokalen Adminrechten auswählen) - der extra Account ermöglicht es auch Usern ohne Adminrechte die VM wie gewünscht laufen zu lassen. Ansonsten gibt es glaub ich keine großen Unterschiede. Ich nutze dies Optionen um die Windows Prozesse sauber trennen zu können.

Danach sollten die VMs nur heruntergefahren werden, wenn Du das Hostsystem beendest und beim Starten des Hosts auch automatisch die VMs hochfahren (siehe Posting 1)

Grüße Sheriff
Bitte warten ..
Neuester Wissensbeitrag
Heiß diskutierte Inhalte
TK-Netze & Geräte
gelöst Telefonanlage gesucht (35)

Frage von Xaero1982 zum Thema TK-Netze & Geräte ...

Erkennung und -Abwehr
Virenschutz - Meinungen (29)

Frage von honeybee zum Thema Erkennung und -Abwehr ...

Windows 10
gelöst Welches OS für Firmengeräte? (20)

Frage von MarkusVH zum Thema Windows 10 ...

Exchange Server
SBS2011: POP3-Connector 10 MB Grenze Email Benachrichtigung (20)

Frage von bogi1102 zum Thema Exchange Server ...