Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

VMWare Server Internetverbindung

Frage Virtualisierung Vmware

Mitglied: stephan.s

stephan.s (Level 1) - Jetzt verbinden

03.05.2010 um 12:46 Uhr, 4348 Aufrufe, 3 Kommentare

Internetverbindung mit aktueller VMWare Server Version funktioniert nicht.

Hallo Zusammen, ich mach gerade meine ersten schritte mit VMWare und habe nun ein kleines Problem.


VMWare Server läuft auf meinem Linux-Rootserver ( Debian ) ich nutze die aktuelle VMWare Server Version und habe nun mit VMWare Server einen Windows Server 2003 Virtualisiert, soweit klappt und funktioniert auch alles bis auf das Internet.

Ich weiss nicht wirklich weiter und google + diverse Foren die ich durchgelesen habe können mir auch nicht Helfen.


Ich weiss nicht wie genau ich das nun Einstellen soll das er die Vorhandene Internetverbindung, die ich auch für Linux nutze, nutzt.

Ich hoffe das jemand zeit hat sich mit mir und meinem Problem auseinanderzusetzen!

Gruß
Stephan
Mitglied: aqui
03.05.2010 um 13:07 Uhr
Es ist eigentlich ganz einfach und mit etwas nachdenken kommt man von selbst drauf ! Du hast bei VmWare 3 Netzwerk Optionen:
1.) Host Modus
2.) NAT Modus
3.) Bridge Modus

Bei 1. dem Host Modus ist die VmWare Verbindung zwischen dem virtuellen Adapter Host und dem VM Adapter ein vollkommen separates IP Netz. Logischerweise müsstest du mit dem Linux Host dann routen und dein VM internes IP Netz dem Hoster bekannt machen. Das erzwingt dann ein öffentliches IP Netz was weltweit im Internet bekannt ist....
vergiss das also denn sowas macht kein Hoster und vermutlich könntest du es auch nicht bezahlen....

Bei 3. arbeiten beide NICs im Bridge_Modus, es besteht also eine einfache LAN Bridge auf Mac Adress Basis. Das würde bedeuten, das du von deinem Hoster eine weitere öffentliche IP Adresse im IP Netz des Linux Rechners requesten müsstest und die dann auf dem VM Interface eintragen müsstest.
Das funktioniert und deine VM ist dann wie der Linux Rechner direkt im Internet..vermutlich musst du das aber zusätzlich bezahlen denn sowas macht ein Hoster nicht umsonst !! Zusätzlich musst du dir Gedanken zur Absicherung des Servers machen, denn einen Server mit MS OS direkt im Internet zu haben hat bekanntlich seine (Sicherheits) Tücken...

Bei 2. hast du auch intern auch ein separates IP Netz, meist ein RFC 1918 privates IP Netz was VmWare vorgibt, aber der Linux Host macht auf seinem Adapter mit der öffentlichen IP Adresse dann NAT (Adress Translation) ! Er übersetzt also das interne Netz auf seine öffentlich erreichbare IP.
Im Grunde ist es IP technisch exakt das gleiche was auch dein lokales Netz zuhause am DSL Router macht. Der NATet auch dein lokales Netz auf seine öffentliche DSL IP vom Provider.
Zusätzlich hast du die Sicherheit einer NAT Firewall für den VM Server.

Fazit: Mit Option 2. also NAT Modus bekommst du das problemlos im Handumdrehen zum Laufen.
Schwierig wird es wenn du den VM Server von außen direkt erreichen willst, denn dann musst du erst die interne NAT Firewall überwinden. Für einzelne Dienste geht das aber problemlos, denn VmWare biete auch dort Port Forwarding an indem eingehende Ports an der Host IP auf den internen VM Server Port forwardest.
Beispiel: Du hast auf dem VM Server einen Webserver laufen. Mit TCP kannst du ihn nicht ansprechen, denn darauf reagiert ja der Webserver des Linux Hosts wenn du aber z.B. den Port TCP 8080 auf die interne VM IP mit dem Port 80 translatest mit der VM Einstellung kannst du den internen Server mit http://<Linux_ip>:8080 erreichen.
Analog machst du das für alle anderen Dienste.
Skalierbar ist das aber natürlich nicht denn es klappt immer nur für einen Port. Ggf. musst du also dann doch den Bridge Modus nehmen und dir eine weitere IP "dazukaufen" !
Bitte warten ..
Mitglied: stephan.s
03.05.2010 um 13:25 Uhr
Es läuft im "Bridge Modus" ich habe diverse IP's, weiss jedoch nicht wo ICH sie eintragen soll / muss, in meiner Übersicht (VMWare Server Interface ) ist auch folgendes zu sehen


DNS Name
Not Available

IP Addresses
Not Available

//edit

Nun ist dort eine DNS und IP Adresse weil ich die Tools nicht Installiert habe was ich nun nachgeholt habe.

Wenn ich jetzt im Explorer beispielweise google.de eingebe dann lädt er sich tot, keine Meldung das er die Seite nicht anzeigen kann o.Ä
Bitte warten ..
Mitglied: aqui
03.05.2010 um 13:33 Uhr
OK, im Bridge Modus musst du logischerweise zwingend eine IP vom Provider haben !! Ohne die geht es im Bridge Modus ja nicht, denn beim Bridging benötigt man keine IP Adressen sondern logischerweise nur MAC Adressen !!
Wenn du also diese öffentliche IP Adresse vom Provider hast, dann hast du von ihm auch eine Subnetzmaske zu dieser IP, eine Gateway IP und auch einen DNS Server IP bekommen.
Nun gehst du wie unter Winblows üblich mit einem Rechtsklick in die Eigenschaften des VM Adapters und trägst dann unter den TCP/IP Einstellungen alle diese IP Adressen ein...und gut ist ! Der Server ist dann über diese IP erreichbar !
Wo ist da dein Problem ?!
Ansonsten wenn du es weiter nicht verstehst lies dir nochmal die Optionen der unterschiedlichen VM Netzwerk Modi durch wie sie auch hier z.B. erklärt sind:
http://en.kioskea.net/faq/1166-vmware-and-virtualbox-the-different-mode ...
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Vmware
Storage für VMWare Server gesucht (10)

Frage von MichiBLNN zum Thema Vmware ...

Vmware
gelöst Server 2008 R2 in VMware (ESX-Farm) extrem langsam (10)

Frage von YotYot zum Thema Vmware ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...