Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

VMWare vCenter Orchestrator - Probleme bei DB-Konfiguration

Frage Virtualisierung Vmware

Mitglied: aAS2Ee

aAS2Ee (Level 1) - Jetzt verbinden

09.02.2011 um 16:15 Uhr, 6081 Aufrufe, 4 Kommentare

Ich versuche gerade den VMWare vCenter Orchestrator zu konfigurieren und komme bei der Datenbankkonfiguration nicht weiter.

Hallo zusammen,

ich habe das folgende Problem. Ich kann bei der Konfiguration des VMWare vCenter Orchestrators keine Verbindung zur SQL 2008 DB aufbauen. Diese befindet sich auf einem separaten System, jedoch in der gleichen Domäne und sogar im gleichen Netz.

Meine derzeitige Konfiguration wie folgt aus.

fc8924404c8871e2a53737a896a35bfd - Klicke auf das Bild, um es zu vergrößern

Ich kann nur sagen, die Angaben stimmen. Habs unzählige Male probiert, erhalte aber immer die folgende Fehlermeldung.

Cannot connect to jdbc:jtds:sqlserver://lab-srv001:1433/VCO;domain=lab.intra;instance=lab_srv001_b. Connection error was: Anmeldefehler. Die Anmeldung stammt aus einer nicht vertrauenswürdigen Domäne und kann mit der Windows-Authentifizierung nicht verwendet werden.

Es erscheint immer die gleiche Fehlermeldung, unabhängig davon was für einen Benutzeraccount ich verwende. Selbst bei einem Domain-Admin erscheint der gleiche Fehler. Die Verbindung funktioniert zudem mit dem SQL Management Studio problemlos. Nur der Orchestrator scheint hier Probleme zu haben. Auf dem SQL Server erscheinen bei den Login versuchen jeweils die folgenden Meldungen.

Login failed. The login is from an untrusted domain and cannot be used with Windows authentication. [CLIENT: 192.168.1.12]

SSPI handshake failed with error code 0x8009030c while establishing a connection with integrated security; the connection has been closed. [CLIENT: 192.168.1.12]

Hab bereits nach einer Lösung gegoogelt. Für die Fehlermeldungen gibts zwar viele Treffer, mir hat aber nichts wirklich weitergeholfen.
Ich hab schon daran gedacht, dass der Orchestrator evtl. den falschen Treiber für den Verbindungsaufbau benutzt, hatte diesbezüglich bereits bei der Installation des vCenter Servers Probleme. Habe aber keine Möglichkeit gefunden den zu verwendenden Treiber mitzugeben.

Ich hoffe jemand kann mir helfen, ich schlag mich jetzt schon den ganzen Nachmittag damit rum. Vielen Dank.
Mitglied: 32067
09.02.2011 um 17:48 Uhr
Hallo,

solltest du nicht unten den Haken bei "Windows Authentication Mode" setzen ?

Dein Username hat ein "\" drin, d.h. das ist ein Windows-User und kein reiner Datenbank-User ...

Mit freundlichen Grüßen
Bitte warten ..
Mitglied: 2hard4you
09.02.2011 um 18:30 Uhr
Moin,

ich würde dann noch checken, ob der User auch Rechte auf dem SQL hat ... ohne das geht es nämlich auch nicht

Gruß

24
Bitte warten ..
Mitglied: aAS2Ee
09.02.2011 um 18:44 Uhr
Bei dem Haken bei "Windows Authentication Mode" war ich mir auch nicht sicher. Ich hab beides ausprobiert und beides ging nicht. Ich denke aber es ist schon richtig, dass der Haken nicht gesetzt ist. Wie ich das verstanden habe, ist der Haken dazu da um NTLM Authentifizierung zu forcieren. Die Authentifizierung sollte doch aber eigentlich über Kerberos erfolgen.

Der User ist tatsächlich ein Windows User. Soweit ich weiss, unterschiedet der Orchestrator anhand der angegebenen Domäne zwischen Windows- und SQL-Authentifizierung. D.h. wenn keine Domäne angegeben wird, nimmt der Orchestrator an, dass es sich um einen SQL User handelt und ansonsten geht er von Windows-Authentifizierung aus.

Der Benutzer hat zudem db_owner Rechte auf der Datenbank. Das sollte daher kein Problem sein. Wie gesagt, habe ich auch versucht mit einem Domain-Admin eine Verbindung zur DB herzustellen. Dieser hat lokale Admin-Rechte auf dem SQL- und dem Orchestrator-Server auch auf den Datenbanken. Ich glaube daher nicht, dass es sich um ein Berechtigungsproblem handelt. Datenbankseitig ist die Authentifizierung natürlich auf Mixed-Mode gestellt, d.h. Windows- und SQL-Authentifizierung. Ausserdem funktioniert die Anmeldung an der DB ja mit dem SQL Management Studio. Wenn es sich um ein Berechtigungsproblem handeln würde, dürfte ja auch das nicht funktionieren.

Mit freundlichen Grüßen
Bitte warten ..
Mitglied: aAS2Ee
10.02.2011 um 13:43 Uhr
Ich hab im Security Log die folgende Meldung gefunden. Hilft das vielleicht jemandem weiter? Beim googeln bin ich auf Hinweise gestossen, wonach der Fehler evtl. mit der Authentifizierung zusammenhängen könnte. Sprich: Client nutzt NTLM aber Server verlangt NTLMv2 oder sowas. Ich hab jetzt mal die Verschlüsselung beidseitig deaktiviert und den "LAN Manager authentication level" auf "Send LM & NTLM - use NTLMv2 session security if negotiated" gestellt (Local Security policies). Hat aber leider auch nichts gebracht. Vielleicht könnt ihr mit der Meldung ja was anfangen.

An account failed to log on.

Subject:
Security ID: NULL SID
Account Name: -
Account Domain: -
Logon ID: 0x0

Logon Type: 3

Account For Which Logon Failed:
Security ID: NULL SID
Account Name: lab\labsrv-vCO
Account Domain: LAB.INTRA

Failure Information:
Failure Reason: Unknown user name or bad password.
Status: 0xc000006d
Sub Status: 0xc0000064

Process Information:
Caller Process ID: 0x0
Caller Process Name: -

Network Information:
Workstation Name:
Source Network Address: -
Source Port: -

Detailed Authentication Information:
Logon Process: NtLmSsp
Authentication Package: NTLM
Transited Services: -
Package Name (NTLM only): -
Key Length: 0

This event is generated when a logon request fails. It is generated on the computer where access was attempted.

The Subject fields indicate the account on the local system which requested the logon. This is most commonly a service such as the Server service, or a local process such as Winlogon.exe or Services.exe.

The Logon Type field indicates the kind of logon that was requested. The most common types are 2 (interactive) and 3 (network).

The Process Information fields indicate which account and process on the system requested the logon.

The Network Information fields indicate where a remote logon request originated. Workstation name is not always available and may be left blank in some cases.

The authentication information fields provide detailed information about this specific logon request.
- Transited services indicate which intermediate services have participated in this logon request.
- Package name indicates which sub-protocol was used among the NTLM protocols.
- Key length indicates the length of the generated session key. This will be 0 if no session key was requested.
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Vmware
Alte Versionen von VMware vCenter Converter (13)

Frage von Dani zum Thema Vmware ...

Server
Probleme bei der Konfiguration von Apache mit IPv6 (3)

Frage von DarkShadow zum Thema Server ...

Windows 7
gelöst Sind euch verstärkte Probleme bei Windows 7 Updates aufgefallen? (4)

Frage von RadioHam zum Thema Windows 7 ...

Cloud-Dienste
gelöst OwnCloud 8 Probleme mit Vorschaubildern auf Mobilgeräten (1)

Frage von zeroblue2005 zum Thema Cloud-Dienste ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (17)

Frage von JayyyH zum Thema Switche und Hubs ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

DSL, VDSL
DSL-Signal bewerten (14)

Frage von SarekHL zum Thema DSL, VDSL ...