Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Vodafone UMTS USB-Stick unter Linux ?

Frage Hardware

Mitglied: Alphavil

Alphavil (Level 2) - Jetzt verbinden

01.02.2008, aktualisiert 22.02.2008, 30874 Aufrufe, 13 Kommentare

Hallo,

Ich habe folgendes Problem:

- Vodafone UMTS-Stick (Novatel MC950D)
- Asus Eee MiniNotebook mit Xandros-Linux (vorinstalliert)

Ich möchte den Stick auf dem Eee nutzen, nur leider wird er nicht als Modem sondern als Speicherstick erkannt. Treiber sind natürlich für Linux keine dabei

Es gibt aber welche unter: http://www.vodafonebetavine.net/web/linux_drivers

Nur wie so oft üblich sind die Manuells nicht verfügbar


Es gibt gewisse Anleitungen für den Stick von E-Plus (Huawei). Ich hänge noch an folgendem:

modprobe usbserial vendor=XXXXXX product=XXXXXX

In der Anleitung is natürlich die VendorNr und productNr von dem E-Plus-Teil drin, wie bekomme ich das für den Vodafone-Stick raus?


Ich brauch da dringend Hilfe, bin schon am verzweifeln


Viele Grüsse


Andre
Mitglied: Alphavil
05.02.2008 um 08:48 Uhr
So nun habe ich ein spezielles Ubuntu (EeeXubunutu) auf den Eee installiert. Mit Hilfe eines kleinen Skriptes, den Tools "comgt" und "GnomePPP" kann ich zumindest mal den Stick ansprechen und er leuchtet auch nicht mehr rot sondern blau, das soviel bedeutet wie das er mit UMTS verbunden ist.

Leider klappt die Einwahl per GnomePPP noch immer nich

Hier die Ausgabe davon:
WvDial<*1>: WvDial: Internet dialer version 1.56
WvModem<*1>: Cannot get information for serial port.
WvDial<*1>: Initializing modem.
WvDial<*1>: Sending: ATZ
WvDial Modem<*1>: ATZ
WvDial Modem<*1>: OK
WvDial<*1>: Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
WvDial Modem<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
WvDial Modem<*1>: OK
WvDial<*1>: Modem initialized.
WvDial<*1>: Sending: ATM1L3DT*99*1#
WvDial<*1>: Waiting for carrier.
WvDial Modem<*1>: ATM1L3DT*99
*1#
WvDial Modem<*1>: CONNECT HSDPA 7.2
WvDial<*1>: Carrier detected. Waiting for prompt.
WvDial<Err>: Connected, but carrier signal lost! Retrying.
Bitte warten ..
Mitglied: nixdorf
06.02.2008 um 14:03 Uhr
Hallo,

ich bin auch gerade dabei mir den Novatel MC950D zu besorgen, ich mochte Ihn an einen Debian/etch - rechner anschließen.

Hast Du schon Fortschritte gemacht? Würdest Du mir das immer noch empfehlen?

Gruß Nixdorf
Bitte warten ..
Mitglied: Alphavil
06.02.2008 um 18:48 Uhr
Hej,

So wir haben das Teil jetzt zum Laufen bekommen, allerdings nach langem rumprobieren. Aber anscheinend haben dem Teil nur ein Zeile Parameter im Init-Script gefehlt. Wie gesagt wir haben es unter Xandros nicht zum Laufen bekommen !!! Unter Ubuntu schon. Da ich heute leider krank bin und die Vorgehensweise in der Firma liegt, kann ich sie erst online stellen sobald ich wieder fit bin.


Gruß André
Bitte warten ..
Mitglied: nixdorf
07.02.2008 um 08:40 Uhr
Hallo,

ja, das wäre sehr nett, wenn Du das noch mal online stellen könntest.

Gute Besserung Nixdorf
Bitte warten ..
Mitglied: Alphavil
11.02.2008 um 15:24 Uhr
Sorry das ich mich jetzt erst wieder melde, aber war ja 3 tage krankgeschrieben.

Bin jetzt gerade dabei das Skript für den Stick noch anzupassen (das er als Modem und nicht wie sonst als Speicher erkannt wird) und poste es dann als Anleitung


Gruß Andre
Bitte warten ..
Mitglied: nixdorf
19.02.2008 um 11:23 Uhr
Hallo Andre,

wie sieht es denn aus? Hast Du das mit dem Script hinbekommen?


Gruß NIxdorf
Bitte warten ..
Mitglied: Alphavil
19.02.2008 um 16:01 Uhr
Servus,

Wir haben es soweit hinbekommen das der Stick automatisch als Modem und nicht mehr als Massenspeicher erkannt wird.

Folgende Vorgehensweise:

- Definieren einer neuen Udev-Regel (die den Stick erkennt und automatisch ein Skript startet):

/etc/udev/rules.d/

Da erstellste ne neue Datei (bei mir heist sie "80-umts_stick.rules") mit folgendem Inhalt:
SUBSYSTEM=="usb", SYSFS{idProduct}=="5010", SYSFS{idVendor}=="1410", ACTION=="add", RUN+="/usr/bin/vodafone.sh"

- Erstellen des neuen Skriptes (vodafone.sh):

unter /usr/bin/

Inhalt:

#! /bin/bash
device=`mount | grep NVTL | cut -f 1 -d " "`
sudo modprobe -r usbserial
sudo eject $device > /dev/null 2>&1
sudo rm /media/NVTL* -rf > /dev/null 2>&1
sudo modprobe usbserial vendor=0x1410 product=0x4400 > /dev/null 2>&1
if [ -e /dev/ttyUSB0 ]; then
sudo echo 5001 | sudo comgt -d /dev/ttyUSB0 > /dev/null 2>&1
fi

Danach kannst du z.B. mit GnomePPP eine Einwahl ins Internet herstellen.


Aber wie gesagt das is alles noch nicht so perfekt, den mal funktioniert es und mal nicht

Die Hoffnung stirbt zu letzt


Gruß Andre
Bitte warten ..
Mitglied: nixdorf
19.02.2008 um 16:34 Uhr
Hallo Andre,

danke für die scripts, aber muß das nicht heißen:

SUBSYSTEM=="usb", SYSFS{idProduct}=="0x4400", SYSFS{idVendor}=="0x1410", ACTION=="add", RUN+="/usr/bin/vodafone.sh"

bei der udev - regel?

Kann ich das auf einem Debian/etch auch anwenden?

Mit dem Stick bin ich jetzt auch im internet. Ich muß momentan immer noch per hand einmal modprobe usbserial vendor=0x1410 product=0x4400 eingeben und dann gehe ich mit vwdial in das Internet.


Gruß Nixdorf
Bitte warten ..
Mitglied: Alphavil
20.02.2008 um 09:21 Uhr
Das Problem ist das der Stick ja zuerst als Massenspeicher erkannt wird und da hat er die
idProduct= 5010 , erst dann wird das Skript aufgerufen. Dadurch ersparst du es dir von Hand modprobe einzugeben.

Wir testen gerade noch ne ganz andere Variante, ohne UDEV


Gruß Andre
Bitte warten ..
Mitglied: nixdorf
20.02.2008 um 11:49 Uhr
Hallo Andre,

vielleicht kannst Du es ja noch mal pasten, es würde mich sehr instessieren.
Wenn ich den Rechner hochfahre mit eingestecktem Stick, modprobe usbserial vendor=0x1410 product=0x4400 ausführe und dann wvdial, bekommich meisten eine Verbindung hin. Ab und an findet er aber auch dann nichts unter /dev/ttyusb0. Dann muß ich erst immer wieder ein paar mal herunterfahren und dann klapt es irgendwann wieder. Hast Du da noch eine Idee woran das liegen kann?
Die Scripte von Dir müste ich ja eigenlich ohne große Änderungen auch unter Debian/etch nuten können, Ihre hattet Sie für Ubuntu programmniert, richtig?

Gruß NIxdorf
Bitte warten ..
Mitglied: Alphavil
21.02.2008 um 08:40 Uhr
Hej,

Ich steck den Stick immer erst rein wenn der Rechner hochgefahren ist. Um online zu gehn benutze ich gnomePPP was ja auch wvdial intern benutzt. Das Problem das er /dev/ttyusb9 nicht findet hatte ich auch schon Aber an was das liegt kann ich dir leider noch nicht sagen. Wir haben das ja hier alles auf einem xUbuntu laufen, daher müsste es unter Debian genauso funktionieren (geh ich mal von aus)


Gruß Andre
Bitte warten ..
Mitglied: nixdorf
21.02.2008 um 16:40 Uhr
Hallo Andre,

funktioniert denn der Stick bei Euch jetzt einwadfrei? Ich komme mit dem Stick zwar irgendwann immer wieder in das Internet, aber nicht immer beim ersten versuch manmal muß dann immer wirder warten es noch mal probieren...

Es kommt immer die Fehlermedung:

-->> Cannot open /dev/ttyUSB0: NO such file or directory


Hast Du noch eine Idee? Habt Ihr Euer Script noch weiter angepasst?


Danke für die Hilfe,

Gruß NIxdorf
Bitte warten ..
Mitglied: nixdorf
22.02.2008 um 11:03 Uhr
Hallo,

noch mal zu der Fehlermeldung, immer wenn die auftritt, zeigt lsusb -v mir an, das er den Stick immer noch als Speicherkarte geladen hat. auch ein modprobe -r usbserial und dann ein modprobe usbserial vendor=0x1410 product=0x4400 ändert daran dan nichts.

Wenn ich den Stick reistecke, bilnkt der zunächst erst mal rot, bevor er dann irgendein Netz anzeigt. Wir das Script von Euch nicht dann zu früh ausgefürt? Solage er rot blinkt, kann er sich doch gar nicht verbinden.

Gruß Nixdorf
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Speicherkarten
USB-Stick laut Windows und Linux belegt, aber kein Inhalt zu sehen (5)

Frage von Pago159 zum Thema Speicherkarten ...

IDE & Editoren
USB STICK Datei AUTOMATISCH beim anschliessen auf fremden PC öffnen (9)

Frage von Jwanner83 zum Thema IDE & Editoren ...

Windows Tools
USB-Stick nur Lesezugriff möglich? (11)

Frage von Nathi1998 zum Thema Windows Tools ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...