Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Voller Datenspeicher auf QNAP TS-809U

Frage Hardware SAN, NAS, DAS

Mitglied: Fenris14

Fenris14 (Level 2) - Jetzt verbinden

27.11.2014, aktualisiert 10.12.2014, 3309 Aufrufe, 6 Kommentare

Guten Tag,

folgendes Problem: Ich habe hier ein QNAP TS-809U das mehrere iSCSI-Ziele hostet. Konfiguriert ist ein Raid 5 und das ganze Volume ist zum Bersten voll. Auf diesem iSCSI-Zielen befinden sich hauptsächlich virtuelle Maschinen und deren VHD´s. Nun habe ich noch ein zweites NAS mit mehr Speicher hier stehen und auf dieses wollte ich jetzt einige VM´s verschieben. Da wir VmWare verwenden, habe ich über dessen vSphere die Daten über Dateimanager auf das leere NAS verschoben. Hat auch super funktioniert. Doch nun ist die Platte immernoch voll. In der Verwaltungsoberfläche des NAS wird immer noch die Warnung und das volle Volume angezeigt. Ich kann auch nichts drauf verschieben, sagt mir immer "Das Ziel ist voll". Auch im vSphere werden mir falsche Werte angezeigt über den Status der Platten.

Also wie bekomme ich es hin das die Platten wieder frei werden?

Bitte jetzt kein Sprüche von wegen: Wer macht den auch so einen scheiß... oder... brauchst dich nicht zu wundern. Ich habe es auch nur übernommen.

Danke im voraus.
Mitglied: felix.huth
27.11.2014 um 15:18 Uhr
Hallo

Da du nun die VHDs von der vollen NAS auf die leere NAS geschaufelt hast (und du dir 100% sicher bist dass VMWare auf die nicht-volle zugreift) musst du bei der alten NAS die LUNs von den Targets lösen - diese LUNs können dann problemlos gelöscht werden und schon hast du wieder freien Speicher.

Ich denke dir ist bekannt dass iSCSI immer aus 2 Teilen besteht - einmal das Target und dann das LUN, wobei letzteres die "Festplatte" ist. Dieser Speicher wird entweder sofort zugewiesen oder mittels Thin Provisoring (wie es bei QNAP so schön heißt). Aber nichts deso trotz - dieses LUN nimmt einfach dann bei dir den Speicher weg, egal ob es noch genutzt wird oder nicht - daher muss das LUN vom iSCSI Target genommen werden und dann seperat gelöscht werden.

Als Anmerkung zur Konfiguration - ich hab beim Kunden ebenfalls die VHDs mittels iSCSI eingebunden (nur halt besseres Modell von QNAP und 10 Gigabit direct atttached an die Server und muss sagen der Kunde ist zufrieden).

LG
Felix
Bitte warten ..
Mitglied: Fenris14
27.11.2014 um 17:00 Uhr
Hmm. Problem ist aber auch das ich nicht alles aus dem target geschaufelt habe. Einige VM´s laufen dort drauf weiter. Ich habe lediglich einige wenige entfernt um die "Last" zu verteilen. Nun wollte ich aber wieder auf den erhofften freien Speicher was rauf schieben. Dies würde dann also erst gehen wenn ich Ziel "abkoppel"... richtig?
Bitte warten ..
Mitglied: felix.huth
LÖSUNG 27.11.2014, aktualisiert 10.12.2014
Gehe ich jetzt Recht der Annahme, dass du nur ein iSCSI Target hast und dort nur ein LUN existiert auf dem alle VHDs sind? Wenn ja hast du ein Problem, heißt VMs runterfahren, VHD auslagern, LUN dekativieren und löschen, neues "kleineres" LUN erstellen und an das Target binden.

Nur als kleinen Tipp: iSCSI ist nicht Multiprozessorfähig bei QNAP, daher empfehle ich dir für jede VM eine seperates Target und LUN zu erstellen (gut nun weiß ich nicht wieviele VMs du hast, aber je nach Modell sollten es laut QNAP mehr iSCSI Targets sein als CPU Kerne ...)
Bitte warten ..
Mitglied: Fenris14
30.11.2014 um 00:33 Uhr
Genau das ist mein Problem... Leider wurden damals zwar drei iSCSI-Targets konfiguriert, aber pro Target nur eine LUN. Als ich dies anfangs gesehen habe, war ich auch "leicht" verwirrt.

Ich habe noch eine andere Möglichkeit gefunden:

http://www.vmworld.net/?p=1353

Schonmal probiert? Hat jemand Erfahrung damit gemacht?
Bitte warten ..
Mitglied: Fenris14
02.12.2014 um 09:11 Uhr
Durch das Thin-Provising bin ich nun gezwungen erstmal das ganze Zeug von dem einem NAS auf das andere zu packen.

Danach werde ich die Target´s neuanlegen und für jede virtuelle VHD nen eigenes LUN verwenden mit ein wenig mehr Speicher dazu. So könnte man es doch machen, oder?

Den wen jetzt eine Platte Voll ist lege ich einfach ein neues LUN an und lösche das alte...
Bitte warten ..
Mitglied: Fenris14
10.12.2014 um 08:36 Uhr
Ok, hat alles funktioniert. Habe mehere kleine LUN´s angelegt und habe die VM´s drauf verteilt.
Bitte warten ..
Ähnliche Inhalte
SAN, NAS, DAS
QNAP Speicherpool voll
gelöst Frage von IllusionFACTORYSAN, NAS, DAS10 Kommentare

Hallo, zusammen, bei einer QNAP NAS ist uns der Speicherpool vollgelaufen. Kein Problem, 3TB gelöscht - aber leider erkennt ...

SAN, NAS, DAS
QNAP NAS (TS-469U)
Frage von chris123SAN, NAS, DAS2 Kommentare

Hallo zusammen, ich habe unser NAS konfiguriert und soweit läuft auch alles, bis auf eine Kleinigkeit! Wenn ich im ...

Netzwerke
Qnap TS-212
gelöst Frage von sodom159Netzwerke5 Kommentare

Hallo alle zusammen, ich habe ein Problem mit einem Qnap. Auf diesem Qnap sichert der Server, ich habe heute ...

SAN, NAS, DAS
Problem mit QNAP TS-469 Pro
gelöst Frage von emeriksSAN, NAS, DAS9 Kommentare

Hi, bei uns ist übers Wochenende eine NAS vollgelaufen (QNAP TS-469 Pro). Warum und womit, das versuchen wir gerade ...

Neue Wissensbeiträge
Batch & Shell

Open Object Rexx: Eine mittlerweile fast vergessene Skriptsprache aus dem Mainframebereich

Information von Penny.Cilin vor 16 StundenBatch & Shell8 Kommentare

Ich kann mich noch sehr gut an diese Skriptsprache erinnern und nutze diese auch heute ab und an noch. ...

Humor (lol)

"gimme gimme gimme": Automatischer Test stolpert über Easter Egg im man-Tool

Information von Penny.Cilin vor 18 StundenHumor (lol)6 Kommentare

Interessant, was man so alles als Easter Egg implementiert. Ist schon wieder Ostern? "gimme gimme gimme": Automatischer Test stolpert ...

MikroTik RouterOS

Mikrotik - Lets Encrypt Zertifikate mit MetaROUTER Instanz auf dem Router erzeugen

Anleitung von colinardo vor 1 TagMikroTik RouterOS8 Kommentare

Einleitung Folgende Anleitung ist aus der Lage heraus entstanden das ein Kunde auf seinem Mikrotik sein Hotspot Captive Portal ...

Sicherheit

Sicherheitslücke in HP-Druckern - Firmware-Updates stehen bereit

Information von BassFishFox vor 1 TagSicherheit1 Kommentar

Ein weiterer Grund, dass Drucker keinerlei Verbindung nach "auswaerts" haben sollen. Unter Verwendung spezieller Malware können Angreifer aus der ...

Heiß diskutierte Inhalte
Windows Server
RDP macht Server schneller???
Frage von JaniDJWindows Server17 Kommentare

Hallo Community, wir betrieben seit geraumer Zeit diverse virtuelle Maschinen und Server mit Windows Server 2012. Leider haben wir ...

Windows 10
Windows 10 dunkler Bildschirm nach Umfallen
Frage von AkcentWindows 1015 Kommentare

Hallo, habe hier einen Windows 10 Rechner der von einem User umgefallen wurde (Beine übers Knie, an den PC ...

Windows 10
Bitlocker nach Verschlüsselung nicht mehr aufrufbar!
gelöst Frage von alexlazaWindows 1013 Kommentare

Hallo, ich besitze ein HP ZBook 17 G4 mit einem Windows 10 Pro Betriebssystem. Bei diesem Problem handelt sich, ...

Batch & Shell
Neuste Datei via PowerShell kopieren
gelöst Frage von kaiuwe28Batch & Shell11 Kommentare

Hallo zusammen, ich hatte mir mit Hilfe der Suche im Forum einen kleinen Code von colinardo rausgesucht und versucht ...