Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

VPN auf einem Cisco Router einrichten... Immer noch kein Erfolg

Frage Netzwerke Router & Routing

Mitglied: spatz75

spatz75 (Level 1) - Jetzt verbinden

17.09.2008, aktualisiert 19.09.2008, 10533 Aufrufe, 7 Kommentare

VPN Tunnel und RDP Zugang mit Cisco 876-SEC-I-K9

Hallo,
ich bin beauftragt worden ein Cisco 876 bei einer Firma zu installieren.
Mein Problem ist - ich bin kein Administrator und habe nur soviel Ahnung von der Materia, die ich im Inet finden konnte.
Ich habe zwar, mehrere Anleitungen auf der Cisco Seite gefunden, kann aber nicht abschätzen, was ich von alldem wirklich brauche.

Die Situation:

1. Ein Netzwerk mit w2k8 Server(DC, DNS, DHCP)
2. Alle Rechner haben eine feste IP Adresse (Software Voraussetzung)
3. Internet Zugang über Cisco Router 876-SEC-I-K9
4. Firma hat keine feste öffentliche IP. es wurde ein dyndns Account eingerichtet - funktioniert (ping)

Aufgabe:
1. RDP Zugang auf den Server und auf einen anderen Rechner im LAN zu ermöglichen
2. VPN Tunnel aufzubauen, damit die Mitarbeiter sich von Zuhause aus in Netz einlogen können.

Bis jetzt habe ich geschaft die Internetverbindung einzurichten.
Es wurden keine weitere Einstellungen vorgenommen.
Da wir keinen Smart-net Vertrag haben, weigert sich Cisco uns i.welchen technischen Support zu gewähren.
Das Gerät wurde mit SDM 2.4 ausgeliefert.

Auf der Cisco Seite habe ich folgende Dokumente gefunden:

Zu Aufgabe 1: http://www.cisco.com/en/US/products/sw/secursw/ps5318/products_configur ...

Zu Aufgabe 2: http://www.cisco.com/en/US/products/sw/secursw/ps5318/products_configur ...

Reicht es um die o.g. Probleme zu lösen, oder muss ich zusätzlich oder was danz anderes machen?
Da ich wie gesagt keine Erfahrung mit Cisco habe, würde ich nur ungern iwas in der Konsole programmieren, sondern am liebsten einfach nach diesen Screenshots step by step die Oberfläche einstellen.
Leider gehen diese Anleitungen nicht auf das Model ein, das wir haben.
Darüber hinaus habe ich nicht gefunden, wie ich mit der dynamischen IP Adresse(von dyndns umgehen soll)

Ein weiteres Problem ist, das ich keine Möglichkeit habe den Cisco VPN Cleient herunterzuladen.
Würde an dieser Stelle standard Windows Lösung bzw. iwelche Freeware Software funktionieren?

Über jede Hilfe würde ich mich sehr freuen und
bedanke mich im Voraus

Spatz75
Mitglied: aqui
17.09.2008 um 16:16 Uhr
Das wichtigste hast du leider nicht geschrieben nämlich WELCHES der zahlreichen VPN Protokolle du denn auf dem Cisco betreiben willst

Nun artet das hier leider mal wieder in wilde Raterei aus...

Raten wir für einen ersten Schrotschuss mal das du ggf. das PPTP Protokoll für dein VPN benutzen willst, was Windows, Mac-OSX, Linux und diverse PDAs von sich aus mit an Bord haben und wo du keine zusätzliche VPN Client SW benötigst.

Dann sähe eine Konfiguration auf deinem Router so aus:

01.
vpdn enable 
02.
03.
vpdn-group 1 
04.
! Default PPTP VPDN group 
05.
 accept-dialin 
06.
  protocol pptp 
07.
  virtual-template 1 
08.
09.
username VPNuser password GeHeim 
10.
11.
interface Ethernet0 
12.
 description Lokales Ethernet 
13.
 ip address 172.16.1.254 255.255.255.0 
14.
15.
interface Virtual-Template1 
16.
 description PPTP Dialin Interface fuer VPN Zugang 
17.
 ip unnumbered Ethernet0 
18.
 no keepalive 
19.
 peer default ip address pool pptp_dialin 
20.
 ppp encrypt mppe auto 
21.
 ppp authentication pap chap ms-chap 
22.
23.
ip local pool pptp_dialin 172.16.1.200 172.16.1.210
Du solltest dringend darauf achten, das der PPTP IP Adresspool den die VPN Clients bekommen bei der Einwahl (172.16.1.200 bis 172.16.1.210) nicht mit einem lokalen DHCP Server oder anderen statisch vergebenen IP Adressen kollidieren im IP Netz an Eth0 !!!

Ansonsten kannst du das Beispiel so abtippen, musst aber ggf. auf deine eigene IP Adressen achten und das ggf. anpassen.

Den VPN Client richtest du unter XP analog so ein wie hier im Abschnitt "Einrichtung des Clients" beschrieben:
http://www.wintotal.de/Artikel/vpnxp/vpnxp.php

Unter MacOSX bzw. Linux geht das analog so...
http://www.vpn.fh-trier.de/howto/index.phtml?BACK=&RFTLOOK=&BOO ...

Damit der Cisco DynDNS fähig wird fügst du folgendes Konfig Kommando hinzu:

01.
02.
ip ddns update method dyndns 
03.
 HTTP 
04.
 add http://<username>:<pw>:@members.dyndns.org/nic/update?system=dyndns&hostname=<h>&myip=<a> 
05.
 interval maximum 1 0 0 0 
06.
!
Username und Password musst du mit dem deines DynDNS Accounts natürlich ersetzen
Bitte warten ..
Mitglied: spatz75
17.09.2008 um 16:43 Uhr
Erstmal vielen Dank.

1. da die Art des VPN Tunnels nicht definiert wurde, werde ich wohl dieses PPTP Protokoll nutzen.
2. Ich habe ein Buch hier liegen, indem ich hoffentlich finde, wo und wie ich diese Codezeilen eintragen kann. Bis jetzt habe ich wie gesagt nur mit CDM gearbeitet.
3. Spielt es eine Rolle an welcher Stelle des Skriptes der neue Code eingetragen wird?
4. was ist mit Remotezugriff, kann ich die NAT Konfiguartion so machen wie unter 1. Link steht.

Noch mal Danke

Spatz75
Bitte warten ..
Mitglied: aqui
17.09.2008 um 16:58 Uhr
Mmmhhh, wenn das nicht definiert wurde kann das aber auch noch IPsec(ESP) oder z.B. L2TP sein... ?? Woher willst du denn wissen was du machen sollst ??? Ziemlich blauäugiger Ansatz... aber egal. Da solltest du besser mal nachfragen damit du nicht völlig umsonst konfigurierst, denn eine PPTP Konfig ist natürlich logischerweise für IPsec völlig unbrauchbar.
Der Cisco supportet alle VPN Protokolle mit entsprechender Konfig !

Den Router konfigurierst du so:

Den Router telnetten mit PUTTY oder TERATERM oder dem Winblows eigenen telnet, dann
ena
conf t

..und dann fröhlich die Zeilen eintippen. Mit ctrl z kommst du aus dem Konfig Modus wieder raus und show run zeigt dir die aktuelle Konfig an. (Kannst du so auch sichern !)
Ein ? hilft dir immer weiter bei der Syntax und ein <TAB> komplettiert die Kommandos automatisch.
Am Schluss wr nicht vergessen um die Konfig zu sichern !!!

Eine NAT Konfig mit einem DSL Beispiel sieht so aus:

01.
interface Ethernet1 
02.
 description DSL Modem Anschluss 
03.
 no ip address 
04.
 duplex auto 
05.
 pppoe enable group global 
06.
 pppoe-client dial-pool-number 1 
07.
 no cdp enable 
08.
09.
interface Dialer0 
10.
 description DSL Einwahl mit DynDNS  
11.
 ip ddns update hostname <dyndns hostname> 
12.
 ip ddns update dyndns 
13.
 ip address negotiated 
14.
 ip mtu 1492 
15.
 ip nat outside 
16.
 encapsulation ppp 
17.
 dialer pool 1 
18.
 dialer idle-timeout 0 
19.
 dialer persistent 
20.
 no fair-queue 
21.
 no cdp enable 
22.
 ppp authentication chap callin 
23.
 ppp chap password Geheim 
24.
 ppp chap hostname <dein user account> 
25.
 ppp ipcp dns request 
26.
 ppp ipcp mask request 
27.
28.
ip route 0.0.0.0 0.0.0.0 Dialer0 permanent 
29.
no ip http server 
30.
31.
ip dns server 
32.
ip nat inside source list 1 interface Dialer0 overload 
33.
34.
access-list 1 permit 172.16.1.0 0.0.0.255 
35.
36.
no cdp run 
37.
!
So, nun musst du nur noch abtippen !!
Bitte warten ..
Mitglied: spatz75
17.09.2008 um 17:03 Uhr
ok
ich fahre jetzt hin und hoffe das beste
vielen dank
Bitte warten ..
Mitglied: aqui
17.09.2008 um 19:39 Uhr
Wenns das war bitte
http://www.administrator.de/index.php?faq=32
nicht vergessen !
Bitte warten ..
Mitglied: spatz75
18.09.2008 um 11:34 Uhr
Tja, die VPN Einrichtung hat leider nicht geklappt.
Ich habe unerwartet Telefonsupport von einem Cisco Techniker bekommmen, der 4 Stundenlang versucht hat einen VPN Tunnel aufzubauen - ohne Erfolg.

Hier ist ein Skript, das vorgeschlagen und eingetragen wurde:

aaa new-model
aaa authentication login userauthen local
aaa authorization network groupauthor local
aaa session-id common
crypto isakmp policy 3
encr 3des
authentication pre-share
group 2
crypto isakmp client configuration group EZVPN_GROUP_1 <------- ist die Group für den VPN Client
key !!!!VPNPASS!!!!! <-------- ist das Passwort für die Gruppe
dns !!!!bitte DNS eintragen!!!!
domain !!!!bitteDoamaineintragen!!!!
pool vpn_clients
crypto ipsec transform-set myset esp-3des esp-md5-hmac
crypto dynamic-map dynmap 10
set transform-set myset
crypto map clientmap client authentication list userauthen
crypto map clientmap isakmp authorization list groupauthor
crypto map clientmap client configuration address respond
crypto map clientmap 10 ipsec-isakmp dynamic dynmap
!
ip local pool vpn_clients 192.168.100.1 192.168.100.254 <----- dhcp server für das vpn netzwerk
ip route 0.0.0.0 0.0.0.0 !!DAILER...!!!!
interface atm 0
crypto map clientmap
username test password test <-------- so wird ein user Angelegt.

Komischerweise war der VPN Server Test im Cisco erfolgreich
Die Clients (weder Windows standard noch Cosco VPN Client ver. 5) konnten den Server erreichen.

Könnten mir jemand helfen und sagen wie ich den Fehler im Skript / Netzwerk / Verkabelung usw. aufspühren könnte?
Gibt es iwelche Tools die die Verbindung von Client Seite testen und aussagekräftige Meldungen geben.
Oder soll ich den Scheißteil einfach in die Tonne werfen und mit Windows VPN Server (Software) probieren?

Mit freundlichen Grüßen
Spatz75
Bitte warten ..
Mitglied: aqui
19.09.2008 um 21:54 Uhr
Jetzt würfelst du alles durcheinander !!

Der Cisco Heini hat dir eine IPsec Konfiguration verpasst.
Hast du ihm etwa nicht gesagt das du wie du oben ja selber schreibst:
"1. da die Art des VPN Tunnels nicht definiert wurde, werde ich wohl dieses PPTP Protokoll nutzen..."
machen willst ???
Wenn du ihm nicht präzise sagst was du willst erzählt er dir natürlich irgendwas und das Chaos ist komplett wie jetzt !!!

Du musst dich jetzt endlich mal entscheiden WAS für ein VPN Protokoll du denn nun umsetzen willst ???

IPsec ist nicht PPTP und umgekehrt. Ein IPsec Client musst du separat installieren bzw. erwerben oder was die Cisco Jungs wollen das du natürlich teuer deren VPN Client kaufst, deshalb hat er dir ja auch die IPsec Konfig angedreht !! Da ist Cisco etwas cleverer als du scheinbar

Damit kannst du aber keine Windows VPN Session auf dem Router terminieren mit dem Windows und Mac OS-X bordeigenen VPN Client, das ist klar, denn der spricht ausnahmslos PPTP und eben kein IPsec !!
Ein Italiener und ein Franzose können sich ja auch nicht jeweils in ihrer Mutersprache miteinander unterhalten, oder ???
Wenn du beises willst benötigst du auch BEIDE Konfigs auf dem System, das ist logisch !

Also entscheide erstmal was du genau willst, dann machen wir hier weiter !!!
Bzw. bei PPTP gilt das Konfigbeispiel von oben !
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Router & Routing
TP-Link Router VPN Verbindung Router Oberfläche nicht erreichbar (3)

Frage von D46505Pl zum Thema Router & Routing ...

Router & Routing
VoIP hinter Cisco Router (23)

Frage von PharIT zum Thema Router & Routing ...

Netzwerkmanagement
SSH auf Cisco Router aktivieren, allerdings ohne line vty (8)

Frage von M.Marz zum Thema Netzwerkmanagement ...

Router & Routing
gelöst Cisco Router C886VAJ-K9 WLAN? (19)

Frage von oce zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...