Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

VPN Einwahl über Cisco Router keine DNS Namensauflösung möglich

Frage Netzwerke

Mitglied: MNormann

MNormann (Level 1) - Jetzt verbinden

07.01.2010, aktualisiert 18.10.2012, 10048 Aufrufe, 10 Kommentare

Hallo an alle,

ich habe folgendes Problem.

Wir haben hier in der Firma ein Labornetz stehen. Dieses Netz ist unabhängig vom Firmennetz.
Es besteht die Möglichkeit sich per Cisco VPN aus dem Firmennetz in das Labornetz einzuwählen. Funktionieren tut das über ein Cisco 2811 Router.
Mein Problem ist nun das wenn man sich aus dem Firmennetz einwählt, die DNS Namensauflösung nicht klappt.
z.b. ping xyz anstatt ping 192.168.x.x
(ping per IP klappt)

Wenn ich direkt im Labornetz bin funktioniert die Namensauflösung einwandfrei.
Muss ich da irgendwas am Cisco Router konfigurieren?

Ich hoffe ihr könnt mir helfen

gruß
Matthias
Mitglied: stuijg
07.01.2010 um 10:54 Uhr
--- beitrag gelöscht ---
Bitte warten ..
Mitglied: Dani
07.01.2010 um 11:32 Uhr
Moin,

a) euer Labornetz und Firmennetz benutzen aber nicht das Selbe IP-Netz?
b) Hast du in der Cisco-Config den VPN-Profil den DNS-Sever vom Labornetz zugewiesen?
c) Hast du auf dem Router eine ACL wo DNS blocken könnte?
d) Wird sobald der Tunnel steht sämlicher Traffic in ins Labornetz geroutet oder hast du SplitTunnteling aktiviert?!


Grüße,
Dani
Bitte warten ..
Mitglied: MNormann
07.01.2010 um 11:38 Uhr
Hallo,

zu a, es sind unterschiedliche Netze

zu b, wie mache ich das?

zu c, ACL ist drauf aber DNS wird nicht geblockt

zu d, sämtlicher Traffic wird geroutet aber das wird wiederum von unserer Cisco ASA je nach ACL geblockt oder durchgelassen
Bitte warten ..
Mitglied: Dani
07.01.2010 um 11:53 Uhr
Moin,
zu b) Das steht wie immer in der Ciscodoku.

zu d) Das entscheidet aber nicht die ASA wenn der Tunnel ins Labornetz steht. Oder steht die ASA hinter eurem 2811er? Was hast du nun konfiguriert - wird alles in den Tunnel geroutet sobald die Verbindung besteht?


Grüße,
Dani
Bitte warten ..
Mitglied: MNormann
07.01.2010 um 12:03 Uhr
zu d, stimmt war ein Gedankenfehler von mir. Es wird alles in den Tunnel geroutet
Bitte warten ..
Mitglied: Dani
07.01.2010 um 12:09 Uhr
Alles klar...in dem Fall DNs-Server, WINS-Server und FQDN nachtragen (falls AD vorhanden) und dann sollte es klappen.


Grüße
Dani

P.S. In anderen Forum sind wir gerade wohl auch an der selben Stelle, wa ^^
Bitte warten ..
Mitglied: aqui
08.01.2010, aktualisiert 18.10.2012
Benutzt du den Cisco VPN Client ?? Wenn ja ist es logisch das alles in den Tunnel geroutet wird, denn das ist der Default beim Cisco Client.
Vermutlich findet er im Labornetz dann deinen DNS Server nicht mehr und das Unglück nimmt seinen Lauf...
Fazit: Vergiss den Cisco Client und nimm einen freien IPsec Client der den Traffic nicht in den Tunnel zwingt, dann klappt das mit dem DNS wieder.
Ein Client ist z.B. der Shrew Client:
http://www.shrew.net/support
Eine passende Router Konfig dafür findest du hier:
http://www.administrator.de/wissen/ipsec-vpn-auf-m0n0wall-oder-pfsense- ...
Bitte warten ..
Mitglied: Dani
08.01.2010 um 14:34 Uhr
@aqui
er sucht doch den Server im Labornetz zu erreichen...was er aber nicht kann weil der DNS-Server in der Cisco-Config fehlt.


Grüße,
Dani
Bitte warten ..
Mitglied: aqui
08.01.2010, aktualisiert 18.10.2012
Mmmmhhh, wenn man seinen Thread liest dann ist es aber so verständlich das er sich mit einem VPN Client (eben dem Cisco VPN Client) vom Firmennetz auf dem Cisco 2811 einwählt und so VPN Zugang zum Labornetz bekommt.
Ab dann geht der DNS nicht mehr was dann aus den o.a. Gründen klar ist, denn der Cisco Client kappt das lokale Netz ab über das (vermutlich) der Firmen DNS Server zu erreichen war.
Bestätigen tut das die Tatsache das er IP technisch alles erreichen kann.
Fazit: Entweder anderen Client oder ganz einfach die Resourcen statisch in die lmhosts eintragen wie hier beschrieben:
http://www.administrator.de/forum/xp-home-mit-2-kabelgebundenen-und-wla ...
Oder Formulierung korrigieren wenns falsch verstanden ist...
Bitte warten ..
Mitglied: MNormann
13.01.2010 um 14:47 Uhr
Hallo an alle,

danke für eure Beiträge und sorry dafür das ich mich erst jetzt wieder melde.
Bei uns in der Firma gab es ein Wasserrohrbruch das zur Folge hatte das das komplette Strom und LAN Netzt abgeschaltet werden musste. Aber jetzt geht es wieder und ich konnte die Config am Router anpassen. Es klappt jetzt.
Ich habe am Router im ISAKMP Client Configuration den DNS Server und die Domäne eintragen müssen.

Vielen Dank für eure Hilfe

gruß
Matthias
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
DSL, VDSL
gelöst VPN-Probleme (CISCO AnyConnect) in Zusammenhang mit Router "Vodafone EasyBox" (7)

Frage von donnyS73lb zum Thema DSL, VDSL ...

Router & Routing
VoIP hinter Cisco Router (23)

Frage von PharIT zum Thema Router & Routing ...

Netzwerkmanagement
SSH auf Cisco Router aktivieren, allerdings ohne line vty (8)

Frage von M.Marz zum Thema Netzwerkmanagement ...

Heiß diskutierte Inhalte
Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Microsoft Office
Keine Updates für Office 2016 (13)

Frage von Motte990 zum Thema Microsoft Office ...

Grafikkarten & Monitore
Tonprobleme bei Fernseher mit angeschlossenem Laptop über HDMI (11)

Frage von Y3shix zum Thema Grafikkarten & Monitore ...