Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Kann nicht über VPN auf mein NAS-System zugreifen

Frage Linux Linux Netzwerk

Mitglied: iDaence

iDaence (Level 1) - Jetzt verbinden

30.05.2011, aktualisiert 18.10.2012, 8324 Aufrufe, 5 Kommentare

Hallo admins,
ich habe mir einen fli4l-Router aufgesetzt ,der mir eine VPN-Verbindung mit OpenVPN zulässt.

Die Verbindung kommt einwandfrei zustande im Tunnelmodus, doch kann ich nicht auf das interne NAS-System zugreifen welches im Netzwerk ist.

Wenn ich den Tunnelmodus zum Bridgemodus verändere passiert das gleiche. Habe dann an der Firewall rumgefrickelt und alle Ports auf das NAS-System freigegeben in beide Richtungen und komm trotzdem

nicht drauf. Hat jemand schonmal ähnliches gehabt oder weiß einfach so eine Lösung?

Freue und bedanke mich für jede Mühe.

mfg, iDänce
Mitglied: aqui
30.05.2011, aktualisiert 18.10.2012
Erstmal solltest du checken ob das NAS ein default Gateway konfiguriert hat und ob das der fli4l Router ist, denn da muss das Gateway hinzeigen.
Zeigt es woanders hin wie zu einem Internet Router der z.B. vor dem Fli4l liegt, dann musst du dort entsprechend eine statische Route eintragen auf das OpenVPN Netzwerk bzw. Gateway.
Solch ein Szenario ist hier in einem Tutorial beschrieben:
http://www.administrator.de/wissen/openvpn-server-installieren-auf-dd-w ...
Ferner solltest du dir das gesamte_Tutorial einmal zu Gemüte führen und mit deinem Setup vergleichen speziell was die Wahl der lokalen und remoten IP Adressen betrifft bzw. der VPN internen IP Adressen von OpenVPN. Da darf es keine Überschneidungen geben.
Es sollte klar sein das du den Zugriff wenigstens lokal aufs NAS wasserdicht testest um Probleme hier gleich ausschliessen zu können.
Kannst du das NAS auch nichtmal anpingen ??
Wenn dein NAS eine lokale Firewall haben sollte (was selten aber denkbar ist da du keinerlei Angabe zum Modell machst) denk dran, das deine Quell IP Adressen nun keine lokalen mehr sind wenn du übers VPN zugreifst und eine evtl. vorhandene FW darauf angepasst werden muss. Kommerzielle NAS als QNAP, Thecus, Synology usw. und der Freeware Klassiker FreeNAS haben aber keine FW.
Ansonsten sind Traceroute und Pathping deine Freunde um das korrekte Routing zu testen.
Das Tutorial zu lesen hilft bei der Fehlersuche... Für detailierteres Troubleshooting wäre eine Skizze hier hilfreich.
Ggf. solltest du mal nachdenken statt dem in Ehren ergrauten fli4l eine pfSense zu nehmen die man bequem auf einem CF Flash installieren kann und als verschleissfreie Festpaltte mit einem entsprechenden_CF-IDE_Adapter betreiben kann für den Dauerbetrieb.
Mit einem bequemen WebGUI als Management und dem o.a. Tutorial ist die OpenVPN Einrichtung dann ein Kinderspiel. Zur Not kann man sogar das PPTP benutzen als VPN.
Bitte warten ..
Mitglied: Byteblizz
30.05.2011 um 19:31 Uhr
Hört sich so an, alsob du eine falsche/keine IP bekommst im Tunnel. (Muss eine sein die du im LAN verwendest, wo dein NAS steht)
Bitte warten ..
Mitglied: iDaence
30.05.2011 um 19:43 Uhr
Nee eine IP bekomme ich sicher da ich sie mir selber zuweise und der Router auch die IP annimmt die ich ihm sagen. Außerdem bin ich von der fli4l-Routersoftware an bestimmte Bedingungen gebunden beim einrichten der OpenVPN -Verbindung.

<Zitat>

Die IP-Adressen für Server und Client (10.0.0.1, 10.0.0.2 und 10.0.0.5, 10.0.0.6) müssen
bestimmte Bedingungen erfüllen:

1. Sie dürfen nicht im LAN vorhanden sein - weder auf Seite des FLI4L noch auf Seite des
Clients.

2. Es müssen „private“ Adressen sein (192.168.*.* oder 10.*.*.*)

3. Sie müssen unter Windows aus einem 255.255.255.252-Subnetz kommen, womit nur
folgende Kombinationen entsprechend der nachfolgenden Liste zulässig sind

</zitat>

Also der OpenVPN-Client sagt mir auch das ich die IP bekommen habe und in der Konsole sehen ichs auch.
Bitte warten ..
Mitglied: aqui
30.05.2011 um 20:38 Uhr
Das kannst du auch wasserdicht prüfen indem du mal ipconfig eingibst und dir den VPN Tunneladapterbzw. Dessen aktuelle IP ansiehst.
Zudem wäre zusätzlich mal ein route print hier ganz hilfreich um zu sehen ob das OpenVPN Netz und das lokale NAS IP Netz an den Client geroutet wird wenn der OpenVPN Client aktiv ist. Leider lieferst du diese Info auch nicht was eine Hilfestellung nicht gerade einfacher macht. Ein Posting dieses Outputs hier hilft also...
Weiterhin fehlen zielführende Tests ob du z.B. Die LAN IP Adresse des Fli4l anpingen kannst, oder irgend eine andere erreichebare IP Adresse möglichst ohne FW im lokalen NAS LAN Segment pingbar ist oder mit Traceroute oder Pathping erreichbar ist..
Das würde ja wenigstens als ersten wichtigen Schritt einmal ganz klar verifizieren ob überhaupt grundlegend dein VPN Zugang funktioniert.
Ohne diesen Ansatzpunkten raten wir hier doch fröhlich weiter im freien Fall und suchen uns einen Wolf.
Bitte warten ..
Mitglied: iDaence
30.05.2011 um 22:40 Uhr
Also an alle "aqui" hatte die Lösung und Sie war das falsche Standardgateway sehr geil jetzt ist alles fertig und läuft zur vollsten Zufreidenheit.

Danke an alle admins die mitgearbeitet haben.


gruß iDänce
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Netzwerkprotokolle
gelöst VPN-Verbindung von Fritzbox 7490 auf Synology NAS am anderen Anschluss (5)

Frage von ExkoSven zum Thema Netzwerkprotokolle ...

Router & Routing
Kein Zugriff auf NAS über VPN bei einigen Providern (9)

Frage von ChrisXmas zum Thema Router & Routing ...

SAN, NAS, DAS
NAS mit VPN Funktion für Datensicherung bzw. Synchronisierung (6)

Frage von hannsgmaulwurf zum Thema SAN, NAS, DAS ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (17)

Frage von liquidbase zum Thema Windows Update ...

Windows Tools
gelöst Aussendienst Datensynchronisierung (12)

Frage von lighningcrow zum Thema Windows Tools ...

Windows Server
Suche passender Treiber (12)

Frage von stolli zum Thema Windows Server ...