Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

VPN - Netzwerkumgebung kann nicht durchsucht werden

Frage Netzwerke Router & Routing

Mitglied: Reefdiver

Reefdiver (Level 1) - Jetzt verbinden

16.10.2006, aktualisiert 17.10.2006, 6212 Aufrufe, 6 Kommentare

Hallo Newsgroup,

ich habe ein VPN/RAS/DHCP-Problem für Euch das mich bald in die Verzweiflung
treibt. Folgendes Szenario:

SBS2003 Premium, 2 NIC, Exchange, WINS, RAS & DHCP laufen. Außerdem der
ISA2004. Zu den Einstellungen des Servers gleich mehr, zuerst das Problem:

Ich habe VPN über den Konfigurationsassistenten konfiguriert und das Login
der Clients (alle XP SP2) von remote klappte sofort fehlerfrei. Die Clients
beziehen die IP per DHCP, die NetBIOS-Setting der Clients unter WINS ist auf
"Default" gesetzt.

Außerdem klappt Client-seitig:

  • ISA-Server-Client erkennt nach erfolgreicher VPN-Verbindung den ISA-Server
und wechselt in den Status "aktiv"

  • Outlook erkennt den Exchangeserver und synchronisiert fehlerfrei.

  • Die Company-Website läd, alle Links, z.B Sharepoint klappen auch

  • Ping auf den NetBIOS-Namen SERVER klappt (IP wird aufgelöst)

  • Ping auf SERVER.DOMÄNE.LAN klappt (IP wird aufgelöst)

  • Ping auf Server-IP klappt auch

Was aber nicht funktioniert ist das Browsen der Netzwerkumgebung. Die
Clients sehen in der Netzwerkumgebung zwar den Ordner für die DOMÄNE (wir
haben nur die eine), aber ein Browsen der Domäne ist nicht möglich und bricht
mit der Fehlermeldung

"Arbeitsgruppe, ist nicht verfügbar. Die Liste der Server in dieser
Arbeitsgruppe ist zur Zeit nicht verfügbar."

ab. Wenn man gezielt nach Rechnern sucht (IP oder nach Name), dann werden
diese gefunden und auch der Zugriff auf die freigegebenen Ordner klappt.
Der Befehl NET VIEW auf den Clients ausgeführt bring die Fehlermeldung

"Ein Fehler trat in der Netzwerkunterstützung Microsoft Windows - Netzwerk
auf. Fehler 6118: Die Liste der Server in dieser Arbeitsgruppe ist zur Zeit
nicht verfügbar."

hoch.

  • Serverseitig werden die Clients im RAS-Monitor angezeigt.

  • RAS verteilt die IP-Adressen via DHCP

  • Serverseitig erscheinen die Clients im WINS unter "Aktive Registrierungen"
mit der IP-Adresse, die ich auch auf den Clients unter dem Status der
SBS-VPN-Verbindung sehe.

Serverseitig kann ich die Clients allerdings nicht anpingen, und die
Namensauflösung klappt auch nicht. Vermutlich desshalb werden die RAS-Clients
auch nicht auf dem Server in der Netzwerkumgebung angezeigt. Obwohl der
Nachrichtendienst auf den Clients läuft kann aus der RAS-Konsole jedoch keine
Nachricht an die Clients geschickt werden. Allerdings "erkennt" RAS das der
Nachrichtendienst auf den Clients aktiv ist denn das Nachrichtenfenster wird
erstmal geöffnet.

Servereigenschaften

Router (Netgear) mit DSL-Modem
IP: 192.168.0.1, Subnetz 255.255.255.0, DNS: vom Provider

Server NIC 1 (Web)
IP: 192.168.0.2, Subnetz 255.255.255.0, DNS 192.168.16.2, Gateway: 192.168.0.1, NetBIOS over TCI/IP nicht aktiv

Server NIC 2 (LAN)
IP: 192.168.16.2, Subnetz 255.255.255.0, DNS 192.168.16.2, NetBIOS over
TCI/IP aktiv

RAS bezieht sich auf NIC 2 (LAN), Broadcastnamensauflösung ist aktiviert,
IP-Routing ist aktiv.

Ich bin eher ein Laie was Routing betrifft, für mich sieht das aber nach
evtl. solch einem Problem aus. Offensichtlich sind die RAS-Clients, obwohl im
WINS registriert, dem Server nicht bekannt. Wenn Ihr mehr Infos braucht bitte
sagen - wäre um Eure geschätzte Hilfe sehr dankbar da ich nicht mehr weiter
weiß.

Also, vielen Dank schon mal vorb und Grüße aus Süddeutschland,

Mark

PS: Ach ja, die viel-diskutierte Firewall auf den Clients habe ich testweise
ausgeschaltet, das hat nichts gebracht. Ausserdem habe ich testweise die
IP-Vergabe per DHCP ausgeschaltet und auf einen festen Bereich innerhalb des
selben Netzwerks (192.168.16.80 bis 192.168.16.90) gesetzt - hat auch keine
Besserung gebracht.
Mitglied: bitfix
16.10.2006 um 12:19 Uhr
hi

also zum browsen in einer Netzwerkumgebung muß immer noch der Broadcast aktiv sein.
Das ist bei einer punkt-zu-punkt Verbindung nur möglich, wenn der VPN Server selber browsen kann, und nicht von einer Firewall geblockt wird.
Tückisch sind da auch die Firewall rules (nicht am Client). Die müßen das ganze Netzwerk einschließen - also inkusive x.x.x.255

Wenn Du es nicht hinbekommen solltest - aus irgendwelchen Gründen bleibt Dir auch unter 2003 nichts anderes übrig als einen wins server aufzusetzen - und im Client einzutragen.

Mit dem Routing scheinst Du alles richtig gemacht zu haben, ansonsten würde der ping nicht funktionieren.
Die vieldiskutierte Firewall kannst Du auch vergessen, da sie nur eingehende Pakete blockiert, es sei denn Du hast schon Vista oder eine 3rd Partiy firewall.

Gruß
Bitte warten ..
Mitglied: Reefdiver
16.10.2006 um 13:43 Uhr
Hallo Bitfix,

danke für Deine Hilfe. Der Tip mit der ISA-Firewall war gut, aber dort ist für VPN der komplette interne Netzwerkbereich x.x.x.0 bis x.x.x.255 eingetragen. Ich bin im ISA-Bereich kein Profi, aber nach allem was ich davon verstehe scheinen die VPN-Einstellungen dort i.O. zu sein.

Bei mir läuft der WINS-Server, die VPN-Clients, die am Netzwerk registriert werden sehe ich dort auch erfolgreich eingetragen. Was muss denn Client-seitig eingetragen sein? Derzeit ist die Einstellung "Enable LMHOSTS lookup" und NetBIOS-Einstellung auf "Default". Vielleicht liegt hier der Hund begraben? Muss der WINS vielleicht trotz "Default" explizit eingetragen sein?

Vielen Dank für Deine Hilfe.

Gruß, Mark
Bitte warten ..
Mitglied: bitfix
16.10.2006 um 13:52 Uhr
Hi

Es ist auf jeden Fall wert auf dem Client mal was einzutragen.
die LMhosts datei ist in Deinem Fall nicht das richtige. Trag doch an einem Client mal den Wins server unter tcp settings ein. (da wo auch dhcp, dns usw drinnen sind.)

Wenn das geht, kann man das auch mit dhcp automatisieren.

Zum Verständnis:
Eigentlich sollte es unter XP und 2003 keinen Wins server mehr brauchen. Allerdings funktioniert das nur - wenn kein Router dazwischen ist. Bei einem VPN Tunnel direkt zum ISA Server ist eigenlich kein router dazwischen - es sollte also theoretisch gehen. (tja - theorie und praxis).
Wins ist eigenlich die ältere Variante. Hat aber den Vorteil dass Du nicht auf Broadcasts angewiesen bist (na ja - fast nicht) und vor allem dass Du Dein Netzwerk auch hinter einem Rotuer siehst.

Ich denke mal - als Ferndiagnose, dass dein VPN am externem Port Deines ISA endet, und der dann vielleicht nicht die richtigen Antworten liefert...

Gruß
Bitte warten ..
Mitglied: Black-Scorpion
16.10.2006 um 14:50 Uhr
Mahlzeit,
mal so eine Frage hast du im ISA-Server eine Firewall regel erstellt die den Netbios Verkehr erlaubt. Das wäre noch ne möglichkeit. findest du unter alle Protokolle wenn du eine neue Regel erstellst.

Mit freundlichen Grüßen Markus
Bitte warten ..
Mitglied: Reefdiver
16.10.2006 um 17:29 Uhr
Hallo Markus,

das wäre tatsächlich eine Möglichkeit..... Ich hab' nicht viel Erfahrung mit den Firewall-Regeln, habe eine Zugriffsregel für den NetBIOS-Namensdienst erstellt von VPN-Clients nach Alle Netzwerke. Stimmt das so? Ich teste das dann nachher gleich mal und poste wieder.

Danke schon mal.

Gruß, Mark
Bitte warten ..
Mitglied: Black-Scorpion
17.10.2006 um 08:29 Uhr
Moin,
Gib vorsichtshalber alle NetBIOS Protokolle frei dem ISA Server mit seiner Regelverwaltung traue ich nicht ganz so. Wenn alles freigegeben ist müsste es eigentlich funktionieren sobald die richtigen adapter ausgewählt sind und die Benutzer zugeteilt wurden. Hoffe mal das dich das weiter bringt.

Mit freundlichen Grüßen Markus
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Windows Netzwerk
Direct Access mit VPN aufbau (6)

Frage von geocast zum Thema Windows Netzwerk ...

Windows Server
Windows Server 2016 VPN richtig konfigurieren (1)

Frage von junior zum Thema Windows Server ...

Windows Server
gelöst Windows Server 2012 mit Fritzbox per VPN verbinden (13)

Frage von StefanT81 zum Thema Windows Server ...

Windows Netzwerk
Kein RDP über VPN per MS-TSC möglich (9)

Frage von survial555 zum Thema Windows Netzwerk ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...