Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

VPN Problem bei Linux und VISTA anpingen nicht möglich

Frage Netzwerke

Mitglied: Weiskopf

Weiskopf (Level 1) - Jetzt verbinden

13.07.2007, aktualisiert 20.07.2007, 6343 Aufrufe, 8 Kommentare

VPN Problem

Hallo,

habe ein Problem mit meinem VPN Netzwerk. Ich kann meinen Server sehen und auf ihn zugreifen, das geht, die anderen PCs im Netzwerk sehe ich auch, kann aber nicht auf sie zugreifen oder anpingen.
Ich hoffe mir kann hier jemand helfen. Arbeite noch nicht so lange mit Linux.

Mein Netzwerk besteht aus einem Linuxserver 192.168.0.1 der zugleich die Verbindung ins Internet über ISDN für das Netzwerk bereitstellt, und mehrern anderen PCs 192.168.0.X mit Windows Vista. Nun möchte ich mit meinem Laptop 192.168.0.61 (wird vom Linuxserver zugewiesen) über VPN Verbindung in das Netzwerk. Die VPN Verbindung wird auch hergestellt, ich kann aber nur auf den Server zugreifen.

Ich glaube das Problem liegt beim routen.

Ach ja, ich benutze pptp.

Linuxserver 192.168.0.1 SUSE 10.0
Netzwerk PCs 192.168.0.X Windows VISTA
Laptop 192.168.0.61 (wird zugewiesen) Windows VISTA


Hoffentlich kann mir jemand helfen.
Mitglied: aqui
18.07.2007 um 10:23 Uhr
Nein, ein Routing Problem kann das niemals sein denn wie du ja richtig bemerkst kommst du auf den Server und bekommst von diesem auch eine korrekte Netzwerkadresse die im gleichen Netz liegt. Ein Routing ist somit ja gar nicht erforderlich, da du ja innerhalb dieses Netzes bleibst !!!

Sehr wahrscheinlich macht dir unter Vista die Firewall ein Strich durch die (Connectivity) Rechnung !
Wenn du ins Suchfeld einmal Windows-Firewall mit erweiterter Sicherheit eingibst (Achtung: Nur Firewall reicht nicht !!!) kannst du diese für ICMP/Ping und remoten Zugriff customizen. Du solltest auch darauf achten, das in Vista der Standorttyp unbedingt auf privat eingestellt ist. (Netzwerk- und Freigabecenter -> Netzwerk -> Anpassen)
Bitte warten ..
Mitglied: Weiskopf
18.07.2007 um 20:33 Uhr
Hi danke erst mal für deine Antwort.

Die firewall ist aus (im Domänenbetrieb, privat,... überall).
Hab ich am anfang schon ausgeschlossen. Hab komischer weise jetzt aber gar keine Anzeige mehr im Netzwerk, nur noch mich selber obwohl ich seit letztes mal nichts verändert hab. Der server lässt sich aber noch anpingen.

Glaub es hat was mit iptables und masquerading zu tun, hab aber davon leider keine Ahnung.

Die lösung könnt Ihr mir auch gerne mit anderen einstellungen geben z.B. Bei den Clients die IP Adressen 192.168.2.X vergben wär mir eh lieber wenn die Clients in einem Anderen Netzwerkbereich liegen würden.
Bitte warten ..
Mitglied: aqui
19.07.2007 um 12:47 Uhr
Dein Linux Host hat ja wohl tunlichst 2 Netzwerkkarten, eine die den PPPoE Link bedient zum Provider und eine die dein lokales Netzwerk bedient. Das über ein Karte zu machen wäre sicherheitstechnischer Unsinn.
Auf dem lokalen Segment machst du natürlich KEIN Masquerading, damit kann es also rein gar nichts zu tun haben.
Ggf. liegt das noch an deiner Samba Config. Du solltest dir also einmal die /etc/smb.conf ansehen und ggf. anpassen. Der Workgroup Name muss hier übereinstimmen mit dem was du unter Vista eingestellt hast !

Als allerletztes Mittel solltest du vielleicht mal 25 Euro investiren und dir einen Router wie z.B. diesen zulegen. Das hätte den großen Vorteil das du dann auch für den Internetzugang nicht immer den Serverlaufen lassen musst und außerdem musst du dich dann nicht mehr mit iptables und masquerading rumschlagen. Nebenbei gibt es da via Dr. Google massenhaft hilfe und Anleitung zu wie das einfach zu customizen ist....
Bitte warten ..
Mitglied: Weiskopf
19.07.2007 um 17:06 Uhr
Mein Linuxserver hat 1 Netzwerkkarte und 1 ISDN Karte, das ist ja auch mit mein problem alle Beispiele richten sich ja immer nur nach DSL mit routern. Mein router (Netgear) ist nur für mein internes Netzwerk da (W-LAN), für mehr nicht. Ich benutze auch nicht eine Arbeitsgruppe sondern eine Domäne und die ist natürlich überall die selbe.
Bitte warten ..
Mitglied: aqui
19.07.2007 um 21:49 Uhr
Hast du in der /etc/smb.conf dann entsprechend den Linux als Master Browser eingerichtet und den os level Wert entsprechend hoch gedreht das der jede Master Browser selection im Netzwerk gewinnt ???

Auf alle Fälle solltest du sicherstellen das iptables (und masquerading sowieso) auf dem lokalen LAN Port disabled sind, was wahrscheinlich sowieso der Fall ist.
Sehr wahrscheinlich ist die Vista Firewall immer noch aktiv. Das kannst du ja ganz einfach testen indem du versuchst den Server im lokalen netz zu pingen. Das sollte in jedem Falle klappen...
Bitte warten ..
Mitglied: Weiskopf
20.07.2007 um 13:30 Uhr
Hab den os level auf 65, Masquerading und ip weiterleitung sind an, sonnst kommen meine normalen clients (lokales Netzwerk) nicht ins iternet. Beim Linuxserver bei der Netzwerkkarte ist der gateway 192.168.99.2 (isdn Karte) eingetragen.
Bitte warten ..
Mitglied: Weiskopf
20.07.2007 um 14:13 Uhr
Jetzt kann ich wenigstens wieder alle im netzwerk sehen, hatte nur datei und Druckerfreigabe ausgeschaltet und noch Client für MS Netzwerke.

Also wie gesagt sehen kann ich alle aber nicht zugreifen oder anpingen, ausser den server.
Bitte warten ..
Mitglied: aqui
20.07.2007 um 16:26 Uhr
Du solltest den OS Level niedriger setzen, denn dann gewinnt immer der Server die Master Browser Selection bzw. behält sie. Wenn du kein Domänen Konzept hast solltest du die Settings in der smb.conf so einstelllen:

[global]
workgroup = Arbeitsgruppe (Muss mit dem der PCs übereinstimmen !!!)
server string = Linux Server
netbios name = Samba-Server (Dieser Name taucht in der Netzwerkumgebung auf)
domain master = no
local master = Yes
preferred master = Yes
os level = 35

Denk dran das du danach den nmbd und smbd restarten musst sonst werden die Änderungen nicht aktiv. Spätestens nach 30 Minuten solltest du dann auch den Server im Netz sehen...so lange kann das dauern. (Nach MS Knowledgebase bis zu 50 Minuten.)

Das du die anderen Vista Clients nicht pingen kannst liegt an der Firewall ! Dort musst du das Antworten auf ICMP Echo Anforderungen erlauben sonst geht kein Ping.
Der Standorttyp MUSS hier auf Privates Netz gesetzt sein und ebenfalls MUSST du zwingend die Netzwerkerkennung im Netzwerk- und Freigabecenter aktivieren !!!
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Router & Routing
FritzBox 7490 VPN Problem ab FritzOS 6.5 (6)

Frage von 1x1speed zum Thema Router & Routing ...

Netzwerke
gelöst VPN Sichtbarkeit im Netzwerk nicht möglich (6)

Frage von serguni zum Thema Netzwerke ...

Windows Netzwerk
Kein RDP über VPN per MS-TSC möglich (9)

Frage von survial555 zum Thema Windows Netzwerk ...

Microsoft
AD Problem und VPN (4)

Frage von Yannosch zum Thema Microsoft ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (17)

Frage von liquidbase zum Thema Windows Update ...