Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

VPN und ... oder Routing Problem?

Frage Netzwerke Router & Routing

Mitglied: bGn

bGn (Level 1) - Jetzt verbinden

07.07.2007, aktualisiert 12.07.2007, 6310 Aufrufe, 5 Kommentare

Hallo adminstrator.de User!

Wir haben hier in der Firma eine AS400 für die Warenwirtschaft, ca. 20 Workstations und seit ein paar Tagen einen Windows 2003 Server mit Exchange. Ausserdem 2 Router wobei einer für die VPN Verbindung der Filiale dient und der 2. für den Internetverkehr innerhalb des 192.168.0.x Netzes. Die Filiale verwendet für VPN und Internet ein und denselben Router.

Zur besseren Anschauung hier das ganze mal als notdürftiger Netzwerkplan ;)
6cb8996f151e4fbd043c937fe06ccac9-yeah-problem - Klicke auf das Bild, um es zu vergrößern

Die Clients in der Zentrale nutzen als Gateway die 192.168.0.254. Dort ist eine Statische Route für 192.168.1.0/24 --> 192.168.0.100 eingetragen. z.b. Remoteadministration in Richtung Filiale von einem Client aus ist problemlos möglich.

In der AS400 ist als Gateway die 192.168.0.100 eingetragen, im Exchange die 192.168.0.254. Von der Filiale aus komme ich Problemlos auf die AS400 bzw. auf alle weiteren Geräte sofern die 192.168.0.100 als Gateway gesetzt ist, nicht allerdings auf Geräte wo 192.168.0.254 als Gateway gesetzt ist. Problem ist nun das die Filiale mit an den Exchange Server angebunden werden muss dieser aber seinen E-Mail-Austausch allerdings über das Normale DSL Gateway verrichten muss um die Standleitung für das VPN frei zu halten.

Ich habe versucht in dem VPN Gateway eine Statische Host-Route einzurichten (192.168.0.1 --> 192.168.0.254), allerdings kann ich trozdem den Exchange Server nicht erreichen.

Habe ich da etwa einen Denkfehler oder ist es einfach nicht möglich sofern der Exchange Server nicht über das "VPN-Gateway" eingerichtet ist?

Ich würde mich wirklich sehr über ein paar Antworten freuen!

mfg

Patrick
Mitglied: sebbre
07.07.2007 um 09:01 Uhr
Hallo Patrick,

[quote] Problem ist nun das die Filiale mit an den Exchange Server angebunden werden muss dieser aber seinen E-Mail-Austausch allerdings über das Normale DSL Gateway verrichten muss um die Standleitung für das VPN frei zu halten. [/quote]

Diesem Absatz nach entnehme ich, dass es elementar um die Anbindung der Filial-Clients an den Exchange in der Firma geht.
Da du den Weg über den VPN-Tunnel vermeiden willst bietet sich für diesen Fall die RPC over HTTPS Funktion des Exchange 2003 (ab SP2) an. Diese verwendet den Port 443 für die Kommunikation zwischen Outlook-Client (ab 2003) und Exchange Server. In der Firewall (192.168.0.254) ist ein port forwarding / Static NAT auf den Exchange nötig. Bietet die DSL Anbindung in der Firma keine statische IP Adressierung kannst du dir z.B. mit www.dyndns.org helfen.

Gruß
Sebastian
Bitte warten ..
Mitglied: bGn
07.07.2007 um 11:26 Uhr
Hallo Sebastian,

danke für deine Antwort!

Das wäre natürlich auch eine möglichkeit! Ich werde es als Notlösung im Hinterkopf behalten.

Ich muss aber gestehen dass ich mich falsch ausgedrückt habe

Ich meine nur das die Zentrale Ihren E-Mail und Internetverkehr über das DSL Gateway verrichten soll. Die Filiale soll die AS400 (was ja geht) und den Exchanger über die VPN Verbindung erreichen!
Bitte warten ..
Mitglied: bGn
09.07.2007 um 17:03 Uhr
Hat denn niemand mehr eine Idee?

mfg

Patrick
Bitte warten ..
Mitglied: aqui
09.07.2007 um 18:04 Uhr
Die M0n0wall ist eine Firewall die scheinbar kein lokales Rerouting mit ICMP Redirect Packets zulässt, was auch nicht weiter verwunderlich ist für eine Firewall. Daher kommt es zu Problemen. IPCop und andere verhalten sich da analog.
Entweder erlaubst du der M0n0wall das per Setup oder du richtest für alle Clients die .100 als Gateway ein und konfigurierst auf der .100 eine statische Default Route auf die .254. Das dürfte das Problem am einfachsten lösen.

Die Routing Problematik liegt aber ganz klar an der M0n0wall, da diese ein Rerouting wie oben beschrieben scheinbar verhindert.
Das Verhalten kannst du mit einem Sniffer wie den Wireshark oder MS NetMonitor sofort auch sichtbar machen !
Bitte warten ..
Mitglied: bGn
12.07.2007 um 02:30 Uhr
Ich habe am Exchange Server eine satische Route eingerichtet

[code]
route -p add 192.168.1.0 MASK 255.255.255.0 192.168.0.100 METRIC 3
[/code]

Somit funktionierts!

Bei der m0n0wall (0.254) wird anscheind in die entgegengesetzte Richtung nicht richtig geNATtet
Bitte warten ..
Ähnliche Inhalte
Router & Routing
gelöst VPN- Routing - Problem - Netzwer 1 kommt auf 2 aber anders herum nicht (8)

Frage von itschloegl zum Thema Router & Routing ...

Netzwerkgrundlagen
Netzwerkaufbau, VPN-Routing, generelle Frage (7)

Frage von macherlthomas zum Thema Netzwerkgrundlagen ...

Router & Routing
Routing Problem (Windows Server Routing und RAS) (5)

Frage von filou204 zum Thema Router & Routing ...

Router & Routing
Routing Problem VLANS Internet (67)

Frage von Cyberurmel zum Thema Router & Routing ...

Neue Wissensbeiträge
RedHat, CentOS, Fedora

Fedora, RedHat, Centos: DNS-Search Domain setzen

(12)

Tipp von Frank zum Thema RedHat, CentOS, Fedora ...

Drucker und Scanner

Samsung SL-M4025ND, firmware update und (kompatible) Tonerkassetten

(1)

Erfahrungsbericht von markus-1969 zum Thema Drucker und Scanner ...

Heiß diskutierte Inhalte
Windows 10
Windows für Privatanwender "nicht mehr handhabbar" (26)

Frage von FA-jka zum Thema Windows 10 ...

LAN, WAN, Wireless
Brauche Hilfe: Mit (schnellem) WLAN Strecke überbrücken (23)

Frage von pierrehansen zum Thema LAN, WAN, Wireless ...

LAN, WAN, Wireless
Komplett neues Netzwerk, Ubiquiti WLAN, Router, Switch (15)

Frage von Freak-On-Silicon zum Thema LAN, WAN, Wireless ...