Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

VPN Routing Problem mit RV082

Frage Internet

Mitglied: blackjacker

blackjacker (Level 1) - Jetzt verbinden

02.04.2009, aktualisiert 11:44 Uhr, 7096 Aufrufe, 9 Kommentare

Routing Problem über mehrere Standorte.

Hallo zusammen,

ich erkläre mal kurz die Situation.
Ich habe drei Standorte die per VPN verbunden sind.
Standort 1 besitzt einen Linksys RV082 Router der als Knotenpunkt dienen soll.
Die beiden anderen Standorte verbinden sich jeweils mit einem Linksys WRVS4400Nv2.
Die VPN Verbindung zum RV082 steht und es lässt sich auch alles auf der jeweiligen anderen Seite erreichen.

Nun zu meiner Frage:
Ich muss von dem ersten 4400 über den 082 auf das Netz von den zweiten 4400 Routern zugreifen.
Und hier liegt mein Problem.

Ich kann das Netz nicht erreichen. Kein Ping. Traceroute scheitert nach dem ersten Hop.
Ich glaube ich muss irgendwo ein Routing einrichten damit er weis welche strecke er gehen soll.
Nur kenne ich mich hierbei nicht so richtig aus.
Ich habe mal eine ähnliche Verbindung gesehen, bei der alles über einen RV082 ging und die anderen Router nur den Tunnel zum RV082 bekamen, als muss ich die Routen wahrscheinlich irgendwo im RV082 eintragen.

Giebt es einen Spezi der mich hierbei etwas unterstützen kann?

Danke für eure Antworten im Voraus.

PS: Ja ich habe bereits Google und die Suchfunktion benutzt, aber keine für mich brauchbaren Antworten gefunden.
Mitglied: aqui
02.04.2009 um 12:21 Uhr
Ja, deine Vermutung ist richtig. Der 4400er routet ja logischerweise nur das VPN Netzwerk zum RV082, da es an ihm angeschlossen ist.
Alle anderen Netzwerke bzw. IP Adressen routet er ganz normal ins Internet, da er sie ja nicht kennt und die Default Route des 4400 ja ins Internet zeigt, denn alle deine so gearteten Zielnetze sind ja hinter dem RV082 und der teilt sie dem 4400er nicht mit.

Die Lösung ist aber recht einfach. Gesetzt den Fall dein RV082 hat als VPN Netzwerk die 172.16.1.0 /24 und die Zweigstellen 2 und 3 die 172.16.2.0 /24 und 172.16.3.0 /24 als lokale IP Netze.

Um nun von Zweigstelle 2 auf auf Zweigstelle 3 zu kommen benötigt die Zweigstelle 2 bzw. der 4400er dort eine statische Route die ihm sagt das er Traffic für das 172.16.3.0 /24er Netzwerk doch bitte auch in den VPN Tunnel zum RV082 routen soll.
Dort muss also sowas stehen wie:
Zielnetz: 172.16.3.0 Maske: 255.255.255.0 Gateway: 172.16.1.254 (Annahme RV082 hat die .1.254)
analog muss in der Zweigstelle 3 dann natürlich
Zielnetz: 172.16.2.0 Maske: 255.255.255.0 Gateway: 172.16.1.253 (Annahme RV082 hat die .1.253)
haben damit es auch umgekehrt klappt !!
Das musst du so für alle Zweigstellen einrichten, damit sollte das Routing dann problemlos klappen.

Ggf. bietet der RV082 ein dynamisches Routing mit RIP oder RIPv2 was du aktivieren kannst und was diese Routen dann dynamisch auf die 4400er überträgt.
Das erspart dir dann die statische Einrichtung.
Ob dem so ist sagt dir das Handbuch beider Systeme !!
Bitte warten ..
Mitglied: blackjacker
02.04.2009 um 12:49 Uhr
Hallo aqui

Erst mal Danke für die schnelle Antwort.
Die Systeme unterstützen alle RIPv2.
Eigentlich müsste das folgendermaßen aussehen denke ich:
Router 4400 Nr1
Netz 192.168.103.0/24 auf GW 192.168.102.254
Route 4400 Nr2
Netz 192.168.101.0/24 auf GW 192.168.102.254

Das eintragen der Routen auf den 4400 funktioniert nicht, da diese mit der Meldung „Network is unreachable“ quittiert wird.
Diese Routen habe ich auf dem RV082 (192.168.102.254) eingetragen und RIPv2 auf allen Geräten Aktiviert. Als Schnittstelle habe ich WAN (Sollte eigentlich stimmen) getestet, aber als kein Ping durch ging hab ich die LAN Schnittstelle (wiederrum) ohne Erfolg getestet.
Bitte warten ..
Mitglied: aqui
02.04.2009 um 12:57 Uhr
Wenn du RIPv2 aktivierst ist doch das Beibehalten der statischen Routen Blödsinn !!
Du hast ja dann statische Routen und dynamische parallel !!
Wenn man das (überflüssigerweise) dennoch macht gewinnen immer die statischen Routen , da sie eine bessere Metrik haben !
Solange die also noch aktiv sind ist das Aktivieren von RIP völlig sinnlos !

Scheinbar ist dir nicht wirklich klar wie Routing, sei es dynmaisch oder statisch, überhaupt funktioniert....kann das sein ???

Die Devise doppelt hält besser... ist hier also vollkommen kontraproduktiv und führt weiterhin in die Sackgasse !!
Bitte warten ..
Mitglied: blackjacker
02.04.2009 um 13:19 Uhr
Hallo aqui,
ich komme eigentlich aus der Programmierung und kenne mich deswegen noch nicht sehr gut im Netzwerkbereich aus, aber ich bin lernwillig und muss es leider alleine schaffen.
Routen bedeutet für mich PC1 schaut in einer Tabelle nach welchen Weg er zu PC2 nehmen soll.
Ich dachte das RIP dafür da sein soll die Routen die ich angelegt habe auf die Geräte zu verteilen.
Dem scheint aber nicht so, wie du mir gerade beigebracht hast.

Aber auch wenn ich nur Statische oder nur Dyn. (RIP) Routen Aktiviere komme ich nicht weiter. Durch eine Firewall können die Pakete nicht geblockt werden, denn ich habe die Firewalls kurzfristig deaktiviert. Sollte denn das VPN Pass Through nicht dafür da sein das alle Pakete entsprechend weitergeleitet werden? Ich habe es nach einer Empfehlung von Linksys Aktiviert.
Warum behauptet der 4400 eigentlich das das Netzwerk nicht erreichbar ist obwohl ich ihm das GW mitteile?

Welche Vorgehensweise würdest du Empfehlen?
Bitte warten ..
Mitglied: blackjacker
02.04.2009 um 15:27 Uhr
OK, ich bin wieder etwas schlauer geworden.

RIP ist eigentlich genau das was ich benötige. Ich gebe den Routern die Möglichkeit Ihre Routingtabellen untereinander aus zu tauschen.
Ich habe jetzt auf den Routern RIPv2 (Send + Recv.) Aktiviert und auf den RV082 Recv. Rip1+Rip2 und Send RIPv2 – Broadcast.
Die Routingtabelle vom RV082 sieht auch gut aus, zumindest finde ich jedes wichtige Netz.
Nur scheint es mir so als ob die 4400 Router die Tabelle nicht erhalten. Nach einem Neustart des Routers sollte dieser doch eigentlich die Tabelle zu seinen beiden anderen Routern die ja über VPN verbunden sind austauschen.
Bei den 4400 sehe ich jedoch nur das eigene Netz und keine weitere Route, was mich etwas stutzig macht, denn ich komme ja auch auf den RV082?
Gibt es eine Besonderheit die ich bei RIP beachten muss?
Bitte warten ..
Mitglied: aqui
02.04.2009 um 15:40 Uhr
Ja, RIPv1 und v2 sind nicht kompatibel !
Du musst dich also für eine Variante entscheiden !! Beide Protokolle parallel solltest du nicht laufen lassen !!

RIPv2 ist moderner und sollte das Protokoll der Wahl sein, denn es kann mit variablen Subnetzmasken umgehen was RIPv1 nicht kann !

Da du aber (vermutlich) nur klassische Class C Netze (192.168.x.0 /24) mit fester 24 Bit Subnetzmaske benutzt ist es mehr oder weniger kosmetisch.
Wichtig ist das beide (oder alle) Router RIP mit send + receive machen !!
Es ist so wie du sagst die Router tauschen dann dynamisch ihre Routingtabellen aus und alle Routen die du im RV082 siehst sollten dann natürlich auch auf den 4400ern auftauchen, das ist klar !
Scheinbar senden die 4400er ja korrekte RIP Updates wenn du deren lokale Netze am RV082 sehen kannst !!

Wenn das nicht der Falls ist kommen die RIP Pakete nicht bei den 4400ern an oder die 4400er nehmen keine RIP Pakete an und senden nur, was aber eigentlich unsinnig wäre.

Ich nehme mal an das du hoffentlich alle Systeme auf die neueste und aktuelle Firmware upgedatet hast ???
Bitte warten ..
Mitglied: blackjacker
02.04.2009 um 16:09 Uhr
Ja, die Firmware ist Aktuell und für die WRVS4400Nv2 gab es noch keine neue Firmware.

Ich habe alle auf RIPv2 (Send+Recv.) eingestellt, leider kommt aber nichts bei den 4400 an. So langsam hab ich keine Idee mehr. Ich mach jetzt bereits seit einer Woche an den Problem rum und komm nicht weiter.
Feste Routen gehen nicht, denn da sagt der 4400er Netz nicht vorhanden.
Dynamische Routen gehen nicht, denn da bekommt der 4400er keine Tabelle.
Das einzige was ich herausgefunden habe ist das wenn ich mich über PPTP zum RV082 verbinde ich alles erreiche. Logisch, denn da bekomme ich ne Adresse aus dem 102er (RV082) Netz

Hast du noch ne Idee?
Bitte warten ..
Mitglied: aqui
02.04.2009 um 16:36 Uhr
Nein, leider nicht, denn das ist eigentlich Routing Grundlage. Vermutlich supportet der 4400er keine Weitergabe der Routen oder kann schlichtweg nicht routen über seine VPN Verbindungen und supportet da nur Point to Point.
Das ist ein Fall für die Linksys Hotline bei der du das klären musst ob Routing im VPN in der FW supportet ist !
Bitte warten ..
Mitglied: blackjacker
02.04.2009 um 17:13 Uhr
Danke, ich werds weiter versuchen.
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Router & Routing
gelöst VPN- Routing - Problem - Netzwer 1 kommt auf 2 aber anders herum nicht (8)

Frage von itschloegl zum Thema Router & Routing ...

Netzwerke
Integration eines fremden Netzwerks (Routing-Problem) (63)

Frage von Brian85 zum Thema Netzwerke ...

Microsoft
AD Problem und VPN (4)

Frage von Yannosch zum Thema Microsoft ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows Server
Mailserver auf Windows Server 2012 (8)

Frage von StefanT81 zum Thema Windows Server ...

Backup
Clients als Server missbrauchen? (8)

Frage von 1410640014 zum Thema Backup ...