Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

VPN Server 2003 - Keine Verbindung vom Server zum VPN Client möglich -

Frage Netzwerke

Mitglied: computer-fuxx

computer-fuxx (Level 1) - Jetzt verbinden

21.07.2008, aktualisiert 25.07.2008, 10119 Aufrufe, 5 Kommentare

kleines Netzwerk, 3 Clients lokal, 1 Server 2003 (SBS), Internet über Kabelmodem, 1 VPN Client von "draussen", alles klappt, ausser Verbindung vom Server / den lokalen Clients zum VPN Client, anders herum schon!

Hallo,
folgendes Szenario:

1x SERVER 2003 (SBS), mit Routing und RAS konfiguriert und aktiviert, DNS konfiguriert (ohne DHCP).
Der Server hat 2 NICs:
1x ins lokale Netz: IP:192.168.10.10, Gateway und DNS leer
1x ins Internet: IP: 213.169.126.250, Gateway und DNS 213.169.126.1 (über SkyDSL Modem, vom ISP zugewiesen).

Der Server weist VPN Clients als RAS-Server IP-Adressen aus dem Pool 192.168.10.100 - 105 zu.
Protokoll: PPTP
_________________________________________________________________________________

3 PCs lokal, statische IP Adressen, von 192.168.10.11 - 13, Gateway und DNS 192.168.10.10

_________________________________________________________________________________

1 PC wählt sich von ausserhalb als VPN Client ein; so eingestellt, dass er die IP Adresse und DNS vom VPN Server automatisch bezieht.
Er erhält eine IP Adresse aus o.g. Pool,
z.B.192.168.10.101.

Sonstige Daten für den virtuellen Adapter nach ipconfig:
DNS Server: 213.169.126.1
Subnetzmaske: 255.255.255.255
WINS Server: leer

Die Verbindung klappt also soweit.
Ich komme vom VPN Client aus über Eingabe der IP 192.168.10.100 auf den Server.
Auch auf die 3 Clients habe ich über Eingabe der IP Zugriff.
Dass die Namnesauflösung nicht funktioniert, ist kein Problem für mich.

_________________________________________________________________________________

WAS NICHT KLAPPT:
Zugriff vom Server / den lokalen Clients auf den verbundenen VPN Client mit der IP 192.168.10.101.
Muss ich dem Server eine statische Route konfigurieren?
Wie kann ich ihm beibringen, Anfragen an den VPN Client über das Internet zu leiten /routen?
Wo ist mein Denkfehler, müsste doch hinhauen ?
Ich versteh´s nicht!

Schon mal danke im voraus, ist wirklich wichtig für mich, das Ganze zu lösen.
Möchte nämlich auf dem VPN Client einen Drucker freigeben, auf dem dann das Firmennetz über das Internet drucken kann.
Mitglied: 60897
21.07.2008 um 22:09 Uhr
Tach,

Da Du ja schon schreibst, dass das Namensauflösungsproblem Dich nicht stört, brauche ich ja nicht zu sagen, dass das zunächst mal störend aussieht. Funktioniert ja. Kannst Du mir trotzdem sagen, wieso Du das mit solcher Konsequenz falsch einstellst?

Nun zu Deinem VPN-Problem:
Der Client ist im gleichen Netz. Wer soll da routen und warum? OK, die internen kommen nicht dran, das liegt daran, dass der externe ja gar nicht direkt für sie erreichbar ist, denn der Server müsste ja weiterrouten. Das macht er aber nicht, weil ... na? Genau! Gleiches Netz! Da wird nicht gerouted.
Lösung: Anderen IP-Bereich für den externen Client verwenden oder Host-Route bauen. Host-Route ist aber eher - na sagen wir mal - gebastelt.

Der Server müsste allerdings eigentlich drankommen. Ist am externen soweit alles korrekt eingestellt? Server-Dienst, Freigaben, Firewall? Kommt ein Ping zurück?

Bonkers
Bitte warten ..
Mitglied: Tigerbaby
24.07.2008 um 11:05 Uhr
Hallo!

Da muss ich mich als Laie auch gleich einmischen.

Ich hab das selbe Problem.
Jedoch haben die "Externen" einen anderen IP.Bereich.
Also das Netz hat 192.168.10.xxx und die Externen haben 192.168.100.xxx

Ping auf die Externen geht. Aber das wars auch schon.
(Die Clients können problemlos ins Firmennetz.)

Dieser IPEnableRouter-Eintrag ist auf den Clients auch aktiv. Muss man den noch irgenwie konfigurieren?


THX
TOM
Bitte warten ..
Mitglied: 60897
24.07.2008 um 11:30 Uhr
Hi Tom,

da die Clients nicht zu routen brauchen, braucht der Eintrag auch nicht auf 1 stehen.

Wenn ein Ping funktioniert, ist der Weg schon mal frei, also suchst Du das Problem jetzt am Client: Firewall an, notwendige Ausnahmen definiert? (<- bedenke nicht nur die Windows-eigene, sondern auch Fremdfirewalls! Wenn 2 aktiv sind: Eine abschalten!). Datei- und Druckerfreigabe eingeschaltet?

Bonkers
Bitte warten ..
Mitglied: computer-fuxx
25.07.2008 um 01:38 Uhr
Also, danke für eure Antworten und Hilfen.
Ich habe das Problem mittlerweile selbst gelöst.

Folgendes habe ich noch eingestellt / umgestellt:
1. Als WINS Server war eine falsche IP Adresse eingegeben, statt der des Servers 192.168.10.10 stand da 192.168.0.40 -> also geändert!
2. Die NIC des Servers ins lokale Netz hatte in ihren TCP/IP Einstellungen keinen Eintrag im Feld DNS, da gehört aber die eigene, also 192.168.10.10 rein.
3. Unter Routing&RAS, "Server" -> Eigenschaften, IP, war als Adapter für DHCP-,DNS- und WINS-Adressen die NIC fürs Internet eingestellt. Hier habe ich die NIC des lokalen Netzes eingestellt.

Somit bekam mein VPN Client nach der Einwahl endlich die korrekten DNS und WINS Adressen zugeteilt und siehe da, Zugriff klappt nun in beide Richtungen, auch die Namensauflösung funktioniert!

Danke nochmal an Bonkers!!!

Für Tom: XP-Firewall im VPN - Client ist aus, im Router des Clients sind die Ports 1723 über TCP und das GRE Protokoll forwarded, sonst nichts.

Grüße,
FloW
Bitte warten ..
Mitglied: 60897
25.07.2008 um 08:24 Uhr
Siehssu! Besser gelernt als vorgesacht
Bitte warten ..
Ähnliche Inhalte
Router & Routing
VPN Verbindung via OpenWRT OpenVPN Client nicht möglich (4)

Frage von bfschmlan zum Thema Router & Routing ...

Windows 10
Problem mit Vpn Verbindung über Shrew Soft VPN Client (5)

Frage von Hannibal87 zum Thema Windows 10 ...

Tipps & Tricks
gelöst Portforwarding üner VPN Verbindung Client side (4)

Frage von fibs7000 zum Thema Tipps & Tricks ...

Router & Routing
Synology Server als VPN Client und VPN Server Gleichzeitig nutzen (3)

Frage von authrey zum Thema Router & Routing ...

Neue Wissensbeiträge
Multimedia

Raspberry Pi als Digital-Signage-Computer

(1)

Information von BassFishFox zum Thema Multimedia ...

Windows Update

Novemberpatches und Nadeldrucker bereiten Kopfschmerzen

(15)

Tipp von MettGurke zum Thema Windows Update ...

Windows 10

Abhilfe für Abstürze von CDPUsersvc auf Win10 1607 und 2016 1607

(7)

Tipp von DerWoWusste zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Router & Routing
Freigabe aus anderem Netz nicht erreichbar (21)

Frage von McLion zum Thema Router & Routing ...

Windows Server
Kennwort vergessen bei Hyper vserver 2012r (20)

Frage von jensgebken zum Thema Windows Server ...

Batch & Shell
Batch Programm verhalten bei shoutdown -p (19)

Frage von Michael-ITler zum Thema Batch & Shell ...

Festplatten, SSD, Raid
Raidcontroller funktioniert nur, wenn unter Legacy-Boot gestartet wird (13)

Frage von DerWoWusste zum Thema Festplatten, SSD, Raid ...