Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

VPN Tunnel über zwei Linksys VPN-Routern RV042 einrichten?

Frage Netzwerke

Mitglied: Panis77

Panis77 (Level 1) - Jetzt verbinden

19.07.2008, aktualisiert 22.07.2008, 11837 Aufrufe, 19 Kommentare

Ich kriege den VPN Tunnel (gateway-to-gateway) zwischen zwei RV042 von Linksys nicht zum laufen..

Hallo, hat jemand eine Anleitung wie ich einen VPN Tunnel zwischen zwei VPN RV042 einrichte, konfiguriere?

Vielen Dank für die Untersützung.
Panis
Mitglied: aqui
19.07.2008 um 15:20 Uhr
Im User Guide:

ftp://ftp.linksys.com/downloads/NA/userguide/RV042_ug.pdf

im Appendix C auf Seite 62 wird das auch für Laien Schritt für Schritt erklärt !!
Bitte warten ..
Mitglied: 60897
19.07.2008 um 23:55 Uhr
Wenn es eine Wahl für "die Watsch'n des Tages" geben würde, würde ich diese Antwort von aqui vorschlagen
Bitte warten ..
Mitglied: Panis77
20.07.2008 um 14:11 Uhr
Hallo aqui,

Danke für deine konstruktive Antwort.
Ich muss meine Frage präzisieren:

Beim einen Gateway habe ich dem VPN Router RV942 das Zyxel Prestige 660 (ADSL) meines Providers vorgelagert, wo auch die fixe-IP Adresse definiert ist. Entsprechend kriege ich hier eine 192.168.x.x vordefiniert.
Ich glaub das könnte das Problem sein. Oder? Denn ich weiss nicht inwieweit das überhaupt klappt, wenn ich bei Remote Security Gateway diese fixe IP Adresse eintrage.
Muss ich das noch zusätzliche Ports forwarden wie 500 oder 1701?

Remotedesktop auf diese fixe-IP Adresse mit Portforwarding 3389 auf den Win2003 Server nach dem RV042 funktioniert einwandfrei.

Ich müsste ja beim Group VPN Status ein Tunnel sehen, der aufgebaut wird oder? Mindestens wenn auf den Server zugreife?

Wer stellt sich der Herausforderung meiner Frage und kann mir dabei weiterhelfen?

Danke!!
Panis
Bitte warten ..
Mitglied: Panis77
20.07.2008 um 14:13 Uhr
Hi Bonkers,

ich hab die Frage präzisiert und jetzt ist es mehr herausfordernder als zu beginn.
Kannst Du einen konstruktiven Input leisten?

Thanks!! Panis
Bitte warten ..
Mitglied: 60897
20.07.2008 um 14:53 Uhr
Ja, Panis, kann ich!
Nimm' meinen Kommentar nicht so persönlich, etwas Spaß im Leben muss noch erlaubt sein!

Ok, also: Du hast das Problem schon richtig erkannt, Du versuchst nämlich, ein VPN aufzubauen mit einer externen IP vom Provider, also etwa 88.77.66.55 und der interne RV042 hat diese IP aber nicht. Folglich schlägt die Überprüfung fehl, weil eine "falsche" IP zurückgegeben wird.
Jetzt musst Du dem RV042 erklären, dass er sich nicht daran stören soll, sondern die Authentisierung über irgendwas anderes laufen soll. Im RV042 kannst Du verschiedene Dinge dafür eintragen, z.B. dyndns oder dyndns+IP oder Domain+IP und noch ein paar andere. Da solltest Du irgendwas, aber auf keinen Fall dyndns auswählen.

Was macht der Zyxel: Leitet der einmal alles komplett weiter an ein interne Adresse? Dann sollte das der RV042 sein, der dann natürlich entsprechend sicher eingestellt sein sollte.
Wenn Du explizit Ports weiterleiten musst: Port 500/udp muss weitergeleitet werden, der Rest baut selbständig auf.

Wenn Du die genauen Punkte und Einstellungen brauchst: Ich habe selbst eine solche Konstruktion hier, muss aber erstmal weg, könnte ich Dir heute Abend im Einzelnen mitgeben.

So, wieder gut gemacht meinen Spruch?

Schönen Sonntag!

Bonkers
Bitte warten ..
Mitglied: aqui
20.07.2008 um 18:23 Uhr
@Panis77
Ja, richtig das ist das Problem. Du musst auf dem Zyxel die folgenden Ports an den RV042 weiterleiten:
Port UDP 500 (IKE)
Port UDP 4500 (NAT-T)
ESP Protokoll (Protokoll Nummer 50)

ESP baut sich nur selber auf wenn der Zyxel das Feature VPN Passthrough supportet, aber das ist nicht sicher. Besser man traegt es explizt statisch ein !!
Solange du das nicht machst wird es nicht funktionieren, denn die IPsec Packete koennen die NAT Firewall des Zyxel nicht ueberwinden und gelangen so niemals zum RV042, das ist klar.

Funktioniert es dennoch nicht hast du noch die Chance einen sog. Exposed Host oder DMZ Host auf dem Zyxel einzutragen sofern er das supportet.
Das ist dann allerdings eine bedenkliche "Scheunentor" Loesung wo der Router alles an Ports an diese IP Adresse forwardet.
Nicht gut da sicherheitstechnisch mehr als bedenklich aber wenns nicht klappt hilft das ggf.
Sollte das auch nicht klappen, kannst du nur den RV042 direkt an die DSL Leitung hängen.
Warum du das nicht sowieso machst bleibt auch unverstaendlich, denn diese Kopplung ist eigentlich sinnlos und ueberfluessig !!!
Bitte warten ..
Mitglied: Panis77
20.07.2008 um 22:10 Uhr
Hi Bonkers,
danke für deinen Input und gerne hätte ich Einzelheiten Deiner "Konstuktion".

Kein Problem, ich habs auch als Spass empfunden.

Gruss, Panis
Bitte warten ..
Mitglied: 60897
21.07.2008 um 16:43 Uhr
So, ja, gestern Abend war nix mehr, Stadtfest und Sohn haben's verhindert.

Hier dann mal die Konfiguration:

Linksys RV042
Webconfig
VPN

Tunnel No.: 2
Tunnel Name: -
Interface: WAN1
Enable: yes
--
Local Security Gateway Type: IP only
IP Address: 192.168.x.5
Local Security Group Type: Subnet
IP Address: 192.168.x.0
Subnet Mask: 255.255.255.0
--
Remote Security Gateway Type: IP only
IP Address: 10.y.z.0
Remote Security Group Type: Subnet
IP Address: "entfernte-externe-ip.dyndns.org"
--
Keying mode: IKE with PSK
Phase1 / DH: Group 2
Phase1 Encryption: AES128
Phase1 Authentication: MD5
Phase1 Lifetime :14400 seconds
PFS: yes
Phase2 / DH: Group 2
Phase2 Encryption: AES128
Phase2 Authentication: MD5
Lifetime: 3600 seconds
PSK: ismirundsachichnich
--
Button Advanced +
--
DPD: yes, alles andere no
--

Davor steht eine FritzBox mit folgenden Einstellungen:
Eingehend UDP-Port 500 frei, Ziel auf den RV042, keine weiteren Ports, die mit VPN zu tun haben.
Die FritzBox macht den vorgelagerten Router und DSL-Modem, Internettelefonie und WLAN zum Nachbarn, falls 1und1 mal wieder die Leitung abschaltet (hatte ich jetzt dreimal in vier Monaten für je vier bis sechs Tage, daher überhaupt dieses Konstrukt)

--
Auf den Gegenseiten (mehrere) stehen auch jeweils RV042, allerdings direkt, d.h., mit Modem an DSL, kein weiterer Router davor.

Beide Seiten arbeiten jeweils mit dynamischen Adressen.

Die VPNs werden von dem oben beschriebenen Gerät aus aufgebaut, was dann auch die Erklärung dafür ist, dass ich Port 4500 nicht freigeben brauchte. Das wäre dann der Fall, wenn von der anderen Seite aus aufgebaut werden müsste. Ist mir ein wenig entfallen, weil ich Linksys-Geräte noch nicht so auswendig kenne. Habe üblicherweise mehr mit Bintec und Astaro zu tun und da hat man einfachere Möglichkeiten.

--

Insofern hat aqui mit dem Port 4500 natürlich Recht, wenn Du das so auf beiden Seiten hast bzw. wenn die Seite, zu der das VPN hin aufgebaut wird, zwei Router hintereinander hat. Ebenso ESP.

Und? Läuft bei Dir schon?

Gruß

Bonkers
Bitte warten ..
Mitglied: Panis77
22.07.2008 um 10:33 Uhr
Hi Bonkers,

vorerst herzlichen Dank für deine Ausführungen.

Ich hab jetzt den anderen Weg von acqui gewählt und
versuche das Prestige 660 als Bridge zu betreiben und
bei WAN 1 PPPoE mit den Provider daten (username, PWD)ausgewählt.

Der VPN Tunnel lässt sich nun aufbauen, nur kriege ich nun
keine Verbindung mehr zum Internet!!???

Das RV042 betreibe ich nachwievor im Gateway mode, muss
ich in Router Mode umschalten?

Das ist doch eine ganz simple Konfig!

Gruss, Panis
Bitte warten ..
Mitglied: 60897
22.07.2008 um 14:30 Uhr
Hm, ich habe da gerade ein gedankliches Problem:

Was nennst Du "als Bridge betreiben"? Wenn der Zyxel nur noch das Modem spielt, vom Linksys also nicht mehr über eine IP angesprochen wird, müssen im Linksys die Zugangsdaten hinterlegt sein und er muss als Gateway arbeiten.

Sind die Zugangsdaten aber im Zyxel und dieser ist der nächste Hop für den Linksys, dann muss der Linksys im Router-Mode arbeiten.
Vorsicht beim Router-Mode: Der Linksys macht dann kein NAT mehr, das musst Du erst manuell wieder einstellen. Das wäre auch so ein Punkt, wo zwar ein VPN, aber kein Internet funktioniert.

Gruß

Bonkers
Bitte warten ..
Mitglied: Panis77
22.07.2008 um 16:58 Uhr
Das Zyxel hat zwei Modi, Bridge u. Routing

1) Bisanhin waren die Provider-Zugangsdaten im Zyxel hinterlegt,
die fixe IP Adresse dort eingetragen, das Ganze im Routing
mode. Das RV042 ist im Gateway mode.

Zyxel:
Mode: Routing
Encapsulation: PPPoE
Dabei war NAT auf SUA only eingestellt. Für Port-Forwarding.

mit Connection Setup für ISP Provider

Linksys:
Mode: Gateway
WAN 1: Static, mit Gateway = IP Adresse von Zyxel

2) Jetzt habe ich versucht, das Zyxel als Modem zu betreiben unds
die Provider Daten im Linksys zu hinterlegen und dabei das
Zyxel im Bridge Mode eingestellt.
Das RV042 ist nachwievor im Gateway mode.
Dabei ist NAT nun auf None eingestellt.

Zyxel:
Mode: Bridge
Encapsulation: RFC 1483 oder PPPoA (??)

Linksys:
Mode: Gateway
WAN 1: PPPoE, die Provider Daten trage ich hier ein. Dabei
wird mir hier auch gleich die fixe IP Adresse zugewiesne.


Die Variate 1) Zyxel im Routing Mode und Linksys als Gateway
funktioniert prima ausser der VPN Tunnel, der kann nicht
aufgebaut werden.

Die Variante 2) Zyxel im Bridge Mode und Linksys als Gateway
funktioniert zwar der VPN Tunnel, nur kriege ich keine Verbindung
zum Internet mehr.

In keinen der beiden Fällen, habe ich Linksys im Router Mode
betrieben.

Was mach ich nur falsch??? Irgendwo ein kleiner Fehler, aber wo?

Gruss,
Panis
Bitte warten ..
Mitglied: Panis77
22.07.2008 um 17:59 Uhr
Ich hab jetzt deinen Rat befolgt und die DSL Leitung direkt an den RV042 gehängt.
Nun läuft zwar der VPN Tunnel nur kriege ich keine Verbindung zum Internet
Details habe ich Bonkers schon geschildert.
Der RV042 läuft ja im Gateway mode, muss ich den nun in den Router Mode umschalten, oder was?
Was mach ich denn bloss falsch?

Dabei muss ich das Zyxel in Mode Bridge schalten, zuvor Routing. Die Provider Daten werden im RV042 jetzt erfasst unter WAN 1 (PPPoE).
Bei der Encapsulation beim Zyxel bin ich mir nicht sicher, muss ich RFC 1483 oder PPPoA wählen, was ich der Unterschied und spielt das überhaupt eine Rolle?

Danke! Gruss, Panis
Bitte warten ..
Mitglied: 60897
22.07.2008 um 20:02 Uhr
Also ich hab nochmal nachgeschaut:
Der RV042 arbeitet bei mir im Gateway Mode, hat aber nicht die Zugangsdaten zum Provider, die sind in der vorgelagerten Fritzbox. Der Gateway Mode sorgt automatisch für NAT.

Wie schon beschrieben wird bei mir das VPN (bzw. es sind mehrere) von mir aus zum Kunden hin aufgebaut, nicht umgekehrt. Das vereinfacht natürlich ein paar Dinge.

Sind bei Dir die Netze spiegelbildlich aufgebaut, d.h., muss das VPN immer durch einen Zyxel durch? Dann muss das mit den Portfreigaben eingestellt sein, was aqui schon geschrieben hat.

Was passiert denn eigentlich, wenn Du am Zyxel einstellst, dass alle ankommenden Pakete 1:1 an den Linksys weitergegeben werden sollen, also die Exposed-Host-Einstellung oder auch DMZ-Rechner genannt (herstellerabhängig). In dem Fall muss der Linksys im Gateway-Mode arbeiten (wegen NAT). Da der dann letztlich aber alles von außen abbekommt, aber auch alles senden kann, sollte das mal der kleinste Nenner sein, bei dem sowohl VPN als auch Internet funktionieren müssen. Wenn Du da schon ein Problem damit hast, müssen wir die Linksys-EInstellungen genauer durchleuchten, dann stimmt da an anderer Stelle was nicht.

Video-Überspielungen von Kamera auf Vista-PC mit mäßiger Leistung sind übrigens sch***! Grrr!

Grüße aus Bayern mit etwas Sonne

Bonkers
Bitte warten ..
Mitglied: 60897
22.07.2008 um 20:12 Uhr
Ah, halt, hab was vergessen:

Zyxel:
Mode: Bridge
Encapsulation: RFC 1483 oder PPPoA (??)

PPPoA ist falsch eigentlich, es sollte PPPoE sein, es sein denn, Du hast eine ATM-Leitung. Allerdings kann man in manchen Routern die Modem-Einstellungen ändern, so dass es zwar noch PPPoA heißt, aber trotzdem mit PPPoE funktioniert. Mit Bintec-Routern kann man sowas rumspielen. RFC 1483 ist auch ATM, hat was mit Layer 5 zu tun, habe ich mir nicht genau durchgelesen, würde jedenfalls sagen, das sieht ganz falsch aus.

Bonkers
Bitte warten ..
Mitglied: Panis77
22.07.2008 um 20:56 Uhr
Wenn ich die Provider Daten im Linksys eingebe und die Verbindung über PPPoE im Linksys (WAN 1) aufbaue dann muss ich das Zyxel als Modem betreiben. Dazu muss ich auf Bridge Mode wechseln, wo ich als Encapsulation lediglich zwischen RFC 1483 oder PPPoA wählen kann.
Wenn aber beides falsch sein sollte, dann müsste ich diese Variante mir aus dem Kopf schlage, was ich aber kaum glauben kann.

Im Linksys baue ich dann schon über PPPoE die Verbindung auf.

Any thoughts?
Sonst muss ich wirklich Deine Variante nochmals ins Auge fassen.

Danke & Grüsse aus Zürich
Panis
Bitte warten ..
Mitglied: Panis77
22.07.2008 um 21:05 Uhr
Eine dumme Frage hätte ich dabei noch.

Wenn ich das Zyxel als Modem betreibe (Bridge Mode) und ich die Verbindung über das RV042 mit PPPoE aufbaue, dann kriege ich als WAN 1 die fixe IP Adresse vom Provider vorgegeben.
Wie aber weisse das RV042, wo es die Internet-request schicken soll???
Ich kann im RV042 keinen Gateway eingeben, sprich das Zyxel Modem.
Wobei ich bisanhin der Ansicht war, dass ich das nicht muss.

Übrigens, danke für deine responsiveness! Schätze ich sehr.
Ich muss langsam das Problem in den Griff kriegen.

Gruss, Panis
Bitte warten ..
Mitglied: 60897
22.07.2008 um 21:43 Uhr
Wenn das Zyxel-Gerät als Modem fungiert, macht es eben genau das. Der Linksys spricht also auch nur ein Modem an, keinen Router, also braucht er kein Gateway, denn das wird ihm vom Provider über das Modem mitgegeben.
Außer der IP vom Provider wird auch ein Gateway übertragen, ebenfalls vom Provider. Wenn Zyxel = Modem, dann alle IP-Konfiguration vom Provider.

Wenn Du das in der zuletzt von Dir beschriebenen Art betreibst, also Linksys bekommt externe Daten für WAN1 vom Provider, dann funktioniert doch auch das VPN, richtig? Wenn Du das nun abbaust, funktioniert dann das Internet?

Bonkers
Bitte warten ..
Mitglied: 60897
22.07.2008 um 21:48 Uhr
Ah - da haben wir's !! Zürich! Was ist denn in Zürich überhaupt für eine Leitung angesagt? In Österreich gelten ja auch so ein paar Besonderheiten. Möglich, dass in der Schweiz ATM funktioniert? Weißt Du da was darüber? Oder ein anderer Mitleser?

Bonkers
Bitte warten ..
Mitglied: Panis77
22.07.2008 um 23:30 Uhr
Der VPN funktioniert. Das Internet aber trotz Abbauch von VPN nicht.

In der letzten Konfig Zyxel als Bridge und PPPoE über Linksys, dann funktioniert der Ping auf www.irgendwas.com.., im Browser jedoch nicht??!!?
Ebenfalls der Remotedesktop auf ein Server im Internet läuft aber kein http...

Habe rausgefunden, bei Zyxel im Bridge Mode ist RFC 1483 richtig!

Any thoughts?

Gruss, Panis
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Netzwerke
Open VPN Server am LINKSYS LRT214 korrekt einrichten (1)

Frage von Thomas866 zum Thema Netzwerke ...

Router & Routing
Tunnel VPN to VPN (8)

Frage von itschloegl zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (17)

Frage von JayyyH zum Thema Switche und Hubs ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

DSL, VDSL
DSL-Signal bewerten (14)

Frage von SarekHL zum Thema DSL, VDSL ...