Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

VPN Tunnel zwischen LINKSYS BEFVP41 und D-LINK DV-804 klappt einfach nicht

Frage Netzwerke

Mitglied: explorizer

explorizer (Level 1) - Jetzt verbinden

14.07.2009, aktualisiert 18.10.2012, 5811 Aufrufe, 6 Kommentare

Hallo! Ich lese schon eine ganze Weile in diesem Forum rum. Und es wurden mir durch die Suchfunktion schon einige Fragen beantwortet. Aber ejtzt ist der Zeitpunkt, wo ich auch mal nachfragen muss.

Ich habe in unserer Firma zwei Standorte. Diese waren bisher mit jeweils einem D-LINK DV-804 VPN Router über VPN verbunden.
Leider hat einer den Geist aufgegeben. Aus diesem Grunde wollte ich die Sachen nach und nach auf Cisco bzw. Linksys umrüsten,
da ich selber von der Cisco Welt komme.

Jetzt habe ich an einem Standort einen D-LINK DV-804 und an dem anderen einen LINKSYS BEFVP41.
Die Standorte haben jeweils eine feste IP und laufen nicht über DynDNS o.Ä.

Ich habe alle Einstellungen nach bestem Wissen gleich eingestellt und eigentlich sollten sich die beiden finden und verbinden.
Doch leider klappt dies nicht.

Hat einer von Euch eine Idee?

Gruß,
MArco
Mitglied: brammer
14.07.2009 um 12:38 Uhr
Hallo,

nun, ohne details deiner konfiguration hilft uns nur die Glaskugel weiter....


brammer
Bitte warten ..
Mitglied: aqui
14.07.2009 um 12:44 Uhr
Genau... wenn du wie du selbst sagst von der Cisco Welt kommst solltest du eigentlich gelernt haben wie man gut dokumentiert, oder ?? Oder bedeutet das bei dir Cisco=Linksys ?
Ohne zu wissen welche Protokolle du nutzt, Einstellungen usw. usw. ist eine Hilfe wie das hier !
Bitte warten ..
Mitglied: explorizer
14.07.2009 um 14:21 Uhr
Nein, nicht nur ein LinksysCisco.
Ich habe mal einen CCNA gemacht. Das ist allerdings jetzt 3 Jahre her und bin momentan nur Zuhause mit einem SOHO Router im IOS unterwegs.
Da rosten natürlich auch ein paar Sachen ein

Also, ich habe die Verbindung mittlerweile hergestellt. Der Fehler lag in der Gruppeneinstellung die war beim alten Router auf 1024 gesetzt

Also die Kommunikation der beiden Rputer steht.
Allerdings ohne Möglichkeit mit dem anderen Netz über NetBios Namen zu kommunizieren.
NetBios broadcast ist bei beiden eingeschaltet. Ping auf einzelne IPs geht.
Wenn ich die IPs verwende, dann geht ja Alles.

Er sagt mir im LOG: 2009-07-14 13:35:59 IKE[12] Tx >> MM_I1 : 0.0.0.0 Error !

Das sieht mir nach einem Broadcast-Error aus, den ich aber nicht auf den ersten Blick nachvollziehen kann.


So, Subnetze , Remotenetze usw. Sind richtig eingestellt auch der Host ist richtig.

Konfiguration LINKSYS
IPSec Passtrough: enabled
TunnelName: VEOB
Encryption: 3DES
Authentication: SHA1
Auto IKE
PFS: enabled
Agressive Mode: enabled
PreSharedKEy: ist gleich mit dem anderen Router

Phase1 Proposal encryption 3DES SHA
Group: 1024

Phase2 Proposal encryption 3DES SHA
Group: 1024
PFS: enabled

Other Settings:
NetBIOS Broadcast: enabled
Keppalive: enabled



Konfiguration D-LINK
TunnelName: VEOB
Methos: IKE
NetBIOS broadcast: enabled
Aggressive Mode: enabled
IKE Keep Alive
Preshare Key: selber wie beim Linksys
IKE Proposal Index: Group2 3DES SHA1
IPsec Proposal Index: Group 2 ESP 3DES SHA1

Ich habe auf beiden auch mal die Firewall ausgeschaltet. Ohne Erfolg.

So, das sollte doch eigentlich funktionieren.

Gruß,
Marco
Bitte warten ..
Mitglied: aqui
14.07.2009, aktualisiert 18.10.2012
Gut wenn der VPN Link nun funktioniert...

"...ohne Möglichkeit mit dem anderen Netz über NetBios Namen zu kommunizieren. "

Das ist aber eine etwas peinliche Frage bzw. Erkenntnis für einen CCNA !
Wie du in der Ausbildung sicherlich gelernt hast basiert der Windows Naming Service ohne einen DNS/WINS Server rein auf UDP Broadcasts.
Eine Basisregel bei IP Netzen besagt das UDP Broadcasts NICHT über Router Interfaces übertragen wird, was auch sinnvoll ist um Broadcast Stürme netzübergreifend zu verhindern in gerouteten Netzen wie auch du sie hast mit deinem VPN.
Als CCNA bist du natürlich das IOS Kommando ip helper-address gewohnt das solche Broadcasts gezielt forwarden kann aber dumme Billigrouter wie die von D-Link können sowas natürlich nicht !

Fazit: Trage deine NetBios Namen gegenseitig bei den Clients in die Datei lmhosts ein die du bei Winblows unter C./windws/system32/drivers/etc/ findest.
Sie ist selbsterklärend wenn du sie mit dem Editor editierst und in der Regel reicht Name und IP vollkommen aus !
Näheres sagt dir noch dieser Thread:
http://www.administrator.de/forum/xp-home-mit-2-kabelgebundenen-und-wla ...

Dann klappts auch problemlos mit deinen NetBiosnamen !
Bitte warten ..
Mitglied: explorizer
14.07.2009 um 23:55 Uhr
Also, was hast Du denn für ein Problem damit, dass ich als CCNA bestimmte Sachen nicht unbedingt mehr aus dem FF weis? Zumal ich geschrieben hab, dass ich aus der Materie mittlerweile 3 Jahre raus bin. Ich wollte lediglich damit asudrücken, dass ich nicht der DAU bin. Mittlerweile habe ich es hin bekommen und das VPN funktioniert endlich. Es gab da auch noch ein Rechteproblem zwischen den Clients und dem eigentlichen DNS unserer Firma.

Na ja, jetzt geht es endlich.

Gruß,
Marco
Bitte warten ..
Mitglied: aqui
15.07.2009 um 16:23 Uhr
Dann bitte auch
http://www.administrator.de/index.php?faq=32
nicht vergessen !
Bitte warten ..
Ähnliche Inhalte
Netzwerke
VPN tunnel anabled und doch keine Verbindung (9)

Frage von Matze08 zum Thema Netzwerke ...

Router & Routing
VPN mit zwei Linksys WRT54GL (50)

Frage von Haegi75 zum Thema Router & Routing ...

LAN, WAN, Wireless
gelöst VPN IPSec mit Linksys Router funktioniert nicht (5)

Frage von knubbie zum Thema LAN, WAN, Wireless ...

Monitoring
gelöst CLI D-Link DGS 3000 (10)

Frage von 121851 zum Thema Monitoring ...

Neue Wissensbeiträge
Windows Update

Novemberpatches und Nadeldrucker bereiten Kopfschmerzen

(14)

Tipp von MettGurke zum Thema Windows Update ...

Windows 10

Abhilfe für Abstürze von CDPUsersvc auf Win10 1607 und 2016 1607

(7)

Tipp von DerWoWusste zum Thema Windows 10 ...

RedHat, CentOS, Fedora

Fedora 27 ist verfügbar

Information von Frank zum Thema RedHat, CentOS, Fedora ...

Heiß diskutierte Inhalte
Server
Bilder aus dem Web mit CSV runterladen (30)

Frage von Yannosch zum Thema Server ...

LAN, WAN, Wireless
Gebäudeverkabelung 10Gigabit LWL (27)

Frage von raffzwo zum Thema LAN, WAN, Wireless ...

Windows Update
Novemberpatches und Nadeldrucker bereiten Kopfschmerzen (14)

Tipp von MettGurke zum Thema Windows Update ...