Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

VPN-Verbindung zu Server (Windows 2003) und dann über den Server ins Internet

Frage Microsoft Windows Server

Mitglied: pinarella

pinarella (Level 1) - Jetzt verbinden

13.07.2007, aktualisiert 21.07.2007, 5170 Aufrufe, 5 Kommentare

Hallo zusammen!

Möchte folgendes realisieren:

Ich möchte mehrere Clients (5 Stück) mit einem Server verbinden. Die Verbindung soll mittels VPN erfolgen. Weiter möchte ich, dass die Clients ausschließlich die Internetverbindung des Servers für ALLE Zugriffe auf das Internet (also auch die IP des Servers) nutzen. Ein Proxy-Server würde für mich denke ich ausscheiden, da nur HTTP, FTP und eventuell ein paar andere Protokolle.

Server: Windows Server 2003 Enterprise Edition (steht im Rechenzentrum, zu erreichen über feste IP)

Clients: Alle Windows XP (Home Edition)

Ich habe bereits versucht, OpenVPN als VPN-Server einzurichten, doch bin leider gescheitert. Darum habe ich testweise die VPN-Verbindung mit Windows Bordmitteln beim Server (Eingehende Verbindung) eingerichtet - funktioniert ohne Probleme.

Soweit ich weiß, muss das Einrichten der VPN-Verbindung sowieso mit Routing und RAS erfolgen, damit die Clients der Internetverbindung des Servers nutzen können. Habe schon rumprobiert aber bislang meinem Ziel nicht näher gekommen.

Habe schon viel im Internet gestöbert, aber keine Lösung für mein Problem gefunden. Gesagt sei an dieser Stelle, dass ich über nur 1 Netzwerkkarte verfüge (habe gehört, dass das ein Problem sein kann). Ich kann auch keine weitere einbauen, da der Server nicht neben mir steht.

Zur VPN noch was: Die Verbindung sollte möglichst sicher sein, Verschlüsselt (min 128 bit, besser 256 bit oder noch besser 1024 bit) wäre nicht schlecht.

Ich hoffe, mein Unwissen erschlägt auch nicht .

Pinarella
Mitglied: Alforno
13.07.2007 um 10:40 Uhr
Hallo,

das sollte fürs erste reichen.
http://www.gruppenrichtlinien.de/HowTo/VPN_Remote_Einwahl.htm

Wenn das funktioniert sollte der Rest kein Problem sein.

Viel Spaß.

Mit freundlichen Grüßen
Alforno
Bitte warten ..
Mitglied: pinarella
13.07.2007 um 12:17 Uhr
Hallo Alforno!

Danke dir!

Bin dabei den DHCP-Server einzurichten. Nun benutze ich den "Bereichserstellungs-Assistent". Dort steht "Geben Sie eine IP unten an, um die Adresse von einem Router, der von den Clients verwendet wird, hinzuzufügen.".
Mein Server hat ja eine "Standleitung". Habe mir mal die TCP/IP-Eigenschaften angesehen. Dort ist als Standardgateway 192.168.121.141 eingetragen.

Welche IP muss ich jetzt dort eintragen? Die oben genannte meines Gateways? Oder localhost (bzw. 127.0.0.1)? Oder was ganz anderes?? Meine Clients sollen sich ja erst mit meinem Server verbinden!?!

Gruß
Pinarella
Bitte warten ..
Mitglied: pinarella
13.07.2007 um 15:24 Uhr
So, habe jetzt einfach mal Gateway die feste IP des Servers und auch mal 127.0.0.1 (für localhost) eingegeben. Beides funktioniert leider nicht.

Wenn ich mich jetzt mit einem Client unter Windows XP versuche einzuwählen, passiert folgendes nach dem Klick auf "Verbinden":

Verbindung wird hergestellt mit xx.xx.xx.xx
Der Computer wird im Netzwerk registriert.
Benutzername und Kennwort werden verifiziert.

Dann kommt folgender Fehler:

Netzwerkprotokollverbindungen werden überprüft...

TCP/IP CP gemeldeter Fehler 733: ein unbekannter Fehler ist aufgetreten.



An welcher Einstellung kann das liegen?

Pinarella
Bitte warten ..
Mitglied: pinarella
13.07.2007 um 17:24 Uhr
Hallo Bastarto,

du wirst es kaum glauben, aber ich habe tatsächlich einen V-Server bei united-hoster!

Ich habe schon mehrfach E-Mail geschrieben, über das Ticketsystem angefragt und auch schon da angerufen. Scheinbar haben die das bei heute nicht hinbekommen.

Hast du bei deinem Account VPN aktivieren lassen bzw. auch schon eingerichtet?

Gruß
Pinarella
Bitte warten ..
Mitglied: pinarella
21.07.2007 um 03:30 Uhr
So, nachdem ich alles probiert habe, und der Server mehrfach nicht wollte (Absturz), habe ich nun das Problem mit einfachsten mitteln gelöst:

Ich habe ganz normal eingehende Verbindungen (VPN) zugelassen. Benutzer eingerichtet und dann den Client mit dem Server verbunden.
Auf dem Server habe ich AnalogX Proxy installiert und entsprechende Ports in der Firewall freigegeben.
Auf dem Client (der ja über eine VPN-Verbindung zum Server verfügt), habe ich das Programm Proxifier installiert (Shareware, 31 Tage-Testversion). Dort habe ich meinem Server als Proxy eingestellt und entsprechende Ausnahmen für private IP-Bereiche und diverse Programme eingerichtet.

Funktioniert hervorragend (bis auf... siehe unten)!

Zur Funktionsweise von Proxyfier: Das Programm leitet sämtlichen Traffic aller Programme (außer die, die man ausschließt) über den Proxy-Server (also auch die, bei denen man keinen Proxy einstellen kann).

Nun zum Problem, was ich habe:

Habe mal einen Speedtest durchgeführt: Upload hat vollen Speed, nur der Download liegt immer nur zwischen 1200 und 1300 KBit/s. Ich (habe meinen Rechner als Client genommen) habe DSL 3000 hier (also wären theoretisch 3072KBit/s drin). Natürlich kommt der Verlust durch Verschlüsselung etc. hinzu, aber....so vieeell??? Da sind ja knapp nur noch 40% vom Speed übrig, also 60% Verlust???

Habe beim Server selbst auch noch einen Speedcheck gemacht. Um die 36000 Kbit/s Download und ca. 6300 Kbit/s Upload. Sollte also mehr als ausreichen.

Jemand eine Idee??
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Windows Netzwerk
gelöst VPN Verbindung von Windows 10 Rechner an FritzBox 7490 (8)

Frage von Schwalbenfahrer zum Thema Windows Netzwerk ...

Netzwerke
gelöst VPN Verbindung WIndows Rechner via FritzBox Fernzugang - Kein Internet

Frage von garack zum Thema Netzwerke ...

Windows Server
gelöst Windows Server 2012 - VPN Verbindung nach Update nicht mehr möglich (1)

Frage von ruNN0r zum Thema Windows Server ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...