Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

VPN Verbindung steht aber kein Datenaustausch möglich

Frage Netzwerke

Mitglied: Kalle322

Kalle322 (Level 1) - Jetzt verbinden

11.10.2009, aktualisiert 18.10.2012, 12399 Aufrufe, 12 Kommentare

Hallo Community,

also ich habe Probeme mit VPN... Als erstes zu meiner Hardware. Habe einen Laptop mit Kabel an einer Fritzbox 7240. Einen DSL Tarif bei Freenet.

Nun wollte ich mich via VPN mit einem Kollege verbinden. Er verbindet sich auch, kann ihn Anpingen aber leider funktioniert der Datenaustausch nicht. Hatte vorher einen Samsung router dran, dachte es hängt an diesem, jedoch habe ich mich getäuscht. Wenn ich aber den Laptop bei meiner Freundin anschließe (auch Fritzbox 7240 aber mit 1und1 Tarif) funktioniert es einwandfrei.

Liegt es nun an Freenet? Sperren die einen Port oder sonstiges und kann ich da einfach anrufen und dies freischalten lassen? Habe schon mehrere Beiträge zu diesem Thema gelesen, leider war keine Lösung, die auf mein Problem passt, dabei.

Habe auch im Internet gelesen, dass Freenet einen eigenen VPN Service anbietet, kann es sein, dass ich diesen Service erst mieten muss damit ich mein eigenes VPN nutzen kann?

Oder gibt es noch eine andere Lösung?
Über eine Antwort, würd ich mich sehr freuen und wär euch sehr dankbar.

Schöner gruß

Kalle
Mitglied: maretz
12.10.2009 um 06:52 Uhr
Moin,

also wenn das VPN steht dann kann Freenet nichts mehr sperren -> da die Ports ja dann auch im Tunnel laufen und somit von Freenet gar nicht gesehen werden können...

Das mit deren VPN-Service ist was anderes -> da brauchst du dich um die Einrichtung gar nicht kümmern...

Hast du denn erstmal die 08/15-Dinge geprüft? Firewall aus / richtig eingestellt? Freigaben richtig? Versuchst du via Rechnernamen oder via IP auf den Rechner zuzugreiffen? Was für ein OS auf den Rechnern? Ist ein Ping in BEIDE Richtungen möglich?
Bitte warten ..
Mitglied: aqui
12.10.2009, aktualisiert 18.10.2012
Es wäre mal sehr hilfreich zu erfahren WAS für eine Art von VPN du betreibst ??

  • Protokoll ?? (IPsec, PPTP, L2TP etc. )
  • Macht der Router VPN oder die Endgeräte ??

Mit den oberflächlichen Angaben von oben ist eine qualifizierte Hilfe nicht möglich !
Wenn der Router VPN macht hilft ggf. das hier:
http://www.avm.de/vpn/
bei Endgerät zu Endgerät VPN evtl. das:
http://www.wintotal.de/Artikel/vpnxp/vpnxp.php
Einen globalen Überblick findest du hier:
http://www.administrator.de/wissen/vpns-einrichten-mit-pptp-117700.html
Bitte warten ..
Mitglied: Kalle322
12.10.2009 um 09:51 Uhr
Vielen dank erstmal für euere Antworten.

Also auf dem Server weiß nich nicht, was instlaliert ist, denn die VPN Zugänge sind von einer Firma. Bin nur Client.

Der Client ist ein digital Receiver mit einer art Linux als Betriebssystem. Firewall hab ich nicht konfiguriert, aber werde ich mal versuchen.

Meine Freundin hat die gleiche Fritzbox und hat auch nichts an der Firewall konfiguriert. Haben die gleiche Firmware drauf.

Freigaben habe ich keine gemacht, da ja eigentlich alles bei meiner Freundin funktionierte. Nur bei mir Zuhause nicht.

Verbinde via IP zu meinem Kollegen...

Ping ist in beide Richtung möglich...

Hmm wie finde ich heraus, welches Protokoll ich nutze?

Die Endgeräte machen VPN, der Router kann zwar VPN, aber hatte Probleme, die Endgeräte hinteruter ins VPN Netz zu bekommen.

Danke für die links, werde diese mir in ruhe durchlesen
Bitte warten ..
Mitglied: aqui
12.10.2009, aktualisiert 18.10.2012
.. ."Die Engeräte machen VPN..." sorry aber auch diese zusätzlichen nur oberflächlichen Beschreibungen sind nicht wirklich hilfreich dein Problem zu verstehen und zu beheben...

Das ist so als ob du in eine Autowerkstatt kommst und sagst: "Ich hab was mit was rundem schwarzen unten. Was muss ich machen damit es rollt...?"

Wie soll man dir da weiterhelfen...sorry aber da musst du schon etwas mehr Details liefern für eine Hilfe ohne wild raten zu müssen...
  • Wie ist die IP Adressierung von VPN Client und Servernetz ?
  • Welches VPN Protokoll nutzt du ?
  • Wie sieht dein Netzwerk aus ? Wer ist VPN Server, wer ist VPN Client ?
  • Benutzt du einen NAT (Adress Translation) Router und hast du die entspr. Port Forwardings für dein spezifisches VPN Protokoll eingetragen ?
  • Hast du die grundlegenden Design_Regeln_für_VPNs beachtet bei der Einrichtung ?

Das sind die minimalsten Fakten die du mal liefern solltest, ansonsten müssen wir hier im freien Fall raten...was dir sicherlich nicht wirklich weiterhilft...
Bitte warten ..
Mitglied: Kalle322
13.10.2009 um 09:14 Uhr
  • Wie ist die IP Adressierung von VPN Client und Servernetz ?

13.168.1.*

  • Welches VPN Protokoll nutzt du ?

Wie finde ich das heraus?


Wie sieht dein Netzwerk aus ? Wer ist VPN Server, wer ist VPN Client ?

VPN Server ist die Firma, bei der ich den Zugang gemietet habe. Client ist der Receiver und über den tunnel, möcht ich mich mit meinem Kollegen verbinden, der auch ein Client ist...


Benutzt du einen NAT (Adress Translation) Router und hast du die entspr. Port Forwardings für dein spezifisches VPN Protokoll eingetragen ?

Benutze eine Fritzbox 7240 ohne Portforwarding
.

Hast du die grundlegenden Design_Regeln_für_VPNs beachtet bei der Einrichtung ?

Ehrlich gesagt, habe ich nur die Anleitung einer Community befolgt, die VPN Zertifikate in die key ordner rein kopiert und danach OpenVPN gestartet.


Also die Datenübertragung funktioniert, aber bricht direkt wieder ab. Mit einem FTP Client, kann ich daten sende, da er immer paar KB überträgt, abbricht und wieder aufnimmt...
Es tut mir leid, wenn ich keine spezifische Antworten abegebe. Ich kenne mich mit OpenVPN noch nicht so gut aus. Weiß also nicht, welche Daten wichtig zur Fehlerbehebung sind.
Bitte warten ..
Mitglied: aqui
13.10.2009, aktualisiert 18.10.2012
  • 13.168.1.* ist keine private IP Adresse sondern eine öffentliche ! Was soll das sein ?? Die Ziel IP vom VPN Server ??
Wohl kaum, denn fragt man nach dem rechtmässigen Besitzer dieser IP Adresse kommt DAS dabei raus:

Using server whois.arin.net.
Query string: "13.168.1.0"

OrgName: Xerox Corporation
OrgID: XEROX-16-Z
Address: 45 Glover Ave
City: Norwalk
StateProv: CT
PostalCode: 06850
Country: US

NetRange: 13.0.0.0 - 13.255.255.255
CIDR: 13.0.0.0/8
NetName: XEROX-NET

Du bist ja wohl kaum ein Angestellter von Xerox in den USA oder ???
Was soll also diese IP Adresse ??
Vielleicht solltest du zur IP Adressvergabe in deinem Netz nochmal DAS hier lesen:
http://de.wikipedia.org/wiki/Private_IP-Adresse

Wichtig sind folgende Daten:
1.) IP Netzwerk Adresse des VPN Client Netzes.
2.) IP Netzwerk Adresse des VPN Server Netzes

  • Wie findest du heraus was für ein VPN Protokoll du nutzt:
a.) Mit welchem Client stellst du die VPN Verbindung her ?
b.) Was ist der VPN Server ?? Ist das ein Winblows Rechner, OpenVPN Server, Router ???
Zur Not frag den der das VPN eingerichtet hat !

Du hast die Frage aber schon im Laufe des Threads selber beantwortet:
Du benutzt OpenVPN !!
Damit ist dann der Punkt des Protokolls schon mal geklärt.....

Auf dem Open VPN Client bei dir:
  • Was sagt das OpenVPN Log bei der Einwahl ??? Irgendwelche Fehlermeldungen ??
  • Was sagt ein ipconfig -all in der Eingabeaufforderung ? Kannst du das aktive OpenVPN Interface dort sehen ?? Was steht dort für eine IP Adresse ??
  • Was sagt ein route print in der Eingabeaufforderung ?? Kannst du das remote Netzwerk dort sehen ??
  • Wie lautet deine OpenVPN Clinent Konfig Datei ???

Hast du beachtet das dein Netzwerk und das remote Netzwerk zwingend unterschiedlich in der IP Adressierung sein MUSS ??
Lese dazu bitte nochmal dringenst das hier:
http://www.administrator.de/wissen/vpns-einrichten-mit-pptp-117700.html ...

Einen Überblick über OpenVPN Installation und Troubleshooting gibt dir dieser Thread hier:
http://www.administrator.de/wissen/openvpn-server-installieren-auf-dd-w ...
global für OpenVPN sonst:
http://www.openvpn.net/index.php/open-source/documentation/howto.html
Bitte warten ..
Mitglied: Kalle322
13.10.2009 um 12:59 Uhr
Das ist die IP, welche ich von der Firma zugewiesen bekommen hab...
Ich habe mir diese IP nicht gegeben...

Das kommt, nachdem ich OpenVPN gestartet hab. Aber TAP0 wird hergestellt und kann meinen Kollegen anpingen.
openvpn --config /etc/openvpn/client.conf
Tue Oct 13 12:51:23 2009 IMPORTANT: OpenVPN's default port number is now 1194, based on an official port number assignment by IANA. OpenVPN 2.0-beta16 and earlier used 5000 as the default port.
Tue Oct 13 12:51:28 2009 NOTE: unable to redirect default gateway -- VPN gateway parameter (--route-gateway or --ifconfig) is missing
Ifconfig
root@dm800:~# ifconfig
eth0 Link encap:Ethernet HWaddr 00:09:34:*:*:*
inet addr:169.254.*.* Bcast:169.254.255.255 Mask:255.255.0.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:824726 errors:0 dropped:0 overruns:0 frame:0
TX packets:303655 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:227492615 (216.9 MiB) TX bytes:56191055 (53.5 MiB)
Interrupt:16

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:162 errors:0 dropped:0 overruns:0 frame:0
TX packets:162 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:18167 (17.7 KiB) TX bytes:18167 (17.7 KiB)

tap0 Link encap:Ethernet HWaddr 72:0D:BB:4B:8F:3F
inet addr:13.168.1.* Bcast:13.168.255.255 Mask:255.255.0.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:8 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:1686 (1.6 KiB) TX bytes:0 (0.0 B)

root@dm800:~#
Route
root@dm800:~# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.0.0 * 255.255.255.0 U 0 0 0 eth0
13.168.0.0 * 255.255.0.0 U 0 0 0 tap0
169.254.0.0 * 255.255.0.0 U 0 0 0 eth0
default fritz.box 0.0.0.0 UG 0 0 0 eth0
root@dm800:~#
OpenVPN Cliente Datei:
client
dev tap
proto udp
remote *.dyndns.org 37*
nobind
persist-key
persist-tun
ca /var/etc/openvpn/keys/ca.crt
cert /var/etc/openvpn/keys/*.crt
key /var/etc/openvpn/keys/*.key
cipher AES-256-CBC
pull
redirect-gateway
auth SHA1
ns-cert-type server
verb 0
mute 20
Aber wie gesagt, die gleichen Einstellungen funktionieren bei meiner Freundin...
Bitte warten ..
Mitglied: aqui
13.10.2009, aktualisiert 18.10.2012
Mmmmhhh, der redirect-gateway Befehl in der Client Konfig schlägt fehl bei dir. Deshalb bekommst du keine Route in das Ziel Netzwerk was deine Routentabelle auch ganz klar zeigt. Dort ist nur das IP Netz zum OpenVPN Server 13.168.x.x drin.

Probleme die dein OpenVPN Admin dringenst ändern sollte:
  • die 13.168.x.x ist keine gute Wahl für das OpenVPN Server netz da diese Adresse der Xerox Inc. in den USA gehört. das sollte er besser ändern auf einen RFC 1918 IP Adresse.
  • Das Problem liegt am redirect-gateway Befehl. Hier ist es besser in der Server Konfig das Kommando: **push "route <remote_netz_ip> <maske>" zu verwenden ! Damit ist immer sicher eine Route an den Client übertragen. Steht auch so hier im Tutorial.

Die Frage ist warum dieses Client Kommando fehlschlägt bei dir. Vermutlich ist das eine Rechtefrage wenn der Client nicht mit Administratorrechten ausgeführt wird. Oder...dein lokales Netzwerk gleicht dem remoten. Hier musst du mal den verbose Modes des Logs höher drehen...
Das Kommando biegt dein Defalt Gateway um auf die VPN Verbindung, so das keine lokale Verbindung mehr möglich ist bei aktivem VPN.
Vermutlich hat dein Netzadmin das aus Sicherheitsgründen gemacht....da kann man aber nur raten !
Bitte warten ..
Mitglied: Kalle322
14.10.2009 um 08:37 Uhr
Verbose 3:

root@dm800:~# openvpn --config /etc/openvpn/client.conf
Wed Oct 14 08:31:47 2009 OpenVPN 2.0.2 mipsel-linux [SSL] [LZO] [EPOLL] built on Jun 28 2009
Wed Oct 14 08:31:47 2009 IMPORTANT: OpenVPN's default port number is now 1194, b ased on an official port number assignment by IANA. OpenVPN 2.0-beta16 and earl ier used 5000 as the default port.
Wed Oct 14 08:31:47 2009 Control Channel MTU parms [ L:1589 D:138 EF:38 EB:0 ET: 0 EL:0 ]
Wed Oct 14 08:31:47 2009 Data Channel MTU parms [ L:1589 D:1450 EF:57 EB:4 ET:32 EL:0 ]
Wed Oct 14 08:31:47 2009 Local Options hash (VER=V4): '7778e742'
Wed Oct 14 08:31:47 2009 Expected Remote Options hash (VER=V4): '3c42a582'
Wed Oct 14 08:31:47 2009 UDPv4 link local: [undef]
Wed Oct 14 08:31:47 2009 UDPv4 link remote: 217.172.177.27:3751
Wed Oct 14 08:31:47 2009 TLS: Initial packet from 217.172.177.27:3751, sid=af6f1 67d e3318521
Wed Oct 14 08:31:47 2009 VERIFY OK: depth=1, /C=DE/ST=Berlin/L=Berlin/O=securecs /CN=ca/emailAddress=client@securecs.de
Wed Oct 14 08:31:47 2009 VERIFY OK: nsCertType=SERVER
Wed Oct 14 08:31:47 2009 VERIFY OK: depth=0, /C=DE/ST=Berlin/L=Berlin/O=securecs /CN=securecs/emailAddress=client@*.de
Wed Oct 14 08:31:50 2009 TLS Error: local/remote TLS keys are out of sync: 217.1 72.*.*:37* [3]
Wed Oct 14 08:31:50 2009 TLS Error: local/remote TLS keys are out of sync: 217.1 72.*.*:37* [3]
Wed Oct 14 08:31:50 2009 TLS Error: local/remote TLS keys are out of sync: 217.1 72.*.*:37* [3]
Wed Oct 14 08:31:50 2009 TLS Error: local/remote TLS keys are out of sync: 217.1 72.*.*:37* [3]
Wed Oct 14 08:31:50 2009 TLS Error: local/remote TLS keys are out of sync: 217.1 72.*.*:37* [3]
Wed Oct 14 08:31:50 2009 TLS Error: local/remote TLS keys are out of sync: 217.1 72.*.*:37* [3]
Wed Oct 14 08:31:50 2009 TLS Error: local/remote TLS keys are out of sync: 217.1 72.*.*:37* [3]
Wed Oct 14 08:31:50 2009 TLS Error: local/remote TLS keys are out of sync: 217.1 72.*.*:37* [3]
Wed Oct 14 08:31:50 2009 TLS Error: local/remote TLS keys are out of sync: 217.1 72.*.*:37* [3]
Wed Oct 14 08:31:50 2009 TLS Error: local/remote TLS keys are out of sync: 217.1 72.*.*:37* [3]
Wed Oct 14 08:31:50 2009 TLS Error: local/remote TLS keys are out of sync: 217.1 72.*.*:37* [3]
Wed Oct 14 08:31:50 2009 TLS Error: local/remote TLS keys are out of sync: 217.1 72.*.*:37* [3]
Wed Oct 14 08:31:50 2009 TLS Error: local/remote TLS keys are out of sync: 217.1 72.*.*:37* [3]
Wed Oct 14 08:31:51 2009 Data Channel Encrypt: Cipher 'AES-256-CBC' initialized with 256 bit key
Wed Oct 14 08:31:51 2009 Data Channel Encrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
Wed Oct 14 08:31:51 2009 Data Channel Decrypt: Cipher 'AES-256-CBC' initialized with 256 bit key
Wed Oct 14 08:31:51 2009 Data Channel Decrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
Wed Oct 14 08:31:51 2009 Control Channel: TLSv1, cipher TLSv1/SSLv3 DHE-RSA-AES2 56-SHA, 2048 bit RSA
Wed Oct 14 08:31:51 2009 [securecs] Peer Connection Initiated with 217.*.*.* 7:37*
Wed Oct 14 08:31:52 2009 SENT CONTROL [securecs]: 'PUSH_REQUEST' (status=1)
Wed Oct 14 08:31:52 2009 PUSH: Received control message: 'PUSH_REPLY,ping 15,pin g-restart 60,ifconfig 13.168.*.* 255.255.0.0'
Wed Oct 14 08:31:52 2009 OPTIONS IMPORT: timers and/or timeouts modified
Wed Oct 14 08:31:52 2009 OPTIONS IMPORT: --ifconfig/up options modified
Wed Oct 14 08:31:52 2009 TUN/TAP device tap0 opened
Wed Oct 14 08:31:52 2009 /sbin/ifconfig tap0 13.168.*.* netmask 255.255.0.0 mt u 1500 broadcast 13.168.255.255
Wed Oct 14 08:31:52 2009 NOTE: unable to redirect default gateway -- VPN gateway parameter (--route-gateway or --ifconfig) is missing
Wed Oct 14 08:31:52 2009 Initialization Sequence Completed


Also wenn ich dein Post richtig verstanden habe, kann ich nichts ändern? Also muss ich den Einrichteservice (30Euro/15min) in anspruch nehmen
Bitte warten ..
Mitglied: aqui
14.10.2009 um 11:17 Uhr
Sieht aus als ob du einen falschen VPN Schlüssel hast ! Die Fehlermeldung ist da ja eindeutig.
Das sieht dann eher nach einem Versehen des Anbieters aus (hat dir einen falschen Schlüssel gegeben)
Oder...du hast einen falschen Schlüssel benutzt, einen z.B. der gar nicht für dich gedacht ist !!
Bitte warten ..
Mitglied: Kalle322
15.10.2009 um 08:08 Uhr
Okay.. danke für deine Hilfe.. werd mich mal an die Firma wenden...

Melde mich, sobald ich Antwort habe ;)
Bitte warten ..
Mitglied: Kalle322
17.10.2009 um 16:08 Uhr
Okay.. lag wirklich an der Firma... Lag an der FireWall des VPN Servers... Nun läufts.. trotzdem vielen dank

Schöner Gruß

Kalle
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Server
gelöst Windows Server 2012 - VPN Verbindung nach Update nicht mehr möglich (1)

Frage von ruNN0r zum Thema Windows Server ...

Netzwerke
Verbindung mit VPN-Verbindung nicht möglich (2)

Frage von Don-Santo zum Thema Netzwerke ...

Windows Server
RODC über VPN - Verbindung weg (9)

Frage von stefan2k1 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...