Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

VPN-Verbindung steht, wird aber nicht von Windows genutzt

Frage Netzwerke Router & Routing

Mitglied: icefresh

icefresh (Level 1) - Jetzt verbinden

28.03.2009, aktualisiert 09:33 Uhr, 8360 Aufrufe, 7 Kommentare

Lokale Netzwerkverbindung steht, Internet etc. funktioniert, VPN-Verbindung scheinbar auch, aber Windows nutzt lokales Netzwerk statt VPN
Software: Sonicwall Global VPN Client

Hallo,

folgendes Problem:

Ich möchte mit der Sonicwall Global VPN Client Software eine Verbindung in ein VPN-Netzwerk aufbauen (dahinter steht ein SonicWall TZ190).
Die Verbindung steht laut der Client Software. Allerdings nutzt Windows XP für alles die lokale Netzwerkverbindung bzw. DSL, was mir beim E-Mail-Verkehr zum Verhängnis wird.
E-Mails müssen nämlich über das VPN-Netzwerk versendet werden, ansonsten weist der Mailserver sie ab.

Wie kann ich veranlassen, dass in Zukunft der gesamte Traffic (oder zumindest die E-Mails) durch das VPN-Netzwerk und nicht direkt ins Internet geschickt werden?


Besten Dank für eure Hilfe!
Mitglied: stefanwesop
28.03.2009 um 10:24 Uhr
Kannst Du die IP des Zielsystems per ping erreichen?

Überschneiden sich die IP-Bereiche für lokales und entferntes Netzwerk und gibt es dadurch einen Konflikt beim Routing zwischen lokaler und entfernter IP-Adresse?
Bitte warten ..
Mitglied: aqui
28.03.2009 um 10:43 Uhr
Wenn der Email Server in einem anderen IP Netz Segment liegt als dein VPN ist es logisch !
Es gilt dann immer das lokale Default Gateway was dann ins Internet zeigt.
Ins VPN werden nur Pakete geroutet die dem VPN IP Netzwerk entsprechen.

Eine Lösung ist aber banal einfach !

Wenn du das Zielnetzwerk mit deinem Mailserver kennst konfigurierst du einfach eine statische Route ala:

route add <zielnetz> mask <maske_zielnetz> <vpn_gateway_IP>

Damit wird dann Traffic der für das <zielnetz> bestimmt ist ebenfalls auf das VPN Gateway geroutet.

Wenns klappt solltest du dieser Route noch ein -p verpassen, damit sie permanent gespeichert wird, sonst ist sie nach dem nächsten Reboot wieder weg !!!

route add <zielnetz> mask <maske_zielnetz> <vpn_gateway_IP> -p
Bitte warten ..
Mitglied: icefresh
28.03.2009 um 11:40 Uhr
Zuerst: vielen Dank euch Beiden!

@Stefan: Ja, IPs im Zielbereich kann ich pingen. Die IP-Bereiche sind ebenfalls unterschiedlich (192.168.0.x & 192.168.1.x)

@aqui: Wunderbar, so hatte ich mir das eigentlich auch gedacht. Nur nachdem es nicht funktioniert hat, hatte ich den Fehler wo anders vermutet.

Angenommen der Aufbau sieht so aus:

Lokale IP: 192.168.1.101
IP des VPN-GW: 62.130.x.x
Bei Verbindung weist es die 192.168.0.10 zu
IP des Mailservers: 91.130.x.x

Ich habe nun

route add 91.130.0.0 mask 255.255.0.0 192.168.0.10

gemacht, kommt auch keine Fehlermeldung etc.

Nun kann ich die IP des Mailservers auch nicht mehr pingen.

Wenn ich die IP des VPN-GW's (62.130.x.x) als Gateway bei route eingebe, funktioniert es ebenfalls nicht.


Blöde Frage, aber: Was muss ich da genau als Gateway eintragen? Meine funktionieren ja nicht
Bitte warten ..
Mitglied: stefanwesop
28.03.2009 um 12:08 Uhr
Der Mailserver ist also nicht im Netz des VPN? Du musst aber die Verbindung zum Mailserver über das VPN herstellen?

Wenn der Mailserver doch im Netz des VPN ist, kannst du ihn vielleicht über eine IP im Bereich 192.168.0.x ansprechen?

Prinzipiell müsste dein route-Kommando eigentlich passen. Meiner Erfahrung nach ist es allerdings bei VPN-Client-Software oft so, dass diese sich nicht in die Windows-Netzwerkeinstellungen einklinkt, sondern unterhalb der Windows-Einstellungen ihre eigenen Einstellungen für das VPN verwaltet. Dann haben die Windows-Kommandos (z. B. route) keinen Einfluss auf die Einstellungen der VPN-Client-Software. Eventuell müsstest Du schauen ob du in der Client-Software irgendwelche Einstellungen bezüglich Routing machen kannst.

Ob der Client sein eigenes Ding macht, sieht man meist daran ob nach Verbindungsherstellung in Windows ein zusätzlicher Netzwerkadapter erscheint (z. B. über ipconfig /all abfragen). Wenn dem nicht so ist, kann man meist davon ausgehen, dass Einstellungen auf Windowsebene keinen direkten Einfluss auf die VPN-Clientsoftware haben.
Bitte warten ..
Mitglied: icefresh
02.04.2009 um 16:02 Uhr
Genau so ist es - der Mailserver ist nicht im VPN-Netz.
Das Problem wurde jetzt so gelöst, dass einfach der komplette Traffic über die VPN-Verbindung geroutet wird.
Bitte warten ..
Mitglied: stefanwesop
02.04.2009 um 16:16 Uhr
Rein interessehalber, wo wurde diese Einstellung getroffen, im Windows-Routing oder in der Client-Software?
Bitte warten ..
Mitglied: icefresh
02.04.2009 um 16:18 Uhr
Im VPN-Gateway auf der anderen Seite (also quasi in der "Hauptzentrale", nicht in der "Niederlassung"). Das teilt dann der Client Software mit, dass das neue Standardgateway die VPN-Verbindung ist.
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Windows Netzwerk
gelöst VPN Verbindung von Windows 10 Rechner an FritzBox 7490 (8)

Frage von Schwalbenfahrer zum Thema Windows Netzwerk ...

Netzwerke
gelöst VPN Verbindung WIndows Rechner via FritzBox Fernzugang - Kein Internet

Frage von garack zum Thema Netzwerke ...

Windows Server
gelöst Windows Server 2012 - VPN Verbindung nach Update nicht mehr möglich (1)

Frage von ruNN0r zum Thema Windows Server ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (33)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...