Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

VPN Verbindung über WAN zu LAN in ein Netz

Frage Microsoft

Mitglied: siegal

siegal (Level 1) - Jetzt verbinden

02.05.2011, aktualisiert 18.10.2012, 3921 Aufrufe, 5 Kommentare

Grüß euch,

versuche seit einigen Tagen eine VPN-Verbindung (mit ShrewSoft VPN Client) über m0n0wall in ein Netz herzustellen.
Leider erfolglos. Ich versteh nicht, was ich falsch mache...

Das ganze sieht so aus:
bba163e31be99782326c43c638299da5 - Klicke auf das Bild, um es zu vergrößern

Also ich möchte vom PC mit der IP 192.168.188.189 auf das Netz 192.168.178.0 zugreifen. Wenn ich einen Host aus 192.168.178.0 anpingen will bekomme ich immer nur "Zeitüberschreitung der Anforderung".
Was muss ich bei der m0n0wall einstellen? Was hab ich falsch gemacht?

Schon mal vielen Dank im Voraus...

Das sind die ShrewSoft VPN Client Einstellungen:
n:network-ike-port:500
n:network-natt-port:4500
n:network-natt-rate:30
n:network-frag-size:540
n:network-dpd-enable:1
n:client-banner-enable:0
n:network-notify-enable:1
n:client-wins-used:0
n:client-wins-auto:1
n:client-dns-used:0
n:client-dns-auto:0
n:client-splitdns-used:0
n:client-splitdns-auto:0
n:phase1-dhgroup:2
n:phase1-life-secs:54600
n:phase1-life-kbytes:0
n:phase2-life-secs:28800
n:phase2-life-kbytes:0
n:policy-list-auto:0
n:client-addr-auto:1
n:version:2
n:network-mtu-size:1380
n:policy-nailed:0
s:client-saved-username:
n:vendor-chkpt-enable:0
s:network-host:192.168.188.188
s:client-auto-mode:pull
s:client-iface:direct
s:network-natt-mode:enable
s:network-frag-mode:disable
s:auth-method:mutual-psk
s:ident-client-type:ufqdn
s:ident-server-type:address
s:ident-client-data:name@email.de
b:auth-mutual-psk:MTIzNDU2Nzg=
s:phase1-exchange:aggressive
s:phase1-cipher:3des
s:phase1-hash:sha1
s:phase2-transform:esp-3des
s:phase2-hmac:sha1
s:ipcomp-transform:disabled
n:phase2-pfsgroup:-1
s:policy-level:auto
s:policy-list-include:192.168.178.0 / 255.255.255.0
Mitglied: aqui
02.05.2011, aktualisiert 18.10.2012
Eigentlich ist das ein Kinderspiel und funktioniert auf Anhieb wenn du dich an die entsprechenden Tutorials hälst:
http://www.shrew.net/support/wiki/HowtoMonowall
und auch
http://www.administrator.de/wissen/ipsec-vpn-auf-m0n0wall-oder-pfsense- ...

Zu 90% ist immer eine fehlende Firewall Regel auf dem WAN Port die Falle in die getappt wird ! Das Firewall Log zeigt dir das dann auch problemlos an.
Du musst hier zwingend die folgenden Protokolle für IPsec freigeben:
UDP 500
UDP 4500
ESP Protokoll
Siehe:
http://www.administrator.de/wissen/ipsec-vpn-auf-m0n0wall-oder-pfsense- ...
am Ende des Kapitels !
Bitte warten ..
Mitglied: siegal
02.05.2011 um 10:18 Uhr
Danke für die schnelle Antwort!

Das hab ich bereits alles gemacht und trotzdem funktioniert es nicht.
Immer der Fehler: "Zeitüberschreitung der Anforderung"
Habe schon vielen Foren und Anleitungen durchforstet, aber nix will funktionieren.
Bitte warten ..
Mitglied: aqui
02.05.2011 um 10:56 Uhr
Klappt hier sofort auf Mausklick !! Irgendwo hast du also einen Fehler eingebaut. Wie probierst du das aus mit einem Testaufbau ??
Vermutlich, denn du hast ja einen RFC 1918 IP Adresse 192.168.188.0 /24 am WAN Port !
Wichtig: Hast du den Default Firewall Filter für RFC 1918 IP Netze entfernt am WAN Port "Interfaces --> WAN " und dort am Ende bei Block private Networks ??
Ggf. mal die WAN Regeln hier posten und den Output des Firewall Logs wenn du die Verbindung initiierst !
Bitte warten ..
Mitglied: siegal
02.05.2011 um 11:49 Uhr
Block private Networks ist deaktiviert.
Um die Verbindung zu testen, lasse ich die Verbindung aufbauen und danach versuche ich einen Host im Netz 192.168.178.0 /24 anzupingen.
Vielleicht hilft das weiter:
WAN ist bei mir mit einer statischen IP belegt
IP 192.168.188.188/24
Gateway 192.168.178.201

Firewall Rules:
Proto Source Port Destination Port Description
ICMP * * * *
TCP * * * * allow all (böse)
UDP * * WAN address 500
UDP * * WAN address 4500
ESP * * WAN address *

Firewall Log:
Time If Source Destination Proto
09:47:16.895476 LAN 192.168.178.1 224.0.0.1 IGMP
Bitte warten ..
Mitglied: aqui
03.05.2011 um 11:18 Uhr
Bedenke das die Firewall Regeln immer eingehend als incoming wirken und du das ebenfalls für das VPN Interface bzw. die entsprechenden IP Netze auch erlauben musst ! (Remote Subnet)
Deine Firewall Regel oben gilt ausschliesslich für den WAN Port um den Tunnel zuzulassen. Kannst du denn im System Log sehen das der Tunnel sauber aufgebaut wird ?? Wenigstens das sollte ja sauber klappen !
Sie immer in das Firewall Log ob dort irgendwas geblockt wird. Das sagt dir immer sofort wo ein Regelproblem ist !
Bitte warten ..
Ähnliche Inhalte
Tipps & Tricks
gelöst Portforwarding üner VPN Verbindung Client side (4)

Frage von fibs7000 zum Thema Tipps & Tricks ...

Router & Routing
gelöst VPN Verbindung bei kaskadierten Routern (9)

Frage von MrNight zum Thema Router & Routing ...

Windows Server
RODC über VPN - Verbindung weg (11)

Frage von stefan2k1 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Verschlüsselung & Zertifikate
gelöst Festplattenverschlüsselung im Ausland (13)

Frage von Nicolaas zum Thema Verschlüsselung & Zertifikate ...

Festplatten, SSD, Raid
gelöst Fehlerhafte Blöcke im RAID 10 (12)

Frage von Kojak-LE zum Thema Festplatten, SSD, Raid ...

Windows Server
gelöst Microsoft-Lizenz CALs und passendes Server-Betriebssystem (12)

Frage von planetIT2016 zum Thema Windows Server ...

Netzwerkgrundlagen
gelöst Cisco SG500 Series LAG hat sich von selbst umgestellt (11)

Frage von Ex0r2k16 zum Thema Netzwerkgrundlagen ...