Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

VPN Verbindung zwischen 2 Standorten, Verbindung steht aber kein Zugriff auf Laufwerke etc

Frage Netzwerke Router & Routing

Mitglied: whmarc

whmarc (Level 1) - Jetzt verbinden

17.01.2013, aktualisiert 18:23 Uhr, 3165 Aufrufe, 7 Kommentare

Guten Abend zusammen,

ich hab nen kleines Problem, und finde den Fehler nicht.

Wir haben 2 Büros an unterschiedlichen Standorten. Diese sollen mittels VPN verbunden werden.

auf Seite 1 sieht die Konfig wie folgt aus:

SBS2011 Server als DHCP, DNS, VPN Server und Gateway - Netz 192.168.19.0

Seite 2:
Cisco Router als VPN Server, dahinter ein SBS 2008 als DHCP und DNS sowie diverse NAS Laufwerke - Netz 192.168.60.0


Nun sollen alle Clients auf Seite 1 auf die NAS Laufwerke der Seite 2 zugreifen können.

Also auf Seite 1 per RRAS eine Verbindung zur Cisco erstellt.
Auch eine statische Route auf dem SBS 2011 angelegt (mit dem Assistenten für die Verbindung)

Ipconfig /all gibt folgendes aus:
[quote]
Windows-IP-Konfiguration

Hostname . . . . . . . . . . . . : xxxxxx
Prim„res DNS-Suffix . . . . . . . : xxxxxxx.local
Knotentyp . . . . . . . . . . . . : Hybrid
IP-Routing aktiviert . . . . . . : Ja
WINS-Proxy aktiviert . . . . . . : Nein
DNS-Suffixsuchliste . . . . . . . : xxxxxxx.local

PPP-Adapter Remoterouter:

Verbindungsspezifisches DNS-Suffix:
Beschreibung. . . . . . . . . . . : Remoterouter
Physikalische Adresse . . . . . . :
DHCP aktiviert. . . . . . . . . . : Nein
Autokonfiguration aktiviert . . . : Ja
IPv4-Adresse . . . . . . . . . . : 192.168.60.108(Bevorzugt)
Subnetzmaske . . . . . . . . . . : 255.255.255.255
Standardgateway . . . . . . . . . :
DNS-Server . . . . . . . . . . . : 192.168.60.5
NetBIOS ber TCP/IP . . . . . . . : Aktiviert
[/quote]
Die Routen konfig sieht so aus:
[quote]
Schnittstellenliste
22...........................Remoterouter
21...........................RAS (Dial In) Interface
10...00 19 b9 15 a9 1c ......Broadcom NetXtreme 57xx-Gigabit-Controller
1...........................Software Loopback Interface 1
11...00 00 00 00 00 00 00 e0 Microsoft-ISATAP-Adapter
12...00 00 00 00 00 00 00 e0 Teredo Tunneling Pseudo-Interface
14...00 00 00 00 00 00 00 e0 Microsoft-ISATAP-Adapter #2
15...00 00 00 00 00 00 00 e0 Microsoft-ISATAP-Adapter #3

IPv4-Routentabelle
Aktive Routen:
Netzwerkziel Netzwerkmaske Gateway Schnittstelle Metrik
0.0.0.0 0.0.0.0 192.168.19.1 192.168.19.5 15
82.198.198.56 255.255.255.255 192.168.19.1 192.168.19.5 11
127.0.0.0 255.0.0.0 Auf Verbindung 127.0.0.1 306
127.0.0.1 255.255.255.255 Auf Verbindung 127.0.0.1 306
127.255.255.255 255.255.255.255 Auf Verbindung 127.0.0.1 306
192.168.19.0 255.255.255.0 Auf Verbindung 192.168.19.5 266
192.168.19.5 255.255.255.255 Auf Verbindung 192.168.19.5 266
192.168.19.53 255.255.255.255 Auf Verbindung 192.168.19.53 306
192.168.19.255 255.255.255.255 Auf Verbindung 192.168.19.5 266
192.168.60.0 255.255.255.0 192.168.19.108 192.168.19.5 264
192.168.60.108 255.255.255.255 Auf Verbindung 192.168.60.108 266
224.0.0.0 240.0.0.0 Auf Verbindung 127.0.0.1 306
224.0.0.0 240.0.0.0 Auf Verbindung 192.168.19.5 266
224.0.0.0 240.0.0.0 Auf Verbindung 192.168.19.53 306
224.0.0.0 240.0.0.0 Auf Verbindung 192.168.60.108 266
255.255.255.255 255.255.255.255 Auf Verbindung 127.0.0.1 306
255.255.255.255 255.255.255.255 Auf Verbindung 192.168.19.5 266
255.255.255.255 255.255.255.255 Auf Verbindung 192.168.19.53 306
255.255.255.255 255.255.255.255 Auf Verbindung 192.168.60.108 266
St„ndige Routen:
Netzwerkadresse Netzmaske Gatewayadresse Metrik
0.0.0.0 0.0.0.0 192.168.19.1 5

IPv6-Routentabelle
Aktive Routen:
If Metrik Netzwerkziel Gateway
1 306 ::1/128 Auf Verbindung
10 266 fe00::/8 Auf Verbindung
10 266 fe80::/64 Auf Verbindung
10 266 fe80::c84f:48bd:65b4:1160/128
Auf Verbindung
10 266 fe80::d702:1e38:d66:8bb9/128
Auf Verbindung
1 306 ff00::/8 Auf Verbindung
10 266 ff00::/8 Auf Verbindung
21 306 ff00::/8 Auf Verbindung
St„ndige Routen:
Keine
[/quote]






Soweit so gut. Allerdings habe ich keinerlei Verbindung von meinen Clients in das andere Netzwerk.
Ich kann aus dem 19er netz nen ping an das 60er netz schicken, der geht aber verloren. heisst ich kann nix anpingen und auch nicht per IP auf irgendein NAS zugreifen.

Und nun kommt die Frage aller Fragen: Was mache ich falsch ? Liegt es am SBS2011 (von dem kann ich auf das 60er Netz zugreifen) oder liegt es vielleicht an einer Client Einstellung ?

Bin für jeden Tip dankbar.

Gruß
Marc
Mitglied: aqui
17.01.2013, aktualisiert um 18:58 Uhr
Falls du PPTP als VPN Dialin Protokoll benutzt findest du hier eine lauffähige Konfig:
http://www.administrator.de/wissen/konfiguration-cisco-886va-mit-adsl-o ...
denn zur Cisco Konfig machst du keinerlei Aussagen..leider, was die zielführende Hilfe nicht leichter macht !
Das ist aber ein essentieller Teil, denn ohne korrektes VPN ggf. ACLs hier kann es solche Probleme geben.
Frage die sich stellt, kannst du das lokale Ethernet LAN Interface des Ciscos pingen !
Wichtig ist auch WELCHES Default Gateway die Clients am Winblows server haben ?? Wenn das der Server ist ist gut, wenn das aber ein lokaler Router ist dann muss DORT die statische Route definiert werden, die am Server nützt dann rein gar nix !
Traceroute (tracert) und Pathping sind hier deine Freunde für die Wegefindung !!
Bitte warten ..
Mitglied: whmarc
17.01.2013 um 19:14 Uhr
Entschuldige,
also alle Clients nehmen den SBS2011 als gateway. Eine direkteinwahl vom Client funktioniert auch mit Zugriff Aug die NAS Laufwerke und alles andere. Werde mir nachher um Büro den anderen Beitrag mal ansehen, bin zur Zeit mobil unterwegs .

von meiner Seite aus kann ich die Cisco nur anpingen wenn ich eine direkte VPN herstelle
Bitte warten ..
Mitglied: whmarc
18.01.2013 um 10:48 Uhr
So, habe nun nochmal alles nachgelesen und geprüft.
Die Cisco läuft, nimmt die VPN Verbindungen auch an.
Mom normalen Client kann ich eine direkte Verbindung herstellen und kann auch auf das entfernte Netz inkl. aller Freigabe und NAS Laufwerke zugreifen.

Von dem SBS 2011 funktioniert auch alles.
Als Protokoll läuft derzeit PPTP.

Jeder Client hat als Gateway den SBS 2011. Nameserver werden zuerst über den SBS dann über einen externen NS aufgelöst.
Irgendwie habe ich das Gefühl das das Routing nicht an die Clients weitergegeben wird.

Ein tracert vom Client ins andere Netz bei bestehender Verbindung des SBS sieht wie folgt aus:

Routenverfolgung zu 192.168.60.5 ber maximal 30 Abschnitte

1 <1 ms * <1 ms xxxxxxxxxxxxxxxxx.local [192.168.19.5]
2 * * * Zeitberschreitung der Anforderung.
3 * * * Zeitberschreitung der Anforderung.
4 * * * Zeitberschreitung der Anforderung.
5 * * * Zeitberschreitung der Anforderung.
6 * * * Zeitberschreitung der Anforderung.
7 * * * Zeitberschreitung der Anforderung.
8 * * * Zeitberschreitung der Anforderung.
9 * * * Zeitberschreitung der Anforderung.
10 * * * Zeitberschreitung der Anforderung.
11 * * * Zeitberschreitung der Anforderung.
12 * * * Zeitberschreitung der Anforderung.
13 * * * Zeitberschreitung der Anforderung.
14 * * * Zeitberschreitung der Anforderung.
15 * * * Zeitberschreitung der Anforderung.
16 * * * Zeitberschreitung der Anforderung.
17 * * * Zeitberschreitung der Anforderung.
18 * * * Zeitberschreitung der Anforderung.
19 * * * Zeitberschreitung der Anforderung.

Vielleicht irgendeine Idee ?
Eine Lösung mit 2 Routern die die Verbindung herstellen ist nicht möglich.
Habe auch dieses Tut http://www.stefan-korn.de/website/computer/winroutingtut.html (obwohl für 2000) mal durchgesehen und keine Unterschiede zu meinem SBS 2011 gefunden. Alles gleich konfiguriert.

Irgendwie bin ich gerade ein wenig ratlos.

Gruß
Marc
Bitte warten ..
Mitglied: aqui
18.01.2013 um 12:01 Uhr
Hast du generell auf dem Server Routing aktiviert ??
http://www.administrator.de/wissen/routing-mit-2-netzwerkkarten-unter-w ...
Das ist essentiell wichtig damit der überhaupt Traffic forwardet.
Zu befürchten ist aber das der Cisco nur als Client Dialin konfiguriert ist, damit ist dann nur ein Client Dialin möglich niemals aber eine Site to Site Kopplung was du da machen willst.
Bitte warten ..
Mitglied: whmarc
18.01.2013 um 13:26 Uhr
Berichtige mich wenn ich falsch liege, aber das forwarding ist an ... richtig ?

  1. ----------------------------------
  2. IPv4-Konfiguration
  3. ----------------------------------
pushd interface ipv4

reset
set global icmpredirects=enabled dhcpmediasense=disabled
add route prefix=0.0.0.0/0 interface="LAN-Verbindung" nexthop=192.168.19.1 metric=5 publish=Ja
set interface interface="Loopback Pseudo-Interface 1" forwarding=enabled advertise=enabled nud=enabled
add address name="LAN-Verbindung" address=192.168.19.5 mask=255.255.255.0


popd
  1. Ende der IPv4-Konfiguration
Bitte warten ..
Mitglied: aqui
18.01.2013 um 15:23 Uhr
Keine Ahnung was der Output bedeuten soll und wo der herkommt aber bei Winblows geht das mit einem Haken im Setup oder einem Eingriff in die Registry. Siehe Tutorial.
Ob es geht kann man sehen, wenn man vom LAN Port z.B. den VPN Port oder einen anderen Port am Server pingen kann.
Dann forwardet der sauber IPv4 Paketes und das Routing ist aktiv.
Wenns nicht geht ist das Routing eben nicht aktiv.
Die Frage ist wie sich der MS Server verhält wenn der als Client ein PPTP Dialin macht, also ob die PPTP Verbindung eine isolierte reine Punkt zu Punkt Client Verbindung ist oder ob er den PPTP Tunnel als transparente IP Verbindung sieht über die er auch routen kann.
Kannst du da im Server Log ggf. was sehen ?
Bitte warten ..
Mitglied: whmarc
18.01.2013 um 17:40 Uhr
Das ist natürlich ne gute Frage ...
Was ich sagen kann ist das wenn der SBS per RAS verbunden ist, bekommt die Einwahlschnittstelle die 192.168.60.107 zugewiesen. Der SBS hat die 192.168.19.5 .

Nun kann ich vom Client (192.168.19.10) die 192.168.60.107 pingen und kriege auch ne Antwort. Aber das war es dann auch ...
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Router & Routing
gelöst VPN-Verbindung zwischen zwei Fritzboxen bricht sehr häufig ab (14)

Frage von mabue88 zum Thema Router & Routing ...

Windows Netzwerk
gelöst Probleme VPN Verbindung zwischen Win 7 Rechnern (13)

Frage von Vsadm07 zum Thema Windows Netzwerk ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (33)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...