Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Vsftp startet nicht mehr

Frage Linux

Mitglied: JanesR

JanesR (Level 1) - Jetzt verbinden

30.06.2009, aktualisiert 18.10.2012, 6814 Aufrufe, 11 Kommentare

Beim Starten von Vsftp bekomme ich folgende Fehlermeldung: "Starting vsftpd startproc: exit status of parent of /usr/sbin/vsftpd: 1"

Hallo, ich habe ein kleines Problem mit Vsftp.
Ich hatte ihn vor wochen mal eingerichtet aber er wurde zunächst nicht gebraucht deshalb hatte ich ihn deaktiviert. Jetzt wird er gebraucht und ich habe die config noch leicht angepasst. Doch jetzt bekomme ich immer wenn ich ihn starten will folgende Fehlermeldung.

  1. rcvsftpd start
Starting vsftpd startproc: exit status of parent of /usr/sbin/vsftpd: 1
failed

Ich nutze openSuse 10.2, und der vsftp soll als Stand alone laufen ohne xinet.d


Über eure Hilfe wäre ich sehr dankbar

Gruß Janes

Dies sind meine einstellungen der vsftd.conf

  1. General Settings
write_enable=YES
dirmessage_enable=YES
#nopriv_user=ftpsecure
ftpd_banner="rrf FTP-Service"
#ls_recurse_enable=YES
#deny_email_enable=YES
#banned_email_file=/etc/vsftpd.banned_emails
#hide_ids=YES
local_enable=YES
#local_umask=022
chroot_local_user=YES
#chroot_list_enable=YES
#chroot_list_file=/etc/vsftpd.chroot_list
#local_max_rate=7200
  1. Anonymus FTP user Settings
anonymous_enable=NO
anon_world_readable_only=YES
#anon_upload_enable=YES
#anon_umask=022
#anon_mkdir_write_enable=YES
#anon_other_write_enable=YES
#chown_uploads=YES
#chown_username=whoever
#anon_max_rate=7200
syslog_enable=YES
#log_ftp_protocol=YES
#xferlog_enable=YES
#vsftpd_log_file=/var/log/vsftpd.log
#xferlog_std_format=YES
#xferlog_file=/var/log/xferlog
#dual_log_enable=YES
#setproctitle_enable=YES
connect_from_port_20=YES
#idle_session_timeout=600
#async_abor_enable=YES
#ascii_upload_enable=YES
#ascii_download_enable=YES
#pasv_enable=NO
pam_service_name=vsftpd
listen=YES
ssl_enable=NO
userlist_deny=NO
userlist_enable=YES
Mitglied: DJKennethcool
30.06.2009 um 14:57 Uhr
Brobire es ma mit neuinstallation

Gruß DJ,
Bitte warten ..
Mitglied: JanesR
30.06.2009 um 15:09 Uhr
Dazu müsste ich erstmal meine linux version Updaten da ich ich die 10.2 damals mit einer net install cd installiert habe und ich jetzt keine quelle mehr für die 10.2 habe.
Bitte warten ..
Mitglied: exceter
30.06.2009 um 15:11 Uhr
Hallo,

da du syslog aktiviert hast, verrat uns doch bitte mal, was die /var/log/messages so hergibt....

Weiterhin: die beiden "1." stehen so aber nicht in der vsftpd.conf, oder?

Servus,
Ex
Bitte warten ..
Mitglied: BCCray
30.06.2009, aktualisiert 18.10.2012
Ich denk nicht das eine Neuinstallation immer gleich der beste Weg ist - man lernt mit Problemen

Check mal:
Vielleicht läuft vsftp schon? (man sollte echt an alles denken)
-> ps -A | grep vsftpd

Status vsftp:
-> /etc/init.d/vsftpd status
wenn unused, dann läuft er ned

ansonten schau mal hier:
Probleme mit vsftpd.conf
Fehler beim Starten von vsftpd
Bitte warten ..
Mitglied: BCCray
30.06.2009 um 15:21 Uhr
stimmt - ist die erste Zeile auskommentiert??? oder war das nur ein Zusatz von dir.....?????
Bitte warten ..
Mitglied: JanesR
30.06.2009 um 15:28 Uhr
Die beiden "1" stehen so nicht in der config, ich habe keine ahnung wo die herkommen, und die log datei ist extrem lang die kann ich nicht komplett posten, ich kann dort auch nicht unterscheiden was davon wichtig und was unwichtig ist
Bitte warten ..
Mitglied: exceter
30.06.2009 um 15:34 Uhr
Oops, habe falsch gelesen, sorry.

Dann wäre der nächste logische Schritt, die von dir gemachten Änderungen mal rückgängig zu machen und dann zu sehen, ob's tut.

Servus,
Ex



Hallo,
kommentier die beiden Zeilen mal aus (mach einen # davor, liest sich dann danach: #1....... )

Jede Zeile, die nicht mit einem # beginnt, wird als Config-Direktive angesehen.
Servus,
Ex
Bitte warten ..
Mitglied: JanesR
30.06.2009 um 15:35 Uhr
Der vsftp deamon läuft nicht.
Die anderen beiden beiträge hatte ich schon gelesen haben mich aber nicht weiter gebracht, pure-ftp habe ich garnicht installiert und ich als linux noob konnte auch so direkt keine fehler in der konfig finden
Bitte warten ..
Mitglied: JanesR
30.06.2009 um 15:48 Uhr
Habe ich versucht: selbe fehlermeldung
Ich glaube ich versuche es mit dem ersten vorschlag vsftp neu installieren. dazu muss ich aber erstmal mein SUSe updaten, ich habe hier auch noch ein net install cd von Suse 10.3 kann ich mein suse damit updaten ohne das ich datenverlust habe ? oder meine anderen dienste wie samba betroffen sind ?
Bitte warten ..
Mitglied: BCCray
30.06.2009 um 15:52 Uhr
Vielleicht hilft hier diese Seite
Manpage vsftpd
Bitte warten ..
Mitglied: exceter
30.06.2009 um 16:07 Uhr
Hallo,
lass das Updaten lieber mal den Yast machen. Starte als root einfach 'you' und schon gehts los

Ex
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung!

(1)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Webbrowser
Mozilla: Firefox 50 startet schnell und bringt Emoji (3)

Link von Frank zum Thema Webbrowser ...

Windows 10
gelöst Windows 10 startet nicht mehr nach dem letztem Update (7)

Frage von Barabas zum Thema Windows 10 ...

CPU, RAM, Mainboards
Neuer PC startet nicht auf (19)

Frage von uridium69 zum Thema CPU, RAM, Mainboards ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (15)

Frage von JayyyH zum Thema Switche und Hubs ...

DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...

Backup
Clients als Server missbrauchen? (10)

Frage von 1410640014 zum Thema Backup ...