Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

W2K-Client und NT 4-Server: IFMEMBER funktioniert nicht

Frage Microsoft Windows Userverwaltung

Mitglied: K3

K3 (Level 1) - Jetzt verbinden

28.12.2004, aktualisiert 16:07 Uhr, 8421 Aufrufe, 7 Kommentare

Folgendes Problem habe ich:

In einem NT 4-Netz sollen die NT-Clients auf W2K aufgerüstet werden. Einen habe ich jetzt probehalber umgestellt.

Mittels einer Batch-Datei und dem Befehl "IFMEMBER" werden den Benutzern in Abhängigkeit ihrer Gruppenzugehörigkeit Laufwerke auf dem NT-Server gemappt.

Auf den NT-Clients funktioniert das vorzüglich.

Der W2K-Client erkennt aber diesen Befehl nicht, wenn sich eine normaler Domänen-Benutzer anmeldet. Die Fehlermeldung lautet etwa: "Befehl nicht bekannt oder falsch geschrieben".

Seltsamerweise funktioniert das Mappen aber problemlos, wenn ich mich als Domänen-Admin anmelde.

Zunächst dachte ich, daß es daran liegt, daß ich den Befehl "IFMEMBER" nicht installiert hatte. Dies habe ich nachgeholt, aber ohne Ergebnis.

Hat jemand eine Idee, wo der Fehler liegen könnte?

Hinzufügen muß ich noch, daß ich mich bisher nicht mit der Administration von W2K-Netzen befaßt habe, da das NT-Netz bisher problemlos lief und ich deshalb keine Notwendigkeit zu einer Änderung sah.

Vielen Dank für Tips,

K3
Mitglied: Atti58
28.12.2004 um 13:01 Uhr
... Du solltest uns schon mal die gesamte Zeile Deines Batchaufrufes zu Verfüguing stellen, so werden wir Dir nur bedingt helfen können ...

Gruß

Atti
Bitte warten ..
Mitglied: K3
28.12.2004 um 14:57 Uhr
Bitte:

ECHO OFF
REM Nachfolgend werden die Laufwerksverbindungen beim Start
REM in Abhaengigkeit von der Gruppenzugehoerigkeit gesetzt.

IFMEMBER ADMINISTRATOREN
if not errorlevel 1 goto weiter
IF EXIST V: NET USE V: /DELETE
NET USE V: \\NEU01\C$ /PERSISTENT:NO

:weiter
IFMEMBER Benutzer
if not errorlevel 1 goto weiter
IF EXIST Z: NET USE Z: /DELETE
NET USE Z: \\NEU01\ALLE_USER /PERSISTENT:NO

:weiter
IFMEMBER DATENBANKEN
if not errorlevel 1 goto weiter
IF EXIST Y: NET USE Y: /DELETE
NET USE Y: \\NEU01\DATENBANKEN$ /PERSISTENT:NO

usw.

:weiter

REM Ende der Datei


Der Pfad auf dem NT-Server ist:

\\WINNT\System32\Repl\Import\Scripts\LWV.BAT


Benötigt Ihr noch weitere Informationen?

K3
Bitte warten ..
Mitglied: Atti58
28.12.2004 um 15:09 Uhr
Das ist doch schon ein wenig mehr , jetzt sollten wir herausbekommen, wann Deine Fehlermeldung erzeugt wird. Nimm einfach mal nur die ersten beiden Teile in eine eigene Batch:

REM ECHO OFF
REM Nachfolgend werden die Laufwerksverbindungen beim Start
REM in Abhaengigkeit von der Gruppenzugehoerigkeit gesetzt.

IFMEMBER ADMINISTRATOREN
pause
if not errorlevel 1 goto weiter
pause
IF EXIST V: NET USE V: /DELETE
pause
NET USE V: \\NEU01\C$ /PERSISTENT:NO
pause

:weiter
IFMEMBER Benutzer
pause
if not errorlevel 1 goto weiter
pause
IF EXIST Z: NET USE Z: /DELETE
pause
NET USE Z: \\NEU01\ALLE_USER /PERSISTENT:NO
pause

:weiter


mache eine Eingabeaufforderung auf und starte diesen neuen Batch-File dort und sage mir, an welcher Stelle die Fehlermeldung kommt,

Gruß

Atti
Bitte warten ..
Mitglied: K3
28.12.2004 um 15:30 Uhr
Direkt am Anfang kommt die Fehlermeldung "Der Befehl "IFMEMBER" ist entweder falsch geschrieben oder konnte nicht gefunden werden.

Das läuft dann so weiter.
Bitte warten ..
Mitglied: Atti58
28.12.2004 um 15:46 Uhr
... da müsste man nun wissen, was dieses Tool so macht und welche "Vorgaben" es finden muss - bist Du sicher, dass das Programm Win2k-geeignet ist? Hast Du schon mal nach einer neueren Version gesucht?

In welchem Verzeichnis liegt denn "IFMEMBER" - kopiere es doch mal nach C:\Winnt\system32" wenn es unter Win2k funktioniert, solte es hier garantiert gefunden werden ...

Gruß

Atti
Bitte warten ..
Mitglied: K3
28.12.2004 um 15:57 Uhr
Hei, genau das war das Problem!

Das Programm IFMEMBER.EXE stand unter C:\Programme\ResourceKit... usw.!

Da hat W2K es nicht gefunden.

Ich habe es gemäß Deinem Rat nach C:\Winnt\system32 kopiert und siehe da: Jetzt geht es!

Vielen Dank! Du hast mir sehr geholfen!

Viele Grüße,

K3
Bitte warten ..
Mitglied: Atti58
28.12.2004 um 16:07 Uhr
... gut Ding will Weile haben , es war zwar eine nicht ganz einfache Geburt, danke aber auch an Dich, dass Du den Erfolg bestätigst,

guten Rutsch,

Atti
Bitte warten ..
Neuester Wissensbeitrag
Microsoft

Lizenzwiederverkauf und seine Tücken

(5)

Erfahrungsbericht von DerWoWusste zum Thema Microsoft ...

Ähnliche Inhalte
Server
gelöst Client bei Windows Server 2003 ändern (5)

Frage von Therealcookie zum Thema Server ...

Windows 7
Wsus client findet am wsus server nicht alle updates (1)

Frage von endurance zum Thema Windows 7 ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (18)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Windows Netzwerk
Windows 10 RDP geht nicht (16)

Frage von Fiasko zum Thema Windows Netzwerk ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...