Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

W2k3 Server Dateiexport unterstützt plötzlich nur noch 8 Zeichen?

Frage Microsoft Windows Server

Mitglied: Matetee

Matetee (Level 1) - Jetzt verbinden

14.09.2009 um 11:45 Uhr, 3452 Aufrufe, 1 Kommentar

Hallo, ich hoffe das mir hier nach langer Suche geholfen werden kann. Vorab vielen Dank für jede Idee oder Lösungshilfe!

Folgendes Phänomen:

Ich habe eine Access-Fachanwendung auf einem W2k3 Server laufen, welche unter anderem per Export-Funktion automatisch eine .txt Datei auf einem Netzlaufwerk erstellt.

Der Dateiname der *.txt Datei wurde bisher nach folgendem Schema erstellt:

10.1234.456.12082009_xxx.txt

Anstatt dem xxx wird eine fortlaufende Nummer vergeben.

Neuerdings funktioniert der Export nicht mehr korrekt sondern es wird ohne ersichtlichen Grund

1. eine leere *.txt Datei erstellt welche die oben beschriebene Zeichenkonvention besitzt. Leider ist dies Datei nun komplett leer.
2. Gleichzeitig erstellt das Programm aber eine neue Datei z.B. 008 ohne jegliche Dateiendung. In dieser befinden sich nun meine Daten.

Wenn ich im Programm manuell in den Export-Prozess eingreife und den Dateinamen manuell auf 8 Zeichen kürze und dann erst exportiere, dann wird wieder wie früher nur eine normale Textdatei erzeugt.

Wenn ich die Datei auf mein lokales Verzeichnis C.\temp und nicht auf das Netzlaufwerk sichere funktioniert es auch ohne Probleme mit dem langen Dateinamen. Nur eben auf das Netzlaufwerk nicht mehr.

Komisch ist das der Export über Jahre hinweg funktioniert hat, und nun plötzlich nicht mehr. Es gab auf dem Server oder in der Anwendung auch keine Updates. Das einzige was ich mir vorstellen kann ist das das Windwosupdate etwas auf dem Server verändert hat, oder das irgendjemand bei uns im Admin-Team irgendwelche Gruppenrichtlinien geändert hat....

Hat jemand schon einmal ein ähnliches Phänomen gehabt, oder eine Idee?
Mitglied: Biber
17.09.2009 um 12:16 Uhr
Bevor es untergeht: Zu dieser Frage hat Matetee selbst eine Lösung gefunden

Zitat von Matetee:
So leider hat hier niemand eine Idee gehabt, aber wir haben es nun selbst rausgefunden.

Eine Gruppenrichtilinie in der AD hat für die Fileserver
automatisch die Unterstützung der 8+3 Namenskonvention abgeschaltet.
Als der Server am Wochendende automatisch neugestartet wurde hat diese erst gegriffen.
Dadurch konnten wir keinen zeitlichen Zusammenhang zwischen einer Änderung und dem Datum des Auftretens des Problems feststellen.

Jetzt wurde der Server aus der Regel ausgenommen nochmal neu gestartet und nun funktioniert das Abspeichern wieder korrekt.
[Zitat von einem dafür neu eröffneten Beitrag, der im Papierkorb landen wird/irgendwann weg ist]

Grüße
Biber
Bitte warten ..
Neuester Wissensbeitrag
Heiß diskutierte Inhalte
Switche und Hubs
LAG zwischen Cisco SG300 und Dlink DGS1100 herstellen - wie? (18)

Frage von White-Rabbit2 zum Thema Switche und Hubs ...

Grafikkarten & Monitore
Neue Graifkkarte - kein Bild (10)

Frage von bestelitt zum Thema Grafikkarten & Monitore ...

Linux
gelöst Boot failed: not a bootable disk (10)

Frage von Fleckmen zum Thema Linux ...

Multimedia & Zubehör
gelöst Iphone 6 prob (8)

Frage von jensgebken zum Thema Multimedia & Zubehör ...