Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Wake on LAN - Senden des Magic Packet funktioniert nur über LAN

Frage Netzwerke LAN, WAN, Wireless

Mitglied: enJOyIT

enJOyIT (Level 1) - Jetzt verbinden

28.02.2013, aktualisiert 02.03.2013, 12058 Aufrufe, 24 Kommentare

Hallo,

wie der Titel schon sagt habe ich das Problem, dass das Magic Packet welches für Wake on Lan gesendet werden muss, nur über das LAN-Kabel gesendet wird. Sobald ich das Notebook per WLAN mit dem Netzwerk verbinde funktioniert es nicht mehr.

Natürlich hat das Notebook Verbindung zum Router und sonst funktioniert auch alles andere!

Ich habe echt keine Ahnung was da eventuell dem Senden des Magic Packet im Wege steht. Auch habe ich schon die interne LAN-Schnittstelle deaktiviert und verschiedene Programme zum Senden des Magic Packet verwendet, alles ohne positives Ergebnis!

Notebook: Lenovo Thinkpad T400 (WLAN NIC Intel 5100 AGN)

Router: LinkSys E2000

Betriebssystem: Windows 7 Prof. 64 Bit
Mitglied: michi1983
28.02.2013 um 13:53 Uhr
Hi,

eventuell hilft dir das hier weiter:
http://technet.microsoft.com/de-de/library/ee851581(v=ws.10).aspx

MfG
Michi
Bitte warten ..
Mitglied: MrNetman
28.02.2013 um 14:58 Uhr
und wen willst du aufwecken?

Vielleich kann ja der Linksys das Magic Paket senden, dann klappt das immer.

GRuß
Netman
Bitte warten ..
Mitglied: enJOyIT
28.02.2013 um 15:09 Uhr
Ich habe in der LinkSys-Software noch nichts dergleichen gefunden. Ich weiß, dass es eine alternative FW für den Router gibt und es dann sehr wahrscheinlich möglich ist. Nur möchte ich nicht jedesmal über die Weboberfläche das Paket abzuschicken.

Wobei ich davon ausgehe, dass dies auch über die neue FW umgangen werden kann und jeder Netzwerkzugriff auf die IP die ich aufwecken möchte dazu führt, dass das Paket abgeschickt wird.

Vielen Dank erstmal für eure Antworten!

Gruß
enJOyIT
Bitte warten ..
Mitglied: enJOyIT
28.02.2013 um 15:11 Uhr
Hallo, danke für deine Antwort!

Leider führt der Link nicht zu der gewünschten Beschreibung die ich benötige. Ich möchte nicht WoWLAN aktivieren, sondern ganz normal per LAN einen anderen Rechner aufwecken. Das funktioniert soweit auch ganz gut, nur wenn ich das Magic-Packet per WLAN absende kommt es nicht bei dem gewünschten Rechner an. Per LAN funktioniert das ohne Probleme!
Bitte warten ..
Mitglied: michi1983
28.02.2013 um 15:15 Uhr
Achso, tut mir Leid, dann hab ich deinen Eintrag missverstanden.

MfG
Michi

Zitat von enJOyIT:
Hallo, danke für deine Antwort!

Leider führt der Link nicht zu der gewünschten Beschreibung die ich benötige. Ich möchte nicht WoWLAN
aktivieren, sondern ganz normal per LAN einen anderen Rechner aufwecken. Das funktioniert soweit auch ganz gut, nur wenn ich das
Magic-Packet per WLAN absende kommt es nicht bei dem gewünschten Rechner an. Per LAN funktioniert das ohne Probleme!
Bitte warten ..
Mitglied: Pjordorf
28.02.2013 um 15:23 Uhr
Hallo,

Zitat von enJOyIT:
sondern ganz normal per LAN einen anderen Rechner aufwecken.
OK. Und der auzuweckende Rechner ist nicht ein ausgeschaltetes Laptop/Notebook wo nur WLAN aktiviert war?

nur wenn ich das Magic-Packet per WLAN absende kommt es nicht bei dem gewünschten Rechner an. Per LAN funktioniert das ohne Probleme!
Das lässt evtl. darauf schliessen das zwischen deinem LAN und WLAN geroutet wird. WOL ist nicht Routing fähig und wird als Broadcast sowieso geblockt (sollte zumindest so sein). Wenn allerdings dein WLAN und LAN im gleichen Netz liegen und somit nicht geroutet werden muss, muss es auch funktionieren. Wireshark sagt es dir genau was da passiert (notfalls Portmirror nutzen um an die Daten zu kommen)

Gruß,
Peter
Bitte warten ..
Mitglied: MrNetman
28.02.2013 um 15:34 Uhr
Aber villeicht gibst du uns ja auch mehr Infos.

Netz, Netzstruktur, IP von LAN und WLAN und Ziel-LAN - der Lnksys kann ja ein bisschen was.... Oder hast du das Cisco Connect tool zum Einrichten verwendet, statt dich mit der Weboberfläche rum zu plagen.
Welches Tool nutzt du zum Abschicken des Magic Packets?
Und was sagt der Wireshark auf der LAN und WLAN Schnittstelle?

GRuß
Netman
Bitte warten ..
Mitglied: enJOyIT
28.02.2013 um 17:15 Uhr
Hallo,

Alle beteiligten Rechner sind im gleichen lokalen Netz.
Wireshark zeigt mir, dass kein Magic Packet ankommt (UDP Port 7 sollte es sein)

Hab den Router natürlich manuell eingerichtet, komme aus der Branche, aber dieses Verhalten ist mir bis dato noch nicht untergekommen.

Tools habe ich jetzt schon 4 verschiedene benutzt, liegt aber mit Sicherheit nicht an der Software, da das absenden des Pakets über LAN funktioniert.

Der aufzuweckende Rechner ist per LAN angeschlossen, der der aufwecken soll per WLAN.

Danke für eure Unterstützung!
Bitte warten ..
Mitglied: MrNetman
28.02.2013 um 17:28 Uhr
Wer sendet das Paket und wer soll es bekommen?
Das hast du uns immer noch nicht verraten.
Wo du schon vermutest, dass es nicht ankommt, solltest du auch checken ob es abgeht.
Bitte warten ..
Mitglied: enJOyIT
28.02.2013, aktualisiert um 17:43 Uhr
Ich habe doch schon ein paar mal geschrieben:

Sender: WLAN

Empfänger: LAN

Oder was möchtest du wissen?

Und ich habe doch per Wireshark probiert ob das Paket ankommt und das tut es nicht!
Bitte warten ..
Mitglied: MrNetman
28.02.2013, aktualisiert um 19:28 Uhr
So was wie oben: OS, NIC, und Verschlüsselung, IPs ...
Oder antwortest du du auf die Frage nach deinem Auto:"Vier Reifen sind dran"
Wireshark am Sender. Am Empfänger wirst ja wohl nichts sehen, der pennt ja. Oder irre ich mich - WOL

Kannst die Teilnehmer pingen und schon tracert gemacht?
Bitte warten ..
Mitglied: enJOyIT
28.02.2013, aktualisiert um 19:44 Uhr
Die Rechner hängen am Router und sonst ist nichts dazwischen - tracert liefert folgerichtig einen Abschnitt.

Wireshark habe ich am Empfängerechner laufen wenn er an ist, um halt zu sehen ob dort auf UDP etwas ankommt. Was aber nicht der Fall ist, weil am Senderechner laut Wireshark auch nichts abgesetzt wird - Wieso auch immer!?

IPs:

192.168.2.1 - Router

192.168.2.10 - Senderechner

192.168.2.164 - Empfangsrechner

Verschlüsselung: WPA2

Anpingen funktioniert. Das einzige was nicht über WLAN geht, ist das senden des Magic Packet.
Bitte warten ..
Mitglied: Pjordorf
28.02.2013 um 21:05 Uhr
Hallo,

Zitat von enJOyIT:
Wireshark habe ich am Empfängerechner laufen
Ok, der zeigt in Wireshark aber nur das bei ihm nichts ankommt. Das sagt nichts aus über dem Versenden ...

um halt zu sehen ob dort auf UDP etwas ankommt. Was aber nicht der Fall ist
Sowiet stimmt dir hier jede Bedingungslos zu, aber jetzt kommt dein
weil am Senderechner laut Wireshark auch nichts abgesetzt wird
und du verwirrst uns. Warum suche ich am Empfänger wenn ich schon weiß das der Sender gar nicht sendet? Du hast am WLAN Client tatsächlich per Wireshark festgestellt das dort schon nichts raus geht? Oder ist das deine Vermutung? Wenn dort nichst raus geht, ist entweder die Software zu Blöd dazu (Glaub ich wiederrum nicht) oder die Firewall blocked ausgehende Pakete oder du hast ein anderes Problem am WLAN Client. Da wir annehmen dürfen (oder auch nicht) das du auf der Sendeseite ebenfalls ein Windows 7 einsetzt würde ich mir mal die Firewall ansehen falls dort tatsächlich nichts gesendet wird. Sonst bleibt nur dein Linksys übrig der filtert und wegschmekßt bzw. blocked. Aber dein linksys hat ja kein log, oder?

- Wieso auch immer!?
Wir vermuten, aber du nicht Antworten auf gestellte Fragen.

Das einzige was nicht über WLAN geht, ist das senden des Magic Packet.
Sagt das PICNIC.

Ich sage dir auch ein WOL per WLAN absetzen funktioniert problemlos. Wireshark kann auch WLAN Interfaces.

Schließe aus was es nicht ist und du hast deinen Fehler.

Gruß,
Peter
Bitte warten ..
Mitglied: enJOyIT
28.02.2013 um 21:12 Uhr
Ich habe am Empfängerrechner und Senderrechner Wireshark installiert weil ich eben genau sehen wollte was wo und wie abgesetzt wird und ankommt, per LAN und WLAN.

Und da WOL per LAN geht ist es eigentlich unerheblich was am Zielsystem existiert, da es ja bereits positiv per LAN am Senderechner getestet wurde.

Firewalls habe ich ausgestellt, gleiches Problem. Es kann eigentlich nur daran liegen, dass der Linksys WLAN anders behandelt als das LAN. Hier ist dann die Frage wo kann ich das verändern?

Welche Fragen soll ich noch beantworten? Ich sehe keine weiteren relevanten Fragen mehr.
Bitte warten ..
Mitglied: MrNetman
28.02.2013 um 23:56 Uhr
WLAN und LAN unterscheiden sich immer. Wenn auch innerhalb der Ethernet-Pakete nicht so dramatisch.
Deshalb fragen wir ja nach Wireshark für WLAN.
Und du sagst, dass nichts rausgeht. Da brauchst du doch am Linksys nicht zu suchen, oder?

Gruß
Netman
Bitte warten ..
Mitglied: enJOyIT
01.03.2013 um 09:08 Uhr
Hallo,

da hast du natürlich Recht! Nur wundert mich, dass auch per Android-Smartphone im WLAN auch kein WOL funktioniert (wobei ich das nicht als Maßstab nehme sondern als zusätzlichen Test) - Das würde dann ja wiederum auf den Router deuten.

Ein ähnliches Problem scheint ja schon einmal jemand gehabt zu haben: Die Lösung scheint dort auch noch auszustehen :/
Hier der Link: http://www.administrator.de/forum/wake-on-lan-magic-packet-%C3%BCber-wl ...

Danke für eure bisherigen Bemühungen!

gruß
enJOyIT
Bitte warten ..
Mitglied: Pjordorf
01.03.2013 um 20:44 Uhr
Hallo,

Zitat von enJOyIT:
Nur wundert mich, dass auch per Android-Smartphone im WLAN auch kein WOL funktioniert
Es ist normalerweise nicht das WLAN was hier blockiert!

auf den Router deuten.
Möglich.

Ein ähnliches Problem scheint ja schon einmal jemand gehabt zu haben
Viele haben ein Problem ein WOL zum laufen zu bringen. Bei vielen geht es und bei anderen nicht

Ich habe mal ein Windows 7 64 Bit als WLAN Client genommen der ein LAN Client mit Windows 8 per WOL aufwecken soll. Das Aufwecken des LAN Clients hat ein paar Jahre problemlos funktioniert, bis jetzt. Huch, was ist da Los. Einzige Änderung letzte Woche - Windows 8 Pro (64) per Upgrade vom Windows 7 Pro(64). Sollten die LAN Karten Einstellungen ... Ja, auch die waren es, sowie die neuen Stromsparmodi des Windows 8. Siehe auch http://support.microsoft.com/kb/2776718 und http://www.pendlebury.biz/win8-wol. Nur bei Ruhezustand und Energiesparen funktioniert ein WOL mit Windows 8 jetzt noch. Alles andere (ob mit oder ohne Schnellstart (was noch andere Probleme hat)) schaltet die LAN Karte rigoros ab. Kein Strom, kein WOL. Nachdem diese Hürde beseitigt war konnte der LAN Client problemlos wieder per WOL eingeschaltet gestartet werden. Wichtig ist natürlich das im BIOS sowie in Windows die Einstellungen für das Aufwecken per WOL eingestellt ist weil sonst geht es einfach nicht. Erkennbar ist dies am Switchport das dort bei einem Windows 7 ausgeschalteten PC oder ein Windows 8 im Ruhezustand oder Energiesparmodus noch ein Link existiert.

Zum einen habe ich per Kommandozeile mit dem Wol.exe von Greg Wittmeyer per UDP Port 12287 sowie mit dem Wol.exe als GUI von Marcus Hottenrott (habe mir dies 2005 gezogen) per UDP Port 80 getestet. Zum Aufwecken diente ein Windows 7 64 Bit Client der per WLAN im Netz hing (kein Routing). Als Access Point wurde unter anderem ein Allnet, Level-One, Conceptronic, FritzBox und ein Gigaset verwendet. Es passierte nicht einmal das der LAN Client sich nicht per WLAN und WOL aufwecken lies. Es funktionierte zu 100%.

Per Wireshark wurde auf den Aufwecker Client per WLAN sowie auf einen am Switch angeschlossen Windows 8 64 Bit Client (Switch Port Mirroring vorher gesetzt um auch den Port des aufzuweckenden LAN Clients beobachten zu können) gleichzeitig per Capture Filter
udp port 9 or udp port 80 or udp port 12287
aufgezeichnet bzw. geschaut.

c3fff9f3a113151ff0326baf2c2ea69a - Klicke auf das Bild, um es zu vergrößern
WOL sent CMD Greg Wittmeyer

2bc29317f3f38653b45c480e27722edc - Klicke auf das Bild, um es zu vergrößern
WOL sent GUI Marcus Hottenrott

26f995b7e7123acbd445d08433548b50 - Klicke auf das Bild, um es zu vergrößern
WOL sent WLAN UDP Port 80

379f1d824317c4ab556ae16def7f049e - Klicke auf das Bild, um es zu vergrößern
WOL sent WLAN UDP Port 12287

9f41fc7f272ec5e242151aac15c3e154 - Klicke auf das Bild, um es zu vergrößern
WOL Sent LAN from Switch to Client UDP Port 80

db4744d0aa417e4007cc10216ac99be0 - Klicke auf das Bild, um es zu vergrößern
WOL Sent LAN from Switch to Client UDP Port 12287

Nicht verwirren lassen, die beiden letzten zeigen den Datenverkehr vom Switchport zum LAN Client. Ein Beobachten am Client ist bein nicht laufendem OS schlecht möglich. Da reicht aber das Auge um zu sehen das er eingeschaltet wurde

@enJOyIT
Ich sehe keine Grund warum es bei dir nicht funktionieren soll den LAN Client per WLAN und WOL aufzuwecken.

Gruß,
Peter
Bitte warten ..
Mitglied: enJOyIT
02.03.2013, aktualisiert um 15:25 Uhr
Hallo Peter,

vielen Dank für deinen ausführlichen Bericht, ich werde das morgen früh mal durcharbeiten.

Gruß
enJOyIT

Randinfo: Mein aufzuweckender Rechner ist ein Windows Server 2012.

Edit:

Ich habe es gerade getestet so wie du es beschrieben hast. Und ich denke ich habe den Fehler gefunden... Und zwar schicken alle WOL-Programme ihre Pakete über den falschen Netzwerkadapter! Und zwar über den internen virtuellen (von VirtualBox) LAN-Anschluss anstelle des WLAN-NIC.

Gibt es eine Möglichkeit den Programmen zu sagen über welche NIC diese senden?

Vielen Dank!

Edit2:

Habe es nun hinbekommen indem ich den virtuellen LAN-Anschluss deaktiviert habe.

Danke euch soweit!
Bitte warten ..
Mitglied: aqui
02.03.2013 um 18:37 Uhr
Mit der Bindungsreihenfolge klappt es auch. Eigentlich sollte ein All Net Broacast an alle Segmente gesendet werden aber das ist vermutlich ein Bug in der WoL Software.

Wenns nun klappt und es das war bitte dann auch
http://www.administrator.de/faq/32
nich vergessen !
Bitte warten ..
Mitglied: MrNetman
03.03.2013 um 00:37 Uhr
und vor zwei Tagen haben wir dich gebeten, nein aufgefordert die WLAN Schnittstelle mit dem Wireshark zu prüfen.
Bitte warten ..
Mitglied: enJOyIT
03.03.2013, aktualisiert um 01:30 Uhr
Ich möchte gerne einmal wissen was eigentlich genau dein Problem ist?

Erstens habe ich auch vor ein paar Tagen die entsprechenden Sachen mit wireshark überwacht und auch mitgeteilt, dass von dem WLAN Client kein Paket rausgeht.

Und zweitens behandelst du die ganze Zeit schon so als ob ich der allerletzte DAU bin, der von Tuten und Blasen keine Ahnung hat. Und das ist mitnichten so!
Bitte warten ..
Mitglied: aqui
03.03.2013 um 14:57 Uhr
Wie geht denn "tuten" ???
Bitte warten ..
Mitglied: enJOyIT
03.03.2013 um 15:05 Uhr
Vielleicht solltest du dich einfach mal mit der deutschen Sprache und den zugehörigen Sprichwörtern befassen.

Das ist mir jetzt zu blöd hier...
Bitte warten ..
Mitglied: hmarkus
04.03.2013, aktualisiert um 10:25 Uhr
Guten Morgen zusammen,

ich habe es gerade getestet so wie du es beschrieben hast. Und ich denke ich habe den Fehler gefunden... Und zwar schicken alle WOL-Programme ihre Pakete über den falschen Netzwerkadapter! Und zwar über den internen virtuellen (von VirtualBox) LAN-Anschluss anstelle des WLAN-NIC

ich habe auch mehrere Schnittstellen, intern Wlan, extern eine UMTS-Verbindung. Das WOL-Paket soll an meinen Server 192.168.98.10 gehen. Seit ich die zusätzliche UMTS-Verbindung habe, ist es erforderlich, wol mitzuteilen, in welches Netz das Paket gesendet werden soll. Mit anderen Worten:
früher (nur ein Adapter)
wol 90:e6:ba:c9:xx:xx
mit der zusätzlichen ppp0 Schnittstelle braucht es dagegen
wol --ipaddr=192.168.98.0 90:e6:ba:c9:xx:xx
die IP-Adresse des Subnetzes! wobei es dann egal ist ob wlan0 oder eth0 benutzt wird.

Betriebssysteme Linux auf allen Rechnern, das funktioniert einwandfrei. Mein Router ist eine uralte Fritzbox.

Markus
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Router & Routing
Cisco IPSEC VPN - Magic Packet (WOL) - ip helper-address (4)

Frage von Bernhard-B zum Thema Router & Routing ...

LAN, WAN, Wireless
gelöst Wake on LAN funktioniert teilweise nicht (11)

Frage von DarkScabs zum Thema LAN, WAN, Wireless ...

Microsoft
Server 2012 Wake on Lan Pakete an alle Geräte im DHCP Lease senden (1)

Frage von thomasreischer zum Thema Microsoft ...

LAN, WAN, Wireless
gelöst Windows 10 - Wake on Lan Problem (4)

Frage von Jannis92 zum Thema LAN, WAN, Wireless ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (14)

Frage von liquidbase zum Thema Windows Update ...