Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

WD20EARS 2TB - langsame Schreib- und Lese-Geschwindigkeit

Frage Hardware Festplatten, SSD, Raid

Mitglied: 92692

92692 (Level 1)

04.10.2010 um 15:25 Uhr, 8597 Aufrufe, 19 Kommentare

Guten Tag zusammen,

Ich habe mir letzte Woche 2 neue Festplatten (WD20EARS 2TB) gekauft und habe nun das Problem, dass ich sehr langsame Schreib- und Lesegeschwindigkeiten habe.
Mir ist bewusst, dass die Platten mit dem Advanced Format (4k Blöcke) ausgeliefert werden, allerdings habe ich schon sämtliche Foren nach einer Lösung durchforstet.

Windows 7 mit der Standardformatierung hat nicht geholfen.
Mit einer Linux Live-CD (GRML) habe ich dann versucht per fdisk eine ntfs-Partition mit dem Startsektor 64 anstelle des defaults von 63 zu erstellen. Auch hier bleibt die Transferrate bei etwa 20MB/s.

Woran kann das liegen, hat jemand eine Idee?

Vielen Dank im Voraus.
Mitglied: Pjordorf
04.10.2010 um 15:33 Uhr
Hallo,

Zitat von 92692:
Woran kann das liegen, hat jemand eine Idee?
Deine CPU ist leider zu langsam dafür. Und 20 MB/s. Was ist das? Lesen / Schreiben oder nur Lesen oder nur Schreiben?

Peter
Bitte warten ..
Mitglied: SamvanRatt
04.10.2010 um 15:35 Uhr
Hi
schau dir mal die SMART Werte an; vermute du hast schon eine 670GB Plater im Einsatz; da ist der Durchsatz nicht so prickelnd (rund 60-95MB/s). Sofern die Smartwerte sich verändern geht die Fehlerkorrektur ran, was den Durchsatz auf wenige Prozent drücken kann; leider erkennt gerade die WD Diag Software diesen Fehler nicht und liefert ein klares OK ab; wenn du mit dd liest was bekommst du dann? Hast du mit dem WD Tool schon mal auf 512B/Sek umgeschalten? Die Transferrate sollte meiner Erfahrung nach (hatte erst ein paar WDs zum Datenretten hier) keinen schlechten Einfluß auf die Leserate haben. Mit RAID Controllern mit 4kB/Sek hatte ich bis auf das fehlschlagen nahezu aller meiner Datenrettunsgsoftware keine schlechten Erfahrungen, allerdings würde ich Image/chkdsk/Defrag/Compressionsprogramme nicht an die HD lassen. Neue Techniken brauchen gerade bei M$ lange bis sie funktionieren.
Das Precomp deiner Partition ist eher ein Cache Thrashing vermeider; bringt nur bedingt mehr Performance und kommt eher im SSD und RAID Einsatz zum tragen
Gruß
Sam
Bitte warten ..
Mitglied: cardisch
04.10.2010 um 15:40 Uhr
ich hatte/Habe die 1TB Variante (und XP) im Einsatz,.,,
Wenn du die als 2. Platte im System hast (ohne betriebssystem drauf) oder mindestens Windows Vista installiert hast, sollte das alles kein Problem sein (angeblich).
Ansonsten müsstest du mal bei WD anch dem Programm advanced Format gucken, dieses Acronis Programm verschiebt dir die Partition schon an die richtige STelle.


Gruß

Carsten
Bitte warten ..
Mitglied: 92692
04.10.2010 um 16:09 Uhr
ich beschreibe nochmal genau meine vorgehensweise (LINUX):

fdisk -u /dev/sda

Command (m for help): n
Command action
e extended
p primary partition (1-4)
p
Partition number (1-4): 1
First sector (63-3907029167, default 63): 64
Last sector, +sectors or +size{K,M,G} (64-3907029167, default 3907029167):
Using default value 3907029167

Command (m for help): w
The partition table has been altered!

Calling ioctl() to re-read partition table.
Syncing disks.

mkntfs -f /dev/sda1
Cluster size has been automatically set to 4096 bytes.
Creating NTFS volume structures.
mkntfs completed successfully. Have a nice day.

Anschließend habe ich die Partition mit ntfs-3g gemountet und folgende Befehle zum Testen der Geschwindigkeit genutzt:

Schreiben:
time dd if=/dev/zero of=/media/backup/test bs=1M count=2048
2048+0 records in
2048+0 records out
2147483648 bytes (2.1 GB) copied, 71.6897 s, 30.0 MB/s
dd if=/dev/zero of=/media/backup/test bs=1M count=2048 0.02s user 10.24s system 14% cpu 1:11.70 total

Lesen:
time dd if=/media/backup/test of=/dev/null
4194304+0 records in
4194304+0 records out
2147483648 bytes (2.1 GB) copied, 65.9517 s, 32.6 MB/s
dd if=/media/backup/test of=/dev/null 2.89s user 8.89s system 17% cpu 1:06.09 total


hdparm liefert folgenden Lesewert zurück:
hdparm -tT /dev/sda1

/dev/sda1:
Timing cached reads: 978 MB in 2.00 seconds = 488.32 MB/sec
Timing buffered disk reads: 94 MB in 3.04 seconds = 30.90 MB/sec

Die genaue Modellbezeichnung meiner Platten lautet: WD20EARS-00MVWB0
@SamvanRatt: es ist die 3 Platter Version, wie du schon sagtest.
und die Platten sollen als Backup genutzt werden (kein Betriebssystem!)
Bitte warten ..
Mitglied: SamvanRatt
04.10.2010 um 18:08 Uhr
Dann probier mal ein time dd if=/dev/sda of=/dev/null bs=1M count=2048
damit siehst du den Dursatz beim lesen ohne den NTFS Overhead (linux kommt mit NTFS nur via reverse Eng zurande; kein gutes Umfeld). Unter Windows wäre hdtune so in der ungefähren Lage das zu beurteilen.
Linux tut sich generell schwer mit allem was nicht 512B/Sec ist. Das hängt zwar stark vom Kernel ab aber nahezu alle Vorgaben gehen direkt immer auf den "standard" ab. Deins Tests sind aber schon recht genau; nur umgehe mal das Thema NTFS unter Linux
Gruß
Sam
Bitte warten ..
Mitglied: 92692
04.10.2010 um 20:59 Uhr
@SamvanRatt:

ich habe jetzt ein EXT3 System auf der Platte installiert und den von dir genannten Befehl nocheinmal ausgeführt. Leider musste ich feststellen, dass auch hier nur eine Transferrate von 32,5MB/s erreicht werden kann.

Das widerlegt dann nun auch die Aussage bzgl. Linux und NTFS.

Die Blocksize und Fragmentsize hat das Programm mkfs.ext2 -j automatisch auf 4096 gestellt, sprich er hat denke ich mal das Advanced Format der Platte sowie den Start von Sektor 64 erkannt, oder?

Ich bin kurz davor die Platte an den Hersteller zurückzuschicken und ggf. die WD20EADS zu bestellen.

Aber so einfach werde ich auch nicht aufgeben, bitte um weitere Geistesblitze und Lösungsansätze! =)
Bitte warten ..
Mitglied: SamvanRatt
04.10.2010 um 22:23 Uhr
Hi
hast du mit smartctl mal die Smartwerte ausgelesen; das sieht für mich entweder nach einem Protokollfehler oder eben Lese/Schreibfehlern aus. Letzteres ist auf jeden Fall zu reklamieren. Da ich hier intern 120 2TB WD2002FYPS im Einsatz habe wovon im okt 2009 bereits die ersten 20 nach etwa 1 Monat hin waren (mittlerweile nur noch 3-4 im Monat), scheint die Endkontrolle da einiges verbessern zu müssen; von den LowEnd Serien habe ich genug zum Datenretten hier. Danach kommt gleich Samsung..
Die Sektorsize sollte richtig ausgelesen sein; dein Versuch dem Memory Thrashing entgegen zu wirken ist bei 512B/S sinnvoll, bei den 4k Blöcken dürfte das nicht mehr kritisch sein, trotzdem schaden binäre Startbereiche (2/4/8/...) nicht.
Gruß
Sam
Bitte warten ..
Mitglied: Florian.Sauber
05.10.2010 um 02:18 Uhr
Hallo!

Probier mal Blocksize mit deutlich jenseits der 1MB beim Schreiben. 2TB-Platten mit 4k Blöcken haben durch ihre 512B-Emulation so ihre Leistungs-Probleme mit "kleinen" Dateien. (siehe auch selbigen unrar-test)

Generell sollten die WD Advanced Format Drives unter Windows XP/Vista mit dem WD Align Utility genutzt werden. Vollen Durchsatz ist aber wohl nur unter Win7/MacOX zu erwarten, darauf sind sie ja auch zugeschnitten.

Bei Linux hast Du ja schon drauf geachtet, dass der erste Sektor bei einem vielfachen von 512 liegt. WD rät als Alternative zu Sektor 64 den Sektor 2048 und gibt an, dass AFD erst ab Kernel 2.6.34 unterstüzt wird.
Weitere Informationen liefert
Aber das hast Du sicherlich schon selbst gefunden.

LG Florian
Bitte warten ..
Mitglied: 92692
05.10.2010 um 08:19 Uhr
@SamvanRatt:
ich werde heute Abend mal die S.M.A.R.T. Werte auslesen und euch hier mitteilen, klingt ja nicht so berauschend, was deine Erfahrungen mit WD angehen...

@Florian.Sauber:
ich werde heute Abend dann auch nochmal den Startsektor 2048 ausprobieren. Ich nutze allerdings weder XP, noch Vista. Betreffende Betriebssysteme wären fast ausschließlich UNIX/Linux Systeme und ggf. Windows 7.

PS: Bei Windows 7 habe ich das Phänomen, dass er beim Schreiben mit einer Geschwindigkeit von 100MB/s beginnt und dann relativ zügig auf 20-30MB/s sinkt. Aber ich vermute, dass dies auf die schlechte Berechnung von Windows-Betriebssystemen zurückzuführen ist. Das war für mich der ausschlaggebende Punkt die Platte mit Linux (GRML Live-CD) zu bearbeiten
- ich nutze die aktuellste GRML-Version mit dem Kernel 2.6.33, vielleicht liegt es wirklich daran, ich werde ggf. heute Abend nochmal einen aktuelleren Kernel und auch statt fdisk das Programm parted nutzen.
Bitte warten ..
Mitglied: cardisch
05.10.2010 um 09:26 Uhr
Es kommt auch darauf an WAS du WOHIN kopierst..
Ein 9 GB Image ist schneller kopiert als 9 GB an Office Daten.
Und wenn du das noch von einer auf die nächste Partition derselben Platte kopierst sollte es zwar schneller sein, aber der Teufel steckt im Detail.

Leiser hast du (oder ich habe es nicht gesehen) nicht erwähnt, wie du vorgehst (Linux scheidet für mich persönlich aus, da ich dort viel zu wenig Ahnung habe)

Gruß

Carsten
Bitte warten ..
Mitglied: SamvanRatt
05.10.2010 um 09:39 Uhr
Hi
die Erfahrung sind auch mit anderen Herstellern gleich (ich lebe zum großen Teil von Datenrettung), WD und Samsung sind halt seit JAhren bekannt dafür, wobei da eher Bad Blocks oder Vollversager hervorstechen, als dein Problem (unendliche Retries, Hänger durch Controller resets, ...). Die ganzen 1.5+2TB Serien sind nicht mehr die Qualität von den 1TB und drunter (und das heißt schon was wenn man die SGT 7200.11 Serie ansieht und einberechnet). Durch RAID Sicherheit habe ich keine großen Kopfzerbrechen damit aber ich habe täglich verzweifelte vor mir sitzen bei denen es um wichtige Firmendokumente geht und Archivierung ein Fremdwort; meist sind es ja Privatpersonen. Es gilt auch hier: man bekommt was man bezahlt. Was auch nicht heißt das die WD2002FYPS mit ihren 220EUR für 2TB viel besser ist als die WD2001FASS für 140EUR oder gar deine WD20EARS. Nur mit den unüblichen Sektorsizes bin ich nicht kompatibel, daher kann ich bis dato nur via Images arbeiten was immer ein zusätzlicher Schritt ist. Ein simpler RMA Tausch sollte dein Problem lösen. An den Settings wirst du sicher keinen Faktor 2-3 rausholen.
Gruß
Sam
Bitte warten ..
Mitglied: SamvanRatt
05.10.2010 um 09:43 Uhr
Hi Carsten
ein dd ist schon ein idealer sequentieller Lesevorgang; die dort erreichten 32MB/s sind gegenüber meiner 4plater WD2002FYPS mit 116-73MB/s schon ein grober Unterschied.
Gruß
Sam
Bitte warten ..
Mitglied: 92692
05.10.2010 um 10:06 Uhr
Hallo Carsten,
ich habe bei meinen Windows 7 Tests sowohl Office-Dateien als auch ~700MB ISO-Files kopiert/verschoben, sowohl von einer anderen auf die neue Platte und andersrum. Die Transferraten lagen im Schnitt bei 25-30MB/s.

Das Problem tritt also betriebssystemunabhängig auf. Danke aber für den Tipp.
Bitte warten ..
Mitglied: Florian.Sauber
05.10.2010 um 11:39 Uhr
Nachdem Du gechrieben hast, unter Win7 seien es auch allenfalls 30 MB/s, sehe ich das genauso, wie SamvanRatt: Schick sie ein oder ab zum Händler!.
Selbst beim Kopieren von Dateien <3MB erzielt die Platte unter Win7 normalerweise gut das Doppelte.

Grüße Florian
Bitte warten ..
Mitglied: 92692
05.10.2010 um 20:44 Uhr
Ich habe mir jetzt mal die SMART Werte angesehen und dort ist nichts auffälliges zu sehen. Kann sie leider nicht posten, da ich grad keine Möglichkeit hatte die Tabelle hier einzufügen (anderes System). Aber da ich solche Tabellen öfters überprüfe kann ich mit Gewissheit sagen, dass dort alles in Ordnung ist.

Ich habe den Startsektor auch testweise mal auf 2048 gesetzt und noch einige Male mit Windows und Linux getauscht. GPT und MBR in allen Variationen formatiert und mit Daten beschrieben... kein Erfolg.

So langsam glaube ich, dass die Platten wirklich nicht mehr als 30MB/s schaffen. Ich habe ja 2 davon gekauft und beide weisen die gleiche Problematik auf.

Ich habe beim Versandhaus im technischen Support heute nochmal angerufen, aber da sprach zu mir die Kompetenz in Person... ich solle doch die Festplattentreiber für das Mainboard installieren... -.-

Naja, kann mir denn wenigstens jemand ne vernünftige 2TB Platte (wenn möglich ohne Advanced Format) für den gleichen Preis von etwa 90€ empfehlen? Würde mich jetzt spontan für die EADS Version entscheiden, allerdings haben die mit dieser Platte momentan Lieferschwierigkeiten.

Ich bedanke mich dennoch für die gut gemeinten Tipps und Ratschläge.

Beste Grüße

Daniel
Bitte warten ..
Mitglied: SamvanRatt
05.10.2010 um 21:14 Uhr
Hi
deine hatte ich bisher weder Privat noch in der Firma zur Hand (zu mir kommt man ja meist wegen der Daten, aber teure HDs werden lieber gerettet als billige). Mit den 2001FASS kann ich gutes berichten; durchaus min 70MB/s seq. Datenrate und mit 115IOPS auch recht performant. Trotzdem kann ich mir beim besten willen nicht vorstellen das eine HD nur 40MB/s schafft (und da kommt deine ja nicht mal hin). Das Dauerparken deiner Köpfe ist lt WD Forum bei deiner nicht mehr aktiv, sonst würde ich die Unterbrecher(=Einbrüche) verstehen, aber das würde man auch deutlich hören). Dein SATA läuft sofern möglich im AHCI oder IRRT Modus oder? Im IDE sollte er aber auch nur rund 10-20% verlieren aber spätestens bei 125MB/s abregeln (das ist recht spaßig bei meinen Velociraptors zu sehen). Die FASS kann ich dir für rund 140EUR inkl besorgen, liegt aber überhalb deiner Preisschiene. Die 4k HDs sind wegen ihrer weitreichenden Fehlerkorrekturen (mehr Netto pro Brutto) billiger als die 512Byter.
Gruß
Sam
Bitte warten ..
Mitglied: 92692
05.10.2010 um 21:34 Uhr
Hi Sam,
ich habe jetzt nocheinmal die Platte in meinen Windows 7 PC zu Hause eingebaut und mit HDTune gemessen... und siehe da, wie durch ein Wunder funktionierts plötzlich...

http://img822.imageshack.us/img822/7476/wd20earss.png

So sollte das aussehen oder?
Bitte warten ..
Mitglied: SamvanRatt
05.10.2010 um 21:49 Uhr
Hi
die Werte klingen auch normal für die HD (5k4, 3plater); da ich deinen Testparcour nicht kenne solltest du mal verschiedene Rechner ausprobieren. Winxy ist eigentlich nicht so wechselmütig was die Konfig angeht; dem Linux Kernel ist das sowieso schnuppe. Da hat man eher Probleme wenn man ein superaktuelles Board mit einem stable Branch zum (überhaupt) laufen bringen will
Gruß
Sam
Bitte warten ..
Mitglied: 92692
05.10.2010 um 21:54 Uhr
alles klar..

Danke an alle Beteiligten und besonderen Dank an Sam für die große Mühe!

Damit ist werd ich den Beitrag als gelöst markieren.

Gute Nacht zusammen!

LG
Daniel
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(2)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Notebook & Zubehör
gelöst HP 8770W - LAN Netzwerkproblem (Aufbau, Geschwindigkeit) (7)

Frage von RiceManu zum Thema Notebook & Zubehör ...

Hyper-V
gelöst Sinnvolle HYPER-V Konfiguration max. Geschwindigkeit erreichen (32)

Frage von Andreas377 zum Thema Hyper-V ...

Windows Server
gelöst Freigabe führt nicht zur Schreib-Berechtigung (11)

Frage von ElmaCx zum Thema Windows Server ...

LAN, WAN, Wireless
Langsame Verbindung zu FRITZ!Box (1)

Frage von eQuest zum Thema LAN, WAN, Wireless ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...