Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

WDS - Windows Deployment Server - Probleme bei Abbilderstellung bzw. Aufzeichnung

Frage Microsoft Windows Server

Mitglied: StephanOL

StephanOL (Level 1) - Jetzt verbinden

16.01.2013, aktualisiert 17.01.2013, 1872 Aufrufe, 3 Kommentare

Hallo Zusammen,

vielen Dank für das Lesen meiner Frage ...

Ich möchte für unsere Firma einen WDS bereitstellen,
um damit neue Clients einfacher und schneller installieren zu können...

Als erstes habe ich eine Testumgebung erstellt:

- Server 2012
- inkl. AD DS, DHCP, DNS und WDS

Der WDS funktioniert soweit auch mit einem Installationsabbild, das von einer DVD (Win7 Enterprise x64) erstellt wurde.

Als Basis habe ich einen Referenz-Client mit einer Standard-Installation (Win7, Office, Browser, Virenscanner, Treiber und Windowsupdates) versorgt.

Nun möchte ich von dieser Installation ein Abbild erstellen:

-> Sysprep /oobe /generalize /shutdown
bzw.
-> Sysprep /oobe /generalize /unattend:Autounattend.xml /shutdown

Die unattend.xml habe ich mit dem AIK erstellt, sie wurde geprüft und scheint fehlerfrei.

Mit Hilfe des WDS zeichne ich nun ein Abbild auf, kopiere es auf den Server und füge es unter Installationsabbilder hinzu.

Nun zu meinem Problem:

Nach der Aufzeichnung befindet sich der Referenz-Client selbst
und auch das per WDS zurückgespielte Abbild in einer Schleife.

Der Rechner startet, Dienste werden gestartet, dann erscheint folgende Fehlermeldung:

"Die Konfiguration des Systems konnte nicht abgeschlossen werden.
Starten Sie den Computer neu, um die Konfiguration fortzusetzen."


UPDATE: Es laufen dann zwei Prozesse - 1. Windows installieren und 2. FirstUXWnd

Meine Vermutung - der Fehler liegt bei Sysprep.
Habe schon viel gelesen und probiert, komme aber irgendwie nicht weiter.

Hat jemand von Euch eine Idee?

Vielen Dank im Voraus.

Viele Grüße
Stephan
Mitglied: Xaero1982
16.01.2013 um 18:38 Uhr
Hi,

das ist nun Glaskugellesen.

Wie sieht die Unattend.xml aus?

Bitte in Code Tags posten.

Gruß
Bitte warten ..
Mitglied: StephanOL
17.01.2013 um 15:12 Uhr
Das Problem besteht aber auch, wenn keine unattend.xml verwendet wird...

Siehe auch das Update meiner Frage, Danke.

Anbei die gewünschte unattend.xml, die ich mit dem WSIM des AIK nach einer Anleitung aus dem TechNet erstellt habe:
01.
<?xml version="1.0" encoding="utf-8"?> 
02.
<unattend xmlns="urn:schemas-microsoft-com:unattend"> 
03.
    <settings pass="auditSystem"> 
04.
        <component name="Microsoft-Windows-Deployment" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> 
05.
            <Reseal> 
06.
                <Mode>Audit</Mode> 
07.
            </Reseal> 
08.
        </component> 
09.
    </settings> 
10.
    <settings pass="windowsPE"> 
11.
        <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> 
12.
            <SetupUILanguage> 
13.
                <UILanguage>de-de</UILanguage> 
14.
            </SetupUILanguage> 
15.
            <InputLocale>de-de</InputLocale> 
16.
            <SystemLocale>de-de</SystemLocale> 
17.
            <UILanguage>de-de</UILanguage> 
18.
            <UserLocale>de-de</UserLocale> 
19.
        </component> 
20.
        <component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> 
21.
            <DiskConfiguration> 
22.
                <Disk wcm:action="add"> 
23.
                    <CreatePartitions> 
24.
                        <CreatePartition wcm:action="add"> 
25.
                            <Size>414460000</Size> 
26.
                            <Order>2</Order> 
27.
                            <Extend>false</Extend> 
28.
                            <Type>Primary</Type> 
29.
                        </CreatePartition> 
30.
                        <CreatePartition wcm:action="add"> 
31.
                            <Size>51200000</Size> 
32.
                            <Order>3</Order> 
33.
                            <Type>Primary</Type> 
34.
                        </CreatePartition> 
35.
                        <CreatePartition wcm:action="add"> 
36.
                            <Order>1</Order> 
37.
                            <Size>300</Size> 
38.
                            <Type>Primary</Type> 
39.
                        </CreatePartition> 
40.
                    </CreatePartitions> 
41.
                    <ModifyPartitions> 
42.
                        <ModifyPartition wcm:action="add"> 
43.
                            <PartitionID>1</PartitionID> 
44.
                            <Label>System-reserviert</Label> 
45.
                            <Format>NTFS</Format> 
46.
                            <Order>1</Order> 
47.
                            <Active>true</Active> 
48.
                        </ModifyPartition> 
49.
                        <ModifyPartition wcm:action="add"> 
50.
                            <Letter>C</Letter> 
51.
                            <Label>System</Label> 
52.
                            <Format>NTFS</Format> 
53.
                            <PartitionID>2</PartitionID> 
54.
                            <Order>2</Order> 
55.
                        </ModifyPartition> 
56.
                        <ModifyPartition wcm:action="add"> 
57.
                            <Order>3</Order> 
58.
                            <PartitionID>3</PartitionID> 
59.
                            <Letter>D</Letter> 
60.
                            <Label>Daten</Label> 
61.
                            <Format>NTFS</Format> 
62.
                        </ModifyPartition> 
63.
                    </ModifyPartitions> 
64.
                    <DiskID>0</DiskID> 
65.
                    <WillWipeDisk>true</WillWipeDisk> 
66.
                </Disk> 
67.
            </DiskConfiguration> 
68.
            <ImageInstall> 
69.
                <OSImage> 
70.
                    <InstallTo> 
71.
                        <DiskID>0</DiskID> 
72.
                        <PartitionID>2</PartitionID> 
73.
                    </InstallTo> 
74.
                    <InstallToAvailablePartition>false</InstallToAvailablePartition> 
75.
                    <WillShowUI>OnError</WillShowUI> 
76.
                </OSImage> 
77.
            </ImageInstall> 
78.
            <UserData> 
79.
                <ProductKey> 
80.
                    <Key>XXXXX-XXXXX-XXXXX-XXXXX-XXXXX</Key> 
81.
                    <WillShowUI>OnError</WillShowUI> 
82.
                </ProductKey> 
83.
                <AcceptEula>true</AcceptEula> 
84.
            </UserData> 
85.
        </component> 
86.
    </settings> 
87.
    <settings pass="oobeSystem"> 
88.
        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> 
89.
            <OOBE> 
90.
                <HideEULAPage>true</HideEULAPage> 
91.
                <ProtectYourPC>3</ProtectYourPC> 
92.
            </OOBE> 
93.
        </component> 
94.
    </settings> 
95.
    <settings pass="specialize"> 
96.
        <component name="Microsoft-Windows-IE-InternetExplorer" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> 
97.
            <Home_Page>http://www.administrator.de</Home_Page> 
98.
        </component> 
99.
    </settings> 
100.
    <settings pass="generalize"> 
101.
        <component name="Microsoft-Windows-PnpSysprep" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> 
102.
            <PersistAllDeviceInstalls>true</PersistAllDeviceInstalls> 
103.
        </component> 
104.
    </settings> 
105.
    <cpi:offlineImage cpi:source="wim:c:/install.wim#Windows 7 ENTERPRISE" xmlns:cpi="urn:schemas-microsoft-com:cpi" /> 
106.
</unattend>
Bitte warten ..
Mitglied: Xaero1982
17.01.2013, aktualisiert um 21:52 Uhr
Hi,

was mir aufgefallen ist, ist dass ich in meiner xml die Partitionen komplett anders habe.

Ich habe ebenfalls W7 installiert damit und auch XP. Man muss diese System-Reserviert Partition nicht in der XML eintragen - die erstellt das Setup automatisch.

Ansonsten kann ich dir nur empfehlen die Windowsinstallation mal direkt im Auditmode durchzuführen. Bei der Installation von W7 drückst du im Fenster in dem du den Benutzernamen eingeben musst:

Ctrl+Shift+F3

Dann landest du im Auditmode und kannst da alles installieren.

Edit: Ich habe zwei xml.

Die eine ist für das Starten des WDS - dort habe ich auch die Partitionierung hinterlegt.
Die andere steuert das Setup ... Eula, etc. pp

Gruß
Bitte warten ..
Ähnliche Inhalte
Windows Server
Windows-File-Server - Macs - Probleme (5)

Frage von guenthergranate zum Thema Windows Server ...

Outlook & Mail
gelöst Outlook 2010 unter Windows 10 hat Probleme mit Exchange Server 2010 (3)

Frage von Speedflo zum Thema Outlook & Mail ...

Neue Wissensbeiträge
RedHat, CentOS, Fedora

Fedora, RedHat, Centos: DNS-Search Domain setzen

(13)

Tipp von Frank zum Thema RedHat, CentOS, Fedora ...

Drucker und Scanner

Samsung SL-M4025ND, firmware update und (kompatible) Tonerkassetten

(1)

Erfahrungsbericht von markus-1969 zum Thema Drucker und Scanner ...

Heiß diskutierte Inhalte
Batch & Shell
Skripterstellung Lehrling (22)

Frage von 133119 zum Thema Batch & Shell ...

Exchange Server
Microsoft Exchange Weiterleitung mit anderer primären E-Mail Adresse (14)

Frage von Rene12345 zum Thema Exchange Server ...

Windows Userverwaltung
gelöst Wie verfahrt Ihr mit den Windows-Benutzerkonten und -dateien von ausgeschiedenen Mitarbeitern? (14)

Frage von Bl0ckS1z3 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
Devolo DLAN 500 pro Wireless+ (13)

Frage von IceAge zum Thema LAN, WAN, Wireless ...