Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Webserver auf eignem Heim PC

Frage Microsoft Windows Server

Mitglied: wollemeet

wollemeet (Level 1) - Jetzt verbinden

24.01.2010 um 20:59 Uhr, 5927 Aufrufe, 8 Kommentare

Webserver mit IIS 6.0, PHP, MySQL

Nun habe ich mal eine Frage bevor ich noch mehr graue Haare bekomme.

Habe einen Rechner mit Windows Server 2003 Std, PHP, MySQL, Wordpress und IIS 6.0 laufen.
Zudem eine 16ner DSL von der Telekom einen Speedport 503 V mit einer "relativ" festen IP, eine regestrierte .de Domain.
Möchte nun die Domain für meinen Webserver verwenden. Nur mein Server hat nach dem Router seine priv. IP.
Wie kann ich denn jetzt dem DNS beim Provider meinen Webserver bekannt machen?
Muss ich da die IP vom Router angeben oder wie kann ich die priv. IP mit der WAN IP routen ?
Liegt es vielleicht auch an dem Speedport?? Der kann ja nicht besonders viel....

Komme hier nicht mehr weiter..
Mitglied: KennyNet
24.01.2010 um 21:16 Uhr
Hallo wollemeet,

generell würde ich Dir davon abraten die Homepage auf dem Homeserver zu betreiben, aus vielerlei Gründen. Dennoch möchte ich darauf nicht näher eingehen, da dieses Thema hier im Forum schon zur Genüge diskutiert wurde. Aber um Dein Problem zu lösen hast Du folgende Möglichkeit:

Die de-Domain ist zwar auf Dich registriert aber mit hoher Wahrscheinlichkeit dem Provider zugeordnet, worüber Du sie beantragt hast.
Dort hast Du normalerweise die Möglichkeit eine Weiterleitung einzurichten und trägst dort die WAN-IP ein, die der Router nach der Verbindung mit T-Online zugeteilt bekommen hat. Logischerweise wird das immer eine andere sein, denn sowas wie eine "relativ" feste IP gibt es nicht. *g* Die ersten beiden Segmente, also die IP-Range, wird meistens dieselbe sein, da jeder Provider bestimmte IP-Bereiche zugeteilt bekommen hat.
Darum wird das Dein Problem nicht lösen, denn spätestens alle 24 Std. müßtest Du diese WAN-IP im Konfigurationsmenü für die de-Domain manuell anpassen. Ich glaube kaum, daß Du das so gewollt hast.

Daher müßtest Du Dir entweder eine statische IP bei der Telekom geben lassen, was mit "relativ" hohen Kosten verbunden ist oder Du hättest Dir einfach nur eine freie statische IP bei einem dieser kostenlosen Anbieter, z.B. dyndns.org anmelden müssen. Sogar der Speedport kann das automatische Aktualisieren der IP bei dyndns.org übernehmen und Du hättest dieses Problem somit umgangen. Allerdings ist dann die de-Domain überflüssig.


Hoffe das hilft Dir erstmal weiter,....
Bitte warten ..
Mitglied: 62929
24.01.2010 um 21:39 Uhr
Hallo,

wie KennyNet schon sagt, am besten mit DynDNS zu lösen. Du lässt deine Domain dann auf die DynDNS-Domain zeigen.

Deine DynDNS Zugangsdaten kannst du auf dem Speedport eintragen, dann wird deine aktuelle (sich durch die Zwangstrennung immer ändernde) IP an DynDNS übertragen.

Jetzt musst du noch Port 80 an die interne IP des Servers forwarden.
Sollte so funktionieren.

Ich hoffe du weist, was du machst und klemmst noch eine vernünftige Firewall dazwischen.

Gruß
dante!
Bitte warten ..
Mitglied: datasearch
24.01.2010 um 22:05 Uhr
ACK

So würde es funktionieren. Ich persönlich hätte mir einem IIS am Internet schlaflose Nächte .
Bitte warten ..
Mitglied: EvilMoe
24.01.2010 um 22:09 Uhr
Falls du die möglichkeit hast bei deiner .de Domain Cnamen zu verwenden gibt es eine möglichkeit.

Du holst die von dyndns eine Adresse und richtest in deinem Router dyndns auf diese ein. Falls dein Router dies nicht unterstüzt gibt es dafür auch eine Software von dyndns.

Von deiner .de Domain setzt du nun den Cname auf die dyndns Domain. So würde es auch wenn etwas umständlich funktionieren.
Bitte warten ..
Mitglied: 62929
24.01.2010 um 22:10 Uhr
[OT]
Hehe, das ist schon wieder ne andre Sache. Ich bin auch lieber mit nem Indianer unterwegs
[/OT]
Bitte warten ..
Mitglied: wollemeet
25.01.2010 um 11:57 Uhr
Hallo KennyNet,

ja das mit dyndns hab ich auch schon überlegt, aber soweit ich das weiss ändert sich die IP nicht. Eine Trennung und Adressänderung hab ich noch nicht festgestellt. Wahrscheinlich liegt es daran, das die Telekom mittlerweile bei Entertain statische IP´s vergibt.
Ansonsten würde ich das über dyndns einstellen, da der Speedport den Service ja auch unterstützt. Ich hab das gerade mal großzügig weggeslassen..

So das Problem ist jetzt, dass die Domain (*.de) auf meinen Router zeigt, also auf die WAN IP und ich diese auch mit nslookup erreiche.
Mein Webserver hat die interne 192.168.2.4. Wie bekomme ich denn nun das ganze auf den Webserver? Also müsste ich doch irgendwie ein IP Forwarding vom Router zum Server machen, oder ?? Muss der Router das forwarding machen oder gibts da ne Möglichkeit das über den Server zu realisieren? Brauch ich noch einen DNS auf dem Webserver oder muss ich irgendwie mit RAS arbeiten?
Das Problem sind einfach nur die 2 IP´s eine interne und die WAN...bringt mir ja nichts das die Domain auf den Router zeigt, brauche ja den Webserver!

Dante schrieb das ich irgendwie nur den Port 80 forwarden soll, aber wo mach ich das? Der Speedport kann sowas glaub ich garnicht...


Danke schon mal für eure Hilfe!!

Grüße
Bitte warten ..
Mitglied: 62929
25.01.2010 um 12:11 Uhr
Moin,

Port Forwarding müsste eigentlich auch "ein Speedport" hinbekommen ;)
Schneller Schuss ins Blaue durch Google -> Punkt Netzwerk -> Punkt NAT&Portregeln.

Ansonsten schreib uns mal, welchen Speedport du genau hast.

Dort kannst du dann einfach Port 80 auf deine Webserver (LAN-)IP weiterleiten.

Gruß
dante!
Bitte warten ..
Mitglied: wollemeet
25.01.2010 um 14:11 Uhr
Hi Dante,

stimmt, der Speedport hat wirklich ein Port forwarding....
Das muss man aber erstmal finden....sch... Menue

Hab jetzt im Speedport auf den Webserver eingestellt, also den Port 80 weitergeleitet.
So dann müsste die Domain ja im Internet aufgelöst werden. So sollte er auch den WebServer finden.

Werde das ganze nochmal testen und mich mit dem IIS rumschlagen.

Vielen Dank erstmal!

Grüße
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Windows 7
Servergespeicherte Profile von 2 PC mischen (4)

Frage von sammy65 zum Thema Windows 7 ...

Grafikkarten & Monitore
PC startet, aber kein Bild (8)

Frage von Linuxguru zum Thema Grafikkarten & Monitore ...

Batch & Shell
gelöst PC nach einem Kopiervorgang herunterfahren - PowerShell Script? (4)

Frage von Stefan007 zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
Viren und Trojaner
gelöst Wie werde ich den Mist "fanli90" wieder los? (18)

Frage von Taumel zum Thema Viren und Trojaner ...

Switche und Hubs
LAG zwischen Cisco SG300 und Dlink DGS1100 herstellen - wie? (15)

Frage von White-Rabbit2 zum Thema Switche und Hubs ...

CPU, RAM, Mainboards
Hardware Fragen (12)

Frage von xaver-2 zum Thema CPU, RAM, Mainboards ...

Backup
gelöst Online-Dateiablage für Verein, mit mehrstufiger Sicherung? (11)

Frage von Demig0d zum Thema Backup ...