Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Frage Internet Server

GELÖST

Webserver über localhost, aber nicht über DynDNS erreichbar

Mitglied: Indianer87

Indianer87 (Level 1) - Jetzt verbinden

25.02.2010 um 10:49 Uhr, 9537 Aufrufe, 20 Kommentare

Hallo Leute,

bastel hier gerade an meinem ersten Webserver. Lokal läuft das Ding schon und kann ich auch über localhost ansprechen. Allerdings funktioniert es übe DynDNS noch nicht. Ich sitze hinter einem Speedport W 700V und habe dort auch die Ports 81 und 21 als Weiterleitung auf den Rechner (Win Server 2003) eingerichtet. Spreche ich ihn jetzt aber über meineseite.dyndns.org an, kriege ich auch nur den nichts-sagenden Fehler: Bad Request (Invalid Hostname). Hat jemand ne Ahnung, was ich noch vergessen habe?

Achja, DynDNS ist im Router auch eingestellt und die IP bei DynDNS wird auch immer brav aktualisiert! Und ein Ping auf die dyndns.org-adresse oder die IP funktioniert auch!


Schon mal Danke und Gruß

BJ
Mitglied: dave114
25.02.2010 um 10:51 Uhr
morgen,

ein Webserver reagiert normalerweise auf Port 80.

Versuch auch mal von einem anderen Rechner im Netzwerk auf den Webserver zuzugreifen.

mfg
David
Bitte warten ..
Mitglied: Indianer87
25.02.2010 um 10:56 Uhr
Meinte ich ja auch, Port 80 ist auch freigegeben!
Bitte warten ..
Mitglied: dave114
25.02.2010 um 11:00 Uhr
Versuch auch mal von einem anderen Rechner im Netzwerk auf den Webserver zuzugreifen.

und?
Bitte warten ..
Mitglied: Indianer87
25.02.2010 um 11:08 Uhr
Ne, da kriege ich auch ein Bad Request.. Also wenn ich versuche, den Server über die interne IP anzusprechen
Bitte warten ..
Mitglied: dave114
25.02.2010 um 11:11 Uhr
Ne, da kriege ich auch ein Bad Request.. Also wenn ich versuche, den Server über die interne IP anzusprechen

na das ist doch schonmal ne Aussage.

Lokal auf dem Server geht es aber wie du sagst?

Hast du mal die Firewall auf dem Server deaktiviert bzw. die Ports freigeschaltet?

Welchen Webserver verwendest du denn?
Bitte warten ..
Mitglied: Indianer87
25.02.2010 um 11:13 Uhr
Auf dem Server kann ich über localhost alle Dateien in dem Webserver-Ordner ansprechen!

Die Firewall sowohl auf dem Server als auch auf dem Router sind deaktiviert! Port 80 /Http) und 20 (ftp) sind auf dem speedport weitergeleitet an den server.

Das ist übrigens ein Windows Server 2003 mit IIS.
Bitte warten ..
Mitglied: dave114
25.02.2010 um 11:18 Uhr
Ich tippe auf Fehlkonfiguration des IIS. Da ich den jedoch bis jetzt nicht genutz habe und somit keine Erfahrung mit dem Ding habe kann ich dir dazu leider nichts sagen.

Mach mal nen Neustart des Server - vllt haben sich die Probleme dann gegessen.
Bitte warten ..
Mitglied: Indianer87
25.02.2010 um 11:25 Uhr
Trotzdem erstmal Danke!

Weiß jemand anderes Bescheid?
Bitte warten ..
Mitglied: Newton
25.02.2010 um 13:15 Uhr
Moin !

Ich sitze hinter einem Speedport W 700V und habe dort auch die Ports 81 und 21 als Weiterleitung auf den Rechner (Win Server 2003) eingerichtet.

Du willst sicher http und ftp selektiv ansprechen können.
Hast Du dazu die lokalen Ports auf zwei unterschiedliche remote-Ports gemappt bzw. die remote-Ports (TCP !) explizit angegeben ?
Z.B. so :

deineseite.dyndns.org:81 --> 192.168.xxx.yyy:80 (?)
deineseite.dyndns.org:21 --> 192.168.xxx.yyy:21 (jeweils local net addresse deines Win Servers)

Auch im browser ist dann natürlich (http://)deineseite.dyndns.org:81 abzurufen, ftp:// als Protokoll-Handle spricht automatisch mit remote port 21, da kann :21 weggelassen werden.
Aber vielleicht ist es das noch nicht, und in irgend'nem anderen Router-Setting wird eingehender TCP-Verkehr geblockt ?

Gruß,
== Newton ==
Bitte warten ..
Mitglied: Indianer87
25.02.2010 um 13:22 Uhr
Hi,

erstmal hatte ich mich oben vertan, meinte natürlich die Ports 80 (http) und 21(ftp) habe ich weitergeleitet. Selektiv will ich das eigentlich nicht machen. Mein Ziel ist es, durch meineseite.dyndns.org ganz normal die index.php anzusprechen, so wie es über localhost auf dem Server selbst auch funktioniert! Die Router-Settings habe ich eigentlich alle durch, da habe ich nichts mehr gefunden, was ich einstellen könnte..

Das Benutzerhandbuch:

http://www.t-home.de/dlp/eki/downloads/Speedport/Speedport_W700V/bedanl ...

Schon mal Danke!
Bitte warten ..
Mitglied: dave114
25.02.2010 um 13:26 Uhr
Dein Problem liegt erstmal nicht am Router sondern warscheinlich am IIS bzw. am WinServer selbst da du ja nicht mal aus dem lokalen Lan auf den Webserver zugreifen kannst.

Geht denn der FTP-Server?
Bitte warten ..
Mitglied: Indianer87
25.02.2010 um 13:30 Uhr
Auf dem Server kann ich über localhost:21 auch den FTP ansprechen. Aber der ist auch nur sekundär wichtig, wichtig ist erstmal, dass der Webserver funktioniert.

Das Problem bem IIS habe ich auch schon vermutet, allerdings weiß ich nicht, was ich da noch konfigurieren müsste...
Bitte warten ..
Mitglied: dave114
25.02.2010 um 13:37 Uhr
Kannst du von einem anderen Computer im Lan auf den FTP-Server zugreifen?
Bitte warten ..
Mitglied: Indianer87
25.02.2010 um 13:44 Uhr
Der FTP kann auch von anderen PC's im LAN über ftp://192.168.2.222:21 anegsprochen werden!
Bitte warten ..
Mitglied: dave114
25.02.2010 um 13:50 Uhr
Der FTP kann auch von anderen PC's im LAN über ftp://192.168.2.222:21 anegsprochen werden!

na das ist doch schonmal was

Muss es umbedingt der IIS als Webserver sein?

Vielleichtt guckst du dir mal den Apache Webserver an. (Ist der verbreiteste Webserver im Netz. - Hatte ihn auch mal ne Zeitlang auf nem WinServer2003 laufen und das ging damals ohne Probleme)
Bitte warten ..
Mitglied: Indianer87
25.02.2010 um 13:58 Uhr
Bin ja hier auf der Arbeit und wollte es einfach mit WinServer 2003 zum Laufen bringen, einen richtigen Nutzen hatte es nicht.

Aber jetzt funktioniert es endlich!!! Laut diverser Anleitungen im Netz, sollte man in den Eigenschaften des Servers im ISS unter "Identifikation der Webseite" einen TCP-Port und einen Hostheaderwert eingeben. Hatte da schon alles mögliche ausprobiert, u.a. auch meine dyndns-domain usw. Letztendlich habe ich einfach keinen Hostheaderwert eingegeben und auch keine IP zugewiesen, sondern lediglich Port 80 eingegeben und es funktioniert ;)

Aber trotzdem Danke für eure Hilfe! Denn ich bin auf die Idee gekommen, als ich FTP und HTTP-Server verglichen habe ;)

mfg
Bitte warten ..
Mitglied: dave114
25.02.2010 um 14:09 Uhr
na also geht doch

Hast du auch schon über die Dyn-DNS-Adresse die Server getestet?

Sollte das nicht funktionieren dann ist noch irgendwas in der Router-Config faul.
Bitte warten ..
Mitglied: Indianer87
25.02.2010 um 14:17 Uhr
Ja, es lag einzig und allein an dem Fehler da oben! Dyndns funktioniert jetzt einwandfrei!
Bitte warten ..
Mitglied: mrtux
25.02.2010 um 19:00 Uhr
Hi !

Zitat von Indianer87:
Die Firewall sowohl auf dem Server als auch auf dem Router sind deaktiviert!

Wie hast Du denn die Firewall im Router abgeschaltet?

mrtux
Bitte warten ..
Mitglied: dave114
25.02.2010 um 21:38 Uhr
morgen,

ja mrtux die Firewall im Router wird er wohl kaum ausgeschaltet haben - wie auch? Ich bezweifel das der komische Speedport das auch nur annähernd kann - Wäre ja auch Schwachsinn.

mfg
David
Bitte warten ..
Ähnliche Inhalte
Netzwerkmanagement
Localhost und 127.0.0.1 nicht erreichbar
Frage von Campino86Netzwerkmanagement13 Kommentare

Hallo, wir haben einen SBS 2011. Wenn ich nun auf dem Server bin und und auf das WebApp zugreifen ...

LAN, WAN, Wireless
Webserver über das eigene Netzwerk nicht erreichbar
gelöst Frage von frilooLAN, WAN, Wireless18 Kommentare

Hallo, ich habe einen kleinen Webserver im Internet gefunden, mit dem ich IN meinem Netzwerk arbeiten möchte Ich möchte ...

Server
Plesk Webserver teilweise nicht Erreichbar
Frage von JoRu1407Server3 Kommentare

Liebe Community! Ich habe ein Problem mit meinem bei Host Europe angemieteten vServer samt Plesk: Leider sind alle Internetseiten ...

Apache Server
DynDns öffnet nur ownCloud - keine Webserver mehr
gelöst Frage von it-kasmoApache Server2 Kommentare

Guten Morgen zusammen. Nach Installation und Konfiguration von ownCloud auf meinem Raspberry Pi, ist über den DynDns Aufruf (auch ...

Neue Wissensbeiträge
Linux

Meltdown und Spectre: Linux Update

Information von Frank vor 2 TagenLinux

Meltdown (Variante 3 des Prozessorfehlers) Der Kernel 4.14.13 mit den Page-Table-Isolation-Code (PTI) ist nun für Fedora freigegeben worden. Er ...

Tipps & Tricks

Solutio Charly Updater Fehlermeldung: Das Abgleichen der Dateien in -Pfad- mit dem Datenobject ist fehlgeschlagen

Tipp von StefanKittel vor 2 TagenTipps & Tricks

Hallo, hier einmal als Tipp für alle unter Euch die mit der Zahnarztabrechnungssoftware Charly von Solutio zu tun haben. ...

Sicherheit

Meltdown und Spectre: Wir brauchen eine "Abwrackprämie", die die CPU-Hersteller bezahlen

Information von Frank vor 2 TagenSicherheit12 Kommentare

Zum aktuellen Thema Meltdown und Spectre: Ich wünsche mir von den CPU-Herstellern wie Intel, AMD oder ARM eine Art ...

Sicherheit

Meltdown und Spectre: Realitätscheck

Information von Frank vor 2 TagenSicherheit10 Kommentare

Die unangenehme Realität Der Prozessorfehler mit seinen Varianten Meltdown und Spectre ist seit Juni 2017 bekannt. Trotzdem sind immer ...

Heiß diskutierte Inhalte
E-Mail
Erfahrungen mit hMailServer gesucht
Frage von it-fraggleE-Mail10 Kommentare

Hallo, meine neue Stelle möchte einen eigenen Mailserver. Ich als Linuxkind war direkt geistig mit Postfix dabei. Leider wollen ...

Firewall
Penetrationstester-Labor - Firewalls
Frage von Oli-nuxFirewall9 Kommentare

Mich würde interessieren warum man beim Einrichten eines Penetrationstester-Labor (VMs) die Firewall der Systeme deaktivieren soll? Hat das nur ...

Entwicklung
VBS: alle PDF-Dateien in einem Ordner gleichzeitig öffnen
gelöst Frage von JuweeeEntwicklung9 Kommentare

Hallo, ich habe in deiner Ordnerstruktur (.\Tagesberichte\xx.18\) mehrere dynamische PDF-Formulare (mit LCD erstellt). Die Berichtsformulare sind im Layout alle ...

Netzwerkgrundlagen
IPv6 Inter-VLAN Routing
gelöst Frage von clSchakNetzwerkgrundlagen8 Kommentare

Hi ich befasse mich gerade mit der Implementierung von IPv6 was bisher (in einem VLAN) korrekt funktioniert inkl. DNS ...