Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

WebService läuft nur lokal auf dem IIS

Frage Entwicklung VB for Applications

Mitglied: Gushiken

Gushiken (Level 1) - Jetzt verbinden

30.10.2008, aktualisiert 26.11.2008, 8225 Aufrufe, 1 Kommentar

Ein von mir erstellter Webservice läuft auf einem IIS, lokal vom Server selber kann ich den Service ohne Probleme aufrufen, von einem anderen PC bekomm ich dann aber eine Fehlermeldung.

Nunja.. ich habe derzeit die Aufgabe CrystalReports über einen Webservice zu veröffentlichen. Klappt soweit auch prima, sowohl lokal über die IDE, remote über die IDE oder lokal auf einem Win2003 Server mit installiertem IIS und ASP.NET. Sobald ich nun aber versuche remote über z.B. den Firefox auf den IIS zuzugreifen und den Service abzurufen bekomme ich folgende Fehlermeldung:


Serverfehler in der Anwendung /.
Laufzeitfehler
Beschreibung: Anwendungsfehler auf dem Server. Aufgrund der aktuellen benutzerdefinierten Fehlereinstellungen für diese Anwendung können die Details des Anwendungsfehlers (aus Sicherheitsgründen) nicht remote angezeigt werden. Sie können jedoch von Browsern angezeigt werden, die auf dem lokalen Server ausgeführt werden.

Details: Sie können die Details dieser Fehlermeldung auf dem lokalen Computer anzeigen, indem Sie ein <customErrors>-Tag in der Konfigurationsdatei web.config erstellen, die sich im Stammverzeichnis der aktuellen Webanwendung befindet. Das mode-Attribut dieses <customErrors>-Tags sollte dann auf "Off" festgelegt werden.


Da ich selbst keine Ahnung vom IIS habe, auch nicht vom Server2003 oder ASP allgemein... bin ich grad mal ziemlich ratlos... Ich hoffe ihr könnt mir da weiterhelfen!!

Gruß,
Gushiken

P.S.: Ich habe schon versucht mir die Details der Fehlermeldung anzeigen zu lassen, leider ohne Erfolg...
Mitglied: speacer
26.11.2008 um 10:10 Uhr
HI, ich hatte das selbe Problem.
webseite über interne IP erreichbar (http://192.XXX.XXX.XXX/meinewebsite.asmx)
über externe IP angesprochen (http://217.xxx.xxx.xxx/meinewebsite.asmx) kam die Fehlermeldung "Serverfehler in der Anwendung /."
Die Lösung war:
auf dem Webserver die Sicherheitseinstellungen für Internetexplorer auf Default gesetzt.
Ist zwar wahrscheinlich nicht die Ideale Sicherheitseinstellung, aber wenigstens läufts.
Gruß, Speacer
Bitte warten ..
Neuester Wissensbeitrag
Off Topic

"Ich habe nichts zu verbergen"

(2)

Erfahrungsbericht von FA-jka zum Thema Off Topic ...

Ähnliche Inhalte
Windows Server
gelöst IIS Benutzerdefinierte Sitedelegierung mittels Skript (16)

Frage von EditorialBagPipe zum Thema Windows Server ...

Windows Server
ARR und IIS in DMZ (2)

Frage von Philipp.S zum Thema Windows Server ...

Batch & Shell
Batch - Warten bis bestimmter Task läuft (5)

Frage von Winfried-HH zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
Linux Netzwerk
gelöst DHCP vergibt keine Adressen (32)

Frage von Maik82 zum Thema Linux Netzwerk ...

Apache Server
gelöst Lets Encrypt SSL mit Apache2 (20)

Frage von banane31 zum Thema Apache Server ...

CPU, RAM, Mainboards
Kaufberatung für mind. 8 verschiedene HighEnd-Mainboards (20)

Frage von yperiu zum Thema CPU, RAM, Mainboards ...

Hardware
gelöst PCI-Express-Adapterfrage (14)

Frage von DerWoWusste zum Thema Hardware ...