Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

WebService läuft nur lokal auf dem IIS

Frage Entwicklung VB for Applications

Mitglied: Gushiken

Gushiken (Level 1) - Jetzt verbinden

30.10.2008, aktualisiert 26.11.2008, 8262 Aufrufe, 1 Kommentar

Ein von mir erstellter Webservice läuft auf einem IIS, lokal vom Server selber kann ich den Service ohne Probleme aufrufen, von einem anderen PC bekomm ich dann aber eine Fehlermeldung.

Nunja.. ich habe derzeit die Aufgabe CrystalReports über einen Webservice zu veröffentlichen. Klappt soweit auch prima, sowohl lokal über die IDE, remote über die IDE oder lokal auf einem Win2003 Server mit installiertem IIS und ASP.NET. Sobald ich nun aber versuche remote über z.B. den Firefox auf den IIS zuzugreifen und den Service abzurufen bekomme ich folgende Fehlermeldung:


Serverfehler in der Anwendung /.
Laufzeitfehler
Beschreibung: Anwendungsfehler auf dem Server. Aufgrund der aktuellen benutzerdefinierten Fehlereinstellungen für diese Anwendung können die Details des Anwendungsfehlers (aus Sicherheitsgründen) nicht remote angezeigt werden. Sie können jedoch von Browsern angezeigt werden, die auf dem lokalen Server ausgeführt werden.

Details: Sie können die Details dieser Fehlermeldung auf dem lokalen Computer anzeigen, indem Sie ein <customErrors>-Tag in der Konfigurationsdatei web.config erstellen, die sich im Stammverzeichnis der aktuellen Webanwendung befindet. Das mode-Attribut dieses <customErrors>-Tags sollte dann auf "Off" festgelegt werden.


Da ich selbst keine Ahnung vom IIS habe, auch nicht vom Server2003 oder ASP allgemein... bin ich grad mal ziemlich ratlos... Ich hoffe ihr könnt mir da weiterhelfen!!

Gruß,
Gushiken

P.S.: Ich habe schon versucht mir die Details der Fehlermeldung anzeigen zu lassen, leider ohne Erfolg...
Mitglied: speacer
26.11.2008 um 10:10 Uhr
HI, ich hatte das selbe Problem.
webseite über interne IP erreichbar (http://192.XXX.XXX.XXX/meinewebsite.asmx)
über externe IP angesprochen (http://217.xxx.xxx.xxx/meinewebsite.asmx) kam die Fehlermeldung "Serverfehler in der Anwendung /."
Die Lösung war:
auf dem Webserver die Sicherheitseinstellungen für Internetexplorer auf Default gesetzt.
Ist zwar wahrscheinlich nicht die Ideale Sicherheitseinstellung, aber wenigstens läufts.
Gruß, Speacer
Bitte warten ..
Ähnliche Inhalte
Windows Server
Migration von IIS6 auf IIS 8.5 (1)

Frage von Stefan007 zum Thema Windows Server ...

CMS
Contao auf einem IIS (10)

Frage von padimonu zum Thema CMS ...

Exchange Server
gelöst Auf SBS 2011 läuft POPcon - bekomme eine Mail nicht raus (9)

Frage von jensgebken zum Thema Exchange Server ...

Neue Wissensbeiträge
Peripheriegeräte

Was beachten bei der Wahl einer USV Anlage im Serverschrank

(2)

Tipp von zetboxit zum Thema Peripheriegeräte ...

Windows 10

Das Windows 10 Creators Update ist auf dem Weg

(5)

Anleitung von BassFishFox zum Thema Windows 10 ...

Administrator.de Feedback

Tipp: Ungelöste Fragen ohne Antwort in Tickeransicht farblich hinterlegen

Tipp von pattern zum Thema Administrator.de Feedback ...

Viren und Trojaner

Neue Magazin Ausgabe: Malware und Angriffe abwehren

Information von Frank zum Thema Viren und Trojaner ...

Heiß diskutierte Inhalte
Windows Systemdateien
Warum System auf "C:" (29)

Frage von DzumoPRO zum Thema Windows Systemdateien ...

Cloud-Dienste
gelöst Bitcoins minen über Nacht? (16)

Frage von 1410640014 zum Thema Cloud-Dienste ...

Windows Server
gelöst Update BackupExec 2015 auf 2016 führt zu SQL-Server Problem (16)

Frage von montylein1981 zum Thema Windows Server ...

Batch & Shell
gelöst Batch um Benutzer aus Sitzung abzumelden (15)

Frage von zeroblue2005 zum Thema Batch & Shell ...