Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Weiterleitung auf 2. Router im Netzwerk?

Frage Netzwerke Router & Routing

Mitglied: goldfisch1980

goldfisch1980 (Level 1) - Jetzt verbinden

17.04.2009, aktualisiert 08:50 Uhr, 6307 Aufrufe, 13 Kommentare

Ich habe 2 Router und möchte mittels Remote Management auf beide via unterschiedlichem Port von extern zugreifen können

Hallo!

Ich habe 2 Linksys Router in einem Netzwerk auf denen die DD-WRT Firmware v24 drauf ist.
Der Router A macht die Einwahl ins Internet und hat die lokale 192.168.2.1 Adresse. Der Router B welcher das Repeating mittels WDS macht hat die Adresse 192.168.2.2.

Logge ich mich von extern via SSH auf dem Router A ein, so kann ich den Router B per Telnet erreichen. Ebenso aus dem lokalen Netzwerk per SSH. Oder per HTTP das Webinterface aus dem lokalen netz.
Versuche ich aber direkt mich mit dem Router B von Remote aus zu verbinden, funktioniert das nicht mehr.

Ich habe versucht eine Portweiterleitung einzurichten:

In Router A unter Port Forwarding trug ich folgendes ein:
Application: routernameB
Port from: 8081
Port to: 8081
Protocol: Both
Address: 192.168.2.2
enabled: Yes.

In Router B:
quasi selbe konfiguration allerdings ohne dem Port Forwarding dafür aber:
DMZ aktiv auf Adresse 192.168.2.2


Es funktioniert aber nicht. Versuche ich nun über den Webbrowser das Webinterface über das Internet welches auf http://WANIP:8081 aufscheinen sollte zu erreichen, kommt irgendwann der timeout....
Aus dem lokalen Netzwerk funktioniert das. Remote management ist natürlich bei beiden aktiv und auf dem Router B auf 8081 Port eingestellt.
Den Router A kann ich hingegen erreichen. Dieser macht das remote management auf 8080 derzeit brav mit und das funktioniert.

Kann mir jemand sagen wie ich das sonst machen muss/kann?


danke schonmal im voraus,
Phil
Mitglied: aqui
17.04.2009 um 09:16 Uhr
Vermutlich hast du den Router B falsch angeschlossen über das WAN Interface. Dann blockt die die NAT Firewall vom Zugriff, sofern du in der DD-WRT Firmware NAT nicht komplett deaktivierst !

Besser ist du schliesst den WDS Repeater so an:

http://www.administrator.de/Kopplung_von_2_Routern_am_DSL_Port.html#toc ...

damit umgehst du das Problem !
Bitte warten ..
Mitglied: goldfisch1980
17.04.2009 um 09:46 Uhr
Der Router B ist ja nur per WDS (also WLAN) an den anderen angebunden. Es existiert keine Kabelgebundene Verbindung zwischen den Routern! Daher nicht über den WAN Port oder verstehe ich da was falsch?
Wo müsste ich denn das abschalten die NAT Firewall? An Router A oder Router B?
Sollte das DMZ auf Router B die gesamte Firewall nicht "umgehen"?
Bitte warten ..
Mitglied: aqui
17.04.2009 um 09:53 Uhr
OK, Das war nicht ganz klar...sorry. Nein, dann ist soweit alles richtig und ein http://<wan_ip_router-a>:8081 sollte dich dann per Weboberfläche direkt auf Router B bringen....
Bitte warten ..
Mitglied: goldfisch1980
17.04.2009 um 09:56 Uhr
aber es tut leider nicht

Muss ich den Port 8081 noch speziell öffnen auf dem Router A oder geschieht das mit der Eingabe der oben durchgeführten Portweiterleitung denn automatisch?
Bitte warten ..
Mitglied: aqui
17.04.2009 um 10:35 Uhr
Das geschieht damit automatisch, denn die Weiterleitung ist ja schon die Öffnung !

Häng mal einen Sniffer wie den Wireshark oder MS NetMonitor ins Netz und sieh dir mal an ob der Router A die Pakete überhaupt weiterleitet.

Was noch sein kann:
Dadurcg das du den Parameter Both eingegeben hast gibt es KEINE Port Translation.
Eingehende HTTP Verbindungen mit Port TCP 8081 gehen also auch raus an den Router B mit Port TCP 8081.
Nocrmalerweise wenn du den Konfiguratior nicht umstellst auf diesen Port antwortet Router B dann nicht, das ist logisch, da er nur TCP 80 (HTTP) und TCP 443 (HTTPS) will !!!

Du solltest also besser wenn du die Ziel Ports an Router B nicht angepasst hast eine Port Translation aufsetzen und nicht Both verwenden !!!

Besser ist dann z.B. INCOMING (extern) Port TCP 54443 auf OUTGOING (intern) TCP 443 zu setzen.

Wenn du nun im Browser remote https://<dsl_ip_router-a>:54443 eingibst, es intern dann eine TCP HTTPS Session auf dem Standardport TCP 443 gibt und damit der Router B dann erreichbar ist.

Ganz bewusst ist hier HTTPS gewählt als beispiel, denn du solltest niemals eine ungeschützte HTTP Verbindung vom Internet machen !
HTTPS bietet da mehr Sicherheit !

Vermutlich hast du auch nur diesen schlichten und banalen Denkfehler gemacht bei der Port Weiterleitung/Translation und die Port Zuordnung nicht beachtet ??!!
Bitte warten ..
Mitglied: goldfisch1980
17.04.2009 um 10:55 Uhr
Also pakete gehen schon weiter.. Wenn ich mit dem Router A verbunden bin (via LAN) und dann auf den Router B zugreifen will passt das. Sobald ich das aber von Remote aus machen möchte geht es nicht. Da komme ich nur auf den Router A.

https geht bei der Firmwareversion leider nicht. Da müsste ich erst ein firmware upgrade machen und dann extra wieder alles neu einstellen. Das möchte ich eigentlich vermeiden. Zumal keine wichtigen Daten übermittelt werden. Das iss ja nur privates Netzwerk.

Das mit Both habe ich auf TCP angepasst. Aber geht immer noch nicht. Die SPI Firewall auf Router B habe ich mittlerweile komplett abgeschalten. Die SPI Firewall von Router A ist noch aktiv.

Was meinst Du mit banalem Fehler genau? Es ist so wie hier beschrieben jetzt eingestellt und tut nicht:
Router A (192.168.2.1): HTTP Remote Management Port 8080, TCP-Portweiterleitung von 8081 auf 8081 an Adresse 192.168.2.2, DMZ aktiviert für 192.168.2.2
Router B (192.168.2.2): HTTP Remote Management Port 8081, SPI Firewall deaktiviert. DMZ aktiviert für 192.168.2.2

Die Firewall an Router A hatte ich auch schon kurz mal abgeschalten zum testen. Aber ging ebenso nicht... Ich verzweifele!!
Bitte warten ..
Mitglied: aqui
17.04.2009 um 15:42 Uhr
OK, wenn der Zielport auch auf 8081 gesetzt ist sollte das so klappen.

Hast du mal mitgesniffert ob der Router A die TCP 8181 Pakete überhaupt auf sein lokales LAN weiterleitet von der remoten Verbindung ???
Bitte warten ..
Mitglied: goldfisch1980
17.04.2009 um 16:06 Uhr
keine ahnung. Wie sollte ich das machen?
Ich bin auch jetzt gerade nicht mehr vor ort...
Bitte warten ..
Mitglied: goldfisch1980
17.04.2009 um 16:17 Uhr
Ahh. ich muss leider feststellen, dass der 2. Router keine Verbindung zum Aussennetzwerk hat...
Kann von Router B also auch kein ping googole.de oder so machen. Dann heisst es: bad address
Da stimmt also irgendwas grundlegend ned!
Bitte warten ..
Mitglied: aqui
17.04.2009 um 16:31 Uhr
So ist es !!

Wie man sniffert kannst du übrigens hier nachlesen:

http://www.heise.de/netze/Fehler-erschnueffeln--/artikel/76929
Bitte warten ..
Mitglied: goldfisch1980
17.04.2009 um 16:35 Uhr
muss ich bei dem Router B vielleicht das gateway oder so was eintragen?
Derzeit bezieht er ja normal seine IP vom DHCP Server der auf Router A liegt...
Bitte warten ..
Mitglied: Der-Phil
18.04.2009 um 21:29 Uhr
Hi!

Trage beim Router B einfach den Router A als DNS und Standard-Gateway ein, dann sollte alles funktionieren.

...hab ich selbst zuhause so am Laufen...

Phil
Bitte warten ..
Mitglied: goldfisch1980
19.04.2009 um 20:36 Uhr
Danke Phil das wars!!!! Jetzt tut es...

lg
ebenso Phil
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Router & Routing
gelöst Proxmox Netzwerk: LAN Netz ohne Router (2)

Frage von sebastian2608 zum Thema Router & Routing ...

Virtualisierung
gelöst VirtualBox offline (ohne Netzwerk bzw. Router) erreichen (5)

Frage von QnavWhat zum Thema Virtualisierung ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...