Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Wenn-Funktion für Text anwenden

Frage Microsoft Microsoft Office

Mitglied: -betty-

-betty- (Level 1) - Jetzt verbinden

17.12.2005, aktualisiert 23.12.2005, 6386 Aufrufe, 3 Kommentare

Hallo,

mit Zahlen funktioniert die Wenn-funktion ja immer wunderbar. Jetzt möchte ich Sie aber mit Text anwenden und das funktioniert überhaupt nicht.
(also wenn in Zelle XY3 misc 1 steht, soll in der anderen ein bestimmter Produktname erscheinen, wenn misc 2 drin steht ein anderer Produktname usw...)
Geht das, entweder mit der Wenn- oder einer anderen Funktion?

Vielen Dank für Eure Hilfe,

Betty
Mitglied: Biber
21.12.2005 um 22:38 Uhr
Moin -betty-,

falls Dein Problem noch bestehen sollte:
Ein Formelwert
=WENN(x3="misc 1";"Product 1";"anderes")
funktioniert tadellos bei mir.
Und Du kannst es relativ beliebig schachteln:
=WENN(E7="misc 1";"Product 1";WENN(E7="misc 2";"Product 2";"anderes")) ........usw.

Bei mehreren Wahlmöglichkeiten würde man/frau allerdings eher irgendwelche LookUp-Funktionen nehmen, aber das war ja nicht Deine Frage.

HTH Biber
Bitte warten ..
Mitglied: -betty-
23.12.2005 um 17:23 Uhr
Vielen Dank, jetzt funktioniert es.

Ich hatte es wohl vorher irgendwie falsch eingegeben.

Leider steht in der Zelle, wenn ich die Formel eingebe jetzt immer FALSCH.

Das ist auch ungünstig, da ich manchmal weniger und manchmal mehr Produkte eingeben möchte und in den Leeren Zeilen darf dann natürlich nicht "Falsch" stehen.

Kann man das noch irgendwie formatieren?
Bitte warten ..
Mitglied: Biber
23.12.2005 um 17:46 Uhr
Moin -betty-,

..wenn dort jetzt "FALSCH" steht, dann ist das ein logischer Rückgabewert.. dann fehlt vielleicht ein "=" am Anfang der Formel.
Aber das pure Spekukation - wenn es wichtig ist, schick mir die Excel-Datei (falls das keine 14 GigaByte sind).
Geht schneller als dieses Stochern im Nebel.
Ich schick Dir mal eine Mail-Adresse per pn.

Gruß Biber
Bitte warten ..
Ähnliche Inhalte
Neue Wissensbeiträge
Rechtliche Fragen

Heiseshow, live ab 12 Uhr: Steht die Vorratsdatenspeicherung vor dem Aus?

Tipp von sabines zum Thema Rechtliche Fragen ...

Outlook & Mail

Outlook Probleme nach Juni Updates - KB3203467 ist Schuld

(1)

Information von Deepsys zum Thema Outlook & Mail ...

Microsoft Office

Windows 7, Office 2016 RTM und Updates ohne WSUS

Tipp von chgorges zum Thema Microsoft Office ...

E-Mail

Thunderbird 52 hat Druckprobleme

(3)

Tipp von magicteddy zum Thema E-Mail ...

Heiß diskutierte Inhalte
Server-Hardware
Einem Stromausfall entgegen wirken (22)

Frage von OIOOIOOIOIIOOOIIOIIOIOOO zum Thema Server-Hardware ...

Festplatten, SSD, Raid
PC stellt nach dem Bios ab (20)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...

Windows 7
Freeware MSI Tool (13)

Frage von uridium69 zum Thema Windows 7 ...

DSL, VDSL
gelöst Ständige Störungen - Internet (12)

Frage von gamerff zum Thema DSL, VDSL ...