Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Wget at Zeichen im Benutzername

Frage Microsoft Windows Tools

Mitglied: Ruffy1984

Ruffy1984 (Level 1) - Jetzt verbinden

01.02.2011 um 09:45 Uhr, 6530 Aufrufe, 10 Kommentare

Hallo Community ,

für die Erfahrenen müsste mein Problem ein Kinderspiel sein.

Ich benutze Wget um Daten von einem FTP Server zu holen.

Bisher hat alles wunderbar mit folgenden Code funktioniert.

01.
wget -nH -P "c:/Temp" -r ftp://testuser:password@server.de:/Ordner


nun wurden aber die Zugangsdaten geändert und ich habe ein " @" Zeichen im Benutzernamen.
01.
 
02.
wget -nH -P "c:/Temp" -r ftp://testuser@server.de:password@server.de:/Ordner 
03.
 
wenn ich es so mache funktioniert es nicht.

Ich habe herausgefunden das man aus dem " @" %40 machen muss aber wie würde dann die Syntax lauten :

01.
wget -nH -P "c:/Temp" -r ftp://testuser%40server.de:password@server.de:/Ordner

dies funktioniert leider nicht, hat jemand eine Idee =
Mitglied: Skyemugen
01.02.2011 um 09:51 Uhr
Aloha,

wie steht es mit der Variante %%40?

greetz André
Bitte warten ..
Mitglied: Ruffy1984
01.02.2011 um 09:57 Uhr
Serwas...

sehr geil mann! es hat funktioniert.Perfekt...

Wunderbar..
Bitte warten ..
Mitglied: Skyemugen
01.02.2011 um 10:10 Uhr
Aloha,

nur zur Info: Das zusätzliche Prozentzeichen dient in diesem Fall dazu, das eigentliche Prozentzeichen zu escapen, damit es als gewöhnlicher Text behandelt wird und nicht als Teil einer Variable (gilt auch nur für das Prozentzeichen, andere Zeichen wie & werden i.d.R. mit ^ escaped).

greetz André

PS: Ein grünes Häkchen im Thread kommt schöner für's Auge ;)
Bitte warten ..
Mitglied: Ruffy1984
07.02.2011 um 09:57 Uhr
Hallo Skyemugen,

das ist gut zu wissen.

Habe jetzt noch eine zusätzliche Frage.

Wenn ich über einen Proxy gehe, meldet wget mir :

Proxy Anforderung gesendet, warte auf Antwort...... 400 Bad Request
Fehler 400: Bad request

01.
 
02.
 wget -nH -P "c:/temp" --proxy=on --proxy-user=user --proxy-passwd=123456 -e ftp_proxy=http://192.167.178.1:8080 -r ftp://user%%40domain.de:password@domain.de 
03.
 
weisst du vielleicht was der Fehlercode 400 bedeutet ?

Grüße
Bitte warten ..
Mitglied: Skyemugen
07.02.2011 um 10:33 Uhr
Aloha,

ich würde jetzt nur das machen, was du auch selber schaffst: googlen.

Der Fehler ist jedoch i.d.R. clientseitig (z.B. falsche Syntax).

greetz André

P.S.: Ich nutze nie tools wie wget oder gehe irgendwo per proxy, daher kann ich dir hier nicht weiterhelfen.
Bitte warten ..
Mitglied: Ruffy1984
07.02.2011 um 10:39 Uhr
Hallo Andre,

okay..vielen dank trozdem für deine mühe. muss dann mal weiter googlen.

Vielleicht ist ja da noch jemand der mir weiter helfen kann.

grüße
Bitte warten ..
Mitglied: Skyemugen
07.02.2011 um 11:38 Uhr
Aloha,

wenn ich das jetzt richtig mitbekommen habe:

  • wget + proxy + alte Kennung (ohne @ bzw. %%40 im Namen) geht

  • wget + neue Kennung (mit @ bzw ...) geht

  • wget + neue Kennung + proxy geht nicht

soweit richtig? (Fehlereingrenzungsversuch für Lösungsfindung)

greetz André
Bitte warten ..
Mitglied: Ruffy1984
07.02.2011 um 12:04 Uhr
Hallo Andre,

du bringst es auf den Punk.

Ich wiederhole nochmal:

wget +proxy+ alte Kennung (ohne @bzw %%40 im Benutzernamen)--> geht
wget + neue Kennung (mit @ im Benutzernamen ) --> geht
wget + neue Kennung + Proxy--> geht nicht
Bitte warten ..
Mitglied: Skyemugen
07.02.2011 um 12:21 Uhr
Aloha,

tja denn wird der Proxy ein Problem mit dem codierten @ haben ... (so wie die meisten eingesetzten Proxies)

da wüsste ich momentan auch keinen workaround für

greetz André
Bitte warten ..
Mitglied: Ruffy1984
07.02.2011 um 13:53 Uhr
Hey,

was mir aufgefallen ist unter der ISA Protokollierung.

GET ftp://user@domain.dede:***@domain.de/


der isa Server hängt einfach noch ein"de." dran, wieso auch immer
Bitte warten ..
Ähnliche Inhalte
Microsoft Office
Outlook 2013 Kontaktname enthält japanische Zeichen

Frage von xbast1x zum Thema Microsoft Office ...

Windows Netzwerk
gelöst Benutzername oder Passwort falsch (3)

Frage von Havanna63 zum Thema Windows Netzwerk ...

Neue Wissensbeiträge
Windows 10

Windows 8.x oder 10 Lizenz-Key aus dem ROM auslesen mit Linux

(6)

Tipp von Lochkartenstanzer zum Thema Windows 10 ...

Tipps & Tricks

Wie Hackt man sich am besten in ein Computernetzwerk ein

(38)

Erfahrungsbericht von Herbrich19 zum Thema Tipps & Tricks ...

Heiß diskutierte Inhalte
Festplatten, SSD, Raid
POS Hardware und alternativen zu Raid 1? (21)

Frage von Brotkasten zum Thema Festplatten, SSD, Raid ...

Windows 10
gelöst Windows 10 Home "Netzlaufwerk nicht bereit" (19)

Frage von Oggy01 zum Thema Windows 10 ...

Viren und Trojaner
Verschlüsselungstrojaner simulieren (18)

Frage von AlbertMinrich zum Thema Viren und Trojaner ...

Exchange Server
Exchange Postfach leeren - nicht löschen (11)

Frage von AndreasOC zum Thema Exchange Server ...