Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Wieso bekomme ich Leerzeichen in FOR-Schleife zurück

Frage Entwicklung Batch & Shell

Mitglied: ganzbaf

ganzbaf (Level 1) - Jetzt verbinden

15.05.2009, aktualisiert 14:22 Uhr, 3167 Aufrufe, 2 Kommentare

Hallo zusammen,

Ich bin neu hier. Vielleicht kann mir jemand von euch erklären, warum ich aus der folgenden FOR-Schleife immer ein Leerzeichen vor dem zweiten Anfühungszeichen zurückbekomme.

for /f "delims=" %%i in (%temp_file1%) do (echo ^<record name="%%i"^> >> %temp_file2%)

Hintergrund ist, dass ich aus einer Textdatei eine XML-Datei erstellen will mit den entsprechenden Tags.

Gruß, Ganzbaf

Problem gelöst, die erste Tempdatei war nicht sauber. Sorry, hab's nicht früher gemerkt, weil diese später im Batch immer gelöscht wurde.
Mitglied: LotPings
15.05.2009 um 14:24 Uhr
Zitat von ganzbaf:
Ich bin neu hier.

Hallo Ganzbaf,

Willkommen in Forum.

Vielleicht kann mir jemand von euch erklären, warum ich aus der folgenden FOR-Schleife immer ein Leerzeichen vor dem zweiten Anfühungszeichen zurückbekomme.

Besser mit < Code> und < /code> Tags formatieren, dann sieht man auch das es ja so in deinem source steht.
01.
 for /f "delims=" %%i in (%temp_file1%) do (echo ^<record name="%%i"^> >> %temp_file2%)
Das Leerzeichen zwischen dem ^> und der Umleitung >> geört zur Ausgabe.
Versuch es mal so.
01.
 for /f "delims=" %%i in (%temp_file1%) do (echo ^<record name="%%i"^>)>> %temp_file2%


Gruß
LotPings
Bitte warten ..
Mitglied: ganzbaf
15.05.2009 um 20:33 Uhr
Hallo LotPings,

danke für deinen Hinweis. Scheint ein gutes Forum zu sein mit kompetenten Benutzern.

01.
Das ist nur ein Testcode
Gruß, Ganzbaf
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Batch & Shell
Zwei Ergänzungen in einer For Schleife

Frage von charmeur zum Thema Batch & Shell ...

Batch & Shell
gelöst FOR Schleife mit Unterverzeichnissen, die Ausgabe kürzen (tokens evtl.) (5)

Frage von Kriegstreiber zum Thema Batch & Shell ...

Batch & Shell
gelöst For Schleife für Abgleich mit Text-Datei und Unterverzeichnisse (4)

Frage von grisur zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
Viren und Trojaner
gelöst Wie werde ich den Mist "fanli90" wieder los? (17)

Frage von Taumel zum Thema Viren und Trojaner ...

Switche und Hubs
LAG zwischen Cisco SG300 und Dlink DGS1100 herstellen - wie? (15)

Frage von White-Rabbit2 zum Thema Switche und Hubs ...

Hardware
Lenovo Yoga 500 über angeschlossene USB Tastatur booten (13)

Frage von thomasreischer zum Thema Hardware ...

CPU, RAM, Mainboards
Hardware Fragen (12)

Frage von xaver-2 zum Thema CPU, RAM, Mainboards ...